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Who is this book for?

Anyone who wants to get up to speed quickly with LibreOffice will find this Getting Started Guide
valuable. You may be new to office software, or you may be familiar with another office suite.

What's in this book?

This book introduces the main components of LibreOffice:
*  Writer (word processing)
* Calc (spreadsheets)
* Impress (presentations)
¢ Draw (vector graphics)
* Base (database
* Math (equation editor)

It also covers some of the features common to all components, including setup and customization,
styles and templates, macro recording, and printing. For more detail, see the user guides for the
individual components.

Where to get more help

This book, the other LibreOffice user guides, the built-in Help system, and user support systems
assume that you are familiar with your computer and basic functions such as starting a program,
opening and saving files.

Help system

LibreOffice comes with an extensive Help system. This is your first line of support for using
LibreOffice.

To display the full Help system, press F1 or select LibreOffice Help from the Help menu. In
addition, you can choose whether to activate Tips, Extended tips, and the Help Agent (using Tools
> Options > LibreOffice > General).

If Tips are enabled, place the mouse pointer over any of the icons to see a small box (“tooltip”) with
a brief explanation of the icon’s function. For a more detailed explanation, select Help > What's
This? and hold the pointer over the icon.

Free online support

The LibreOffice community not only develops software, but provides free, volunteer-based support.
See Table 1 and this web page: http://www.libreoffice.org/get-help/

You can get comprehensive online support from the community through mailing lists and the Ask
LibreOffice website. Other websites run by users also offer free tips and tutorials. This forum
provides community support for LibreOffice: http://en.libreofficeforum.org/

This site provides support for LibreOffice, among other programs:
http://forum.openoffice.org/en/forum/
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Table 1: Free support for LibreOffice users

Free LibreOffice support

Questions and answers from the LibreOffice community

Ask LibreQfice http://ask.libreoffice.org/en/questions/

User guides, how-tos, and other documentation.
Documentation http://www.libreoffice.org/get-help/documentation/
https://wiki.documentfoundation.org/Documentation/Publications

Answers to frequently asked questions

FAQs http://wiki.documentfoundation.org/Faq

Free community support is provided by a network of experienced users

Mailing lists http://www.libreoffice.org/get-help/mailing-lists/

The LibreOffice website in your language.

i http://www.libreoffice.org/international-sites/
International support , b
International mailing lists

http://wiki.documentfoundation.org/Local_Mailing_Lists

Information about available accessibility options.

Accessibility options http:/Avww.libreoffice. org/get-help/accessibility/

Paid support and training

Alternatively, you can pay for support services. Service contracts can be purchased from a vendor
or consulting firm specializing in LibreOffice.

What you see may be different

lllustrations

LibreOffice runs on Windows, Linux, and Mac OS X operating systems, each of which has several
versions and can be customized by users (fonts, colors, themes, window managers). The
illustrations in this guide were taken from a variety of computers and operating systems. Therefore,
some illustrations will not look exactly like what you see on your computer display.

Also, some of the dialogs may be differ because of the settings selected in LibreOffice. You can
either use dialogs from your computer system (default) or dialogs provided by LibreOffice. To
change to using LibreOffice dialogs:

1) On Linux and Windows operating systems, go to Tools > Options >LibreOffice > General
on the main menu bar to open the dialog for general options.

2) On a Mac operating system, go to LibreOffice > Preferences > General on the main
menu bar to open the dialog for general options.

3) Select Use LibreOffice dialogs in Open/Save dialogs and, in Linux and Mac OS X operating
systems only, Print dialogs to display the LibreOffice dialogs on your computer display.

4) Click OK to save your settings and close the dialog.

Icons

The icons used to illustrate some of the many tools available in LibreOffice may differ from the
ones used in this guide. The icons in this guide have been taken from a LibreOffice installation that
has been set to display the Galaxy set of icons.
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If you wish, you can change your LibreOffice software package to display Galaxy icons as follows:

1) On Linux and Windows operating systems, go to Tools > Options >LibreOffice > View on
the main menu bar to open the dialog for view options.

2) On a Mac operating system, go to LibreOffice > Preferences > View on the main menu
bar to open the dialog for view options.

3) In User interface > Icon size and style select Galaxy from the options available in the drop-
down list.

4) Click OK to save your settings and close the dialog.

Some Linux operating systems, for example Ubuntu, include LibreOffice as part of
the installation and may not include the Galaxy set of icons. You should be able to
download the Galaxy icon set from the software repository for your Linux operating
system.

Note

Using LibreOffice on a Mac

Some keystrokes and menu items are different on a Mac from those used in Windows and Linux.
The table below gives some common substitutions for the instructions in this chapter. For a more
detailed list, see the application Help.

Windows or Linux Mac equivalent Effect
Tools > Options LibreOffice > Preferences Access setup options
menu selection
Right-click Control+click and/or right-click Open a context menu
depending on computer setup
Ctrl (Control) z (Command) Used with other keys
F5 Shift+z+F5 Open the Navigator
Fi1 z+T Open the Styles and Formatting window

What are all these things called?

The terms used in LibreOffice for most parts of the user interface (the parts of the program you see
and use, in contrast to the behind-the-scenes code that actually makes it work) are the same as for
most other programs.

A dialog is a special type of window. Its purpose is to inform you of something, or request input
from you, or both. It provides controls for you to use to specify how to carry out an action. The
technical names for common controls are shown in Figure 1. In most cases we do not use the
technical terms in this book, but it is useful to know them because the Help and other sources of
information often use them.

1) Tabbed page (not strictly speaking a control).
2) Radio buttons (only one can be selected at a time).
3) Checkbox (more than one can be selected at a time).

4) Spin box (click the up and down arrows to change the number shown in the text box next to
it, or type in the text box).

5) Thumbnail or preview.
6) Drop-down list from which to select an item.
7) Push buttons.
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Figure 1: Dialog showing common controls

In most cases, you can interact only with the dialog (not the document itself) as long as the dialog
remains open. When you close the dialog after use (usually, clicking OK or another button saves
your changes and closes the dialog), then you can again work with your document.

Some dialogs can be left open as you work, so you can switch back and forth between the dialog
and your document. An example of this type is the Find & Replace dialog.

Who wrote this book?

This book was written by volunteers from the LibreOffice community. Profits from sales of the
printed edition will be used to benefit the community.
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Frequently asked questions

How is LibreOffice licensed?
LibreOffice 4.2 is distributed under the Open Source Initiative (OSI) approved Mozilla Public
License (MPL). The MPL license is available from http://www.mozilla.org/MPL/2.0/.

May | distribute LibreOffice to anyone? May I sell it? May | use it in my business?
Yes.

How many computers may | install it on?
As many as you like.

Is LibreOffice available in my language?
LibreOffice has been translated (localized) into over 40 languages, so your language probably
is supported. Additionally, there are over 70 spelling, hyphenation, and thesaurus dictionaries
available for languages, and dialects that do not have a localized program interface. The
dictionaries are available from the LibreOffice website at: www.libreoffice.org.

How can you make it for free?
LibreOffice is developed and maintained by volunteers and has the backing of several
organizations.

I am writing a software application. May | use programming code from LibreOffice in my
program?
You may, within the parameters set in the MPL. Read the license:
http://www.mozilla.org/MPL/2.0/.

Why do | need Java to run LibreOffice? Is it written in Java?
LibreOffice is not written in Java; it is written in the C++ language. Java is one of several
languages that can be used to extend the software. The Java JDK/JRE is only required for
some features. The most notable one is the HSQLDB relational database engine.

Note: Java is available at no cost. If you do not want to use Java, you can still use nearly all of
the features of LibreOffice.

How can | contribute to LibreOffice?
You can help with the development and user support of LibreOffice in many ways, and you do
not need to be a programmer. To start, check out this webpage:
http://www.documentfoundation.org/contribution/

May | distribute the PDF of this book, or print and sell copies?
Yes, as long as you meet the requirements of one of the licenses in the copyright statement at
the beginning of this book. You do not have to request special permission. We request that you
share with the project some of the profits you make from sales of books, in consideration of all
the work we have put into producing them.

What’s new in LibreOffice 4.2?

The LibreOffice 4.2 Release Notes (changes from version 4.1) are here:
https://wiki.documentfoundation.org/ReleaseNotes/4.2.

You may also want to read the LibreOffice 4.1 Release Notes (changes from version 4.0) here:
https://wiki.documentfoundation.org/ReleaseNotes/4.1.
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What is LibreOffice?

LibreOffice is a freely available, fully-featured office productivity suite. Its native file format is Open
Document Format (ODF), an open standard format that is being adopted by governments
worldwide as a required file format for publishing and accepting documents. LibreOffice can also
open and save documents in many other formats, including those used by several versions of
Microsoft Office.

LibreOffice includes the following components.

Writer (word processor)

Writer is a feature-rich tool for creating letters, books, reports, newsletters, brochures, and other
documents. You can insert graphics and objects from other components into Writer documents.
Writer can export files to HTML, XHTML, XML, Adobe Portable Document Format (PDF), and
several versions of Microsoft Word files. It also connects to your email client.

Calc (spreadsheet)

Calc has all of the advanced analysis, charting, and decision making features expected from a
high-end spreadsheet. It includes over 300 functions for financial, statistical, and mathematical
operations, among others. The Scenario Manager provides “what if” analysis. Calc generates 2D
and 3D charts, which can be integrated into other LibreOffice documents. You can also open and
work with Microsoft Excel workbooks and save them in Excel format. Calc can also export
spreadsheets in several formats, including for example Comma Separated Value (CSV), Adobe
PDF and HTML formats.

Impress (presentations)

Impress provides all the common multimedia presentation tools, such as special effects, animation,
and drawing tools. It is integrated with the advanced graphics capabilities of LibreOffice Draw and
Math components. Slideshows can be further enhanced using Fontwork special effects text, as
well as sound and video clips. Impress is compatible with Microsoft PowerPoint file format and can
also save your work in numerous graphics formats, including Macromedia Flash (SWF).

Draw (vector graphics)

Draw is a vector drawing tool that can produce everything from simple diagrams or flowcharts to
3D artwork. Its Smart Connectors feature allows you to define your own connection points. You can
use Draw to create drawings for use in any of the LibreOffice components, and you can create
your own clip art then add it to the Gallery. Draw can import graphics from many common formats
and save them in over 20 formats, including PNG, HTML, PDF, and Flash.

Base (database)

Base provides tools for day-to-day database work within a simple interface. It can create and edit
forms, reports, queries, tables, views, and relations, so that managing a relational database is
much the same as in other popular database applications. Base provides many new features, such
as the ability to analyze and edit relationships from a diagram view. Base incorporates HSQLDB as
its default relational database engine. It can also use dBASE, Microsoft Access, MySQL, or Oracle,
or any ODBC compliant or JDBC compliant database. Base also provides support for a subset of
ANSI-92 SQL.
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Math (formula editor)

Math is the LibreOffice formula or equation editor. You can use it to create complex equations that
include symbols or characters not available in standard font sets. While it is most commonly used

to create formulae in other documents, such as Writer and Impress files, Math can also work as a

standalone tool. You can save formulae in the standard Mathematical Markup Language (MathML)
format for inclusion in web pages and other documents not created by LibreOffice.

Advantages of LibreOffice

Here are some of the advantages of LibreOffice over other office suites:

No licensing fees. LibreOffice is free for anyone to use and distribute at no cost. Many
features that are available as extra cost add-ins in other office suites (like PDF export) are
free with LibreOffice. There are no hidden charges now or in the future.

Open source. You can distribute, copy, and modify the software as much as you wish, in
accordance with either of the LibreOffice Open Source licenses.

Cross-platform. LibreOffice runs on several hardware architectures and under multiple
operating systems, such as Microsoft Windows, Mac OS X and Linux.

Extensive language support. The LibreOffice user interface is available in over 40
languages and the LibreOffice project provides spelling, hyphenation, and thesaurus
dictionaries in over 70 languages and dialects. LibreOffice also provides support for both
Complex Text Layout (CTL) and Right to Left (RTL) layout languages (such as Urdu,
Hebrew, and Arabic).

Consistent user interface. All the components have a similar “look and feel,” making them
easy to use and master.

Integration. The components of LibreOffice are well integrated with one another.

- All the components share a common spelling checker and other tools, which are used
consistently across the suite. For example, the drawing tools available in Writer are
also found in Calc, with similar but enhanced versions in Impress and Draw.

- You do not need to know which application was used to create a particular file. For
example, you can open a Draw file from Writer.

Granularity. Usually, if you change an option, it affects all components. However,
LibreOffice options can be set at a component level or even at document level.

File compatibility. In addition to its native OpenDocument formats, LibreOffice includes
PDF and Flash export capabilities, as well as support for opening and saving files in many
common formats including Microsoft Office, HTML, XML, WordPerfect, and Lotus 1-2-3
formats. An extension (included) provides the ability to import and edit some PDF files.

No vendor lock-in. LibreOffice uses OpenDocument, an XML (eXtensible Markup
Language) file format developed as an industry standard by OASIS (Organization for the
Advancement of Structured Information Standards). These files can easily be unzipped and
read by any text editor, and their framework is open and published.

You have a voice. Enhancements, software fixes, and release dates are community-
driven. You can join the community and affect the course of the product you use.

You can read more about LibreOffice and The Document Foundation on their websites at
http://www.libreoffice.org/ and http://www.documentfoundation.org/.
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Minimum requirements

LibreOffice 4.2 requires one of the following operating systems:
* Microsoft Windows XP, Vista, Windows 7, or Windows 8
* GNUILinux Kernel version 2.6.18, glibc2 v2.5 or higher, and gtk v2.10.4 or higher

* Mac OS X 10.6 (Snow Leopard) or higher for LibreOffice 4.1 and 4.2; for LibreOffice
versions up to 4.0, Mac OS X 10.4 or higher

Administrator rights are needed for the installation process.

Some LibreOffice features (wizards and the HSQLDB database engine) require that the Java
Runtime Environment (JRE) is installed on your computer. Although LibreOffice will work without
Java support, some features will not be available.

For a more detailed listing of requirements, see the LibreOffice website,
http://www.libreoffice.org/get-help/system-requirements/.

How to get the software

The software can be downloaded from http://www.libreoffice.org/download. You can also download
the software by using a Peer-to-Peer client, such as BitTorrent, at the same address.

Linux users will find LibreOffice included in many of the latest Linux distributions; Ubuntu is just
one example.

How to install the software

Information on installing and setting up LibreOffice on the various supported operating systems is
given here: http://www.libreoffice.org/get-help/install-howto/.

Extensions and add-ons

Extensions and add-ons are available to enhance LibreOffice. Several extensions are installed with
the program and you can get others from the official extensions repository,
http://extensions.libreoffice.org/. See Chapter 14 Customizing LibreOffice for more information on
installing extensions and add-ons.

Starting LibreOffice

The most common way to launch any component of LibreOffice is by using the system menu, the
standard menu from which most applications are started. On Windows, it is called the Start menu.
On GNOME, it is called the Applications menu. On KDE it is identified by the KDE logo. On Mac
OS X, itis the Applications menu. On Windows 8 you will see tiles on the Start screen, which has
replaced the Start menu.

When LibreOffice was installed on your computer, a menu entry for LibreOffice and each
LibreOffice component was added to your system menu if your computer uses a Linux or Windows
operating system. On computers operating Mac OS X, only a menu entry for LibreOffice is added
to the Applications menu.

Clicking on the LibreOffice menu entry or tile opens the LibreOffice Start Center (Figure 2) from
where you can select the individual components of LibreOffice. You can also select to open an
existing file or use a template.
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Figure 2: LibreOffice Start Center
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Starting from an existing document

You can start LibreOffice by double-clicking the filename of an ODF document in a file manager
such as Windows Explorer. The appropriate component of LibreOffice will start and the document
will be loaded.

If Microsoft Office is installed on your computer and you have associated Microsoft Office file types
with LibreOffice, when you double-click on the file:

* For a Word file (*.doc or *.docx), it opens in Writer.
* For an Excel file (*.xls or *.xlIsx), it opens in Calc.
* For a PowerPoint file (*.ppt or *.pptx), it opens in Impress.

If you did not associate the file types and Microsoft Office is installed on your computer, then when
you double-click on a Microsoft Office file, it opens using the appropriate Microsoft Office
component.

For more information on opening files, see “Opening existing documents” on page 26.

Quickstarter

When LibreOffice is installed on computers running Windows or Linux, a Quickstarter feature may
also be installed. When Quickstarter is activated, the necessary library files are loaded when the
computer system is started, resulting in a shorter startup time for LibreOffice components.

Computers with a Mac operating system do not have a Quickstarter.
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Activating Quickstarter

On computers operating a Linux or Windows operating system, the default installation of
LibreOffice does not set the Quickstarter to load automatically. To activate it:

8) Open LibreOffice.

9) Go to Tools > Options > LibreOffice > Memory on the menu bar and select Load
LibreOffice during system start-up (if using Windows) or select Enable systray Quickstarter
(if using Linux).
10) Close and restart LibreOffice to have Quickstarter appear.

Using Quickstarter on Windows or Linux

\]
After Quickstarter has been activated, an icon D is installed into the system tray at the bottom of
the display. Quickstarter is then available at all times, whether LibreOffice is open or not.
To start a LibreOffice component directly by using Quickstarter:
1) Right-click the Quickstarter icon in the system tray to open a pop-up menu (Figure 3).

2) Select the LibreOffice component you want to open to create a new document, or select
From Template to open the Template Manager, or select Open Document to open an
existing document.

@ Text Document

Spreadsheet
Prezentation

@ Drawing
Database

@ Formula

@ From Template...

, Open Document...

v Load LibreOffice During Systermn Start-Up

Bxit Quickstarter
Figure 3: Quickstarter menu in Windows

Disabling Quickstarter

To temporarily close Quickstarter on a computer using a Windows operating system, right-click on
the Quickstarter icon in the system tray and select Exit Quickstarter in the pop-up menu.
However, when the computer is restarted, Quickstarter will be loaded again.

To prevent the Quickstarter from loading during system startup, do one of the following:

* Right-click on the Quickstarter icon and deselect Load LibreOffice during system start-
up on the pop-up menu (on Windows) or select Disable systray Quickstarter (on Linux).

* Goto Tools > Options > LibreOffice > Memory on the menu bar and deselect Load
LibreOffice during system start-up (on Windows) or deselect Enable systray
Quickstarter on Linux.

Reactivating Quickstarter

If Quickstarter has been disabled, you can reactivate it by using the instructions given in
“Activating Quickstarter” above.
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Parts of the main window

The main window is similar for each component of LibreOffice, although some details vary. See the
relevant chapters in this guide about Writer, Calc, Draw, and Impress for descriptions of those
details.

Common features include the menu bar, standard toolbar, and formatting toolbar at the top of the
window and the status bar at the bottom.

Menu bar

The menu bar is located across the top of the LibreOffice window, just below the title bar. When
you select one of the menus listed below, a sub-menu drops down to show commands.

* File — contains commands that apply to the entire document such as Open, Save, and
Export as PDF.

* Edit — contains commands for editing the document such as Undo: xxx (where xxx is the
command to undo) and Find & Replace. It also contains commands to cut, copy, and paste
selected parts of your document.

* View — contains commands for controlling the display of the document such as Zoom and
Web Layout.

* Insert — contains commands for inserting elements into your document such as Headetr,
Footer, and Picture.

* Format — contains commands, such as Styles and Formatting and AutoCorrect, for
formatting the layout of your document.

¢ Table — contains all commands to insert and edit a table in a text document.
* Tools — contains functions such as Spelling and Grammar, Customize, and Options.
* Window — contains commands for the display window.

* Help - contains links to the LibreOffice Help file, What's This?, and information about the
program.

Toolbars

LibreOffice has two types of toolbars: docked (fixed in place) and floating. Docked toolbars can be
moved to different locations or made to float, and floating toolbars can be docked.

In a default LibreOffice installation, the top docked toolbar, just under the menu bar, is called the
Standard toolbar. It is consistent across the LibreOffice applications.

The second toolbar at the top, in a default LibreOffice installation, is the Formatting bar. It is
context-sensitive; that is, it shows the tools relevant to the current position of the cursor or the
object selected. For example, when the cursor is on a graphic, the Formatting bar provides tools
for formatting graphics; when the cursor is in text, the tools are for formatting text.

Displaying or hiding toolbars
To display or hide toolbars, go to View > Toolbars on the main menu bar, then click on the name

of a toolbar from the drop-down list. An active toolbar shows a check-mark beside its name.
Toolbars created from tool palettes are not listed in the View menu.

To close a toolbar, click on the X on the right of the toolbar title or go to View > Toolbars on the
main menu bar and deselect the toolbar.
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Sub-menus and tool palettes

Toolbar icons with a small triangle to the right will display sub-menus, tool palettes, and alternative
methods of selecting items, depending on the icon.

Tool palettes can be made into a floating toolbar. Figure 4 shows an example of a tool palette from
the Drawing toolbar made into a floating toolbar. See “Moving toolbars” and “Floating toolbars”
below for more information on moving and floating these toolbars created from tool palettes.

Tool palette Floating toolbar
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floating toolbar from a tool palette

Figure 4: Example of tearing off a tool palette

Moving toolbars
Docked toolbars can be undocked and moved to a new docked position or left as a floating toolbar.

1) Move the mouse cursor over the toolbar handle, which is the small vertical bar to the left of
a docked toolbar and highlighted in Figure 5.

2) Hold down the left mouse button and drag the toolbar to the new location. The toolbar can
be docked in a new position at the top, sides or bottom of the main window, or left as a
floating toolbar.

3) Release the mouse button.

4) To move a floating toolbar, click on its title bar and drag it to a new floating location or dock
the toolbar at the top or bottom of the main window.

File Edit View i
* (B - =Y
@ |Default Style

Figure 5: Toolbar handles

You can also dock a floating toolbar by holding down the Ctrl key and double clicking

Note in the title bar of the toolbar.

Floating toolbars

LibreOffice includes several additional toolbars, whose default setting appear as floating toolbars in
response to the current position of the cursor or selection. You can dock these toolbars to the top
or bottom of the main window, or reposition them on your computer display (see “Moving toolbars”
above).
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Some of these additional toolbars are context sensitive and will automatically appear depending on
the position of the cursor. For example, when the cursor is in a table, a Table toolbar appears, and
when the cursor is in a numbered or bullet list, the Bullets and Numbering toolbar appears.

Customizing toolbars

You can customize toolbars in several ways, including choosing which icons are visible and locking
the position of a docked toolbar. You can also add icons and create new toolbars, as described in
Chapter 14 Customizing LibreOffice. To access the customization options for a toolbar, right-click in
an empty space between the icons on a toolbar to open a context menu as follows:

* To show or hide icons defined for the selected toolbar, click Visible Buttons. Visible icons
on a toolbar are indicated by an outline around the icon (Figure 6) or by a check mark
beside the icon, depending on your operating system. Select or deselect icons to hide or

show them on the toolbar.
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Figure 6: Selection of visible toolbar icons
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* Click Customize Toolbar to open the Customize dialog, see Chapter 14 Customizing
LibreOffice for more information.

* Click Dock Toolbar to dock the selected toolbar. By default, a toolbar will dock at the top of
the workspace. You can reposition the toolbar to a different docked position, see “Moving

toolbars” on page 22.

* Click Dock All Toolbars to dock all floating toolbars. By default, toolbars will dock at the
top of the workspace. You can reposition the toolbars to different docked positions, see
“Moving toolbars” on page 22.

¢ Click Lock Toolbar Position to lock a docked toolbar into its docked position.

* Click Close Toolbar to close the selected toolbar.
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Dockingl/floating dialogs

When dialogs open, they are floating dialogs, unless they have been docked when LibreOffice was
last opened. These floating dialogs can be docked by holding down the Ctrl key and double-
clicking in a vacant area near the icons at the top of the floating dialog. The dialog will then dock in
its last docked position on the workspace. After docking, you can resize the docked dialog and
reposition in a new docked position.

To undock a docked dialog and make it floating, hold down the Ctrl key and double-click in a
vacant area near the icons at the top of the docked dialog. Alternatively, click and hold in a vacant
area near the icons at the top of the docked dialog and drag it to a floating position.

Context menus

Context menus are a quick access to many menu functions and are opened by right-clicking on a
paragraph, graphic, or other object. When a context menu opens, the functions or options available
will be dependent on the object that has been selected. A context menu can be the easiest way to
reach a function, especially if you are not sure where a function is located in the menus or toolbars.

Status bar

The status bar is located at the bottom of the workspace provides information about the document
and convenient ways to quickly change some features. It is similar in Writer, Calc, Impress, and
Draw, but each LibreOffice component includes some component-specific items. An example of the
Writer status bar is shown in Figure 7.

Number of words Selection Object Zoom

and characters Language mode information slider
Page 9/264 76261 words, 430463 characters =~ OOoPageStyle  English (USA) Overwrite wf [ OOcNum 123:level1 [BBM - —+—C + 112%|
Page number and Page style Insert  Digital View Zoom
number of pages mode  signature layout percentage

Figure 7: Example status bar from Writer

Page, sheet, or slide number and page count
Shows the current page, sheet, or slide number and the total number of pages, sheets, or
slides in the document. Double-click on this field to open the Navigator. Other uses of this field
depend on the LibreOffice component.

Words and characters
Shows the total number of words and characters in the document or in the selection.

Page style or slide design
Shows the current page style or slide design. To edit the current page style or slide design,
double-click on this field.

Language
Shows the current language of the whole document.

Insert mode
Shows the type of insert mode the program is in. This field is blank if the program is in Insert
mode. Each time the Ins key is pressed the mode toggles between Insert and Overwrite.
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Unsaved changes
An icon appears here if changes to the document have not been saved.

Digital signature
If the document has been digitally signed, an icon shows here. You can double-click the icon to
view the certificate.

Object information
Displays information relevant to the position of the cursor or the selected element of the
document. Double-clicking in this area usually opens a relevant dialog.

View layout
Select between Single Page, Multiple Pages and Double Sided Pages on how your document
is displayed.

Zoom slider
Drag the Zoom slider, or click on the + and - signs to change the view magnification of your
document.

Zoom percentage
Indicates the magnification level of the document. Right-click on the percentage figure to open
a list of magnification values from which to choose. Double-clicking on this percentage figure
opens the Zoom & View Layout dialog.

Sidebar

To activate the Sidebar, select View > Sidebar from the Menu Bar. The sidebar is located on the
right side of the edit views of Writer, Calc, Impress, and Draw. It contains one or more panels,
based on the current document context. Panels are organized into decks. A tab bar on the right
side of the sidebar allows you to switch between different decks.

All components contain the Properties, Styles and Formatting, Gallery, and Navigator decks. Some
components have additional decks, such as Master Pages, Custom Animation, and Slide Transition
for Impress and Functions for Calc.

A panel is like a combination of a toolbar and a dialog. For example, you can freely mix working in
the main edit window to enter text and use the Properties panel in the sidebar to change text
attributes.

Tool bars and sidebar panels share many functions. For example, the buttons for making text bold
or italic exist in both the Formatting toolbar and the Properties panel.

For more detail, see the Sidebar explanation in the relevant LibreOffice component’s user guide.

Starting new documents

You can start a new, blank document in LibreOffice in several ways.

When LibreOffice is open but no document is open, the Start Center (Figure 2 on page 19) is
shown. Click one of the icons to open a new document of that type, or click the Templates icon to
start a new document using a template.

You can also start a new document in one of the following ways:
* Use File > New on the menu bar and select the type of document from the context menu.

* Use the keyboard shortcut Ctrl+N to create a new document. The type of document created
depends on which LibreOffice component is open and active. For example, if Calc is open
and active, a new spreadsheet is created.
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* Use File > Wizards on the menu bar and select the type of document from the context
menu.

* If a document is already open in LibreOffice, click the New icon on the Standard toolbar
and a new document of the same type is created in a new window. For example, if Calc is
open and active, a new spreadsheet is created. The New icon changes depending on
which component of LibreOffice is open.

* If a document is already open in LibreOffice, click on the small triangle to the right of the
New icon on the Standard toolbar and select the type of document from the context menu
that opens.

* On Windows or Linux, use the Quickstarter feature included with LibreOffice. See
“Quickstarter” on page 19 for more information.

If all documents are closed without closing LibreOffice, then the Start Center will be

Note displayed.

Opening existing documents

You can also open an existing document in one of the following ways:
* When no document is open, click Open File in the Start Center to reach the Open dialog.
* Go to File > Open on the menu bar the reach the Open dialog.
* Use the keyboard shortcut Ctr/+O to reach the Open dialog.

¢ [|f adocument is already open, click the Open icon on the Standard toolbar and select
from a list of available documents from the Open dialog.

¢ Click the small triangle to the right of the Open icon and select from a list of recently
opened documents.

* When no document is open, double-click on a thumbnail of recently opened documents
displayed in the Start Center. You can scroll up or down in the Start Center to locate a
recently opened document.

When using the Open dialog, navigate to the folder you want and select the file you want, and then
click Open. If a document is already open in LibreOffice, the second document opens in a new
window.

In the Open dialog, you can reduce the list of files by selecting the type of file you are looking for.
For example, if you choose Text documents as the file type, you will only see documents Writer
can open (including .odt, .doc, . txt); if you choose Spreadsheets, you will see .ods, .x1s,
and other files that Calc opens.

You can also open an existing document that is in a format that LibreOffice recognizes by double-
clicking on the file icon on the desktop or in a file manager such as Windows Explorer. LibreOffice
has to be associated with file types that are not ODF files for the appropriate LibreOffice
component to open.

You can choose whether to use the LibreOffice Open/Save dialogs or the ones
Note provided by your computer’s operating system. See “Open and Save As dialogs” on
page 29 for more information.
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Saving documents

You can save documents as follows:
e Save command — use if you are keeping the document, its current filename and location.

e Save As command — use if you want to create a new document, or change the filename
and/or file format, or save the file in a different location on your computer.

e Password protection — use if you want to restrict who can open and read the document, or
open and edit the document.

Save command

To save a document if you are keeping the document, its current filename and location, do one of
the following:

* Use the keyboard shortcut Ctr/+S.
¢ Go to File > Save on the main menu bar.

* Click the Save icon E on the Standard toolbar.

Using the Save command will overwrite the last saved version of the file.

Save As command

To save a document if you want to create a new document, or change the filename and/or file
format, or save the file in a different location on your computer:

* Use the keyboard shortcut Ctr/+Shift+S.
* Goto File > Save As on the main menu bar.

When the Save As dialog (Figure 8) or Save dialog opens, enter the file name, change the file type
(if applicable), navigate to a new location (if applicable), and click Save.

The dialog that opens when using the Save As command depends on the options that have been
set in LibreOffice. See “Open and Save As dialogs” on page 29 for more information.

@ saveas

[/home/peter =) @7 (By)

Places Title a Type Size Date modified

My Documents | B Desktop Folder 29/11/2011=
3 Documents Folder 13/01/201
3 Downloads Folder 09/01/201
3 Dropbox Folder 22/01/2011.
3 il pivo - wicked Game Folder 02/01/201
3 Music Folder 02/01/201
£3 Pictures Folder 17/01/201
£3 Public Folder 29/11/201

E] 3 Templates Folder 29/11/201%-
[ T | A T Foldae GLELENLT.TEN

File name: Untitied 1 [ P —
File type: |ODF Drawing (.odg) ™ E
. Help |

[] save with password [ Automatic file name extension

| Editfilter settings

Figure 8: Example of LibreOffice Save As dialog

Chapter 1 Introducing LibreOffice | 27



Password protection

To protect a document and restrict who can open and read the document, or open and edit the
document, you have to use password protection.

1) Using the Save As command above, select the Save with password option in the Save As
dialog or Save dialog.
2) Click Save and the Set Password dialog opens (Figure 9).
3) In File encryption password, enter a password to open the document and then enter the
same password as confirmation.
4) To restrict who can edit the document, click the More Options button. This button changes
to Fewer Options when clicked.
5) In File sharing password, select Open file read only and enter a password to allow editing
and then enter the same password as confirmation.
6) Click OK and the dialog closes. If the passwords match, the document is saved password
protected. If the passwords do not match, you receive an error message.
#® Set Password ]
File encryption password
Enter password ko open
Confirm password
MNote: After a password has been set, the document will only
open with the password. Should you lose the password,
there will be no way to recover the document. Please also
note that this password is case-sensitive.
(Feweroptions +| (NN |  concel |
File sharing password
[] open file read-only
Enter password ko allow editing
Confirm password
Figure 9: Set Password dialog
tion . , . . .
0 LibreOffice uses a very strong encryption mechanism that makes it almost

7\

impossible to recover the contents of a document if you lose or forget the password.
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Changing the password

When a document is password-protected, you can change the password while the document is
open. Go to File > Properties > General on the menu bar and click the Change Password button
in the Properties dialog. This opens the Set Password dialog where you can enter a new
password.

Saving documents automatically
LibreOffice can save files automatically as part of the AutoRecovery feature. Automatic saving,
like manual saving, overwrites the last saved state of the file. To set up automatic file saving:

1) Go to Tools > Options > Load/Save > General on the menu bar.

2) Select Save AutoRecovery information every and set the time interval.

3) Click OK.

Renaming and deleting files

You can rename or delete files within the LibreOffice dialogs, just as you can in a file manager.
Select a file and then right click to open a context menu. Select either Delete or Rename, as
appropriate. However, you cannot copy or paste files within the dialogs.

Open and Save As dialogs

You can choose whether to use the LibreOffice Open and Save As dialogs or the ones provided by
your operating system.

* To use LibreOffice dialogs for saving or opening files, go to Tools > Options > LibreOffice
> General and check the option Use LibreOffice dialog boxes. An example of a
LibreOffice dialog is shown in Figure 8 on page 27.

* To use the operating system dialogs for saving or opening files, go to Tools > Options >
LibreOffice > General and uncheck the option Use LibreOffice dialog boxes.

The three icons in the top right of the LibreOffice Open and Save As dialogs are as follows:

* Connect To Server u — a dialog opens allowing you to connect to a network server if
the file you want is not located on your computer.

* Up One Level l@_J — moves up one folder in the folder hierarchy. Click and hold the
mouse button on this icon to display a drop down a list of higher level folders. Move the
cursor over a higher level folder and release the mouse button to navigate to that folder

* Create New Folder lgj — creates a new sub-folder in the folder that is displayed in the
dialog.
Use the File type field to specify the type of file to be opened or the format of the file to be saved.
The Read-only option on the Open dialog opens the file for reading and printing only. Most of the

icons and most menu options are disabled on the toolbars. The Edit File icon becomes active
on the Standard toolbar. Click on this icon to open the file for editing.
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Using the Navigator

The LibreOffice Navigator lists objects contained within a document, collected into categories. For
example, in Writer it shows Headings, Tables, Text frames, Comments, Graphics, Bookmarks, and
other items, as shown in Figure 10. In Calc it shows Sheets, Range Names, Database Ranges,
Graphics, Drawing Objects, and other items. In Impress and Draw it shows Slides, Pictures, and
other items.

To open the Navigator, click the Navigator icon @ on the Standard toolbar, or press the F5 key,
or go to View > Navigator on the menu bar.

You can dock the Navigator to either side of the main LibreOffice window or leave it floating (see
“Docking/floating dialogs" on page 24 for more information).

Click the marker (+ or triangle) by any of the categories to display the list of objects in that
category.

| @ Navigator

o - N |z e -~
BE ¢ ZEE =
| E

EH Tables

[&] Text frames

ER Image

|k OLE objects

% Bookmarks

= Sections

@ Hyperlinks

£% References

%= Indexes

2] Comments

B Draw objects

-

4

| |Untitled1 (active) =

Figure 10: Navigator in Writer

The Navigator provides several convenient ways to move around a document and find items in it:

* When a category is showing the list of objects in it, double-click on an object to jump
directly to that object location in the document.

* Objects are much easier to find if you have given them recognizable names when creating
them, instead of keeping the LibreOffice default names, for example Sheetl, Tablel,
Table2, and so on. The default names may not correspond to the actual position of the
object in the document.

* Each Navigator in the individual LibreOffice components has a different range of functions
and these functions are further explained in the appropriate user guides for each
LibreOffice component.
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Undoing and redoing changes

To undo the most recent change in a document, use the keyboard shortcut Ctr/+Z, or click the

Undo icon E_P] on the Standard toolbar, or go to Edit > Undo on the menu bar. Click the small
triangle to the right of the Undo icon to get a list of all the changes that can be undone. You can
select multiple changes and undo them at the same time.

After changes have been undone, you can redo changes. To redo a change use the keyboard

shortcut Ctrl+Y, or click the Redo icon @ or go to Edit > Redo on the menu bar. As with Undo,
click on the triangle to the right of the arrow to get a list of the changes that can be reapplied.

To modify the number of changes LibreOffice remembers, go to Tools > Options > LibreOffice >
Memory on the menu bar. In the Undo section increase or decrease the Number of steps. Be
aware that asking LibreOffice to remember more changes consumes more computer memory.

Closing a document

If only one document is open and you want to close that document, go to File > Close on the
menu bar or click on the X on the right side of the menu bar. The document closes and the
LibreOffice Start Center opens.

If more than one document is open and you want to close one of them, go to File > Close on the
menu bar or click on the X on the title bar of that document’s window. The X may be located on
either the right or left end of the title bar.

If the document has not been saved since the last change, a message box is displayed. Choose
whether to save or discard your changes.

Caution . :
j Not saving your document could result in the loss of recently made changes, or

worse still, the entire file.

Closing LibreOffice

To close LibreOffice completely, go to File > Exit on the menu bar in Windows and Linux operating
systems. In a Mac operating system, go to LibreOffice > Quit LibreOffice on the menu bar.

When you close the last document using the X on the Title bar of the window, then LibreOffice will
close completely. A Mac operating system does not have this function; instead, you need to go to
LibreOffice > Quit LibreOffice on the menu bar.

You can also use a keyboard shortcut as follows:
* In Windows and Linux — Ctrl+Q
* In Mac OS X — Command $+Q

If any documents have not been saved since the last change, a message box is displayed. Choose
whether to save or discard your changes.
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Choosing options for all of LibreOffice

This section covers some of the settings that apply to all the components of LibreOffice. For
information on settings not discussed here, see the Help.

Click Tools > Options. The list in the left-hand box of the Options — LibreOffice dialog varies
depending on which component of LibreOffice is open. The illustrations in this chapter show the list
as it appears when a Writer document is open.

Click the marker (+ or triangle) by LibreOffice on the left-hand side. A list of pages drops down.
Selecting an item in the list causes the right-hand side of the dialog to display the relevant page.

v LibreOffice

General

Memory

View

Print

Paths

Colors

Fonts

Security

Personalization

Appearance

Accessibility

Advanced

Basic IDE Options

Online Update
» Load/Save

Figure 11: LibreOffice options

The Revert button, located in the lower right of the full Options dialog, has the same
Note effect on all pages of the dialog. It resets the options to the values that were in place
when you opened the dialog.

If you are using a version of LibreOffice other than US English, some field labels may be different
from those shown in the illustrations.

User Data options

Because LibreOffice can use the name or initials stored in the LibreOffice — User Data page for
several things, including document properties (created by and last edited by information) and the
name of the author of comments and changes, you will want to ensure that the correct information
appears here.

Fill in the form (not shown here), or amend or delete any existing information. If you do not want
user data to be part of the document’s properties, clear the box at the bottom.
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General options

The options on the LibreOffice — General page are described below.

Help
™ Tips [ | Extended tips

Open/5Save dialogs
M Use LibreOffice dialogs

Document status
| Printing sets "document modified" status

Allow to save document even when the document is not modified

Year (two digits)

Interpret as years between 1930 and 2029

Figure 12: Setting general options for LibreOffice

Help - Tips
When Tips is active, one or two words will appear when you hold the mouse pointer over an
icon or field, without clicking.

Help - Extended tips
When Extended tips is active, a brief description of the function of a particular icon or menu
command or a field on a dialog appears when you hold the mouse pointer over that item.

Open/Save dialogs — Use LibreOffice dialogs
To use the standard Open and Save dialogs for your operating system, deselect the Use
LibreOffice dialogs option. When this option is selected, the Open and Save dialogs supplied
with LibreOffice will be used. See Chapter 1, Introducing LibreOffice, for more about the
LibreOffice Open and Save dialogs. This book uses the LibreOffice Open and Save dialogs in
illustrations.

Document status - Printing sets “document modified” status
If this option is selected, then the next time you close the document after printing, the print date
is recorded in the document properties as a change and you will be prompted to save the
document again, even if you did not make any other changes.

Document status - Allow to save document even when the document is not modified
Normally when a document has not been modified, the File > Save menu option and the Save
button on the Standard toolbar are disabled and the keyboard shortcut Ctr/+S has no effect.
Select this option to allow documents to be saved even when they have not been modified.

Year (two digits)
Specifies how two-digit years are interpreted. For example, if the two-digit year is set to 1930,
and you enter a date of 1/1/30 or later into your document, the date is interpreted as 1/1/1930
or later. An “earlier” date is interpreted as being in the following century; that is, 1/1/20 is
interpreted as 1/1/2020.
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Memory options

The options on the LibreOffice — Memory page control how LibreOffice uses your computer’s
memory and how much memory it requires. Before changing them, you may wish to consider the
following points:

* More memory can make LibreOffice faster and more convenient (for example, more undo
steps require more memory); but the trade-off is less memory available for other
applications and you could run out of memory altogether.

* If your documents contain a lot of objects such as images, or the objects are large,
LibreOffice’s performance may improve if you increase the memory for LibreOffice or the
memory per object. If you find that objects seem to disappear from a document that
contains a lot of them, increase the number of objects in the cache. (The objects are still in
the file even if you cannot see them on screen.)

* To load the Quickstarter when you start your computer, select the option near the bottom of
the dialog. This makes LibreOffice start faster; the trade-off is LibreOffice uses some
memory even when not being used. This option is called Enable systray quickstarter on
Linux. It is not available on Mac OS X or on systems where the Quickstarter module has
not been installed.

Undao

4k

Mumber of steps 100

Graphics cache

Use for LibreOffice 20 | MB
Memaory per object 5.2 1| MBE
Remove from memory after 0010 | > hh:mm

Cache for inserted objects

4|k

Murnber of objects 20

LibreQffice Quickstarter
| Load LibreOffice during system start-up

Figure 13: Choosing Memory options for the LibreOffice applications

View options

The options on the LibreOffice — View page affect the way the document window looks and
behaves. Some of these options are described below. Set them to suit your personal preferences.

User Interface — Scaling
If the text in the help files or on the menus of the LibreOffice user interface is too small or too
large, you can change it by specifying a scaling factor. Sometimes a change here can have
unexpected results, depending on the screen fonts available on your system. However, it does
not affect the actual font size of the text in your documents.

User Interface - Icon size and style
The first box specifies the display size of toolbar icons (Automatic, Small, or Large). The
Automatic icon size option uses the setting for your operating system. The second box
specifies the icon style (theme); here the Automatic option uses an icon set compatible with
your operating system and choice of desktop: for example, KDE or Ghome on Linux.

User Interface — Use system font for user interface
If you prefer to use the system font (the default font for your computer and operating system)
instead of the font provided by LibreOffice for the user interface, select this option.
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User Interface Graphics output

Use hardware acceleration
™ Use Anti-Aliasing

Scaling 100% | 3]

lcon size and style

[Small 4| |Automatic (Tango) +

Menu

™ Use system font for user interface lcons in menus

_Automatic )

(¥ Screen font antialiasing

from 8 pixels E] romg Listy
[ | Show preview of fonts
Mouse ( Show font history

Mouse positioning
Selection
|Ne automatic positioning =

g

™ Transparency
Middle Mouse button

| Automatic scrolling =

Figure 14: Choosing View options for LibreOffice applications

User interface — Screen font anti-aliasing
(Not available in Windows.) Select this option to smooth the screen appearance of text. Enter
the smallest font size to apply anti-aliasing.

Menu - icons in menus
Causes icons as well as words to be visible in menus.

Font Lists — Show preview of fonts
Causes the font list to look like Figure 15, Left, with the font names shown as an example of
the font; with the option deselected, the font list shows only the font names, not their formatting
(Figure 15, Right). The fonts you will see listed are those that are installed on your system.

Fonts which are tuned for use with a specific script, such as Arabic, Hebrew, Malayalam, and
so on, now show an additional preview of some sample text in the target script.

Liberation Sans| 11 ldl B _.!r Ll = |z Liberation Sansl 11
Liberation Mono & Liberation Mono

. . | Liberation Sans
Liberation Sans Liberation Sans Marrow

i d Liberation Serif
LI.bEFEL'[IIIJH SElFISI Marrow Liffey Script 5F
Liberation Serif LilyuPC

o . Linux Biolinum G
ey o oFgF

il Linux Libertine G

LivUPC JTiusing Lucida Bright

. - Lucida Calligraph
Linux Biolinum G Lucida c-:.ngnlep Y
Linux Libertine G Lucida Fax

i i Lucida Handwriting
Lucida Bright Lucida Sans
Fuc Edfﬁl Caﬂig?aﬁ ﬁy Lucida Sans Typewriter
. Lucida Sans Unicode

Lucida Console W Mackintosh SF

Figure 15: Font list (Left) With preview; (Right) Without preview
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Font Lists — Show font history
Causes the last five fonts you have assigned to the current document to be displayed at the top
of the font list. Otherwise fonts are shown in alphabetical order.

Graphics output — Use hardware acceleration
Directly accesses hardware features of the graphical display adapter to improve the screen
display. Not supported on all operating systems and LibreOffice distributions.

Graphics output — Use anti-aliasing
Enables and disables anti-aliasing, which makes the display of most graphical objects look
smoother and with fewer artifacts. Not supported on all operating systems and LibreOffice
distributions.

Ti Press Shift+Ctrl+R to restore or refresh the view of the current document after
p changing the anti-aliasing settings, to see the effect.
Mouse positioning

Specifies if and how the mouse pointer will be positioned in newly opened dialogs.

Middle mouse button
Defines the function of the middle mouse button.

* Automatic scrolling — dragging while pressing the middle mouse button shifts the view.

¢ Paste clipboard — pressing the middle mouse button inserts the contents of the “Selection
clipboard” at the cursor position.

The “Selection clipboard” is independent of the normal clipboard that you use by Edit >
Copyl/Cut/Paste or their respective keyboard shortcuts. Clipboard and “Selection clipboard”
can contain different contents at the same time.

Function Clipboard Selection clipboard

Copy content Edit > Copy Ctrl+C Select text, table, or object.

Paste content Edit > Paste Ctr/+V pastes at Clicking the middle mouse button
the cursor position. pastes at the mouse pointer position.

Pasting into another No effect on the clipboard The last marked selection is the

document contents. content of the selection clipboard.

Selection - Transparency
Determines the appearance of selected text or graphics, which appear on a shaded
background. To make the shaded background more or less dark, increase or decrease the
Transparency setting.

If you prefer selected material to appear in reversed color (typically white text on a black
background), deselect this option.

Print options

On the LibreOffice — Print page, set the print options to suit your default printer and your most
common printing method. Most of these options should be self-explanatory.

The option PDF as Standard Print Job Format is not available on Windows. Select this option to
change the internal print job format from a Postscript document description to a PDF description.
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This format has a number of advantages over Postscript. For more information, see
http://www.linuxfoundation.org/collaborate/workgroups/openprinting/pdf_as_standard_print_job_format

Deselecting this option reverts to the Postscript document workflow system.

Reduce print data

Settings for: (s) Printer () Print to file
¥ Reduce transparency ™ Reduce gradient
(*) Automatically (s) Gradient stripes |64 |

() No transparenc i
. p Y () Intermediate color

¥ Reduce bitmaps | | Convert colors to grayscale
() High print quality
() Normal print quality
(*) Resolution |200 DPI (default)
# Include transparent objects
(¥ PDF as Standard Print Job Format

Printer warnings
[ | Paper size v/ Transparency

| Paper orientation

Figure 16: Choosing general printing options to apply to all LibreOffice components

In the Printer warnings section near the bottom of the page, you can choose whether to be warned
if the paper size or orientation specified in your document does not match the paper size or
orientation available for your printer. Having these warnings turned on can be quite helpful,
particularly if you work with documents produced by people in other countries where the standard
paper size is different from yours.

If your printouts are incorrectly placed on the page or chopped off at the top, bottom,
Tip or sides, or the printer is refusing to print, the most likely cause is page size
incompatibility.

Paths options

On the LibreOffice — Paths page, you can change the location of files associated with, or used by,
LibreOffice to suit your working situation. In a Windows system, for example, you might want to
store documents by default somewhere other than My Documents.

To make changes, select an item in the list shown in Figure 17 and click Edit. On the Select Path
dialog (not shown; may also be titled Edit Paths), add or delete folders as required, and then click
OK to return to the Options dialog. Note that some items can have at least two paths listed: one to
a shared folder (which might be on a network) and one to a user-specific folder (normally on the
user’s personal computer).

You can use the entries on the LibreOffice — Paths page to compile a list of files,
Tip such as those containing AutoText, that you need to back up or copy to another
computer.
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Type
AutoCorrect
AutoText
Backups
Dictionaries
Gallery
Images

Templates

My Documents

Paths used by LibreOffice

Path

[Users/jean/Library/Application Support/LibreOffice/4 fuser/autocorr
[Users/jean/Library/Application Support/LibreOffice/4 fuser/autotext
[Users/jean/Library/Application Support/LibreOffice/4 fuser/backup
{Users/jean/Library/Application Support/LibreOffice/4 fuser/wordbook
[Users/jean/Library/Application Support/LibreOffice/4 fuser/gallery
{Users/jean/Library/Application Support/LibreOffice/4 fuser/gallery
[Users/jean/Documents

/Applications/LibreOffice.app/Contents /MacQ5/../share/template /commao

Tempoaorary files /Users/jean/Library/Application Support/LibreOffice/4 fuser/temp

Figure 17: Viewing the paths of files used by LibreOffice

Color options
On the LibreOffice — C

olors page, you can specify colors to use in LibreOffice documents. You can
select a color from a color table, edit an existing color, and define new colors. These colors are

stored in your color palette and are then available in all components of LibreOffice.

To modify a color:

1) Select the color to modify from the list or the color table.

2) Enter the new values that define the color. You can choose the RGB (Red, Green, Blue) or
the CMYK (Cyan, Magenta, Yellow, Black) system to specify your color. The changed color
appears in the lower of the two color preview boxes at the top.

3) Modify the Name as required.

4) Click the Modify button. The newly defined color is now listed in the Color table.

Properties
Mame Blue 8
Color | Blue8 [=]
Color table
HEREEEREN -
[ Rce 7]
1] R 153 2
HEEEREEN A
EEEEEEEE ¢ ¢ C
HEERERERC & = 2
SEEEEEE
HEREEN

Figure 18: Defining colors to use in color palettes in LibreOffice

Alternatively, click the Edit button to open the Color Picker dialog, shown in Figure 19. Here you
the window on the left, or you can enter values on the right using your

can select a color from

choice of RGB, CMYK,

or HSB (Hue, Saturation and Brightness) values.
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x Color Picker
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O Blue 200
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Figure 19: Editing colors

The color window on the left is linked directly with the color input fields on the right; as you choose
a color in the window, the numbers change accordingly. The color field at the lower left shows the

value of the selected color on the left and the currently set value from the color value fields on the
right.

Modify the color components as required and click OK to exit the dialog. The newly defined color
now appears in the lower of the color preview boxes shown in Figure 18. Type a name for this color
in the Name box, then click the Add button. A small box showing the new color is added to the
Color table.

Another way to define or alter colors is through the Colors page of the Area dialog, where you can
also save and load palettes, a feature that is not possible here. In Calc, draw a temporary draw
object and use the context menu of this object to open the Area dialog. If you load a palette in one
component of LibreOffice, it is only active in that component; the other components keep their own
palettes.

Fonts options

You can define replacements for any fonts that might appear in your documents. If you receive
from someone else a document containing fonts that you do not have on your system, LibreOffice
will substitute fonts for those it does not find. You might prefer to specify a different font from the
one that the program chooses.

On the LibreOffice — Fonts page:

1) Select the Apply Replacement Table option.

2) Select or type the name of the font to be replaced in the Font box. (If you do not have this
font on your system, it will not appear in the drop-down list in this box, so you need to type
itin.)

3) In the Replace with box, select a suitable font from the drop-down list of fonts installed on
your computer.
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Replacement table

Font Replace with
Likeration Sans v | |Open Sans W 58
Always Screen only | Font Replace with

Liberation Sans Open Sans -

Apply replacement table

Font settings for HTML, Basic and SQL sources

Fonts |Autumatic W

Neon-proportional fonts only
Size |10 v

Figure 20: Defining a font to be substituted for another font

4) The check mark to the right of the Replace with box turns green. Click on this check mark.
A row of information now appears in the larger box below the input boxes. Select Always to
replace the font, even if the original font is installed on your system. Select Screen only to
replace the screen font only and never replace the font for printing. The results of
combining these selections are given in Table 2.

5) In the bottom section of the page, you can change the typeface and size of the font used to
display source code such as HTML and Basic (in macros).

Table 2. Font substitution replacement actions

Always Screen only Replacement action

checkbox checkbox

checked blank Font replacement on screen and when printing, whether the font is
installed or not.

checked checked Font replacement only on screen, whether the font is installed or not.

blank checked Font replacement only on screen, but only if font is not available.

blank blank Font replacement on screen and when printing, but only if font is not
available.

Security options

Use the LibreOffice — Security page to choose security options for saving documents and for
opening documents that contain macros.
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Security options and warnings

Adjust security related options and define warnings for hidden Ooti
. A ptions...
information in documents.

Passwords for web connections

Persistently save passwords for web connections
Connections...
Protected by a master password (recommended)

Passwords are protected by a master password. You will be
asked to enter it once per session, if LibreOffice retrieves a Master Password...
password from the protected password list.

Macro security

Adjust the security level for executing macros and specify trusted Macro Security...
macro developers.

Certificate Path

Select the Network Security Services certificate directory to use

for digital signatures. Certificate...

Figure 21: Choosing security options for opening and saving documents

Security options and warnings
If you record changes, save multiple versions, or include hidden information or notes in your
documents, and you do not want some of the recipients to see that information, you can set
warnings to remind you to remove it, or you can have LibreOffice remove some of it
automatically. Note that (unless removed) much of this information is retained in a file whether
the file is in LibreOffice’s default OpenDocument format, or has been saved to other formats,
including PDF.

Click the Options button to open a separate dialog with specific choices (Figure 23). See
“Security options and warnings” below.

Passwords for web connections
You can enter a master password to enable easy access to websites that require a user name
and password. If you select the Persistently save passwords for web connections option, a
new dialog opens (Figure 22). LibreOffice will securely store all passwords that you use to
access files from web servers. You can retrieve the passwords from the list after you enter the
master password.

Macro security
Click the Macro Security button to open the Macro Security dialog (not shown here), where
you can adjust the security level for executing macros and specify trusted sources.

Certificate Path

This option appears only on Linux and Mac systems. On Windows, LibreOffice uses
Note the default Windows location for storing and retrieving certificates.

Users can digitally sign documents using LibreOffice. A digital signature requires a personal
signing certificate. Most operating systems can generate a self-signed certificate. However, a
personal certificate issued by an outside agency (after verifying an individual's identity) has a
higher degree of trust associated with it than does a self-signed certificate. LibreOffice does not
provide a secure method of storing these certificates, but it can access certificates that have
been saved using other programs. Click Certificate and select which certificate store to use.
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(& 00 Set Master Password

Passwords for web connections are protected by a master
password. You will be asked to enter it once per session, if
LibreOffice retrieves a password from the protected password
list.

Enter password:

Reenter password:

Caution: If you forget the master password, you will be
unable to access any of the information protected by it.
Passwords are case sensitive.

|  Help | OK | Cancel |

Figure 22: Set Master Password dialog for web connections

Security options and warnings
The following options are on the Security options and warnings dialog (Figure 23).

Remove personal information on saving
Select this option to always remove user data from the file properties when saving the file. To
manually remove personal information from specific documents, deselect this option.

Ctrl-click required to follow hyperlinks
The default behavior in LibreOffice is to Ctrl+click on a hyperlink to open the linked document.
Many people find creation and editing of documents easier when accidental clicks on links do
not activate the links. To set LibreOffice to activate hyperlinks using an ordinary click, deselect
this option.

The other options on this dialog should be self-explanatory.

Security warnings
Warn if document contains recorded changes, versions, hidden information or notes:
[ ]:When saving or sending: When signing
[ ] When printing [ | When creating PDF files

Security options
[] Remove personal information on saving
[ ] Recornmend password protection on saving
Ctrl-click required to follow hyperlinks

[] Bleck any links frem decuments not ameng the trusted locations (see Macre Security]

OK Cancel Help

Figure 23: Security options and warnings dialog
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Personalization

You can customize the overall appearance of LibreOffice with themes designed for Mozilla Firefox.
On the LibreOffice — Personalization page (left side of Figure 24), select either of the themes
options and then click Select Theme, the dialog shown on the right opens. Click Visit Firefox
Themes to open the Firefox theme page in the default web browser (an internet connection is
required). Select a theme, copy the contents of the browser's address bar, and paste the address
into the Theme address field.

First visit Firefox Themes
(https://addons.mozilla.org/firefox/themes). Find
the Theme you like, and want to choose for

Firefox Themes LibreOffice.
lain look, do not use Themes
Oe k Visit Firefox Themes!
(O Pre-installed Theme (if available)
@ Own Theme Select Theme Then, in your web browser's location bar, copy the

address of the page that contains the Theme to
clipboard, and paste it to the input field below.

Theme address:

\https:,’,a’addons.moziIIa.orgffirefox!themesf l

OK Cancel Help

Figure 24: Personalization dialogs

Click OK and after a brief pause the appearance of LibreOffice will refresh and reflect the selected
theme. An example is shown in Figure 25. For full details about themes, visit the Mozilla website:
https://www.addons.mozilla.org/firefox/themes

File Edit View |nsert Format Table Jools Window Help .
B-3-aBe P aar $E L G- B 6 5 = =S80 L2 i R E R R
M 00oTextBody v | |Liberation Sans v (11 « "By E! = !

Figure 25: Sample personalized theme

Appearance options

Writing, editing, and (especially) page layout are often easier when you can see the page margins
(text boundaries), the boundaries of tables and sections (in Writer documents), page breaks in
Calc, grid lines in Draw or Writer, and other features. In addition, you might prefer to use colors that
are different from LibreOffice’s defaults for such items as comment indicators or field shadings.

On the LibreOffice — Appearance page (Figure 26), you can specify which items are visible and the
colors used to display various items.

* To show or hide items such as text boundaries, select or deselect the options next to the
names of the items.

* To change the default colors for items, click the down-arrow in the Color Setting column by
the name of the item and select a color from the list box. Note that you can change the list
of available colors as described in “Color options” on page 40.

* To save your color changes as a color scheme, click Save, type a name in the Scheme
box, and then click OK.
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Color scheme

Scheme LibreQffice |

Custom colors

On |User interface elements | Color setting |Preview |
General i
Diocument background [ automatic | » I:I

Text boundaries [ automatic |» I:I
Application background [ automatic | I:I

Object boundaries [ automatic | I:I

Table boundaries [ automatic | I:I
Font color I :utomatic [+ -

[ Unvisited links m cutomatic [~ [

1 whicismd liclen j— . e

Figure 26: Showing or hiding text, object, and table boundaries

Accessibility options

Accessibility options include whether to allow animated graphics or text, how long help tips remain
visible, some options for high contrast display, and a way to change the font for the user interface
of the LibreOffice program.

Accessibility support relies on the Java Runtime Environment for communication with assistive
technology tools. The Support assistive technology tools option is not shown on all LibreOffice
installations. See Assistive Tools in LibreOffice in the Help for other requirements and information.

Select or deselect the options as required.

Miscellanecus options

Support assistive technology tools (program restart required)
Use text selection curser in read-only text documents
| Allow animated graphics

| Allow animated text

J| Help tips disappear after 4 = 1| seconds

Options for high contrast appearance

| Autornatically detect high contrast mode of operating system
Use automatic font color for screen display

| Use systern colors for page previews

Figure 27: Choosing accessibility options
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Advanced options

Java options
If you install or update a Java Runtime Environment (JRE) after you install LibreOffice, or if you
have more than one JRE installed on your computer, you can use the LibreOffice — Advanced
options page to choose the JRE for LibreOffice to use.

If you are a system administrator, programmer, or other person who customizes JRE
installations, you can use the Parameters and Class Path pages (reached from the Java page)
to specify this information.

If you do not see anything listed in the middle of the page, wait a few minutes while LibreOffice
searches for JREs on the hard disk.

If LibreOffice finds one or more JREs, it will display them there. You can then select the Use a
Java runtime environment option and (if necessary) choose one of the JREs listed.

Java options
[ Use a Java runtime environment
Java runtime environments (JRE) already installed:

Vendor Version Features Add...
(») Apple Inc. 1.6.0_65
Parameters...
Class Path...

Location: [System/Library/)ava/JavaVirtualMachines/1.6.0.jdk/Contents/Home

Optional (unstable) options
[V Enable experimental features

[ Enable macro recording (limited)

Expert Configuration

Figure 28: Choosing a Java runtime environment

Optional (unstable) options

Enable experimental features
Selecting this option enables features that are not yet complete or contain known bugs. The list
of these features is different version by version.

Enable macro recording (limited)
This option enables macro recording with some limitations. Opening a window, switching
between windows, and recording in a different window to that in which the recording began, is
not supported. Only actions relating to document contents are recordable, so changes in
Options or customizing menus are not supported. For more about macro recording, see
Chapter 13, Getting Started with Macros.

Expert Configuration
Most users will have no need to use this. Click the Expert Configuration button to open a new
window in which you can fine-tune the LibreOffice installation. The page offers detailed
configuration options for many aspects of LibreOffice's appearance and performance. Double-
click on a listed preference to enter a value to configure the preference.
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Basic IDE options

The Basic IDE Options are available after Enable experimental features has been selected on
the Advanced page of the Options dialog and the options have been saved. These options are for
macro programmers and are not discussed here.

Code Completion

[ | Enable Code Completion

Code Suggestion
Autocorrection
| Autoclose Quotes
[ | Autoclose Parenthesis

| Autoclose Procedures

Language Features
| Use extended types

Figure 29: Basic IDE Options dialog

Online update options

On the LibreOffice — Online Update page (Figure 30), you can choose whether and how often to
have the program check the LibreOffice website for program updates. If the Check for updates
automatically option is selected, an icon appears at the right-hand end of the menu bar when an
update is available. Click this icon to open a dialog where you can choose to download the update.

If the Download updates automatically option is selected, the download starts when you click the
icon. To change the download destination, click the Change button and select the required folder in
the file browser window.

Online Update Options
| Check for updates automatically

Every Day
Every Week
@ Every Month

Last checked: 08/25/10, 05:27:00 PP

Check now

Download updates automatically

Download destination:

ChUsersiJared\Desktop Change...

Figure 30: Online update options
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Choosing Load/Save options

You can set the Load/Save options for loading and saving documents to suit the way you work.

If the Options dialog is not already open, click Tools > Options. Click the expansion symbol (+ or
triangle) to the left of Load/Save.

General

Most of the choices on the Load/Save — General page are familiar to users of other office suites.
Some items of interest are described below.

Load
[ Load user-specific settings with the document
[ Load printer settings with the document

Save

™ Save AutoRecovery information every |15 Minutes

Automatically save the document too
Edit document properties before saving
Always create backup copy
™ Save URLs relative to file system
LE] Save URLs relative to internet
Default file format and ODF settings

ap

ODF format version: | 1.2 Extended (recommended)

™ Warn when not saving in ODF or default format

ar

Document type: Text document

ar

Always save as: ODF Text Document

Figure 31: Choosing Load and Save options

Load user-specific settings with the document
A LibreOffice document contains certain settings that are read from the user’s system. When
you save a document, these settings are saved with it.

Select this option so that when a document loads, it ignores the stored settings in favor of the
settings on your computer.

Even if you do not select this option, some settings are taken from your LibreOffice installation:
e Settings available in File > Print > Options
* Name of Fax
* Spacing options for paragraphs before text tables
¢ Information about automatic updating for links, field functions and charts
* Information about working with Asian character formats.

The following setting is always loaded with a document, whether or not this option is marked:
e Data source linked to the document and its view.

If you deselect this option, the user’s personal settings do not overrule the settings in the

document. For example, your choice (in the options for LibreOffice Writer) of how to update
links is affected by the Load user-specific settings option.
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Load printer settings with the document
If enabled, the printer settings will be loaded with the document. This can cause a document to
be printed on a distant printer (perhaps in an office setting), if you do not change the printer
manually in the Print dialog. If disabled, your standard printer will be used to print this
document. The current printer settings will be stored with the document whether or not this
option is selected.

Save AutoRecovery information every __ Minutes
Choose whether to enable AutoRecovery and how often to save the information used by the
AutoRecovery process.

AutoRecovery in LibreOffice saves the information needed to restore all open documents in
case of a crash. If you have this option set, recovering your document after a system crash will
be easier.

Automatically save the document too
Specifies that LibreOffice saves all open documents when saving auto recovery information.
Uses the same time interval as AutoRecovery does.

Edit document properties before saving
If you select this option, the Document Properties dialog pops up to prompt you to enter
relevant information the first time you save a new document (or whenever you use Save As).

Always create backup copy
Saves the previous version of a document as a backup copy whenever you save a document.
Every time LibreOffice creates a backup copy, the previous backup copy is replaced. The
backup copy gets the extension BAK. Authors whose work may be very lengthy should always
consider using this option.

Save URLs relative to file system / internet
Use this option to select the default for relative addressing of URLSs in the file system and on
the Internet. Relative addressing is only possible if the source document and the referenced
document are both on the same drive.

A relative address always starts from the directory in which the current document is located. In
contrast, absolute addressing always starts from a root directory. The following table
demonstrates the difference in syntax between relative and absolute referencing:

Examples File system Internet
relative ../images/img.jpg ..[images/img.jpg
absolute file:/l/c|/work/images/img.jpg http://myserver.com/work/images/img.jpg

If you choose to save relatively, the references to embedded graphics or other objects in your
document will be saved relative to the location in the file system. In this case, it does not matter
where the referenced directory structure is recorded. The files will be found regardless of
location, as long as the reference remains on the same drive or volume. This is important if you
want to make the document available to other computers that may have a completely different
directory structure, drive or volume names. It is also recommended to save relatively if you
want to create a directory structure on an Internet server.

If you prefer absolute saving, all references to other files will also be defined as absolute,
based on the respective drive, volume or root directory. The advantage is that the document
containing the references can be moved to other directories or folders, and the references
remain valid.
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Default file format and ODF settings
ODF format version. LibreOffice by default saves documents in OpenDocument Format
(ODF) version 1.2 Extended. While this allows for improved functionality, there may be
backwards compatibility issues. When a file saved in ODF 1.2 Extended is opened in an editor
that uses earlier versions of ODF (1.0/1.1), some of the advanced features may be lost. Two
notable examples are cross-references to headings and the formatting of numbered lists. If you
plan to share documents with people who use editors that use older versions of ODF, you may
wish to save the document using ODF version 1.0/1.1.

Document type. If you routinely share documents with users of Microsoft Office, you might
want to change the Always save as attribute for documents to one of the Microsoft Office
formats. Current versions of Microsoft Word can open ODT files, so this may no longer be
needed.

VBA Properties

On the VBA Properties page, you can choose whether to keep any macros in Microsoft Office
documents that are opened in LibreOffice.

Microsoft Word 97/2000/XP
Load Basic code

Executable code

Save original Basic code

Microsoft Excel 97/2000/XP
Load Basic code

Executable code

Save original Basic code

Microsoft PowerPoint 97/2000/XP
Load Basic code

Save original Basic code

Figure 32: Choosing Load/Save VBA Properties

If you choose Load Basic code, you can edit the macros in LibreOffice. The changed code is
saved in an ODF document but is not retained if you save into a Microsoft Office format.

If you choose Save original Basic code, the macros will not work in LibreOffice but are retained
unchanged if you save the file into Microsoft Office format.

If you are importing a Microsoft Word or Excel file containing VBA code, you can select the option
Executable code. Whereas normally the code is preserved but rendered inactive (if you inspect it
with the StarBasic IDE you will notice that it is all commented), with this option the code is ready to
be executed.

Save original Basic code takes precedence over Load Basic code. If both options are selected
and you edit the disabled code in LibreOffice, the original Microsoft Basic code will be saved when
saving in a Microsoft Office format.

To remove any possible macro viruses from the Microsoft Office document, deselect Save original
Basic code. The document will be saved without the Microsoft Basic code.
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Microsoft Office

On the Load/Save — Microsoft Office page, you can choose what to do when importing and
exporting Microsoft Office OLE objects (linked or embedded objects or documents such as
spreadsheets or equations).

Select the [L] options to convert Microsoft OLE objects into the corresponding LibreOffice OLE
objects when a Microsoft document is loaded into LibreOffice (mnemonic: “L” for “load”).

Select the [S] options to convert LibreOffice OLE objects into the corresponding Microsoft OLE
objects when a document is saved in a Microsoft format (mnemonic: “S” for “save”).

Embedded objects
[L] [5]
MathType to LibreOfficeDev Math or reverse Py
WinWord to LibreOfficelev Writer or reverse
Excel to LibreOfficeDev Calc or reverse
PowerPaint to LibreOfficeDev lmpress or reverse
] Srnarthrt to LibreOfficeDev shapes or reverse W

[L]: Load and convert the object

[5]: Convert and save the object

Figure 33: Choosing Load/Save Microsoft Office options

HTML compatibility

Choices made on the Load/Save — HTML Compatibility page affect HTML pages imported into
LibreOffice and those exported from LibreOffice. See HTML documents; importing/exporting in the
Help for more information.

Font sizes Import
Size 1 7 s [] Use 'English (USA)' locale for numbers
Size 2 10 Eﬂ [ ] Import unknown HTML tags as fields
Ignore font settings
Size 3 12 [ tgnore § ¢
Export
Size 4 14 [ P
|Mn:nzi||a Firefox [VH
Size § 18 il
[ ] Libre0ffice Basic
Size & 24 i
B Ev} Display warning
Size 7 3 2

[ ] Print layout
Copy local graphics to Internet

Character get |'|."'.u'estern Europe I:'L"u'inu:l-:u'.-\'s-ll{\f“

Figure 34. Choosing HTML compatibility options

Font sizes
Use these fields to define the respective font sizes for the HTML <font size=1> to <font size=7>
tags, if they are used in the HTML pages. (Many pages no longer use these tags.)
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Import — Use 'English (USA)' locale for numbers
When importing numbers from an HTML page, the decimal and thousands separator
characters differ according to the locale of the HTML page. The clipboard, however, contains
no information about the locale. If this option is not selected, numbers will be interpreted
according to the Locale setting in Tools > Options > Language Settings > Languages (see
page 54). If this option is selected, numbers will be interpreted as for the English (USA) locale.

Import - Import unknown HTML tags as fields
Select this option if you want tags that are not recognized by LibreOffice to be imported as
fields. For an opening tag, an HTML_ON field will be created with the value of the tag name.
For a closing tag, an HTML_OFF will be created. These fields will be converted to tags in the
HTML export.

Import - Ignore font settings
Select this option to have LibreOffice ignore all font settings when importing. The fonts that
were defined in the HTML Page Style will be used.

Export
To optimize the HTML export, select a browser or HTML standard from the Export box. If
LibreOffice Writer is selected, specific LibreOffice Writer instructions are exported.

Export - LibreOffice Basic
Select this option to include LibreOffice Basic macros (scripts) when exporting to HTML format.
You must activate this option before you create the LibreOffice Basic macro; otherwise the
script will not be inserted. LibreOffice Basic macros must be located in the header of the HTML
document. Once you have created the macro in the LibreOffice Basic IDE, it appears in the
source text of the HTML document in the header.

If you want the macro to run automatically when the HTML document is opened, choose Tools
> Customize > Events. See Chapter 13, Getting Started with Macros, for more information.

Export - Display warning
When the LibreOffice Basic option (see above) is not selected, the Display warning option
becomes available. If the Display warning option is selected, then when exporting to HTML a
warning is shown that LibreOffice Basic macros will be lost.

Export - Print layout
Select this option to export the print layout of the current document as well. The HTML filter
supports CSS2 (Cascading Style Sheets Level 2) for printing documents. These capabilities
are only effective if print layout export is activated.

Export - Copy local graphics to Internet
Select this option to automatically upload the embedded pictures to the Internet server when
uploading using FTP.

Export — Character set
Select the appropriate character set for the export.

Choosing language settings

To customize the language settings in LibreOffice, you can do any of the following:
* Install the required dictionaries
¢ Change some locale and language settings
* Choose spelling options
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Install the required dictionaries

LibreOffice automatically installs several dictionaries with the program. To add other dictionaries,
be sure you are connected to the Internet, and then choose Tools > Language > More
Dictionaries Online. LibreOffice will open your default web browser to a page containing links to
additional dictionaries that you can install. Follow the prompts to select and install the ones you

want.

Change some locale and language settings

You can change some details of the locale and language settings that LibreOffice uses for all

documents, or for specific documents.

In the Options dialog, click Language Settings > Languages. The exact list shown depends on

the Enhanced language support settings (see Figure 36).

+ LibreQffice &
Load/Save &
Language -

W g Aids

English sentence checking
LibreCffice Writer
LibreCffice Writer Mieb
LibreCffice Base
Charts
Internet

+ [+

+| [

LibreQffice
Load/Save

......................

Writing Aids
Searching in Japanese
Asian Layout
Complex Text Layout
English sentence checking
LibreQffice Writer
LibreQffice Writer Meb
LibreOffice Base
Charts
Internet

Figure 35: LibreOffice language options, without and with

Asian and CTL options enabled

On the right-hand side of the Language Settings — Languages page, change the User interface,
Locale setting, Default currency, and Default languages for documents as required. In the

example, English (USA) has been chosen for all the appropriate settings.

Language of

Default languages for documents

User interface | Default - English (USA)
Locale setting |English (USA)

Decimal separator key [ Same as locale setting (. )
Default currency | Default - USD

Date acceptance patterns M/D/Y:M/D

Western |% English (USA)
[ | Asian [None]
Complex text layout (CTL) [None]

Enhanced language support
[_| Ignore system input language

|| For the current document only

Figure 36: Choosing language options
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User interface
The language of the user interface is usually set at the time LibreOffice is installed to match the
language of the operating system. If more than one language has been installed for
LibreOffice, you can select which language will be used for menus, dialogs, and help files.

Locale setting
The local setting is the basis for many other settings within LibreOffice, for example defaults for
numbering, currency, and units of measure. Unless you select something else here, the locale
of the operating system will be set as default.

Decimal separator key
If the Decimal separator key option is selected, LibreOffice will use the character defined by the
default locale. If this option is not selected, the keyboard driver defines the character used.

Default currency
The Default currency is that used in the country entered as Locale. The default currency
determines the proper formatting of fields formatted as currency. If the locale setting is
changed, the default currency changes automatically. If the default currency is changed, all
dialogs involving currency and all currency icons will be changed in all open documents.
Documents that were saved with one currency as the default will open using the new currency
defaults.

Date acceptance patterns
Date acceptance patterns define how LibreOffice recognizes input as dates. Locale also
defines the default expression of dates. You can define additional date patterns, separated by
semicolons, using Y, M, & D for Year, Month, and Day. LibreOffice will always correctly interpret
dates entered in ISO 8601 format as Y-M-D and YYYY-MM-DD.

Caujtlon Data entered into a Calc spreadsheet or a Writer table must be entered in a format

defined by Local in order to be recognized as dates.

Default languages for documents
Select the languages used for the spelling checker, thesaurus, and hyphenation features of
LibreOffice. If these options are only for the current document, select For the current document
only.

If necessary, select the options to enable support for Asian languages (Chinese, Japanese,
Korean) and support for CTL (complex text layout) languages such as Urdu, Thai, Hebrew, and
Arabic. If you choose either of these options, the next time you open this dialog, you will see
some extra choices under Language Settings, as shown in Figure 35. These choices
(Searching in Japanese, Asian Layout, and Complex Text Layout) are not discussed here.

Enhanced language support — Ignore system input language
Default language settings depend on the Locale setting. The default locale is based on that of
the computer's operating system. A keyboard layout is normally based on the language used by
the operating system but can be changed by the user. If this option is not selected, and there is
a change in keyboard layout, input from the keyboard will be different from what is expected.

Chapter 2 Setting up LibreOffice | 55



Choose spelling options

To choose the options for checking spelling, click Language Settings > Writing Aids. In the
Options section of the page (Figure 37), choose the settings that are useful for you.

Some considerations:
* If you do not want spelling checked while you type, deselect Check spelling as you type.

This option can also be deselected using the AutoSpellcheck button on the Standard
toolbar.

* |If you want grammar to be checked as you type, you must have Check spelling as you
type enabled too.
¢ |f you use a custom dictionary that includes words in all upper case and words with
numbers (for example, AS/400), select Check uppercase words and Check words with
numbers.
* Check special regions includes headers, footers, frames, and tables when checking
spelling.
Here you can also check which user-defined (custom) dictionaries are active by default, and add or
remove user-installed dictionaries, by clicking the New or Delete buttons. Dictionaries installed by
the system cannot be deleted.

Writing aids
Available language modules
™ Hunspell SpellChecker Edit...
@ Mac OS5 X Spell Checker
il 1 imbbmennt menmamane -~ bhonrsleme (Cmmlinkd

User-defined dictionaries

[ standard [All] New...
™ en-GB '[' English (UK) "'
™ en-US '[' English (USA} 'T
™ technical [All] Delete
[ IgnoreAllList [All]

Edit...

Options
[2] Check spelling as you type Edit...

Check uppercase words
Check words with numbers

Get more dictionaries online...

Figure 37: Choosing languages, dictionaries, and options for checking spelling

English sentence checking

On the Language Settings > English sentence checking page, you can choose which items are
checked for, reported to you, or converted automatically. This menu is also found in the English
dictionaries extension installed by default by LibreOffice. Select Tools > Extension Manager,
select the English spelling dictionaries and click the Options button to reveal the menu. Select
which of the optional features you wish to check.

After selecting the additional grammar checks, you must restart LibreOffice, or reload the
document, for them to take effect.
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Grammar checking
Possible mistakes Capitalization Word duplication Parentheses

Punctuation

» Word spacing Em dash Quotation marks (¥ Multiplication sign

Sentence spacing En dash Apostrophe Ellipsis
More spaces Minus sign

Others
Convert to metric (°C, km/h, m, ka, 1) Thousand separation of large numbers
Convert to non-metric (°F, mph, ft, Ib, gal)

Figure 38: Choosing options for checking sentences in English

Grammar checking

Possible mistakes
Checks for things such as; with it's, he don't, this things and so on.

Capitalization
Checks for the capitalization of sentences. The sentence boundary detection depends on
abbreviations.

Word duplication
Checks for all word duplication, rather than just the default words ‘and’, ‘or’, ‘for’, and ‘the’.

Parentheses
Checks for pairs of parentheses and quotation marks.

Punctuation

Word spacing
This option is selected by default. It checks for single spaces between words, indicating
instances of double or triple spaces, but not of more than that.

Sentence spacing
Checks for a single space between sentences, indicating when one or two extra spaces are
found.

More spaces
Checks word and sentence spacing for more than two extra spaces.

Em dash; En dash
These options force a non-spaced em dash to replace a spaced en dash, or force a spaced en
dash to replace a non-spaced em dash, respectively.

Quotation marks
Checks for correct typographical double quotation marks.

Multiplication sign
This option is selected by default. It replaces an 'x' used as a multiplication symbol with the
correct typographical symbol.

Apostrophe
Replaces an apostrophe with the correct typographical character.
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Ellipsis
Replaces three consecutive periods (full stops) with the correct typographical symbol.

Minus sign
Replaces a hyphen with the correct minus typographical character.

Others

Convert to metric; Convert to non-metric
Converts guantities in a given type of unit to quantities in the other type of unit: metric to
imperial or imperial to metric.

Thousands separation of large numbers
Converts a number with five or more significant digits to a common format, that is one which
uses the comma as a thousands separator, or to the ISO format which uses a narrow space as

a separator.

Choosing Internet options

The Internet options available depend on your operating system.
Use the Proxy page (if available) to save proxy settings for use with LibreOffice.

E

[§ options - Internet - E-mail

LibreOffice
Load/Save Sending documents as e-mail attachments

Language Settings
LibreOffice Writer E-mail program  |/usr/lib/thunderbird/thunderbird m
LibreOffice Writer/Web
LibreOffice Base
Charts
Internet
Proxy
E-maik
Browser Plug-in
MediaWiki

{ v VvV w

Figure 39: Internet options, showing E-mail page available to Linux users

If you are using a Mozilla browser (such as Firefox) on Windows or Linux, you can enable the
Browser Plug-in so you can open LibreOffice files in your browser, print them, save them, and work
with them in other ways.

If you are using a Unix- or Linux-based operating system (including Mac OS X), an additional page
of E-mail options is available, where you can specify the e-mail program to use when you send the
current document as e-mail. Under Windows the operating system’s default e-mail program is
always used.

A MediaWiki publisher is included on Windows and Linux. To enable it, select MediaWiki in the
Internet options, then click the Add button to open the dialog shown in Figure 40. Here you can
specify the address (URL) and log-in information for a wiki. You can add several wikis to the list.
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[ Mediawiki
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[ Save password

Help l oK ] l Cancel

Figure 40: Specifying a MediaWiki server account

Controlling LibreOffice’s AutoCorrect functions

Some people find some or all of the items in LibreOffice’s AutoCorrect function annoying because
they change what you type when you do not want it changed. Many people find some of the
AutoCorrect functions quite helpful; if you do, then select the relevant options. But if you find
unexplained changes appearing in your document, this is a good place to look to find the cause.

To open the AutoCorrect dialog, click Tools > AutoCorrect Options. (You need to have a
document open for this menu item to appear.) In Writer, this dialog has five tabs, as shown in
Figure 41. In other components of LibreOffice, the dialog has only four tabs. More details are given
in the component guides.

[§ AutocCorrect

Replacements and exceptions for language: lEnglish (Australia) v]

Replace | Exceptions |Options Localized Options | Word Completion

Use replacement table L]
Correct TWo INitial CApitals

Capitalize first letter of every sentence

Automatic *bold* and underline_

URL Recognition

Replace dashes

Delete spaces and tabs at beginning and end of paragraph

Delete spaces and tabs at end and start of line

lgnore double spaces

Correct accidental use of cAPS LOCK key

Apply numbering - symbol: *
Apply border

Create table

Apply Styles

Remove blank paragraphs
Replace Custom Styles
Replace bullets with: =

=
=
=

M EEEEEE
OFEEEOREEEEERE

IHEEO

- -

— [M]: Replace while modifying existing text
Edit...

[T]: AutoFormat/AutoCorrect while typing

" oK IH Cancel H Help H Reset l

Figure 41: The AutoCorrect dialog in Writer, showing some of the choices on the Options tab

Chapter 2 Setting up LibreOffice | 59






j LibreOffice

The Document Foundation

Chapter 3
Using Styles and Templates

Using consistent formatting in your documents



What is a template?

A template is a model document that you use to create other documents. For example, you can
create a template for business reports that has your company’s logo on the first page. New
documents created from this template will all have your company’s logo on the first page.

Templates can contain anything that regular documents can contain, such as text, graphics, a set
of styles, and user-specific setup information such as measurement units, language, the default
printer, and toolbar and menu customization.

All documents in LibreOffice are based on templates. You can create a specific template for any
document type (text, spreadsheet, drawing, presentation). If you do not specify a template when
you start a new document, then the document is based on the default template for that type of
document. If you have not specified a default template, LibreOffice uses the blank template for that
type of document that is installed with LibreOffice. See “Setting a default template” on page 73 for
more information.

What are styles?

A style is a set of formats that you can apply to selected pages, text, frames, and other elements in
your document to quickly change their appearance. Often applying a style means applying a whole
group of formats at the same time.

Many people manually format paragraphs, words, tables, page layouts, and other parts of their
documents without paying any attention to styles. They are used to writing documents according to
physical attributes. For example, you might specify the font family, font size, and any formatting
such as bold or italic.

Styles are logical attributes. Using styles means that you stop saying “font size 14pt, Times New
Roman, bold, centered”, and you start saying “Title” because you have defined the “Title” style to
have those characteristics. In other words, using styles means that you shift the emphasis from
what the text (or page, or other element) looks like, to what the text is.

Styles help improve consistency in a document. They also make major formatting changes easy.
For example, you may decide to change the indentation of all paragraphs, or change the font of all
titles. For a long document, this simple task can require making individual changes in dozens of
places. By contrast, when you use styles, you only need to make a single change.

In addition, styles are used by LibreOffice for many processes, even if you are not aware of them.
For example, Writer relies on heading styles (or other styles you specify) when it compiles a table
of contents. Some common examples of style use are given in “Examples of style use” on page 76.

LibreOffice supports the following types of styles:

* Page styles include margins, headers and footers, borders and backgrounds. In Calc, page
styles also include the sequence for printing sheets.

* Paragraph styles control all aspects of a paragraph’s appearance, such as text alignment,
tab stops, line spacing, and borders, and can include character formatting.

* Character styles affect selected text within a paragraph, such as the font and size of text, or
bold and italic formats.

* Frame styles are used to format graphic and text frames, including text wrap, borders,
backgrounds, and columns.

* List styles allow you to select, format, and position numbers or bullets in lists.

* Cell styles include fonts, alignment, borders, background, number formats (for example,
currency, date, number), and cell protection.
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Graphics styles in drawings and presentations include line, area, shadowing, transparency,
font, connectors, dimensioning, and other attributes.

Presentation styles include attributes for font, indents, spacing, alignment, and tabs.

Different styles are available in the various components of LibreOffice, as listed in Table 3.

LibreOffice comes with many predefined styles. You can use the styles as provided, modify them,
or create new styles, as described in this chapter.

Table 3. Styles available in LibreOffice components

Style Type Writer Calc Draw Impress

Page

X X

Paragraph

Character

Frame

Numbering

X
X
X
X

Cell

Presentation X X

Graphics (included in X X

Frame styles)

Applying styles

LibreOffice provides several ways for you to select styles to apply:

Styles and Formatting window
Fill Format Mode

Apply Style List

Keyboard shortcuts

Using the Styles and Formatting window

The Styles and Formatting window includes the most complete set of tools for styles. To use it for
applying styles:

1)

2)

3)

Select the Styles and Formatting button located at the left-hand end of the Formatting
toolbar, or select Format > Styles and Formatting, or press F11 (¥+T on a Mac) or click
the Styles and Formatting tab in the Sidebar (View > Sidebar to open it).

The Styles and Formatting window shows the types of styles available at the current
position of the mouse cursor. Figure 42 shows the window for Writer, with Paragraph Styles
visible. You can move this window to a convenient position on the screen or dock it to the
right edge (hold down the Ctrl key and drag it by the title bar to where you want it docked).

Select one of the buttons at the top left of the Styles and Formatting window to display a list
of styles in a particular category.

To apply an existing style, position the insertion point in the paragraph, frame, page, or
word, and then double-click the name of the style in one of these lists. To apply a character
style to more than one word, select the characters first.
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At the bottom of the Styles and Formatting window is a drop-down list. In Figure 42
the window shows Automatic, meaning the list includes only a standard set of styles

Tip suggested by LibreOffice. You can choose to show all styles or other groups of
styles, for example only custom styles.
Paragraph Styles—i7] a3 £ i@ & B 1= -—| New Style from Selection
Defaulf Style ~ Update Style
Character Styles ;' ellnjentt Load Styles
HEEgiI’IS .
Frame Styles —+wsirm Fill Format Mode
Heading 2
Page Styles— reres
Heading 5
. Heading 6
List Styles H::d::;? "
‘Automatic W |

Figure 42: The Styles and Formatting window for Writer, showing paragraph styles

Using Fill Format Mode

Use Fill Format to apply a style to many different areas quickly without having to go back to the
Styles and Formatting window and double-click every time. This method is quite useful when you
need to format many scattered paragraphs, cells, or other items with the same style:
1) Open the Styles and Formatting window and select the style you want to apply.
2) Select the Fill Format Mode button.
3) To apply a paragraph, page, or frame style, hover the mouse over the paragraph, page, or
frame and click. To apply a character style, hold down the mouse button while selecting the
characters. Clicking a word applies the character style for that word.

4) Repeat step 3 until you have made all the changes for that style.
5) To quit Fill Format mode, click the Fill Format Mode button again or press the Esc key.

Caution When this mode is active, a right-click anywhere in the document undoes the last Fill
é Format action. Be careful not to accidentally right-click and undo actions you want to
keep.

Using the Apply Style list
After you have used a style at least once in a document, the style name appears on the Apply Style
list near the left-hand end of the Formatting toolbar, next to the Styles and Formatting button.

You can open this list and click the style you want, or you can use the up and down arrow keys to
move through the list and then press Enter to apply the highlighted style.

Select More at the bottom of the Apply Style list to open the Styles and Formatting

Tip window.
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Figure 43: The Apply Style list
on the Formatting toolbar

Using keyboard shortcuts

Some keyboard shortcuts for applying styles are predefined. For example, in Writer Ctrl+0 applies
the Text body style, Ctrl+1 applies the Heading 1 style, and Ctrl+2 applies the Heading 2 style. You
can modify these shortcuts and create your own; see Chapter 14, Customizing LibreOffice, for
instructions.

Manual formatting (also called direct formatting) overrides styles, and you cannot
get rid of the manual formatting by applying a style to it.

A To remove manual formatting, select the text, right-click, and choose Clear Direct
Formatting from the context menu, or use Ctrl+M after selecting the text.

Caution

Modifying styles

LibreOffice includes predefined styles, but you can also create custom styles. You can modify both
types of styles in several ways:

* Change a style using the Style dialog

* Update a style from a selection

* Use AutoUpdate (paragraph and frame styles only)

* Load or copy styles from another document or template

Any changes you make to a style are effective only in the current document. To
Note change styles in more than one document, you need to change the template or copy
the styles into the other documents as described on page 66.
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Changing a style using the Style dialog

To change an existing style using the Style dialog, right-click on the required style in the Styles and
Formatting window and select Modify from the pop-up menu.

The Style dialog displayed depends on the type of style selected. Each Style dialog has several
tabs. See the chapters on styles in the user guides for details.

Updating a style from a selection

To update a style from a selection:
1) Open the Styles and Formatting window.
2) In the document, select an item that has the format you want to adopt as a style.

Caution When updating a paragraph style, make sure that the selected paragraph contains
unique properties. If it mixes font sizes or font styles, those mixed properties will
remain the same as before.

3) Inthe Styles and Formatting window, select the style to update, then click on the arrow next
to the New Style from Selection icon and click Update Style.

@& Styles and Formatting
EEooB & -

00oTextBod New Skyle from Selection
0OoTextBody Listintro Ipdate Sty

OOoTextBodylndent
OO0oTextBodylndented
OOoTextBodyNolndent
O0oTip/Moke/Caution
O0oToCHead
Preformatted Text !
Quotations 7|
Sender j
Sidehead -

All Styles .

Load Styles...
ST

Figure 44: Updating a style from a selection

Using AutoUpdate

AutoUpdate applies to paragraph and frame styles only. If the AutoUpdate option is selected on the
Organizer page of the Paragraph Style or Frame Style dialog, applying direct formatting to a
paragraph or frame using this style in your document automatically updates the style itself.

If you are in the habit of manually overriding styles in your document, be sure that

Tip AutoUpdate is not enabled.

Updating styles from a document or template

You can update styles by copying or loading them from a template or another document. See
“Copying styles from a template or document” on page 68.
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Creating new (custom) styles

You may want to add some new styles. You can do this by using either the Styles dialog or the
New Style from Selection tool.

Creating a new style using the Style dialog

To create a new style using the Styles dialog, right-click in the Styles and Formatting window and
select New from the pop-up menu.

If you want your new style to be linked with an existing style, first select that style and then right-
click and select New.

If you link styles, then when you change the base style (for example, by changing the font from
Times to Helvetica), all the linked styles will change as well. Sometimes this is exactly what you
want; other times you do not want the changes to apply to all the linked styles. It pays to plan
ahead.

The dialogs and choices are the same for defining new styles and for modifying existing styles.
See the chapters on styles in the user guides for details.

Creating a new style from a selection
You can create a new style by copying an existing manual format. This new style applies only to
this document; it will not be saved in the template.
1) Open the Styles and Formatting window and choose the type of style you want to create.
2) In the document, select the item you want to save as a style.
3) Inthe Styles and Formatting window, select on the New Style from Selection icon.

4) In the Create Style dialog, type a name for the new style. The list shows the names of
existing custom styles of the selected type. Click OK to save the new style.

@ O Create Style

Style name
Definition Lis

Computer Code
Figure caption

| oK | Cancel

Figure 45: Naming a new style
created from a selection

Dragging and dropping to create a style

You can drag and drop a selection into the Styles and Formatting window to create a new style.
The element to drag depends upon the LibreOffice application.
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Writer
Select some text and drag it to the Styles and Formatting window. If Paragraph Styles are
active, the paragraph style will be added to the list. If Character Styles are active, the character
style will be added to the list.

Calc
Drag a cell selection to the Styles and Formatting window to create cell styles.

Draw/Impress
Select and drag drawing objects to the Styles and Formatting window to create graphics styles.

Copying styles from a template or document

You can copy styles into a document by loading them from a template or from another document:
1) Open the document you want to copy styles into.

2) Inthe Styles and Formatting window, click the arrow next to the New Style from Selection
icon, and then select Load Styles (see Figure 44).

3) Select the categories of styles to be copied. Select Overwrite if you want the styles being
copied to replace any styles of the same names in the document you are copying them
into.

4) On the Load Styles dialog (Figure 46), find either a template or an ordinary document from
which to copy files from. Click the From File button to open a window from which to select
the required document.

#® Load Styles

Categories Templates oK |
Business Correspondence ; Cancel

Forms and Contracts

Presentation Backgrounds Help

& Text Frame | Pages Numbering Overwrite _ From File...

Figure 46: Copying styles from a template into the open document

5) Select the types of styles to copy from the checkboxes at the bottom of the dialog.

6) Select Overwrite if you want to replace styles in the original document that have the same
name as styles in the document from which you are importing styles. If this box is not
selected, you will only copy styles whose names are not used in the original document.

7) Click OK to copy the styles.

If your document has a table of contents, and if you have used custom styles for

Caution headings, the heading levels associated with outline levels in Tools > Outline
Numbering will revert to the defaults of Heading 1, Heading 2, and so on when you
load Text styles from a file that does not use the same custom styles. You will need

to change these back to your custom heading styles.
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Deleting styles

You cannot remove (delete) any of LibreOffice's predefined styles from a document or template,
even if they are not in use.

You can remove any user-defined (custom) styles; but before you do, you should make sure the
styles are not in use in the current document. If an unwanted style is in use, you can replace it with
a substitute style.

To delete any unwanted styles, in the Styles and Formatting window select each one to be deleted
(hold Ctrl while selecting multiple styles), and then right-click on a selected style and select Delete
on the context menu.

If the style is not in use, it is deleted immediately without confirmation. If the style is in use, you
receive a warning message asking you to confirm deletion.

Caution . . . :
j If you delete a style that is in use, all objects with that style will return to the default

style.

Using a template to create a document

To use a template to create a document:

1) From the Menu bar, choose File > New > Templates. The Template Manager dialog
opens.

2) From the tabs at the top of the dialog, select the category of template you want to use.

3) Select the folder that contains the template that you want to use. All the templates
contained in that folder are listed on the page (as shown in Figure 47).

4) Select the template that you want to use. If you wish to view the template’s properties, click
the Properties button above the list of templates. The template’s properties appear in a
pop-up window. Click Close to close this pop-up window.

5) Select the required template. A new document based on the selected template opens in
LibreOffice.

The template the document is based upon is listed in File > Properties > General. The connection
between the template and the document remains until the template is modified and, the next time
that the document is opened, you choose not to update it to match the template.

| ® - o Template Manager

Documents | Spreadsheets | Presentations Drawings
Ec}pen =] Edit @Properties | €| Set as default @Mwe to folder = | = Export @Delete Q - =

AllTemplates My Templates

&

mediawiki myAgendaTemplate rrl_yfletbei‘ﬁmplate

Figure 47: Template Manager dialog, showing a selected template
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Creating a template

You can create your own templates in two ways: by saving a document as a template or by or
using a wizard.

Creating a template from a document

To create a template from a document and save it to My Templates:

1) Open a new or existing document of the type you want to make into a template (text
document, spreadsheet, drawing, or presentation).

2) Add any content that you want to appear in any document you create from the new
template, for example company logo, copyright statement, and so on.

3) Create or maodify any styles that you want to use in the new template.

4) From the Menu bar, choose File > Templates > Save As Template. The Template
Manager dialog (Figure 48) opens, displaying the default folders and any user-created
folders.

5) Select the My Templates folder.

6) Select Save.

7) In the dialog that opens, type a hame for the new template and click Accept.
8) Close the Template Manager dialog.

& - o Template Manager

h%j Save DNewfolder Q {L::( o
| |
My Templates Mediawiki Presentation
Backgrounds

Figure 48: Template Manager dialog, showing default folders

In addition to formatting, any settings that can be added to or modified in a document can be saved
within a template. For example, you can also save printer settings, and general behaviors set from
Tools > Options, such as Paths and Colors.

Templates can also contain predefined text, saving you from having to type it every time you create
a new document. For example, a letter template may contain your name, address, and salutation.

You can also save menu and toolbar customizations in templates; see Chapter 14, Customizing
LibreOffice, for more information.

Creating a template using a wizard

You can use wizards to create templates for letters, faxes, agendas, and to create presentations,
and Web pages.

For example, the Fax Wizard guides you through the following choices:
* Type of fax (business or personal)

¢ Document elements like the date, subject line (business fax), salutation, and
complementary close
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Options for sender and recipient information (business fax)
Text to include in the footer (business fax)

To create a template using a wizard:

1)

2)

3)

4)

5)

From the Menu bar, choose File > Wizards > [type of template required].

Edit View Insert Format Table Tools Window Hel
New R A5 [ac] &
Open... Ctrl+O

Recent Documents , beration Serif | ~ | |12

|,,_*r.¢;a_m-- ds ,*.,‘ _ LELLET... |

Fax...

Templates , o
Agenda...

Close .

z ] Presentation...

Save Ctrl+s

Save As... Ctrl+Shift+s Web Page...

S S Document Converter...

Save A

Euro Converter...

Address Data Source...

...........

Figure 49: Creating a template using a wizard

Follow the instructions on the pages of the wizard. This process is slightly different for each
type of template, but the format is very similar.

In the last section of the wizard, you can specify the template name which will show in the
Template Manager, and also the name and location for saving the template. The two names
can be different but may cause you confusion if you choose two different names. The
default location is your user templates directory, but you can choose a different location if
you prefer.

Selecting the Path button to set the file name, and perhaps change the directory, causes
the Save As dialog to open. Setting the file name and clicking Save closes the dialog.
Finally, you can choose whether to create a new document from your template immediately,

or manually change the template by clicking Finish. For future documents, you can re-use
the template created by the wizard, just as you would use any other template.

You may need to open the Template Manager and click Refresh on the Action menu to have any
new templates appear in the listings.

Editing a template

You can edit a template’s styles and content, and then, if you wish, you can reapply the template’s
styles to documents that were created from that template. You cannot reapply content.

To edit a template:

1)
2)

3)

From the Menu bar, choose File > Template> Manage or press Ctr/+Shift+N. The
Template Manager dialog opens.

Navigate to the template that you want to edit. Click once on it to activate the file handling
controls (see Figure 47). Click Edit. The template opens in LibreOffice.

Edit the template just as you would any other document. To save your changes, choose
File > Save from the Menu bar.
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Updating a document from a changed template

If you make any changes to a template and its styles, the next time you open a document that was
created on the template before the changes, a confirmation message is displayed.
To update the document:

1) Click Update Styles to apply the changed styles in the template to the document.

2) Select Keep Old Styles if you do not want to apply the changed styles in the template to
the document. (but see the Caution notice below).

If you choose Keep Old Styles, the document is no longer connected to the

Caution template, even though the template is still listed under File > Properties >
General. You can still import styles manually from the template, but to reconnect it
A to the template, you will have to copy it into an empty document based on the
template.

Adding templates obtained from other sources

LibreOffice refers to sources for templates as repositories. A repository can be local (a directory on
your computer to which you have downloaded templates) or remote (a URL from which you can
download templates).

You can get to the official template repository by using the Get more templates for LibreOffice
button at the right-hand end of the Template Manager dialog, as shown in Figure 50, or by entering
http://templates.libreoffice.org/template-center in your browser.

| @ - Template Manager 1

Documents | Spreadsheets | Presentations | Drawings
| Import Q

AllTemplates My Templates

Get more templates for LibreOffice

Figure 50: Getting more templates for LibreOffice

If you have enabled experimental features in Tools > Options > Advanced, the Template
Manager shows a Repository button that you can use to add other template repositories. As this is
an experimental feature, it may not work reliably.

On other websites you may find collections of templates that have been packaged into extension
(OXT) files. These are installed a little differently, as described below.

Installing individual templates

To install individual templates:
1) Download the template and save it anywhere on your computer.

2) Import the template into a template folder by following the instructions in “Importing a
template” on page 75.

You can manually copy new templates into the template folders. The location
Tip varies with your computer’s operating system. To learn where the template folders
are stored on your computer, go to Tools > Options > LibreOffice > Paths.

72 | Getting Started with LibreOffice 4.2


http://templates.libreoffice.org/template-center

Installing collections of templates
The Extension Manager provides an easy way to install collections of templates that have been
packaged as extensions. Follow these steps:

1) Download the extension package (OXT file) and save it anywhere on your computer.

2) In LibreOffice, select Tools > Extension Manager from the Menu bar. In the Extension
Manager dialog, click Add to open a file browser window.

3) Find and select the package of templates you want to install and click Open. The package
begins installing. You may be asked to accept a license agreement.

4) When the package installation is complete, restart LibreOffice. The templates are available
for use through File > Templates > Manage and File > New > Templates and the
extension is listed in the Extension Manager.

See Chapter 14 Customizing LibreOffice for more about the Extension Manager.

Setting a default template

If you create a document by choosing File > New > Text Document (or Spreadsheet,
Presentation, or Drawing) from the Menu bar, LibreOffice creates the document from the default
template for that type of document. You can, however, change the default whenever you choose.

Note for You may know that Microsoft Word employs a normal.dot ornormal.dotx
Microsoft file for its default template and how to regenerate it.

Word LibreOffice does not have a similar default template file; the “factory defaults” are
users embedded within the software.

Setting a template as the default

You can set any template displayed in the Template Manager dialog to be the default:
1) From the Menu bar, choose File > Templates > Manage.

2) In the Template Manager dialog, open the folder containing the template that you want to
set as the default, then select the template.

3) Click the Set as default button above the list of templates (see Figure 47).

The next time that you create a document by choosing File > New, the document will be created
from this template.

Although many important settings can be changed in the Tools > Options dialog (see Chapter 2)
for the default template, for example default fonts and page size, more advanced settings (such as
page margins) can be changed only by replacing the default template with a new one.

Resetting the default template

To re-enable LibreOffice’s default template for a document type as the default:
1) Inthe Template Manager dialog, click the Action Menu icon on the right
2) Point to Reset Default Template on the drop-down menu, and click Text Document (or
other template type).
These choices do not appear unless a custom template has been set as the default, as
described in the previous section.

The next time that you create a document by choosing File > New, the document will be created
from the default template for the document type.
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Figure 51: Resetting the default template for text documents

Associating a document with a different template

LibreOffice has no direct method of changing the template that a document uses. However, you
can copy the contents of a document into an empty document that uses a different template.

In LibreOffice 3.x, you could use the Template Changer extension to simplify this

Note process. Unfortunately, this extension does not work in LibreOffice 4.x.

For best results, the names of styles should be the same in the existing document and the new
template. If they are not, use Edit > Find & Replace to replace old styles with new ones. See
Chapter 4, Getting Started with Writer, for more about replacing styles using Find & Replace.
To associate a document with another template:

1) Use File > Templates > Manage to open the Template Manager dialog, and select the
template you want to use. A new document opens, containing any text or graphics that
were in the template.

2) Delete any unwanted text or graphics from this new document.
3) Open the document you want to change. Select Edit > Select All or press Ctrl+A.
4) Select Edit > Copy, or press Ctrl+C, to copy the contents of the document to the clipboard.

5) Click inside the blank document created in step 1. Go to Edit > Paste, or press Ctrl+V, to
paste the contents from the old document into the new one.

6) Update the table of contents, if there is one. Close the old file without saving. Go to File >
Save As to save the new file with the name of the file from which content was taken. When
asked, confirm that you want to overwrite the old file. You may prefer to save the new file
under a new name and preserve the old file under its original name.

Organizing templates

LibreOffice can use only those templates that are in its template folders. You can create new
template folders and use them to organize your templates. For example, you might have one
template folder for report templates and another for letter templates. You can also import and
export templates.

To begin, choose File > Templates > Manage to open the Template Manager dialog.

Creating a template folder

To create a template folder:
1) Go to the All Templates section of the Template Manager dialog.
2) Click the New folder button (see Figure 52).
3) Inthe pop-up dialog, type a name for the new folder and click Accept.
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Figure 52: Creating a new folder

Deleting a template folder

You cannot delete template folders supplied with LibreOffice. Nor can you delete any folders
created by the Extension Manager unless you first delete the extension that installed them.

However, you can select a folder that you created and click the Delete button. When a message
box appears, asking you to confirm the deletion, click Yes.

Moving a template

To move a template from one template folder to another, select it in the Template Manager dialog,
and click the Move to folder button above the list of templates (see Figure 53).

| @ - o Template Manager

Documents | Spreadsheets Presentations Drawings

EOpen [l Edit éProperties Ll Set as default Inge to folder v.| | = Export ®Delete Q g;r; T

AllTemplates My Templates My Templates
Business Correspondence

Forms and Contracts
Presentation Backgrounds

mediawiki myLetterTemplate

Figure 53: Template file handling icons

Deleting a template

You cannot delete templates supplied with LibreOffice. Nor can you delete any templates created
by the Extension Manager except by deleting the extension that installed them.
However, you can delete templates that you have created or imported:

1) Inthe Template Manager dialog, double-click the folder that contains the template you want
to delete.

2) Select the template to delete.

3) Select the Delete button above the list of templates. A message box appears and asks you
to confirm the deletion. Click Yes.

Importing a template
Before you can use a template in LibreOffice, it must be in one of the folders listed for the Template
path in Tools > Options > LibreOffice >Paths:

1) Inthe Template Manager dialog, select the folder into which you want to import the
template.
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2) Click the Import button above the list of template folders. A standard file browser window
opens.

3) Find and select the template that you want to import and click Open. The file browser
window closes and the template appears in the selected folder.

Exporting a template
To export a template from a template folder to another location:
1) Inthe Template Manager dialog, double-click the folder that contains the template to export.

2) Select the template that you want to export.
3) Select the Export button above the list of template folders. The Save As window opens.
4) Find the folder into which you want to export the template and select Save.

Examples of style use

The following examples of common use of page and paragraph styles are taken from Writer. There
are many other ways to use styles; see the guides for the various components for details.

Defining a different first page for a document

Many documents, such as letters and reports, have a first page that is different from the other
pages in the document. For example, the first page of a letterhead typically has a different header,
or the first page of a report might have no header or footer, while the other pages do. With
LibreOffice, you can define the page style for the first page and specify the style for the following
pages to be applied automatically.

As an example, we can use the First Page and Default page styles that come with LibreOffice.
Figure 54 shows what we want to happen: the first page is to be followed by the default page, and
all the following pages are to be in the Default page style. Details are in Chapter 4, Formatting
Pages, in the Writer Guide.

First Default
Page

Fiqure 54: Flow of page styles

Dividing a document into chapters

In a similar way, you can divide a document into chapters. Each chapter might start with the First
Page style, with the following pages using the Default page style, as above. At the end of the
chapter, insert a manual page break and specify the next page to have the First Page style to start
the next chapter, as shown in Figure 55.
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Figure 55: Dividing a document into chapters using page styles

Changing page orientation within a document

A Writer document can contain pages in more than one orientation. A common scenario is to have a
landscape page in the middle of a document, whereas the other pages are in a portrait orientation.
This setup can also be created with page breaks and page styles.

Displaying different headers on right and left pages

Page styles can be set up to have the facing left and right pages mirrored or only right (first pages
of chapters are often defined to be right-page only) or only left. When you insert a header on a
page style set up for mirrored pages or right-and-left pages, you can have the contents of the
header be the same on all pages or be different on the right and left pages. For example, you can
put the page number on the left-hand edge of the left pages and on the right-hand edge of the right
pages, put the document title on the right-hand page only, or make other changes.

Controlling page breaks automatically

Writer automatically flows text from one page to the next. If you do not like the default settings, you
can change them. For example, you can require a paragraph to start on a new page or column and
specify the style of the new page. A typical use is for chapter titles to always start on a new right-
hand (odd-numbered) page.

Compiling an automatic table of contents

To compile an automatic table of contents, first apply styles to the headings you want to appear in
the contents list, then use Tools > Outline Numbering to tell Writer which styles go with which
level in the table of contents. By default, tables of contents use Heading styles, but you can use
whatever combination of styles you prefer. See Chapter 4 for more information.

Defining a sequence of paragraph styles

You can set up one paragraph style so that when you press Enter at the end of that paragraph, the
following paragraph automatically has the style you wish applied to it. For example, you could
define a Heading 1 paragraph to be followed by a Text Body paragraph. A more complex example
would be: Title followed by Author followed by Abstract followed by Heading 1 followed by Text
Body. By setting up these sequences, you can usually avoid having to apply styles manually.
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What is Writer?

Writer is the word processor component of LibreOffice. In addition to the usual features of a word
processor (spelling check, thesaurus, hyphenation, autocorrect, find and replace, automatic
generation of tables of contents and indexes, mail merge and others), Writer provides these
important features:

* Templates and styles (see Chapter 3)

* Page layout methods, including frames, columns, and tables

* Embedding or linking of graphics, spreadsheets, and other objects

¢ Built-in drawing tools

* Master documents—to group a collection of documents into a single document
* Change tracking during revisions

¢ Database integration, including a bibliography database

e Export to PDF, including bookmarks (see Chapter 10)

* And many more

These features are covered in detail in the Writer Guide.

The Writer interface

The main Writer workspace is shown in Figure 56. The menus and toolbars are described in
Chapter 1, Introducing LibreOffice.

Some other features of the Writer interface are covered in this chapter.

r% WorkingWithGraphics.odt - LibreOffice Writer g@ﬁ
Fie Edit View | Insert Format Tabley Tools Window Help

Bre-pal@ sga uy B-a BE-P+ @@ 0O
i [ oooHeafing 0 ] [Uberfonsans  [v] (32 [ &|E|& || == & - »
L i x i ] : ) 3 ) ‘*4 ) .5 : ;'".'_‘

Title bar Menu bar —q Standard toolbar| I Formatting toolbarl

The Document Foundation

Status bar

Writer Guide

{ I} }

MEIP] <

Page 135 | 11062 words, 63093 characters| OQoFirstPage | English (USA) m | [ (il

Figure 56: The main Writer workspace in Print Layout view (without the Sidebar)
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Status Bar
The Writer Status Bar provides information about the document and convenient ways to quickly
change some document features.

| Page 1/1| 11 words, 50 characters Defaullt Style Englislh (Lsa) Overwrite ] E.

Page Word & character Page style Language Insert Selecion Document
number count mode mode changes
status

Figure 57: Left end of Status Bar

58 OQutline Numbering : Level 2 o0 | - - + | 100%
Digital Object View Zoom Zoom
signature information layout slider percent

Figure 58: Right end of Status Bar

Page number
Shows the current page number, the sequence number of the current page (if different), and
the total number of pages in the document. For example, if you restarted page numbering at 1
on the third page, its page number is 1 and its sequence number is 3.

If any bookmarks have been defined in the document, a right-click on this field pops up a list of
bookmarks; click on the required one.
To jump to a specific page in the document, double-click on this field. The Navigator opens.

Click in the Page Number field and type the sequence number of the required page and press
Enter.

Word and character count
The word and character count of the document is shown in the Status Bar, and is kept up to
date as you edit. Any text selected in the document will be counted and this count will replace
the displayed count.

What now?

What now?
Docking a Hoat.

Doclang a boat.

11 words, 50 characters 3 words, 8 characters selected

To display extended statistics such as character counts excluding spaces, double-click the
word count in the Status Bar, or choose Tools > Word Count.

Page style
Shows the style of the current page. To change the page style, right-click on this field. A list of
page styles pops up; choose a different style by clicking on it.

To edit the current page style, double-click on this field. The Page Style dialog opens.

Language
Shows the language at the cursor position, or for the selected text, that is used for
spellchecking, hyphenation and thesaurus.

Click to open a menu where you can choose another language for the selected text or for the
paragraph where the cursor is located. You can also choose None (Do not check spelling) to
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exclude the text from a spelling check or choose More to open the Character dialog. Any
directly formatted language settings can be reset to the default language from this menu.

Insert mode
This area is blank when in Insert mode. Double-click to change to Overwrite mode; single-click
to return to Insert mode. In Insert mode, any text after the cursor position moves forward to
make room for the text you type; in Overwrite mode, text after the cursor position is replaced by
the text you type. This feature is disabled when in Edit > Changes > Record mode.

Selection mode
Click to choose different selection modes. The icon does not change, but when you hover the
mouse pointer over this field, a tooltip indicates which mode is active.

When you click in the field, a context menu displays the available options.

Mode Effect

Standard selection Click in the text where you want to position the cursor; click in a
cell to make it the active cell. Any other selection is deselected.

Extending selection (F8) Clicking in the text extends or crops the current selection.

Adding selection (Shift+F8) A new selection is added to an existing selection. The result is a

multiple selection.

Block selection (Ctrl+Shift+F8) A block of text can be selected.

On Windows systems, you can hold down the Alt key while dragging to select a block of text.
You do not need to enter the block selection mode.

Document changes status
The icon that is displayed here changes from this one ( E') if the document has no unsaved

changes, to this one (E“) if it has been edited and the changes have not been saved.

Digital signature

If the document has been digitally signed, this icon (|:ﬁ) is displayed here; otherwise, it is blank.
To view the certificate, double-click the icon.

Section or object information
When the cursor is on a section, heading, or list item, or when an object (such as a picture or
table) is selected, information about that item appears in this field. Double-clicking in this area
opens a relevant dialog. For details, consult the Help or the Writer Guide.

View layout
Click an icon to change between single page, side-by-side, and book layout views. The effect
varies with the combination of window width and zoom factor in use. You can edit the document
in any view. See Figure 59.

Zoom
To change the view magnification, drag the Zoom slider, or click on the + and — signs, or right-
click on the zoom level percent to pop up a list of magnification values from which to choose.
Zoom interacts with the selected view layout to determine how many pages are visible in the
document window.

= i + | 100%
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Figure 59: View layouts: single, side-by-side, book.

Sidebar

The Writer sidebar (View > Sidebar) is located on the right side of the edit view. It is a mixture of
toolbar and dialog and consists of four decks: Properties, Styles and Formatting, Gallery, and
Navigator. Each deck has a corresponding icon on the Tab panel to the right of the sidebar,
allowing you to switch between them.

Each deck consists of a title bar and one or more content panels. Toolbars and sidebar panels
share many functions. For example, the buttons for making text bold or italic exist in both the
Formatting toolbar and the Character panel of the Properties deck.

Some panels contain a More Options button ( =1 ) which when clicked opens a dialog to give

greater choice of editing controls. The dialog that opens locks the document for editing until the
dialog is closed.

The decks are described below:

* Properties: Contains tools for direct formatting within the document. By default, the tools
are separated into the following three panels for text editing:

- Character: Modify text by the font type, size, color, weight, style and spacing.

- Paragraph: Style the paragraph by alignment, lists or bullets, background color, indent,
and spacing.

- Page: Format the page by orientation, margin, size, and number of columns.

If a graphic is selected, then the following panels open;
Graphic: Modify the graphic's brightness, contrast, color mode and transparency.

Position: Modifications to width and height.
- Wrap: Permits wrap modifications where these are available.

If a drawing object is selected, then the following panels are available;
Area: Fill and transparency edits are available.
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- Line: Permits edits to the line style, width, color, arrows, corners and cap styles.
- Position and Size: Enables edits to width, height, rotation and flip attributes.

If a frame is selected, then the wrap panel opens but may be grayed-out if frame wrap is
not available.

Caution Be aware that by changing the options on the Page panel you will change the page
ﬁ style in use, modifying not only the current page but all pages using the same page
style.

¢ Styles and Formatting: Manage the styles used on the document, applying existing styles,
creating new ones or modifying them. This deck is also a floating toolbar that can be
accessed from Format > Styles and Formatting from the Menu bar.

* Gallery: Add images and diagrams included in the Gallery themes. The Gallery displays as
two sections; the first lists the themes by name (Arrows, Background, Diagrams, etc.) and
the second displays the images in the selected category. Select the New Theme button to
create new categories. To insert an image into a file, or add a new image to the new
category, just drag and drop the selected image using the file manager. This deck is also a
docked toolbar that can be accessed from Tools > Gallery or the Gallery button on the
Standard Toolbar.

* Navigator: Browse the document and reorganize its content by selecting different content
categories, such as headings, tables, frames, graphics, etc. This deck is similar to the
floating toolbar that can be accessed from View > Navigator or the Navigator button on
the Standard Toolbar. In contrast, the Sidebar Navigator does not contain a List Box
On/Off button.

Properties K|| = —|Cmrﬁguratinn menu button

=l Character 1 ] = Title bar
L]
Liberation Sans w| (12 b
) (Y
B A4 A& A Tabs
Lt
@a- A & - .
-4
=l Paragraph Panel title
ERNE R Y s— Deck
Spadng: Indent:
[E=NE] $7E Content panel
= 0.00 2 "= 0.0 2
= n.10" + =7 jo.00” $
= - = .00 2
[ page [j=———More Options button

Figure 60: Sidebar Properties deck and text content panels
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Changing document views

Writer has several ways to view a document: Print Layout, Web Layout, and Full Screen. To access
these and other choices, go to the View menu and click on the required view. (When in Full Screen
view, press the Esc key to return to either Print or Web Layout view.)

Print Layout is the default view in Writer. In this view, you can use the Zoom slider and the View
Layout icons on the Status Bar to change the magnification.

You can also choose View > Zoom > Zoom from the menu bar to display the Zoom & View Layout
dialog, where you can set the same options as on the Status Bar. In Web Layout view, most of the
choices are not available.

Zoom & View Layout
Zoom factor View layout
(O Optimal (%) Automatic
(" Fit width and height i) Single page
(O Fit width ) Columns: |2
© i
(") Variable: 100%5
[ CIK, l I Cancel ] I Help

Figure 61: Choosing Zoom and View Layout options.

Moving quickly through a document

In addition to the navigation features of the Status Bar (described above), you can use the
Navigator window and the Navigation toolbar, either from the Standard toolbar or the Sidebar, as
described in Chapter 1, Introducing LibreOffice.

In Writer, you can also display the Navigation toolbar by clicking on the Navigation button near the
lower right-hand corner of the window below the vertical scroll bar, as shown in Figure 62.

Previous "

— 2]

Navigation

Nextf— —G)

OOoOm | - . + | 100%

Figure 62: Navigation buttons

The Navigation toolbar (Figure 63) shows buttons for all the object types shown in the Navigator,
plus some extras (for example, the Find command).

Navigation ]
= flm A =N
EwEE06E R E

Page

ke

44

Figure 63: Navigation toolbar
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Click a button to select that object type. Now all the Previous and Next button presses (in the
Navigator itself, in the Navigation Toolbar, and on the scroll bar) will jump to the next object of the
selected type. This is particularly helpful for finding items like index entries, which can be difficult to
see in the text. The names of the buttons (shown in the tooltips) change to match the selected
category; for example, Next Graphic, Next Bookmark, or Continue search forward.

For more uses of the Navigator in Writer, see the Writer Guide.

Working with documents

Chapter 1, Introducing LibreOffice, includes instructions on starting new documents, opening
existing documents, saving documents, and password-protecting documents. Chapter 3, Using
Styles and Templates, covers how to create a document from a template.

Saving as a Microsoft Word file

If you need to exchange documents with users of Microsoft Word who are unwilling or unable to
receive ODT files, you can save a document as a Microsoft Word file.

1) Important—First save your document in the file format used by LibreOffice Writer (ODT). If
you do not, any changes you made since the last time you saved will appear only in the
Microsoft Word version of the document.

2) Then choose File > Save As. On the Save As dialog (Figure 64), in the File type (or Save
as type) drop-down menu, select the type of Word format you need. Files cannot be saved
to the Word version 6.0/95 file format. Click Save.

From this point on, all changes you make to the document will occur only in the new document.
You have changed the name and file type of your document. If you want to go back to working with
the ODT version of your document, you must open it again.

Save as W

C:\Documents and Settings\Pat and JohniMy Documents E]

Flaces Title Type |5i3E
My Documents AnyBizSoft PDF to Word Folder kad
Cdeaner Folder
Computer training Folder
Downloads Folder
e-fnails Falder

Fax Folder
E] 1 qeql-0.0 Folder ]
Save
File type: O0F Text Document {,odt)
Microsoft Ward 2007,/2010/2013 XML {docx)

Microsoft Word 2003 XML (L xml) Help
(Microsoft Word 97/2000,/XP/2003 (.doc)
|:| Save with passwo(Microso Word 2377 2000/5F /2003 Template [.dof,
- DiocBook (L xml)

Edit filter settings

= =" [HTML Document (Writer) { html)
Dirh Tawt § riFY

Figure 64: Saving a file in Microsoft Word format
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To have Writer save documents by default in the Microsoft Word file format, go to
Tools > Options > Load/Save > General. In the section named Default file format

Tip and ODF settings, under Document type, select Text document, then under
Always save as, select your preferred file format. See Figure 65.
. It is recommended that if you use a Microsoft Word format, you use the DOC and
Caution

not the DOCX format.

& Saving in ODF format gives you the option to redo the document if the recipient of
your document experiences trouble with the Microsoft format.

Warn when not saving in ODF or default format

Document type: Text document v

Always save as: ;DDF Text Document m

CODF Text Document Template
ODF Text Document
Microsoft Word 2007/2010/2013 XML

-

Unified Office Format text
Text
OpenCffice.org 1.0 Text Document Template
OpenDocument Text (Flat XML)
Office Opep XML Text
Microsoft Word 97/2000,/P/2003 I
ext Encoded
Rich Text
DocBook

OpenOffice.org 1.0 Text Document
Microsoft Waord 2003 XML
[EVIED TIter

Figure 65: Tools > Options > Load/Save > General page

Working with text

Working with text (selecting, copying, pasting, moving) in Writer is similar to working with text in
any other program. LibreOffice also has some convenient ways to select items that are not next to
each other, select a vertical block of text, and paste unformatted text.

Selecting items that are not consecutive

To select nonconsecutive items (as shown in Figure 66) using the mouse:
1) Select the first piece of text.
2) Hold down the Ctrl key and use the mouse to select the next piece of text.
3) Repeat as often as needed.

Now you can work with the selected text (copy it, delete it, change the style, or whatever).

Macintosh users: substitute the Command key when instructions in this chapter

Note say to use the Ctrl key.
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Around the World in 80 Days - Jules Verne

overspread Passepartout's round face; clearly he had not comprehended his

master.
'Monsieur is going to leave home?"

"Yes," returned Phileas Fogg. "We are going round the world."

Passepartout ppened wide his eyes, raised his eyebrows, held up his hands, and seemed ahout
to collapse, so overcome was he with stupefied astonishment.

"Round the world![' he mwmured.

"In eighty days," responded [Mr. Fogg. "So we haven't a moment to lose."
"But the trunks?" gasped Passepartout, unconsciously swaying his head from right to left.

"We'll have no trunks; only a carpet—bag, with two shirts and three pairs of stockings for me|
and the same for youl We'll buy our clothes on the way. Bring down my mackintosh and
traveling-cloak, and some stout shoes, though we shall do little walking. Make haste!"

Figure 66: Selecting items that are not next to each other

To select nonconsecutive items using the keyboard:

1) Select the first piece of text. (For more information about keyboard selection of text, see the
topic “Navigating and selecting with the keyboard” in the Help.)

2) Press Shift+F8. This puts Writer in “Adding selection” mode.

3) Use the arrow keys to move to the start of the next piece of text to be selected. Hold down
the Shift key and select the next piece of text.

4) Repeat as often as required.
Now you can work with the selected text.

Press Esc to exit from this mode.

Selecting a vertical block of text

You can select a vertical block or “column” of text that is separated by spaces or tabs (as you might
see in text pasted from e-mails, program listings, or other sources), using LibreOffice’s block
selection mode. To change to block selection mode, use Edit > Selection Mode > Block Area, or
press Ctrl+F8, or click on the Selection icon in the Status Bar and select Block selection from the
list.

— Standard selection
Selection icon

Extending selection

Adding selection
® Block selection
English {USA) wm | [ |

Now highlight the selection, using mouse or keyboard, as shown below.

January March
April June

July September
October December

Figure 67: Selecting a vertical block of text
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Cutting, copying, and pasting text

Cutting and copying text in Writer is similar to cutting and copying text in other applications. You
can use the mouse or the keyboard for these operations. You can copy or move text within a
document, or between documents, by dragging or by using menu selections, toolbar buttons, or
keyboard shortcuts. You can also copy text from other sources such as Web pages and paste it
into a Writer document.

To move (drag and drop) selected text using the mouse, drag it to the new location and release it.
To copy selected text, hold down the Ctrl key while dragging. The text retains the formatting it had
before dragging.

To move (cut and paste) selected text, use Ctrl+X to cut the text, insert the cursor at the paste-in
point and use Ctr/+V to paste. Alternatively, use the buttons on the Standard toolbar.

When you paste text, the result depends on the source of the text and how you paste it. If you click
on the Paste button, any formatting the text has (such as bold or italics) is retained. Text pasted
from Web sites and other sources may also be placed into frames or tables. If you do not like the
results, click the Undo button or press Ctrl+Z.

To make the pasted text take on the formatting of the surrounding text where it is being pasted:
* Choose Edit > Paste Special, or
* Click the arrow button of the combination Paste button, or
* Click the Paste button without releasing the left mouse button.

Then select Unformatted text from the resulting menu.

The range of choices on the Paste Special menu varies depending on the origin and formatting of
the text (or other object) to be pasted. See Figure 68 for an example with text on the clipboard.

e S

Paste Special

Source:  LibreQffice 4.2 Text Document

Selection
LibreQffice Writer
Formatted text [RTF]
HTML (HyperText Markup Language)
Unformatted text =

Figure 68: Paste Special menu

Finding and replacing text and formatting

Writer has two ways to find text within a document: the Find toolbar for fast searching and the Find
& Replace dialog. In the dialog, you can:

* Find and replace words and phrases

* Use wildcards and regular expressions to fine-tune a search
* Find and replace specific attributes or formatting

* Find and replace paragraph styles
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Using the Find toolbar

If the Find toolbar is not visible, you can display it by choosing View > Toolbars > Find from the
Menu bar or by pressing Ctrl+F. The Find toolbar is shown docked at the bottom of the LibreOffice
window (just above the Status Bar) in Figure 69, but you can float it or dock it in another location.
For more information on floating and docking toolbars, see Chapter 1, Introducing LibreOffice.

Using the Find toolbar

If the Find toolbar is not visible, you can dit
Menu bar or by pressina Ctri+F. The Find t

® [Find = Find All [ | Match Case &

Page 14 / 37 10913 words, 62822 characters Default Style
Figure 69: Docked position of Find toolbar

To use the Find toolbar, click in the box and type your search text, then press Enter to find the next
occurrence of that term from the current cursor position. Click the Find Next or Find Previous
buttons as needed.

Click the Find All button to select all instances of the search term within the document. Select
Match Case to find only the instances that exactly match the search term. Select the button to the
right of Match Case to open the Find & Replace dialog.

The Find toolbar can be closed by clicking the red X button on the left, or by pressing Esc on the
keyboard when the text cursor is in the search box.

Using the Find & Replace dialog
To display the Find & Replace dialog, use the keyboard shortcut Ctrl+H or choose Edit > Find &
Replace from the Menu bar. If the Find toolbar is open, click the Find and Replace button ( € ) on
the toolbar. Once opened, optionally click the Other Options symbol to expand the dialog. Click
the button again to reduce the dialog options.
To use the Find & Replace dialog:

1) Type the text you want to find in the Search for box.

2) To replace the text with different text, type the new text in the Replace with box.

3) You can select various options such as matching the case, matching whole words only, or
doing a search for similar words.

4) When you have set up your search, click Find. To replace the found text, click Replace.

For more information on using Find & Replace, see the Writer Guide.

If you click Find All, LibreOffice selects all instances of the search text in the

Tip document. Similarly, if you click Replace All, LibreOffice replaces all matches.
Caution Use Replace All with caution; otherwise, you may end up with some hilarious (and
highly embarrassing) mistakes. A mistake with Replace All might require a
manual, word-by-word, search to fix.
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Figure 70: Expanded Find & Replace dialog

Inserting special characters

A special character is one not found on a standard English keyboard. For example, © % & ¢ i 0 @
¢ are all special characters. To insert a special character:

1) Place the cursor where you want the character to appear.
2) Choose Insert > Special Character to open the Special Characters dialog.

3) Select the characters (from any font or mixture of fonts) you wish to insert, in order, then
click OK. The characters selected for insertion are shown in the lower left of the dialog. As
you select a character, it is shown on the right, along with its numerical code.

Not Different fonts include different special characters. If you do not find a particular
ote special character, try changing the Font selection.
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Special Characters
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Characters: cfiyde

ok || cancel || b || Dekete

Figure 71: The Special Characters dialog, where you can insert special characters

Inserting dashes and non-breaking spaces and hyphens

To prevent two words from being separated at the end of a line, press Ctrl+Shift when you type the
space between the two words.

In cases where you do not want the hyphen to appear at the end of a line, for example in a number
such as 123-4567, you can press Shift+Ctrl+minus sign to insert a non-breaking hyphen.

To enter en and em dashes, you can use the Replace dashes option on the Options tab under
Tools > AutoCorrect Options. This option replaces two hyphens, under certain conditions, with
the corresponding dash.

— is an en-dash; that is, a dash the width of the letter “n” in the font you are using. Type at
least one character, a space, one or two hyphens, another space, and at least one more
letter. The one or two hyphens will be replaced by an en-dash.

— is an em-dash; that is, a dash the width of the letter “m” in the font you are using. Type at
least one character, two hyphens, and at least one more character. The two hyphens will be
replaced by an em-dash.

See the Help for more details. For other methods of inserting dashes, see Chapter 3, Working with
Text in the Writer Guide.

Setting tab stops and indents

The horizontal ruler shows the tab stops. Any tab stops that you have defined will overwrite the
default tab stops. Tab settings affect indentation of full paragraphs (using the Increase Indent and
Decrease Indent buttons on the Formatting toolbar) as well as indentation of parts of a paragraph
(by pressing the Tab key on the keyboard).

Using the default tab spacing can cause formatting problems if you share documents with other
people. If you use the default tab spacing and then send the document to someone else who has
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chosen a different default tab spacing, tabbed material will change to use the other person’s
settings. Instead of using the defaults, define your own tab settings, as described in this section.

To define indents and tab settings for one or more selected paragraphs, double-click on a part of
the ruler that is not between the left and right indent icons to open the Indents & Spacing page of
the Paragraph dialog. Double-click anywhere between the left and right indent icons on the ruler to
open the Tabs page of the Paragraph dialog.

A better strategy is to define tabs for the paragraph style. See Chapters 6 and 7 in the Writer
Guide for more information.

Using tabs to space out material on a page is not recommended. Depending on

Tip what you are trying to accomplish, a table is usually a better choice.

Changing the default tab stop interval

Any changes to the default tab setting will affect the existing default tab stops in
Note any document you open afterward, as well as tab stops you insert after making the
change.

To set the measurement unit and the spacing of default tab stop intervals, go to Tools > Options >
LibreOffice Writer > General.

Settings
Measurement unit inch W
Tab stops 0.50" >

Figure 72: Selecting a default tab stop interval

You can also set or change the measurement unit for rulers in the current document by right-
clicking on the ruler to open a list of units. Click on one of them to change the ruler to that unit. The
selected setting applies only to that ruler.

Millime ter

Centimeter
| L Inch

Point

Pica

Line

Figure 73: Changing the measurement unit for a ruler

Checking spelling and grammar

Writer provides a spelling checker, which can be used in two ways.

sec | AutoSpellcheck checks each word as it is typed and displays a wavy red line under any
i unrecognized words. When the word is corrected, the line disappears.
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sec 10 perform a combined spelling and grammar check on the document (or a text selection)
click the Spelling and Grammar button. This checks the document or selection and opens
the Spelling and Grammar dialog if any unrecognized words are found. In order to use this,
the appropriate dictionaries must be installed. By default, four dictionaries are installed: a
spellchecker, a grammar checker, a hyphenation dictionary, and a thesaurus.

Here are some more features of the spelling checker:

* You can right-click on a word with a wavy underline to open a context menu. If you select
from the suggested words on the menu, the selection will replace the unrecognized word in
your text. Other menu options are discussed below.

* You can change the dictionary language (for example, Spanish, French or German) on the
Spelling and Grammar dialog.

* You can add a word to the dictionary. Click Add to Dictionary in the Spelling and Grammar
dialog or in the context menu.

* Click the Options button on the Spelling and Grammar dialog to open a dialog similar to
the one in Tools > Options > Language Settings > Writing Aids described in Chapter 2.
There you can choose whether to check uppercase words and words with numbers, and
you can manage custom dictionaries, that is, add or delete dictionaries and add or delete
words in a dictionary.

* There are a number of different methods by which you can set paragraphs to be checked in
a specific language (different from the rest of the document). For example by clicking on
the Language button on the Status Bar. See Chapter 7, Working with Styles, in the Writer
Guide for more information.

See Chapter 3, Working with Text, in the Writer Guide, for a detailed explanation of the spelling
and grammar checking facility.

Using built-in language tools

Writer provides some tools that make your work easier if you mix multiple languages within the
same document or if you write documents in various languages.

The main advantage of changing the language for a text selection is that you can then use the
correct dictionaries to check spelling and apply the localized versions of Autocorrect replacement
tables, thesaurus, grammar, and hyphenation rules.

You can also set the language for a paragraph or a group of characters as None (Do not check
spelling). This option is especially useful when you insert text such as web addresses or
programming language snippets that you do not want to check for spelling.

Specifying the language in character and paragraph styles can be problematic unless you use a
particular style for a different language. Changing the Language on the Font tab of the Paragraph
Styles dialog, will change the language for all paragraphs that use that paragraph style. You can
set certain paragraphs be checked in a language that is different from the language of the rest of
the document by putting the cursor in the paragraph and changing the language on the Status Bar.
See Chapter 7, Working with Styles, in the Writer Guide for information on how to manage the
language settings of a style.

You can also set the language for the whole document, for individual paragraphs, or even for
individual words and characters, from Tools > Language on the Menu bar.

Another way to change the language of a whole document is to use Tools > Options > Language
Settings > Languages. In the Default languages for documents section, you can choose a
different language for all the text that is not explicitly marked as a different language.
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AB
The spelling checker works only for those languages in the list that have the symbol ( rt"‘E;) next to
them. If you do not see the symbol next to your preferred language, you can install the additional
dictionary using Tools > Language > More Dictionaries Online.

The language used for checking spelling is also shown in the Status Bar, next to the page style in
use.

Using AutoCorrect

Writer's AutoCorrect function has a long list of common misspellings and typing errors, which it
corrects automatically. For example, “hte” will be changed to “the”.

AutoCorrect is turned on when Writer is installed. To turn it off, uncheck Format > AutoCorrect >
While Typing.

Choose Tools > AutoCorrect Options to open the AutoCorrect dialog. There you can define
which strings of text are corrected and how. In most cases, the defaults are fine.

To stop Writer replacing a specific spelling, go to the Replace tab, highlight the word pair, and click
Delete.

To add a new spelling to the list, type it into the Replace and With boxes on the Replace tab, and
click New.

See the different tabs of the dialog for the wide variety of other options available to fine-tune
AutoCorrect.

AutoCorrect can be used as a quick way to insert special characters. For example,

Tip (c) will be changed to ©. You can add your own special characters.

Using word completion

If Word Completion is enabled, Writer tries to guess which word you are typing and offers to
complete the word for you. To accept the suggestion, press Enter. Otherwise, continue typing.

To turn off Word Completion, select Tools > AutoCorrect Options > Word Completion and
deselect Enable word completion.

You can customize word completion from the Word Completion page of the AutoCorrect dialog:
* Add (append) a space automatically after an accepted word

e Show the suggested word as a tip (hovering over the word) rather than completing the text
as you type

e Collect words when working on a document, and then either save them for later use in
other documents or select the option to remove them from the list when closing the
document.

* Change the maximum number of words remembered for word completion and the length of
the smallest words to be remembered

* Delete specific entries from the word completion list

* Change the key that accepts a suggested entry—the options are Right arrow, End key,
Return (Enter), and Space bar

Automatic word completion only occurs after you type a word for the second time

Note in a document.
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Using AutoText

Use AutoText to store text, tables, graphics and other items for reuse and assign them to a key
combination for easy retrieval. For example, rather than typing “Senior Management” every time
you use that phrase, you can set up an AutoText entry to insert those words when you type “sm”
and press F3.

AutoText is especially powerful when assigned to fields. See Chapter 14, Working with Fields, in
the Writer Guide for more information.

Creating AutoText
To store some text as AutoText:
1) Type the text into your document.
2) Select the text.
3) Choose Edit > AutoText (or press Cirl+F3).

4) In the AutoText dialog box, type a name for the AutoText in the Name box. Writer will
suggest a one-letter shortcut, which you can change.

5) In the large box to the left, choose the category for the AutoText entry, for example My
AutoText.

6) Click the AutoText button on the right and select New (text only) from the menu.
7) Click Close to return to your document.

If the only option under the AutoText button is Import, either you have not entered

Tip a name for your AutoText or there is no text selected in the document.

Inserting AutoText
To insert AutoText, type the shortcut and press F3.

Formatting text

Using styles is recommended

Styles are central to using Writer. Styles enable you to easily format your document consistently,
and to change the format with minimal effort. A style is a named set of formatting options. When
you apply a style, you apply a whole group of formats at the same time. In addition, styles are used
by LibreOffice for many processes, even if you are not aware of them. For example, Writer relies
on heading styles (or other styles you specify) when it compiles a table of contents.

Sl Manual formatting (also called direct formatting) overrides styles, and you cannot get
A rid of the manual formatting by applying a style to it.

Writer defines several types of styles, for different types of elements: characters, paragraphs,
pages, frames, and lists. See Chapter 3, Using Styles and Templates, in this book and Chapters 6
and 7 in the Writer Guide.
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Formatting paragraphs

You can apply many formats to paragraphs using the buttons on the Formatting toolbar and by
using the Paragraph panel of the Sidebar's Properties deck (see Figure 60). Figure 74 shows the
Formatting toolbar as a floating toolbar, customized to show only the buttons for paragraph
formatting. The appearance of the buttons may vary with your operating system and the selection
of icon size and style in Tools > Options > LibreOffice > View.

Formatting *
Llaaefaultsm.a SN EIERERENEIEENENEEENEE -
1 2 3 4 5 B 7 8 9 101 1213 14
1 Open Styles and 5 Align Right 10 Numbering On/Off
Formatting Window 6 Justified 11 Bullets On/Off
2 Apply Style 7 Line Spacing: 1 12 Decrease Indent
3 Align Left 8 Line Spacing: 1.5 13 Increase Indent
4 Centered 9 Line Spacing: 2 14 Paragraph format dialog

Figure 74: Formatting toolbar, showing buttons for paragraph formatting

Formatting characters

You can apply many formats to characters using the buttons on the Formatting toolbar. Figure 75
shows the Formatting toolbar, customized to include only the buttons for character formatting. The
Character panel of the Sidebar's Properties deck also provides buttons for character formatting.

The appearance of the buttons may vary with your operating system and the selection of icon size
and style in Tools > Options > LibreOffice > View.

‘ I_a O0oTextBody % | |Liberation Sans w11 hl 8B A & ﬁ - A -El- HBE

1 2 3 4 5 6 7 8 9% 1011 12 13 14 15

1 Open Styles and Formatting 6 Italic 12 Font Color
Window 7 Underline 13 Highlighting

2 Apply Style 8 Superscript 14 Background Color

3 Font Name 9 Subscript 15 Open Character Format Dialog

4 Font Size 10 Increase Font

5 Bold 11 Reduce Font

Figure 75: Formatting toolbar, showing buttons for character formatting

To remove manual formatting, select the text and choose Format > Clear Direct
Tip Formatting from the Menu bar, or right-click and choose Clear Direct Formatting
from the context menu, or use Ctrl+M from the keyboard.

Autoformatting

You can set Writer to automatically format parts of a document according to the choices made on
the Options page of the AutoCorrect dialog (Tools > AutoCorrect Options).
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Ti If you notice unexpected formatting changes occurring in your document, this is
P the first place to look for the cause.

The Help describes each of these choices and how to activate the autoformats. Some common
unwanted or unexpected formatting changes include:

* Horizontal lines. If you type three or more hyphens (---), underscores (___) or equal signs
(===) on a line and then press Enter, the paragraph is replaced by a horizontal line as wide
as the page. The line is actually the lower border of the preceding paragraph.

¢ Bulleted and numbered lists. A bulleted list is created when you type a hyphen (-), star (*),
or plus sign (+), followed by a space or tab at the beginning of a paragraph. A numbered list
is created when you type a number followed by a period (.), followed by a space or tab at
the beginning of a paragraph. Automatic numbering is only applied to paragraphs formatted
with the Default, Text body or Text body indent paragraph styles.

To turn autoformatting on or off, choose Format > AutoCorrect and select or deselect the items on
the list.

Creating numbered or bulleted lists

There are several ways to create numbered or bulleted lists:
* Use autoformatting, as described above.

* Use list (numbering) styles, as described in Chapter 6, Introduction to Styles, and Chapter
7, Working with Styles, in the Writer Guide.

* Use the Numbering and Bullets buttons on the Formatting toolbar (see Figure 74) or on
the Paragraph panel of the Sidebar's Properties deck: select the paragraphs for the list,
and then click the appropriate button on the toolbar or in the Sidebar.

It is a matter of personal preference whether you type your information first, then

Note apply Numbering/Bullets, or apply them as you type.

Using the Bullets and Numbering toolbar

You can create nested lists (where one or more list items has a sub-list under it, as in an outline)
by using the buttons on the Bullets and Numbering toolbar (Figure 76). You can move items up or
down the list, create sub-points, change the style of bullets, and access the Bullets and Numbering
dialog, which contains more detaled controls. Use View > Toolbars > Bullets and Numbering to
see the toolbar.

If numbering or bullets are being applied automatically in a way that you find
Note inappropriate, you can switch them off temporarily by unchecking Format >
AutoCorrect > While Typing.

Using the Sidebar for Bullets and Numbering

The Bullets and Numbering features (drop-down palettes of tools) on the Paragraph panel on the
Properties deck of the Sidebar can also be used to create nested lists and access the Bullets and
Numbering dialog. However, the Sidebar does not include tools for promoting and demoting items
in the list, as found on the Bullets and Numbering toolbar.
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Bullets and Numbering *

TITTITIT T
1 2 3 4 5 67 8B 9% 1N
1 Promote One Level 5 Insert Unnumbered Entry 8 Move Up with Subpoints
2 Demote One Level 9 Move Down with Subpoints
3 Promote One Level with 6 Move Up 10 Restart Numbering
Subpoints
4 Demote One Level with 7 Move Down 11 Bullets and Numbering
Subpoints

Figure 76: Bullets and Numbering toolbar

Hyphenating words

You have several choices regarding hyphenation: let Writer do it automatically (using its
hyphenation dictionaries), insert conditional hyphens manually where necessary, or don’t
hyphenate at all.

Automatic hyphenation
To turn automatic hyphenation of words on or off:

1) Press F11 (36+T on Mac) to open the Styles and Formatting window, or, if the Sidebar is
open, click on the Styles and Formatting tab to open the Styles and Formatting deck.

2) On the Paragraph Styles page (Figure 77), right-click on Default Style and select Modify.

Styles and Formatting ]
i 2] £ o Ba 9= -
Complimentary Close -~
Default Style Il

First Line Ind HEw. ..
Hanaing Inde .
Heading Modify...
Heading 1
Heading 2
Heading 3 lal

Automatic v

Figure 77: Modifying a style

3) On the Paragraph Style dialog (Figure 78), go to the Text Flow page.
4) Under Hyphenation, select or deselect the Automatically option. Click OK to save.
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Paragraph 5tyle: Default Style
Position Qutline & Mumbering Tabs Drop Caps Background Borders
Organizer Indents & Spacing Alignment Text Flow Font Font Effect

Hyphenation
Automatically;
2 ‘%] Characters atline end
2 %1 Characters at line begin
0 ) Maximum number of consecutive hyphens

Figure 78: Turning on automatic hyphenation

Turning on hyphenation for paragraph Default Style affects all other paragraph
styles that are based on Default Style. You can individually change other styles so
that hyphenation is not active; for example, you might not want headings to be
hyphenated. Any styles that are not based on Default Style are not affected. See
Chapter 3, Using Styles and Templates, for more about styles based on other
styles.

Note

You can also set hyphenation choices through Tools > Options > Language Settings > Writing
Aids. In Options, near the bottom of the dialog, scroll down to find the hyphenation settings.

Options

Characters before line break: 2
Characters after line break: 2
r Hyphenate without inguiry
"2 Hyphenate spedal regions o

Minimurm number of characters for hyphenation: 5 i| Edit...

Figure 79: Setting hyphenation options

To change the minimum number of characters for hyphenation, the minimum number of characters
before a line break, or the minimum number of characters after a line break, select the item, and
then click the Edit button in the Options section.

Hyphenation options set on the Writing Aids dialog are effective only if hyphenation is turned on
through paragraph styles.

Manual hyphenation

To manually hyphenate words, do not use a normal hyphen, which will remain visible even if the
word is no longer at the end of a line when you add or delete text or change margins or font size.
Instead, use a conditional hyphen, which is visible only when required.

To insert a conditional hyphen inside a word, click where you want the hyphen to appear and press
Ctrl+hyphen. The word will be hyphenated at this position when it is at the end of the line, even if
automatic hyphenation for this paragraph is switched off.
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Formatting pages

Writer provides several ways for you to control page layouts: page styles, columns, frames, tables,
and sections. For more information, see Chapter 4, Formatting Pages, in the Writer Guide.

Page layout is usually easier if you show text, object, table, and section

Tip
Formatting Aids.

Which layout method to choose?

boundaries in Tools > Options > LibreOffice > Appearance, and paragraph end,
tabs, breaks, and other items in Tools > Options > LibreOffice Writer >

The best layout method depends on what the final document should look like and what sort of
information will be in the document. Here are some examples.

For a book similar to this user guide, with one
column of text, some figures without text beside
them, and some other figures with descriptive text,
use page styles for basic layout, and tables to place
figures beside descriptive text when necessary.

For an index or other document with two columns of
text, where the text continues from the left-hand
column to the right-hand column and then to the
next page, all in sequence (also known as “snaking
columns” of text), use page styles (with two
columns). If the title of the document (on the first
page) is full-page width, put it in a single-column
section.

[tems
formatted as
a table
Titleis in a
single .
column ST I —
section = L H et
:;':‘;.-.;_..‘r-“'-_ﬁ"-"—"‘_,—
Wﬁ‘ﬂm‘Hﬂ-—‘d-—mE
ATt (e e T e
T e
Basic layout = et EN
is in two 35 — T
o ey e e
columns Femeeam s PR LT T
““-‘;ﬂ.—- e . e
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For a newsletter with complex layout, two or three This is a

columns on the page, and some articles that header on

continue from one page to some place several the first page

pages later, use page styles for basic layout. Place only

articles in linked frames and anchor graphics to

fixed positions on the page if necessary. This frame is
linked to a
frame on

another page

These frames
are not linked

pair of words
is in a separate
row, and each
wordis in a
cell of the
table.

to other
frames
For a document with terms and translations to
appear side-by-side in what appear to be columns, T g s o st
use a table to keep items lined up, and so you can e
type in both “columns”. =L
Thisis a e
borderless e
table. Each = E{"

TR
i

EE[EE{{E[{E["

Creating headers and footers

A header is an area that appears at the top of a page above the margin. A footer appears at the
bottom of the page below the margin. Information such as page numbers inserted into a header or
footer displays on every page of the document with that page style.

Inserting a header or footer
To insert a header, you can either:
* Choose Insert > Header > Default Style (or some other page style, if not Default Style), or

* Click above the top margin to make the Header marker appear (Figure 80), and then click
on the +.

What |S Writer?ﬂ [Header (00oPageStyle) 'l']

Writer is the word processor component of LibreOffice. In addition to the usual features of a word
processor (spelling check, thesaurus, hyphenation, autocorrect, find and replace, automatic
generation of tables of contents and indexes, mail merge and others), Writer provides these

Figure 80: Header marker at top of text area
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After a header has been created, a down-arrow appears on the header marker. Click on this arrow
to drop down a menu of choices for working with the header (Figure 81).

Creati ng headers and footers T[ Header (OOoPageStyle)

. Format Header...
A header is an area that appears at the top of a page. A footer appears at the  gorder and Background...

Information such as page numbers inserted into a header or footer displays @  Delete Header...
document with that page style.

Figure 81: Header menu

To format a header, you can use either the menu item shown in Figure 81 or Format > Page >
Header. Both methods take you to the same tab on the Page Style dialog.

Inserting header and footer contents
Other information such as document titles and chapter titles is often put into the header or footer.
These items are best added as fields. That way, if something changes, the headers and footers are
updated automatically. Here is one common example.
To insert the document title into the header:

1) Choose File > Properties > Description and type a title for your document.

2) Add a header (Insert > Header > Default).

3) Place the cursor in the header part of the page.

4) Choose Insert > Fields > Title. The title should appear on a gray background (which does
not show when printed and can be turned off).

5) To change the title for the whole document, go back to File > Properties > Description.
Fields are covered in detail in Chapter 14, Working with Fields, in the Writer Guide.

For more about headers and footers, see Chapter 4, Formatting Pages, and Chapter 6,
Introduction to Styles, in the Writer Guide.

Numbering pages

Displaying the page number
To automatically display page numbers:
1) Insert a header or footer, as described in “Creating headers and footers” above.

2) Place the cursor in the header or footer where you want the page number to appear and
choose Insert > Fields > Page Number.

Including the total number of pages
To include the total number of pages (as in “page 1 of 12"):
1) Type the word “page” and a space, then insert the page number as above.

2) Press the space bar once, type the word “of” and a space, then choose Insert > Fields >
Page Count.

The Page Count field inserts the total number of pages in the document, as shown
on the Statistics tab of the document’s Properties window (File > Properties). If

Note you restart page numbering anywhere in the document, then the total page count
may not be what you want. See Chapter 4, Formatting Pages, in the Writer Guide
for more information.

Chapter 4 Getting Started with Writer | 103



Restarting page humbering

Often you will want to restart the page numbering at 1, for example on the page following a title
page or a table of contents. In addition, many documents have the “front matter” (such as the table
of contents) numbered with Roman numerals and the main body of the document numbered in
Arabic numerals, starting with 1.

You can restart page numbering in two ways.

Method 1:
1) Place the cursor in the first paragraph of the new page.
2) Choose Format > Paragraph.
3) On the Text Flow tab of the Paragraph dialog (Figure 78 on page 100), select Breaks.
4) Select Insert and then With Page Style and specify the page style to use.
5) Specify the page number to start from, and then click OK.

Method 1 is also useful for numbering the first page of a document with a page
. number greater than 1. For example, you may be writing a book, with each chapter
Tip in a separate file. Chapter 1 may start with page 1, but Chapter 2 could begin with
page 25 and Chapter 3 with page 51.

Method 2:
1) Insert > Manual break.
2) By default, Page break is selected on the Insert Break dialog (Figure 82).
3) Choose the required page Style.
4) Select Change page number.
5) Specify the page number to start from, and then click OK.

e S

Insert Break
Type
|
i) Line break
{*) Page break
sty
Default Style el
Chanage page number:
1 &3

Figure 82: Restarting page numbering after a manual page break

Changing page margins

You can change page margins in three ways:
* Using the page rulers—quick and easy, but does not have fine control
¢ Using the Page Style dialog—can specify margins to two decimal places
* Using the Page panel on the Properties deck of the Sidebar

104 | Getting Started with LibreOffice 4.2



If you change the margins, the new margins affect the page style and will be shown
in the Page Style dialog the next time you open it.

A Because the page style is affected, the changed margins apply to all pages using
that style.

Caution

To change margins using the rulers:

1) The gray sections of the rulers are the margins. Put the mouse cursor over the line
between the gray and white sections. The pointer turns into a double-headed arrow and
displays the current setting in a tool-tip.

2) Hold down the left mouse button and drag the mouse to move the margin.

!
: i

4 4 4

i

Figure 83: Moving the margins

The small arrowheads on the ruler (the gray triangles) are used for indenting

Caution paragraphs. They are often in the same place as the page margins, so you need to
be careful to move the margin marker, not the arrows. The double-headed arrows
shown in Figure 83 are mouse cursors shown in the correct position for moving the

margin markers.

To change margins using the Page Style dialog:
1) Right-click anywhere in the text area on the page and select Page from the context menu.
2) On the Page tab of the dialog, type the required distances in the Margins boxes.

To change margins using the Page panel of the Properties deck of the Sidebar:
1) On the open Sidebar (View > Sidebar) select the Properties tab.
2) Open the Page panel if is not open by clicking the plus (+) symbol in the panel title

3) Click the Margin button to open the sub-panel and enter the required dimensions in the
Custom size boxes (clicking the More Options button will open the Page Style dialog).

Adding comments to a document

Authors and reviewers often use comments to exchange ideas, ask for suggestions, or mark items
needing attention.

You can select a contiguous block of text, which may be multiple paragraphs, for a comment; or
you can select a single point at which the comment will be inserted.

To insert a comment, select the text, or place the cursor in the place the comment refers to, and
choose Insert > Comment or press Ctrl+Alt+C. The anchor point of the comment is connected by
a dotted line to a box on the right-hand side of the page where you can type the text of the
comment. A Comments button is also added to the right of the horizontal ruler; you can click this
button to toggle the display of the comments.
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Writer automatically adds at the bottom of the comment the author’'s name and a time stamp
indicating when the comment was created. Figure 84 shows an example of text with comments
from two different authors.

«t Modulel and click Save.
:ate other macros, for example to insert an em-dash. En-dash and Em-dash spelling

mize > Keyboard tab (Figure 11). In the Shortcut keys list, pick an EE:Thi;G match Help files.

; i ged for the shortcut
r example, Ctri-Shift+M for an em-dash). In the Category list, scroll names though.
acros, click the + sign {or small triangle, depending on your
click the + {or tiangle) next to the Standard library and choose e
n list, choose Emdash and click the Medify button on the upper
combination now appears in the Keys list on the lower right, and :
o [Ctri+Shift4M in the Shortcut keys list. ~ Formatting altered to meet

macro, selectiﬁg perhaps CtrH+5Shift+N for the shortcut key and then requirements|

Joe Soap
Today, 20:32

Figure 84: Example of comments

Choose Tools > Options > LibreOffice > User Data to configure the name you want to appear in
the Author field of the comment, or to change it.

If more than one person edits the document, each author is automatically allocated a different
background color.

Right-click on a comment to open a context menu where you can delete the current comment, all
the comments from the same author, or all the comments in the document. From this menu, you
can also apply some basic formatting to the text of the comment. You can paste saved text using
the Paste button in the menu. You can also change the font type, size, and alignment in the usual
editing manner.

To navigate from one comment to another, open the Navigator (F5), expand the Comments
section, and click on the comment text to move the cursor to the anchor point of the comment in
the document. Right-click on the comment to quickly edit or delete it.

You can also navigate through the comments using the keyboard. Use Ctrl+Alt+Page Down to
move to the next comment and Ctrl+Alt+Page Up to move to the previous comment.

Creating a table of contents

Writer’s table of contents feature lets you build an automated table of contents from the headings
in your document. Before you start, make sure that the headings are styled consistently. For
example, you can use the Heading 1 style for chapter titles and the Heading 2 and Heading 3
styles for chapter subheadings.

Although tables of contents can be customized extensively in Writer, often the default settings are
all you need. Creating a quick table of contents is simple:

1) When you create your document, use the following paragraph styles for different heading
levels (such as chapter and section headings): Heading 1, Heading 2, Heading 3, and so
on. These are what will appear in your table of contents.

2) Place the cursor where you want the table of contents to be inserted.
3) Choose Insert > Indexes and Tables > Indexes and Tables.
4) Change nothing in the Insert Index/Table dialog. Click OK.

If you add or delete text (so that headings move to different pages) or you add, delete, or change
headings, you need to update the table of contents.
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To do this:
1) Place the cursor within the table of contents.
2) Right-click and choose Update Index/Table from the context menu.

If you cannot place the cursor in the table of contents, choose Tools > Options >
Note LibreOffice Writer > Formatting Aids, and then select Enable in the Cursor in
protected areas section.

You can customize an existing table of contents at any time. Right-click anywhere in it and choose

Edit Index/Table from the context menu. Chapter 12, Creating Tables of Contents, Indexes and
Bibliographies, of the Writer Guide describes in detail all the customizations you can choose.

Creating indexes and bibliographies

Indexes and bibliographies work in a similar way to tables of contents. Chapter 12, Creating Tables
of Contents, Indexes and Bibliographies, in the Writer Guide describes the process in detail.

In addition to alphabetical indexes, other types of indexes supplied with Writer include those for
illustrations, tables, and objects, and you can even create a user-defined index. For example, you
might want an index containing only the scientific names of species mentioned in the text, and a
separate index containing only the common names of species. Before creating some types of
indexes, you first need to create index entries embedded in your Writer document.

Working with graphics

Graphics in Writer are of three basic types:
* Image files, including photos, drawings, scanned images, and others
* Diagrams created using LibreOffice’s drawing tools
* Charts created using LibreOffice’s Chart component

See Chapter 11, Graphics, the Gallery, and Fontwork, in this book and Chapter 8, Working with
Graphics, in the Writer Guide.

Printing

See Chapter 10, Printing, Exporting, and E-mailing, in this book and Chapter 5, Printing, Exporting,
Faxing, and E-mailing, in the Writer Guide for details on previewing pages before printing, selecting
print options, printing in black and white on a color printer, printing brochures, and other printing
features.

Using mail merge

Writer provides very useful features to create and print:
* Multiple copies of a document to send to a list of different recipients (form letters)
* Mailing labels
* Envelopes
All these facilities use a registered data source (a spreadsheet or database containing the name

and address records and other information). Chapter 11, Using Mail Merge, in the Writer Guide
describes the process.
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Tracking changes to a document

You can use several methods to keep track of changes made to a document.

1) Make your changes to a copy of the document (stored in a different folder, or under a
different name, or both), then use Writer to combine the two files and show the differences.
Choose Edit > Compare Document. This technique is particularly useful if you are the
only person working on the document, as it avoids the increase in file size and complexity
caused by the other methods.

2) Save versions that are stored as part of the original file. However, this method can cause
problems with documents of non-trivial size or complexity, especially if you save a lot of
versions. Avoid this method if you can.

3) Use Writer's change marks (often called “redlines” or “revision marks”) to show where you
have added or deleted material, or changed formatting. Choose Edit > Changes > Record
before starting to edit. Later, you or another person can review and accept or reject each
change. Choose Edit > Changes > Show. Right-click on an individual change and choose
Accept Change or Reject Change from the context menu, or choose Edit > Changes >
Accept or Reject to view the list of changes and accept or reject them. Details are in the
Writer Guide.

Not all changes are recorded. For example, changing a tab stop from align left to

Tip align right, and changes in formulas (equations) or linked graphics are not
recorded.
Using fields

Fields are extremely useful features of Writer. They are used for data that changes in a document
(such as the current date or the total number of pages) and for inserting document properties such
as name, author, and date of last update. Fields are the basis of cross-referencing (see below);
automatic numbering of figures, tables, headings, and other elements; and a wide range of other
functions—far too many to describe here. See Chapter 14, Working with Fields, in the Writer Guide
for details.

Linking to another part of a document

If you type in cross-references to other parts of a document, those references can easily get out of
date if you reorganize the order of topics, add or remove material, or reword a heading. Writer
provides two ways to ensure that your references are up to date, by inserting links to other parts of
the same document or to a different document:

* Hyperlinks
* Cross-references

The two methods have the same result if you Ctri+click the link when the document is open in
Writer: you are taken directly to the cross-referenced item. However, they also have major
differences:

* The text in a hyperlink does not automatically update if you change the text of the linked
item (although you can change it manually), but changed text does automatically update in
a cross-reference.

* When using a hyperlink, you do not have a choice of the content of the link (for example
text or page number), but when using a cross-reference, you have several choices,
including bookmarks.
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To hyperlink to an object such as a graphic, and have the hyperlink show useful text such
as Figure 6, you need to give such an object a useful name (instead of a default name like
Graphics6), or use the Hyperlink dialog to modify the visible text. In contrast, cross-
references to figures with captions automatically show useful text, and you have a choice of
several variations of the name.

If you save a Writer document to HTML, hyperlinks remain active but cross-references do
not. (Both remain active when the document is exported to PDF.)

Using hyperlinks

The easiest way to insert a hyperlink to another part of the same document is by using the
Navigator:

1)
2)
3)

4)

5)
6)

Open the document containing the items you want to cross-reference.
Open the Navigator by clicking its button, choosing View > Navigator, or by pressing F5.

Click the arrow part of the combination Drag Mode button, and choose Insert as
Hyperlink.

In the list at the bottom of the Navigator, select the document containing the item that you
want to cross-reference.

In the Navigator list, select the item that you want to insert as a hyperlink.

Drag the item to where you want to insert the hyperlink in the document. The name of the
item is inserted in the document as an active hyperlink.

You can also use the Hyperlink dialog to insert and modify hyperlinks within and between
documents. See Chapter 12, Creating Web Pages.
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Changing document views:
Moving quickly through a document

+  Working with documents ]
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e
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Figure 85: Inserting a hyperlink using the Navigator

Using cross-references

If you type in references to other parts of the document, those references can easily get out of date
if you reword a heading, add or remove figures, or reorganize topics. Replace any typed cross-
references with automatic ones and, when you update fields, all the references will update
automatically to show the current wording or page numbers. The Cross-references tab of the
Fields dialog lists some items, such as headings, bookmarks, figures, tables, and numbered items
such as steps in a procedure. You can also create your own reference items; see “Setting
References” in Chapter 14, Working with Fields, in the Writer Guide for instructions.
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To insert a cross-reference to a heading, figure, bookmark, or other item:
1) In your document, place the cursor where you want the cross-reference to appear.

2) If the Fields dialog is not open, click Insert > Cross-reference. On the Cross-references
tab (Figure 86), in the Type list, select the type of item to be referenced (for example,
Heading or Figure). You can leave this page open while you insert many cross-references.

3) Click on the required item in the Selection list, which shows all the items of the selected
type. In the Insert reference to list, choose the format required. The list varies according to
the Type. The most commonly used options are Reference (to insert the full text of a
heading or caption), Category and Number (to insert a figure number preceded by the
word Figure or Table, but without the caption text), Numbering (to insert only the figure or
table number, without the word “Figure” or “Table”), or Page (to insert the number of the
page the referenced text is on). Click Insert.

.,
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Document |Cross-references Functions |DocInformation |Variables |Database

Type Selection
Set Reference Figure 1: The main Writer warkspace in Print Layout wview |
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Figure 86: The Cross-references tab of the Fields dialog

Using bookmarks

Bookmarks are listed in the Navigator and can be accessed directly from there with a single mouse
click. You can cross-reference to bookmarks and create hyperlinks to bookmarks, as described
above.

1) Select the text you want to bookmark. Click Insert > Bookmark.

2) On the Insert Bookmark dialog, the larger box lists any previously defined bookmarks. Type
a name for this bookmark in the top box, and then click OK.
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Figure 87: Inserting a bookmark

Using master documents

Master documents are typically used for producing long documents such as a book, a thesis, or a
long report; or when different people are writing different chapters or other parts of the full
document, so you don’t need to share files. A master document joins separate text documents into
one larger document, and unifies the formatting, table of contents (TOC), bibliography, index, and
other tables or lists.

Yes, master documents do work in Writer. However, until you become familiar with them, you may
think that master documents are unreliable or difficult to use. See Chapter 13, Working with Master
Documents, in the Writer Guide.

Creating fill-in forms

A standard text document displays information: a letter, report, or brochure, for example. Typically
the reader may either edit everything or nothing in any way. A form has sections that are not to be
edited, and other sections that are designed for the reader to make changes. For example, a
guestionnaire has an introduction and questions (which do not change) and spaces for the reader
to enter answers.

Forms are used in three ways:

* To create a simple document for the recipient to complete, such as a questionnaire sent out
to a group of people who fill it in and return it.

¢ Tolink into a database or data source and allow the user to enter information. Someone
taking orders might enter the information for each order into a database using a form.

* To view information held in a database or data source. A librarian might call up information
about books.

Writer offers several ways to fill information into a form, including check boxes, option buttons, text
boxes, pull-down lists and spinners. See Chapter 15, Using Forms in Writer, in the Writer Guide.
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What is Calc?

Calc is the spreadsheet component of LibreOffice. You can enter data (usually numerical) in a
spreadsheet and then manipulate this data to produce certain results.

Alternatively, you can enter data and then use Calc in a ‘What if...” manner by changing some of
the data and observing the results without having to retype the entire spreadsheet or sheet.

Other features provided by Calc include:
* Functions, which can be used to create formulas to perform complex calculations on data.
¢ Database functions, to arrange, store, and filter data.
* Dynamic charts; a wide range of 2D and 3D charts.

* Macros, for recording and executing repetitive tasks; scripting languages supported include
LibreOffice Basic, Python, BeanShell, and JavaScript.

* Ability to open, edit, and save Microsoft Excel spreadsheets.

* Import and export of spreadsheets in multiple formats, including HTML, CSV, PDF, and
PostScript.

If you want to use macros written in Microsoft Excel using the VBA macro code in
Note LibreOffice, you must first edit the code in the LibreOffice Basic IDE editor. See
Chapter 13 Getting Started with Macros and Calc Guide Chapter 12 Calc Macros.

Spreadsheets, sheets and cells

Calc works with elements called spreadsheets. Spreadsheets consist of a number of individual
sheets, each sheet containing cells arranged in rows and columns. A particular cell is identified by
its row number and column letter.

Cells hold the individual elements — text, numbers, formulas, and so on — that make up the data to
display and manipulate.

Each spreadsheet can have several sheets, and each sheet can have several individual cells. In
Calc, each sheet can have a maximum of 1,048,576 rows (65,536 rows in Calc 3.2 and earlier) and
a maximum of 1024 columns.

Calc main window

When Calc is started, the main window opens (Figure 88). The parts of this window are described
below.

Title bar

The Title bar, located at the top, shows the name of the current spreadsheet. When the
spreadsheet is newly created, its name is Untitled X, where X is a number. When you save a
spreadsheet for the first time, you are prompted to enter a name of your choice.

Menu bar

The Menu bar is where you select one of the menus and various sub-menus appear giving you
more options. You can also customize the Menu bar; see Chapter 14 Customizing LibreOffice for
more information.
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Figure 88: Calc main dialog, without Sidebar

* File — contains commands that apply to the entire document; for example Open, Save,
Wizards, Export as PDF, Print, Digital Signatures and so on.

¢ Edit — contains commands for editing the document; for example Undo, Copy, Changes,
Fill, Plug-in and so on.

* View — contains commands for modifying how the Calc user interface looks; for example
Toolbars, Column & Row Headers, Full Screen, Zoom and so on.

* Insert — contains commands for inserting elements into a spreadsheet; for example Cells,
Rows, Columns, Sheets, Picture and so on.

* Format — contains commands for modifying the layout of a spreadsheet; for example Cells,
Page, Styles and Formatting, Alignment and so on.

* Tools — contains various functions to help you check and customize your spreadsheet, for
example Spelling, Share Document, Gallery, Macros and so on.

* Data — contains commands for manipulating data in your spreadsheet; for example Define
Range, Sort, Consolidate and so on.

* Window — contains commands for the display window; for example New Window, Split and
S0 on.

* Help — contains links to the help system included with the software and other
miscellaneous functions; for example Help, License Information, Check for Updates and so
on.

Toolbars

The default setting when Calc opens is for the Standard and Formatting toolbars to be docked at
the top of the workspace (Figure 88).
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Calc toolbars can be either docked and fixed in place, or floating, allowing you to move a toolbar
into a more convenient position on your workspace. Docked toolbars can be undocked and moved
to different docked position on the workspace, or undocked to become a floating toolbar. Toolbars
that are floating when opened can be docked into a fixed position on your workspace.

The default set of icons (sometimes called buttons) on toolbars provide a wide range of common
commands and functions. You can also remove or add icons to toolbars, see Chapter 14
Customizing LibreOffice for more information.

Formula bar

The Formula Bar is located at the top of the sheet in the Calc workspace. The Formula Bar is
permanently docked in this position and cannot be used as a floating toolbar. If the Formula Bar is
not visible, go to View on the Menu bar and select Formula Bar.

(A1 v A E = | I

Figure 89: Formula bar

Going from left to right and referring to Figure 89, the Formula Bar consists of the following:

* Name Box — gives the cell reference using a combination of a letter and number, for
example Al. The letter indicates the column and the number indicates the row of the
selected cell.

* Function Wizard ﬁ; — opens a dialog from which you can search through a list of
available functions. This can be very useful because it also shows how the functions are
formatted.

* Sum E — clicking on the Sum icon totals the humbers in the cells above the selected cell
and then places the total in the selected cell. If there are no numbers above the selected
cell, then the cells to the left are totaled.

* Function = - clicking on the Function icon inserts an equals (=) sign into the selected cell
and the Input line, allowing a formula to be entered.

* Input line — displays the contents of the selected cell (data, formula, or function) and
allows you to edit the cell contents.

* You can also edit the contents of a cell directly in the cell itself by double-clicking on the
cell. When you enter new data into a cell, the Sum and Function icons change to Cancel

and Accept icons o "‘5?.

In a spreadsheet the term function covers much more than just mathematical
Note functions. See the Calc Guide Chapter 7 Using Formulas and Functions in for more
information.

Spreadsheet layout

Individual cells

The main section of the workspace in Calc displays the cells in the form of a grid. Each cell is
formed by the intersection of the columns and rows in the spreadsheet.

At the top of the columns and the left end of the rows are a series of header boxes containing
letters and numbers. The column headers use an alpha character starting at A and go on to the
right. The row headers use a numerical character starting at 1 and go down.
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These column and row headers form the cell references that appear in the Name Box on the
Formula Bar (Figure 89). If the headers are not visible on your spreadsheet, go to View on the
Menu bar and select Column & Row Headers.

Sheet tabs

In Calc you can have more than one sheet in a spreadsheet. At the bottom of the grid of cells in a
spreadsheet are sheet tabs indicating how many sheets there are in your spreadsheet. Clicking on
a tab enables access to each individual sheet and displays that sheet. An active sheet is indicated
with a white tab (default Calc setup). You can also select multiple sheets by holding down the Ctr/
key while you click on the sheet tabs.

To change the default name for a sheet (Sheetl, Sheet2, and so on), right-click on a sheet tab and
select Rename Sheet from the context menu. A dialog opens, in which you can type a new name
for the sheet. Click OK when finished to close the dialog.

To change the color of a sheet tab, right-click on the tab and select Tab Color from the context
menu to open the Tab Color dialog (Figure 90). Select your color and click OK when finished to
close the dialog. To add new colors to this color palette, see Chapter 14 Customizing LibreOffice
for more information.
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Figure 90: Tab color dialog

Status bar

The Calc status bar (Figure 91) provides information about the spreadsheet as well as quick and
convenient ways to change some of its features. Most of the fields are similar to those in other
components of LibreOffice; see Chapter 1 Introducing LibreOffice in this guide and the Calc Guide
Chapter 1 Introducing Calc for more information.

Selection Digital Cell or object Zoom
mude\‘ signat\ui infﬂrm\atin percentage
Sheet1/1 Default m  [F Sum=0 = O + | 100%
Sheet Page Insert Unsaved Zoom
number style mode changes slider

Figure 91: Calc status bar
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Sidebar

The Calc Sidebar (View > Sidebar) is located on the right side of the window. It is a mixture of
toolbar and dialog and consists of five decks: Properties, Styles and Formatting, Gallery,
Navigator, and Functions. Each deck has a corresponding icon on the Tab panel to the right of the

sidebar, allowing you to switch between them.

Properties XN = Configuration Menu button
=l Character ] ]
fa- Title bar
Liberation Sans v 10 | = %
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A - &)
=E === Ell .
EY &Y Panel title
Left indent: Merge Cells
. Deck
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Text orientation:
Content panel
ARy Vertically Stacked
= —=
- | . 0° -
E cell Appearance = More Options button

Figure 92: Calc Sidebar with Properties open
The decks are described below.

* Properties: This deck includes four content panels.

- Character: Provides controls for formatting the text, such as font family, size, and color.
Some controls, such as superscript, only become active when the text cursor is active

in the Input line of the Formula bar or the cell.

- Alignment: Provides controls to align the text in various ways, including horizontal and
vertical alignment, wrapping, indenting, merging, text orientation, and vertical stacking.

- Cell Appearance: Provides controls to set the appearance options, including cell
background color, cell border formats including line color and style, and grid lines.

- Number Format: Provides a way to quickly change the format of numbers including
decimals, currency, dates, or numeric text. Numerical and label field controls for Forms

are also available.

Each of these panels has a More Options button, which opens a dialog that gives a
greater number of options. These dialogs lock the document for editing until they are

closed.

¢ Styles and Formatting: This deck contains a single panel, which is the same as that
opened by selecting the Styles and Formatting button (F11) from the Text Formatting

toolbar.

* Gallery: This deck contain a single panel, which is the same as that opened by selecting
Gallery from the Standard toolbar or Tools > Gallery from the Menu bar.
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Navigator: This deck contains a single panel, which is essentially the same as the
Navigator window opened by clicking the Navigator button on the Standard toolbar or
selecting View > Navigator (F5) from the Menu bar. Only the Contents button is absent in
the Sidebar’s Navigator panel.

Functions: This deck contains a single panel, which is the same as the window opened by
selecting Insert > Function List from the Menu bar.

To the right side of the title bar of each open deck is a Close button (X), which closes the deck to
leave only the Tab bar open. Clicking on any Tab button reopens the deck.

The Sidebar can be hidden, or revealed if already hidden, by clicking on the edge Hide/Show
button. You can adjust the deck width by dragging on the left edge of the sidebar.

Opening a CSV file

Comma-separated-values (CSV) files are spreadsheet files in a text format where cell contents are
separated by a character, for example a comma or semi-colon. Each line in a CSV text file
represents a row in a spreadsheet. Text is entered between quotation marks; numbers are entered

without quotation marks.
To open a CSV file in Calc:

1)
2)

3)

Choose File > Open on the Menu bar and locate the CSV file that you want to open.
Select the file and click Open. By default, a CSV file has the extension .csv. However,
some CSV files may have a . txt extension.

The Text Import dialog (Figure 93) opens allowing you to select the various options
available when importing a CSV file into a Calc spreadsheet.

% 0 Text Import - [SampleSpreadsheet.csv]

&
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Character set | SOV N (Bnas: =

Language |Default - English (UK) =

From row 1 =

Separator options
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& Tab & comma & semicolon Space Other
Merge delimiters Text delimiter | " v

Other options

Quoted field as text | Detect special numbers
Fields
Column type
__|standard |Standard _|standard __|Standard |Standard |Standard
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Figure 93: Text Import dialog
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4) Click OK to open and import the file.

The various options for importing CSV files into a Calc spreadsheet are as follows:

* Import

Character Set — specifies the character set to be used in the imported file.
Language — determines how the number strings are imported.

If Language is set to Default for CSV import, Calc will use the globally set language. If
Language is set to a specific language, that language will be used when importing
numbers.

From Row — specifies the row where you want to start the import. The rows are visible
in the preview window at the bottom of the dialog.

e Separator Options — specifies whether your data uses separators or fixed widths as
delimiters.

Fixed width — separates fixed-width data (equal number of characters) into columns.
Click on the ruler in the preview window to set the width.

Separated by — select the separator used in your data to delimit the data into columns.
When you select Other, you specify the character used to separate data into columns.
This custom separator must also be contained in your data.

Merge delimiters — combines consecutive delimiters and removes blank data fields.
Text delimiter — select a character to delimit text data.

¢ Other options

Quoted fields as text — when this option is enabled, fields or cells whose values are
guoted in their entirety (the first and last characters of the value equal the text delimiter)
are imported as text.

Detect special numbers — when this option is enabled, Calc will automatically detect all
number formats, including special number formats such as dates, time, and scientific
notation.

The selected language also influences how such special numbers are detected, since
different languages and regions many have different conventions for such special
numbers.

When this option is disabled, Calc will detect and convert only decimal numbers. The
rest, including numbers formatted in scientific notation, will be imported as text. A
decimal number string can have digits 0-9, thousands separators, and a decimal
separator. Thousands separators and decimal separators may vary with the selected
language and region.

* Fields — shows how your data will look when it is separated into columns.

Column type — select a column in the preview window and select the data type to be
applied the imported data.

Standard — Calc determines the type of data.
Text — imported data are treated as text.

US English — numbers formatted in US English are searched for and included
regardless of the system language. A number format is not applied. If there are no US
English entries, the Standard format is applied.

Hide — the data in the column are not imported.
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Saving spreadsheets

To save a spreadsheet, see Chapter 1 Introducing LibreOffice for more details on how to save files
manually or automatically. Calc can also save spreadsheets in a range of formats and also export
spreadsheets to PDF, HTML and XHTML file formats, see the Calc Guide Chapter 6 Printing,
Exporting, and E-mailing for more information.

Saving in other spreadsheet formats

If you need to exchange files with users who are unable to receive spreadsheet files in Open
Document Format (ODF) (* . ods), which Calc uses as default format, you can save a spreadsheet
in an another format.

1)
2)
3)
4)
5)

6)
7

8)

Save your spreadsheet in Calc spreadsheet file format (* . ods).

Select File > Save As on the Menu bar to open the Save As dialog (Figure 94).

In File name, if you wish, enter a new file name for the spreadsheet.

In File type drop-down menu, select the type of spreadsheet format you want to use.

If Automatic file name extension is selected, the correct file extension for the
spreadsheet format you have selected will be added to the file name.

Click Save.

Each time you click Save, the Confirm File Format dialog opens (Figure 95). Click Use
[xxx] Format to continue saving in your selected spreadsheet format or click Use ODF
Format to save the spreadsheet in Calc ODS format.

If you select Text CSV format (* . csv) for your spreadsheet, the Export Text File dialog

(Figure 96) opens allowing you to select the character set, field delimiter, text delimiter and
S0 on to be used for your CSV file.

@@ Saveas
[;"humefpeterfDrnpbnfoOBﬁ- Calc Guide l - | |5 [“_1
Places Title |T3.rpe Size |Date modified
[3 Default Directo 5 calc 3.4 Folder 29/11/2012, 13:04:47 [~
3 chapoo Folder 29/11/2012, 13:03:48
3 Chap01 Folder 06/12/2012,11:56:32 |=
3 chapo2 Folder 29/11/2012, 13:03:49
3 chapo3 Folder 29/11/2012, 13:04:17
3 chapo4 Folder 29/11/2012, 13:03:48
3 chapos Folder 29/11/2012, 13:04:47
3 chapoé Folder 29/11/2012, 13:04:17
3 chapo? Folder 29/11/2012,13:03:49 |
= 1 Chapo8 Folder 29/11/2012.13:03:49 =
File name: [ sampleSpreadsheet [w] “
File type: IMicrosoft Excel 2007/2010/2013 XML (.xlsx) §z GanEal |
. Help .
[[] save with password & Automatic file name extension
_| EditFilter settings

Figure 94: Save As dialog
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( @ Confirm File Format W
This document may contain formatting or content that cannot be

saved in the currently selected File format "Microsoft Excel
2007/2010/2013 XML".

Use the default ODF File Format to be sure that the document is saved correctly.

& Ask when notsaving in ODF format

| Use ODF Format | I ‘Use Microsoft Excel 2007/2010/2013 XML Format:

Figure 95: Confirm File Format dialog

@ Export Text File
Field options

Character set lUnicode (UTF-8) B ﬁ
Field delimiter [ : [ =]
Text delimiter (" [w] Help

[& Save cell content as shown

[] save cell formulae instead of calculated values
[[] Quote all text cells

[ Fixed column width

Figure 96: Export Text File dialog for CSV files

To have Calc save documents by default in a file format other than the default ODF
format, go to Tools > Options > Load/Save > General. In Default file format and
ODF settings > Document type, select Spreadsheet, then in Always save as,
select your preferred file format.

Tip

Navigating within spreadsheets

Calc provides many ways to navigate within a spreadsheet from cell to cell and sheet to sheet. You
can generally use the method you prefer.

Cell navigation

When a cell is selected or in focus, the cell borders are emphasized. When a group of cells is
selected, the cell area is colored. The color of the cell border emphasis and the color of a group of
selected cells depends on the operating system being used and how you have set up LibreOffice.

* Using the mouse — place the mouse pointer over the cell and click the left mouse button.
To move the focus to another cell using the mouse, simply move the mouse pointer to the
cell where you want the focus to be and click the left mouse button.

* Using a cell reference — highlight or delete the existing cell reference in the Name Box on
the Formula Bar (Figure 89 on page 116). Type the new cell reference of the cell you want
to move to and press Enter key. Cell references are case-insensitive: for example, typing
either a3 or A3 will move the focus to cell A3.
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* Using the Navigator — click on the Navigator icon @ on the Standard toolbar or press
the F5 key to open the Navigator dialog (Figure 97) or click the Navigator Tab button in
the open Sidebar. Type the cell reference into the Column and Row fields and press the
Enter key.

* Using the Enter key — pressing Enter moves the cell focus down in a column to the next
row. Pressing Shift+Enter moves the focus up in a column to the next row.

* Using the Tab key — pressing Tab moves the cell focus right in a row to the next column.
Pressing Shift+Tab moves the focus to the left in a row to the next column.

* Using the arrow keys — pressing the arrow keys on the keyboard moves the cell focus in
the direction of the arrow pressed.

@ Navigaktor

column A - B B8
Row 1 - % B e -

Sheet1
Sheet2
Sheet3
Sheet4
Sheets
EH Range names
& Database ranges
P Linked areas
B Image
|th OLE objects
[Z) comments
&Y Drawing objects

Unkiliecd (active) -

Figure 97: Navigator dialog in Calc
* Using Home, End, Page Up and Page Down
- Home moves the cell focus to the start of a row.
- End moves the cell focus to the last cell on the right in the row that contains data.
- Page Down moves the cell focus down one complete screen display.
- Page Up moves the cell focus up one complete screen display.

Sheet navigation

Each sheet in a spreadsheet is independent of the other sheets in a spreadsheet, though
references can be linked from one sheet to another sheet. There are three ways to navigate
between different sheets in a spreadsheet.

* Using the Navigator — when the Navigator is open (Figure 97), double-clicking on any of
the listed sheets selects the sheet.

* Using the keyboard — using key combinations Ctrl+Page Down moves one sheet to the
right and Ctrl+Page Up moves one sheet to the left.

* Using the mouse — clicking on one of the sheet tabs at the bottom of the spreadsheet
selects that sheet.

If your spreadsheet contains a lot of sheets, then some of the sheet tabs may be hidden behind the
horizontal scroll bar at the bottom of the screen. If this is the case:

* Using the four buttons to the left of the sheet tabs can move the tabs into view (Figure 98).
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* Dragging the scroll bar edge to the right may reveal all the tabs.

* Right-clicking on any of the arrows opens a context menu where you can select a sheet
(see Figure 99).

When you insert a new sheet into your spreadsheet, Calc automatically uses the
next number in the numeric sequence as a name. Depending on which sheet is

Note open when you insert a new sheet, and the method you use to insert a new sheet,
the new sheet may not be in numerical order. It is recommended to rename sheets
in your spreadsheet to make them more recognizable.

Move to the first sheet
Move to the next sheet on the left
Mave to the next sheet on the right

/ Move to the last sheet

Sheet 2 /6 Default

Sheet tabs
Figure 98: Navigating sheet tabs

26
27

29 |

v Sheelt
Sheet2

L Sheet3
7 Sheet4
Sheets

[ itz /Sheets ;Sheetd /Sheet)

e e e

Sheet1/5
Figure 99: Right-click any arrow button

Keyboard navigation

Pressing a key or a combination of keys allows you to navigate a spreadsheet using the keyboard.
A key combination is where you press more than one key together, for example Ctrl+Home key
combination to move to cell A1. Table 4 lists the keys and key combinations you can use for
spreadsheet navigation in Calc.

Table 4. Keyboard cell navigation

ls(ﬁg ftgz:d Cell navigation

- Moves cell focus right one cell
- Moves cell focus left one cell

1 Moves cell focus up one cell

l Moves cell focus down one cell
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Keyboard
shortcut

Ctri+ -

Ctrl+ —

Ctrl+1

Ctrl+!

Ctrl+Home

Ctrl+End

Alt+Page Down
Alt+Page Up
Ctrl+Page Down

Ctrl+Page Up

Tab
Shift+Tab
Enter

Shift+Enter

Cell navigation

Moves cell focus to the first column on the right containing data in that row if
cell focus is on a blank cell.

Moves cell focus to the last column on the right in the same range of occupied
cells in that row if cell focus is on a cell containing data.

Moves cell focus to the last column on the right in the spreadsheet if there are
no more cells containing data.

Moves cell focus to the last column on the left containing data in that row if
cell focus is on a blank cell.

Moves cell focus to the first column on the left in the same range of occupied
cells in that row if cell focus is on a cell containing data.

Moves cell focus to the first column in that row if there are no more cells
containing data.

Moves cell focus from a blank cell to the first cell above containing data in the
same column.

Moves cell focus to the first row in the same range of occupied cells if cell
focus is on a cell containing data.

Moves cell focus from the last cell containing data to the cell in the same
column in the last row of the spreadsheet.

Moves cell focus from a blank cell to the first cell below containing data in the
same column.

Moves cell focus to the last row in the same range of occupied cells in that
column if cell focus is on a cell containing data.

Moves cell focus from the last cell containing data to the cell in the same
column in the last row of the spreadsheet.

Moves cell focus from anywhere on the spreadsheet to Cell A1 on the same
sheet.

Moves cell focus from anywhere on the spreadsheet to the last cell in the
lower right-hand corner of the rectangular area of cells containing data on the
same sheet.

Moves cell focus one screen to the right (if possible).
Moves cell focus one screen to the left (if possible).

Moves cell focus to the same cell on the next sheet to the right in sheet tabs if
the spreadsheet has more than on sheet.

Moves cell focus to the same cell on the next sheet to the left in sheet tabs if
the spreadsheet has more than on sheet.

Moves cell focus to the next cell on the right
Moves cell focus to the next cell on the left
Down one cell (unless changed by user)

Up one cell (unless changed by user)
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Customizing the Enter key

You can customize the direction in which the Enter key moves the cell focus by going to Tools >
Options > LibreOffice Calc > General. Select the direction cell focus moves from the drop-down
list. Depending on the file being used or the type of data being entered, setting a different direction
can be useful. The Enter key can also be used to switch into and out of editing mode. Use the first
two options under Input settings in Figure 100 to change the Enter key settings.

Input settings

B Press Enter to move selection =

Down
[] Press Enter ko switch to edit mode Right
"] Expand formatting up

[ ] Expand references when new columns/rows are inserted
& Highlight selection in column/row headers

[] Use printer metrics For text Formatting

& show overwrite warning when pasting data

Figure 100: Customizing the Enter key

Selecting items in a spreadsheet

Selecting cells

Single cell

Left-click in the cell. You can verify your selection by looking in the Name Box on the Formula Bar
(Figure 89 on page 116).

Range of contiguous cells
Arange of cells can be selected using the keyboard or the mouse.

To select a range of cells by dragging the mouse cursor:
1) Clickin a cell.
2) Press and hold down the left mouse button.
3) Move the mouse around the screen.
4) Once the desired block of cells is highlighted, release the left mouse button.

To select a range of cells without dragging the mouse:
1) Click in the cell which is to be one corner of the range of cells.
2) Move the mouse to the opposite corner of the range of cells.
3) Hold down the Shift key and click.

You can also select a contiguous range of cells by first clicking in the Selection
mode field on the Status Bar (Figure 91 on page 117) and selecting Extending

Tip selection before clicking in the opposite corner of the range of cells. Make sure to
change back to Standard selection or you may find yourself extending a cell
selection unintentionally.
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To select a range of cells without using the mouse:
1) Select the cell that will be one of the corners in the range of cells.
2) While holding down the Shift key, use the cursor arrows to select the rest of the range.

You can also directly select a range of cells using the Name Box. Click into the
Name Box on the Formula Bar (Figure 89 on page 116). To select a range of cells,

Tip enter the cell reference for the upper left-hand cell, followed by a colon (:), and
then the lower right-hand cell reference. For example, to select the range that
would go from A3 to C6, you would enter A3:C6.

Range of non-contiguous cells
1) Select the cell or range of cells using one of the methods above.
2) Move the mouse pointer to the start of the next range or single cell.

3) Hold down the Ctrl key and click or click-and-drag to select another range of cells to add to
the first range.

4) Repeat as necessary.
Selecting columns and rows

Single column or row
To select a single column, click on the column header (Figure 88 on page 115).

To select a single row, click on the row header.

Multiple columns or rows

To select multiple columns or rows that are contiguous:
1) Click on the first column or row in the group.
2) Hold down the Shift key.
3) Click the last column or row in the group.

To select multiple columns or rows that are not contiguous:
1) Click on the first column or row in the group.
2) Hold down the Ctrl key.
3) Click on all of the subsequent columns or rows while holding down the Ctrl key.

Entire sheet

To select the entire sheet, click on the small box between the column headers and the row headers
(Figure 101), or use the key combination Ctr/+A to select the entire sheet, or go to Edit on the
Menu bar and select Select All.

Ll \ .
Select all box

Figure 101: Select All box
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Selecting sheets

You can select either one or multiple sheets in Calc. It can be advantageous to select multiple
sheets, especially when you want to make changes to many sheets at once.

Single sheet

Click on the sheet tab for the sheet you want to select. The tab for the selected sheet becomes
white (default Calc setup).

Multiple contiguous sheets

To select multiple contiguous sheets:
1) Click on the sheet tab for the first desired sheet.
2) Move the mouse pointer over the sheet tab for the last desired sheet.
3) Hold down the Shift key and click on the sheet tab.

4) All tabs between these two selections will turn white (default Calc setup). Any actions that
you perform will now affect all highlighted sheets.

Multiple non-contiguous sheets
To select multiple non-contiguous sheets:
1) Click on the sheet tab for the first desired sheet.
2) Move the mouse pointer over the sheet tab for the second desired sheet.
3) Hold down the Ctrl key and click on the sheet tab.
4) Repeat as necessatry.

5) The selected tabs will turn white (default Calc setup). Any actions that you perform will now
affect all highlighted sheets.

All sheets
Right-click a sheet tab and choose Select All Sheets from the context menu.

Working with columns and rows

Inserting columns and rows

When you insert a column, it is inserted to the left of the highlighted column. When
you insert a row, it is inserted above the highlighted row.

When you insert columns or rows, the cells take the formatting of the
corresponding cells in the next column to left or the row above.

Note

Single column or row
Using the Insert menu:
1) Select a cell, column, or row where you want the new column or row inserted.
2) Go to Insert on the Menu bar and select either Insert > Columns or Insert > Rows.

Using the mouse:
1) Select a column or row where you want the new column or row inserted.
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2) Right-click the column or row header.
3) Select Insert Columns or Insert Rows from the context menu.

Multiple columns or rows
Multiple columns or rows can be inserted at once rather than inserting them one at a time.

1) Highlight the required number of columns or rows by holding down the left mouse button on
the first one and then dragging across the required number of identifiers.

2) Proceed as for inserting a single column or row above.

Deleting columns and rows

Single column or row
To delete a single column or row:
1) Select a cell in the column or row you want to delete.

2) Go to Edit on the Menu bar and select Delete Cells or right-click and select Delete from
the context menu.

3) Select the option you require from the Delete Cells dialog (Figure 102).

@ Delete Cells

selection [ ]
) shift cells up

| cancel |

() Delete entire row(s) { Help J

() Delete entire column(s)

Figure 102: Delete Cells dialog

Alternatively:
1) Click in the column or header to select the column or row.

2) Go to Edit on the Menu bar and select Delete Cells or right-click and select Delete
Columns or Delete Rows from the context menu.

Multiple columns or rows
To delete multiple columns or rows:

1) Select the columns or rows, see “Multiple columns or rows” on page 127 for more
information.

2) Go to Edit on the Menu bar and select Delete Cells or right-click and select Delete
Columns or Delete Rows from the context menu.

Working with sheets

Inserting new sheets

Click on the Add Sheet icon 5E. This inserts a new sheet after the last sheet in the spreadsheet
without opening the Insert Sheet dialog. The following methods open the Insert Sheet dialog
(Figure 103) where you can position the new sheet, create more than one sheet, name the new
sheet, or select a sheet from a file.
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1) Select the sheet where you want to insert a new sheet, then go to Insert > Sheet on the
Menu bar.

2) Right-click on the sheet tab where you want to insert a new sheet and select Insert Sheet
from the context menu.

3) Click in the empty space at the end of the sheet tabs.

4) Right-click in the empty space at the end of the sheet tabs and select Insert Sheet from
the context menu.

@ Insert Sheet

postion
@® Before current sheet: L
() After current sheet Cancel

Sheet . ﬂelp |

@® Newsheet

No. of sheets |1 e

Name [sheets |
() From file

Browse...

| Link

Figure 103: Insert Sheet dialog

Moving and copying sheets

You can move or copy sheets within the same spreadsheet by dragging and dropping or using the
MovelCopy Sheet dialog. To move or copy a sheet into a different spreadsheet, you have to use
the MovelCopy Sheet dialog.

Dragging and dropping
To move a sheet to a different position within the same spreadsheet, click and hold on the sheet
tab and drag it to its new position before releasing the mouse button.

To copy a sheet within the same spreadsheet, hold down the Ctrl key (Option key on Mac) then
click on the sheet tab and drag it to its new position before releasing the mouse button. The mouse
pointer may change to include a plus sign depending on the setup of your operating system.

Using a dialog
Use the MovelCopy Sheet dialog (Figure 104) to specify exactly whether you want the sheet in
the same or a different spreadsheet, its position within the spreadsheet, the sheet name when you
move or copy the sheet.
1) Inthe current document, right-click on the sheet tab you wish to move or copy and select
Movel/Copy Sheet from the context menu or go to Edit > Sheet > Movel/Copy on the
Menu bar.

2) Select Move to move the sheet or Copy to copy the sheet.

3) Select the spreadsheet where you want the sheet to be placed from the drop-down list in
To document. This can be the same spreadsheet, another spreadsheet already open, or
you can create a new spreadsheet.
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4) Select the position in Insert before where you want to place the sheet.

5) Type a name in the New name text box if you want to rename the sheet when it is moved
or copied. If you do not enter a name, Calc creates a default name (Sheet 1, Sheet 2, and
S0 on).

6) Click OK to confirm the move or copy and close the dialog.

Caution .
j When you move or copy to another spreadsheet or a new spreadsheet, a conflict

may occur with formulas linked to other sheets in the previous location.

# 0 MovefCopy Sheet

Action
Copy
Location
To document
Untitled1 (current document) =

-

Insert before

Sheet2
Sheet3
-move to end position -

New name

Sheet1

Help | [ [o]4 | Cancel

Figure 104: Move/Copy Sheet dialog

Deleting sheets

To delete a single sheet, right-click on the sheet tab you want to delete and select Delete Sheet
from the context menu, or go to Edit > Sheet > Delete from on the Menu bar. Click Yes to confirm
the deletion.

To delete multiple sheets, select the sheets (see “Selecting sheets” on page 128), then right-click
one of the sheet tabs and select Delete Sheet from the context menu, or go to Edit > Sheet >
Delete from on the Menu bar. Click Yes to confirm the deletion.

Renaming sheets

By default, the name for each new sheet added is SheetX, where X is the number of the next sheet
to be added. While this works for a small spreadsheet with only a few sheets, it can become
difficult to identify sheets when a spreadsheet contains many sheets.
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You can rename a sheet using one of the following methods:

* Enter the name in the Name text box when you create the sheet using the Insert Sheet
dialog (Figure 103 on page 130).

* Right-click on a sheet tab and select Rename Sheet from the context menu to replace the
existing name with a different one.

* Double-click on a sheet tab to open the Rename Sheet dialog.

Sheet names must start with either a letter or a number; other characters including
spaces are not allowed. Apart from the first character of the sheet name, permitted
characters are letters, numbers, spaces, and the underscore character. Attempting
to rename a sheet with an invalid name will produce an error message.

Note

Viewing Calc

Changing document view

Use the zoom function to show more or fewer cells in the window when you are working on a
spreadsheet. For more about zoom, see Chapter 1 Introducing LibreOffice in this guide.

Freezing rows and columns

Freezing locks a number of rows at the top of a spreadsheet or a number of columns on the left of
a spreadsheet or both rows and columns. Then, when moving around within a sheet, the cells in
frozen rows and columns always remain in view.

Figure 105 shows some frozen rows and columns. The heavier horizontal line between rows 3 and
23 and the heavier vertical line between columns F and Q indicate that rows 1 to 3 and columns A
to F are frozen. The rows between 3 and 23 and the columns between F and Q have been scrolled
off the page.

A | B | ¢ | b | E | F Q | R |
1 Sumame |First Name |Address City Country
2 Weber Jean PO Box 640  |Airie Beach |Australia
3 Schofield |Peter Jankowskiego |(Opole Poland
23
—29 |

Figure 105: Frozen rows and columns

Freezing rows or columns

1) Click on the row header below the rows where you want the freeze, or click on the column
header to the right of the columns where you want the freeze.

2) Go to Window on the Menu bar and select Freeze. A heavier line appears between the
rows or columns indicating where the freeze has been placed.

Freezing rows and columns

1) Click into the cell that is immediately below the rows you want frozen and immediately to
the right of the columns you want frozen.

2) Go to Window on the Menu bar and select Freeze. A heavier line appears between the
rows or columns indicating where the freeze has been placed.
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Unfreezing

To unfreeze rows or columns, go to Window on the Menu bar and uncheck Freeze. The heavier
lines indicating freezing will disappear.

Splitting the screen

Another way to change the view is by splitting the screen your spreadsheet is displayed in (also
known as splitting the window). The screen can be split horizontally, vertically, or both giving you
up to four portions of the spreadsheet in view at any one time. An example of splitting the screen is
shown in Figure 106 where a split is indicated by additional window borders within the sheet.

Why would you want to do this? For example, consider a large spreadsheet in which one cell
contains a number that is used by three formulas in other cells. Using the split-screen technique,
you can position the cell containing the number in one section and each of the cells with formulas
in the other sections. You can then change the number in one cell and watch how it affects each of

the formulas.

1 Beta= 3.2000
2 A= 0.1000
Fi Al= Beta®AD"(1*A0) 0.2880
8 A2= Beta*Al*(1"Al) 0.6562
9 Ad=| Beta*AZ*(1*AZ) 0.7219
10 Ad= Beta*A3"(1*A3) 0.6424
11 AS= Beta*A0'(1"Ad) 0.7351

Figure 106: Split screen example

Splitting horizontally or vertically
1) Click on the row header below the rows where you want to split the screen horizontally or
click on the column header to the right of the columns where you want to split the screen
vertically.
2) Go to Window on the Menu bar and select Split. Window borders appear between the
rows or columns indicating where the split has been placed, as shown in Figure 107.
3) Alternatively
* For a horizontal split, drag the new horizontal window border beneath the row where
you want the horizontal split positioned.
* For a vertical split, drag the new vertical window border across to the right of the
column where you want the vertical split positioned.

Splitting horizontally and vertically
1) Click in the cell that is immediately below the rows where you want to split the screen
horizontally and immediately to the right of the columns where you want to split the screen
vertically.

2) Go to Window on the Menu bar and select Split. A heavy black line appears between the
rows or columns indicating where the split has been placed.
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Beta=
AO=

Beta*AQ*(1*A0)
Beta*Al*(1*Al)
Beta*A2*(1*A2)
Beta*A3*(1*A3)
Beta*AQ*(1*Ad)

Figure 107: Split screen window borders

Removing split views

To remove a split view, do one of the following:
* Drag the split window borders back to their places at the ends of the scroll bars.
* Go to Window on the Menu bar and uncheck Split.

Using the keyboard

Most data entry in Calc can be accomplished using the keyboard.

Numbers

Click in the cell and type in a number using the number keys on either the main keyboard or
numeric keypad. By default, numbers are right aligned in a cell.

Minus numbers

To enter a negative number, either type a minus (-) sign in front of the number or enclose the
number in parentheses (), for example (1234). The result for both methods of entry will be the
same, for example -1234.

Leading zeroes

To retain a minimum number of integer characters in a cell when entering numbers in order to
retain the number format, for example 1234 and 0012, leading zeros have to be added using one
of the following methods:

Method 1

1) With the cell selected, right-click on the cell, select Format Cells from the context menu or
go to Format > Cells on the Menu bar or use the keyboard shortcut Ctr/+1 to open the
Format Cells dialog (Figure 108).
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#® Format Cells

]Number5|ant Font Effects Alignment Borders Background| cCell Protection

Category Format Language
= A |Default-English (UK) |2 |

Percent -1234
Currency -1234.12
Date -1,234
i -1,234.12
Scientific -1,234.12
EmeEan E1.§§)1 2) 1234.56789
Euqlean Value ey g
Options

Decimal places 0 = [] Negative numbers red

Leading zeros 1 : t_:; [C] Thousands separator
Format code
[General ]Iw:'é':%@-

Figure 108: Format Cells dialog — Numbers page

2) Make sure the Numbers tab is selected then select Number in the Category list.

3) In Options > Leading Zeros, enter the minimum number of characters required. For
example, for four characters, enter 4. Any number less than four characters will have
leading zeros added, for example 12 becomes 0012.

4) Click OK. The number entered retains its number format and any formula used in the
spreadsheet will treat the entry as a number in formula functions.

Method 2

1) Select the cell.

2) Open the Sidebar (View > Sidebar) and click the Open Panel (+) icon on the Number
Format panel to open it.

3) Select Number in the Category list box.
4) Setthe Leading zeroes value box to 4. Formatting is applied immediately.

El Number Format &=

Category:

L]

(Number

123 9% B 5] asc

Decimal places: 'Leading geroes:'

2 = 4 =
Negative numbers rec.l .

Thousands separator

Figure 109: Set Leading zeroes

If a number is entered with leading zeroes, for example 01481, without first setting the Leading
zeros parameter, then by default Calc will automatically drop the leading 0. To preserve leading
zeros in a number:

1) Type an apostrophe (') before the number, for example '01481.

2) Move the cell focus to another cell. The apostrophe is automatically removed, the leading
zeros are retained and the number is converted to text left aligned.
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Numbers as text
Numbers can also be entered as text using one of the following methods.

Method 1
1) With the cell selected, right-click on the cell and select Format Cells from the context
menu or go to Format > Cells on the Menu bar or use the keyboard shortcut Ctr/+1 to
open the Format Cells dialog (Figure 108).

2) Make sure the Numbers page is selected, then select Text from the Category list.
3) Click OK and the number, when entered, is converted to text and, by default, left aligned.

Method 2
1) Select the cell.

2) Open the Sidebar (View > Sidebar) and click the Open Panel (+) icon on the Number
Format panel.

3) Select Text in the Category list box. Formatting is applied to the cell immediately.

4) Click back on the cell. Enter the number and move focus from the cell to have the data
formatted.

Any numbers that have been formatted as text in a spreadsheet will be treated as
Note a zero by any formulas used in the spreadsheet. Formula functions will ignore text
entries.

Text

Click in the cell and type the text. By default, text is left-aligned in a cell.

Date and time
Select the cell and type the date or time.

You can separate the date elements with a slash (/) or a hyphen (-) or use text, for example 10 Oct
2012. The date format automatically changes to the selected format used by Calc.

When entering a time, separate time elements with colons, for example 10:43:45. The time format
automatically changes to the selected format used by Calc.

To change the date or time format used by Calc, use one of the following methods.

Method 1
1) With the cell selected, right-click on the cell and select Format Cells from the context
menu, or go to Format > Cells on the Menu bar, or use the keyboard shortcut Ctr/+1, to
open the Format Cells dialog (Figure 108).

2) Make sure the Numbers page is selected, then select Date or Time from the Category list.
3) Select the date or time format you want to use from the Format list.
4) Click OK.

Method 2
1) Select the cell.

2) Open the Sidebar (View > Sidebar) and click the Open Panel (+) icon on the Number
Format panel.

3) Select Date in the Category list box, or click the Date icon below the list box.
4) Click the More Options button in the panel title bar to open the Format Cells dialog.
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5) Select the date or time format you want to use from the Format list.

6) Click OK.

= Number Format

Category:

123 % j‘j@nc

Decimal places:

0

Megative numbers red

Thousands separator

=]
X

More Options

Leading zeroes:

0

Autocorrection options

Figure 110: Select Date and More Options

Calc automatically applies many changes during data input using autocorrection, unless you have
deactivated any autocorrect changes. You can also undo any autocorrection changes by using the
keyboard shortcut Ctr/+Z or manually by going back to the change and replacing the autocorrection
with what you want to actually see.

To change the autocorrect options, go to Tools > AutoCorrect Options on the Menu bar to open
the AutoCorrect dialog (Figure 111).

@ AutoCorrect
Replacements and exceptions for language: [English (UK) = J
‘Replal:e| Exceptinns'i Optinn;E Localised Optinnsi
Replace with: [v] Textonly
2 = s
-> -
(© ©
(R) ®
(tm) ™
< -
- .
<> ©
<> ©
1/2 1%
1/4 Ya
3/4 Y
abotu about
abouta abouta
aboutit aboutit
abscence absence e
arrecnriac arrecenriac bl

[LoK || cancel | Help || Reset

Figure 111: AutoCorrect dialog
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Replace

Edits the replacement table for automatically correcting or replacing words or abbreviations in your
document.

Exceptions

Specify the abbreviations or letter combinations that you do not want LibreOffice to correct
automatically.

Options
Select the options for automatically correcting errors as you type and then click OK.

Localized options

Specify the AutoCorrect options for quotation marks and for options that are specific to the
language of the text.

Reset
Resets modified values back to the LibreOffice default values.

Deactivating automatic changes

Some AutoCorrect settings are applied when you press the spacebar after you enter data. To turn
off or on Calc AutoCorrect, go to Tools > Cell Contents on the Menu bar and deselect or select
Autolnput.

Speeding up data entry

Entering data into a spreadsheet can be very labor-intensive, but Calc provides several tools for
removing some of the drudgery from input.

The most basic ability is to drop and drag the contents of one cell to another with a mouse. Many
people also find Autolnput helpful. Calc also includes several other tools for automating input,
especially of repetitive material. They include the fill tool, selection lists, and the ability to input
information into multiple sheets of the same document.

Using the Fill tool

The Calc Fill tool is used to duplicate existing content or create a series in a range of cells in your
spreadsheet (Figure 112).
1) Select the cell containing the contents you want to copy or start the series from.

2) Drag the mouse in any direction or hold down the Shift key and click in the last cell you
want to fill.

3) Go to Edit > Fill on the Menu bar and select the direction in which you want to copy or
create data (Up, Down, Left or Right) or Series from the context menu.
Alternatively, you can use a shortcut to fill cells.
1) Select the cell containing the contents you want to copy or start the series from.

2) Move the cursor over the small square in the bottom right corner of the selected cell. The
cursor will change shape.
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3) Click and drag in the direction you want the cells to be filled. If the original cell contained

text, then the text will automatically be copied. If the original cell contained a number, a
series will be created.

"AT:A8 v & = |AnA8 B D

Figure 112: Using the Fill tool

Using a fill series

When you select a series fill from Edit > Fill > Series, the Fill Series dialog (Figure 113) opens.
Here you can select the type of series you want.

@ Fill series

Direction Series type Time unit
@® Down @ Linear (® Day ﬁ
() Right () Growth ) Weekday l Cancel
O up ) Date () Month

O Left O AutoFill © Year
Startvalue 32 |
End value [ |
Increment " |

Figure 113: Fill Series dialog

¢ Direction — determines the direction of series creation.

Down — creates a downward series in the selected cell range for the column using the
defined increment to the end value.

Right — creates a series running from left to right within the selected cell range using the
defined increment to the end value.

Up — creates an upward series in the cell range of the column using the defined
increment to the end value.

Left — creates a series running from right to left in the selected cell range using the
defined increment to the end value.

* Series Type — defines the series type.

Linear — creates a linear number series using the defined increment and end value.
Growth — creates a growth series using the defined increment and end value.
Date — creates a date series using the defined increment and end date.

AutoFill — forms a series directly in the sheet. The AutoFill function takes account of
customized lists. For example, by entering January in the first cell, the series is
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completed using the list defined in LibreOffice > Tools > Options > LibreOffice Calc
> Sort Lists. AutoFill tries to complete a value series by using a defined pattern. For
example, a numerical series using 1,3,5 is automatically completed with 7,9,11,13; a
date and time series using 01.01.99 and 15.01.99, an interval of fourteen days is used.

* Unit of Time — in this area you specify the desired unit of time. This area is only active if
the Date option has been chosen in the Series type area.

- Day - use the Date series type and this option to create a series using seven days.
- Weekday — use the Date series type and this option to create a series of five day sets.

- Month — use the Date series type and this option to form a series from the names or
abbreviations of the months.

- Year — use the Date series type and this option to create a series of years.
e Start Value — determines the start value for the series. Use numbers, dates or times.
¢ End Value — determines the end value for the series. Use numbers, dates or times.

* Increment — determines the value by which the series of the selected type increases by
each step. Entries can only be made if the linear, growth or date series types have been
selected.

% Options - LibreOffice Calc - Sort Lists

LibreQFffice Lists Entries

[ 3
* Load/Save " | New
» Language Settings Sun,Mon,Tue,Wed,Thu,Fri,Sat January S
¥ LibreOFfice Calc sunday,Monday,Tuesday,Wednesday,Thur |February Add
General Jan,Feb,Mar,Apr,May,Jun,Jul,Aug,Sep,0¢ Mar;h =
Defaults January,February,March,April,May,June, [lilaIi8
View sunday,Monday,Tuesday,Wednesday,Thur |May Delete y
Calculate Nissan, lyar,Sivan.Tammuz,Av,ElulTishri, - |[June
Formula July
August
Changes September
Compatibility October
Grid MNovember
Print December
» LibreOffice Base
* Charts
* Internet
Copy list from: |$Sheet1.5A51:5A%8 Copy
[ oK | | cancel [ | Help | Revert

Figure 114: Sort Lists dialog

Defining a fill series
To define your own fill series:

1) Go to Tools > Options > LibreOffice Calc > Sort Lists to open the Sort Lists dialog
(Figure 114). This dialog shows the previously-defined series in the Lists box on the left and
the contents of the highlighted list in the Entries box.

2) Click New and the Entries box is cleared.

3) Type the series for the new list in the Entries box (one entry per line).
4) Click Add and the new list will now appear in the Lists box.

5) Click OK to save the new list.
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Using selection lists

Selection lists are available only for text and are limited to using only text that has already been
entered in the same column.

1) Select a blank cell in a column that contains cells with text entries.

2) Right-click and select Selection Lists from the context menu. A drop-down list appears
listing any cell in the same column that either has at least one text character or whose
format is defined as text.

3) Click on the text entry you require and it is entered into the selected cell.

Sharing content between sheets

You might want to enter the same information in the same cell on multiple sheets, for example to
set up standard listings for a group of individuals or organizations. Instead of entering the list on
each sheet individually, you can enter the information in several sheets at the same time.

1) Go to Edit > Sheet > Select on the Menu bar to open the Select Sheets dialog.

@ Select Sheets

i

Sheet1 -
Sheet2 Cancel
Sheet3

Sheeta Help |

Figure 115: Select Sheets dialog

2) Select the individual sheets where you want the information to be repeated. Use the Shift
and Ctrl (Options on Mac) keys to select multiple sheets.

3) Click OK to select the sheets and the sheet tabs will change color.

4) Enter the information in the cells on the first sheet where you want it to appear and it will be
repeated in all the selected sheets.

This technique automatically overwrites, without any warning, any information that
is already in the cells on the selected sheets. Make sure you deselect the
additional sheets when you are finished entering information that is going to be
repeated before continuing to enter data into your spreadsheet.

Note

Validating cell contents

When creating spreadsheets for other people to use, validating cell contents ensures that they
enter data that is valid and appropriate for the cell. You can also use validation in your own work as
a guide to entering data that is either complex or rarely used.

Fill series and selection lists can handle some types of data, but are limited to predefined
information. To validate new data entered by a user, select a cell and go to Data > Validity on the
Menu bar to define the type of contents that can be entered in that cell. For example, a cell may
require a date or a whole number with no alphabetic characters or decimal points, or a cell may not
be left empty.
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Depending on how validation is set up, validation can also define the range of contents that can be
entered, provide help messages explaining the content rules set up for the cell and what users
should do when they enter invalid content. You can also set the cell to refuse invalid content,
accept it with a warning, or start a macro when an error is entered. See the Calc Guide Chapter 2
Entering, Editing and Formatting Data for more information on validating cell contents.

Editing data

Deleting data

Deleting data only

Data can be deleted from a cell without deleting any of the cell formatting. Click in the cell to select
it and then press the Delete key.

Deleting data and formatting
Data and cell formatting can be deleted from a cell at the same time.
1) Click in the cell to select it.

2) Press the Backspace key, or right-click in the cell and select Delete Contents from the
context menu, or go to Edit > Delete Contents) on the Menu bar to open the Delete
Contents dialog (Figure 116). Here you can delete the different aspects of the data in the
cell or to delete everything in the cell.

@ 0 Delete Contents

Selection

& Mumbers
[ Formulas

Formats

[ oK | Cancel | Help

Figure 116: Delete Contents dialog

Replacing data

To completely replace data in a cell and insert new data, select the cell and type in the new data.
The new data will replace the data already contained in the cell but will retain the original
formatting used in the cell.

Alternatively, click in the Input Line on the Formula Bar (Figure 89 on page 116), then double-click
on the data to highlight it completely and type the new data.

Editing data

Sometimes it is necessary to edit the contents of cell without removing all of the data from the cell.
For example, changing the phrase “Sales in Qtr. 2" to “Sales rose in Qtr” can be done as follows.
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Using the keyboard
1) Click in the cell to select it.
2) Press the F2 key and the cursor is placed at the end of the cell.

3) Use the keyboard arrow keys to reposition the cursor where you want to start entering the
new data in the cell.

4) When you have finished, press the Enter key and your editing changes are saved.

Using the mouse
1) Double-click on the cell to select it and place the cursor in the cell for editing.
2) Either:
* Reposition the cursor to where you want to start entering the new data in the cell.
* Single-click to select the cell.

3) Move the cursor to the Input Line on the Formula Bar (Figure 89 on page 116) and click at
the position where you want to start entering the new data in the cell.

4) When you have finished, click away from the cell to deselect it and your editing changes
are saved.

Formatting data

All the settings discussed in this section can also be set as a part of the cell style.
Note See the Calc Guide Chapter 4 Using Styles and Templates in Calc for more
information.

Multiple lines of text

Multiple lines of text can be entered into a single cell using automatic wrapping or manual line
breaks. Each method is useful for different situations.

Automatic wrapping
To automatically wrap multiple lines of text in a cell, use one of the following methods.

Method 1
1) Right-click on the cell and select Format Cells from the context menu, or go to Format >
Cells on the Menu bar, or press Ctrl+1, to open the Format Cells dialog.

2) Click on the Alignment tab (Figure 117).
3) Under Properties, select Wrap text automatically and click OK.
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& 0 Format Cells

Numbers | Font Fonk Effects | Alignment | Borders  Background | Cell Prokection
Text alignment

Horizontal Indent Vertical

s | opt |Default =

L, Degrees ["] Wertically stacked
0 =
Reference edge
o RS == [u}]
Properties
| Wrap text automatically
Hyphenation active

—| Shrink to Fit cell size

| Cancel I Help | | Reset

Figure 117: Format Cells dialog — Alignment page

Method 2
1) Select the cell.

2) Open the Sidebar (View > Sidebar) and click the Open Panel (+) icon on the Alignment
panel.

3) Select the Wrap text option to apply the formatting immediately.

= Alignment |
=E = = =
Leftindent: Merge Cells
opt - | |

Text orientation:

. . [ Vertically Stacked
- —=
- ~ 0° b4

Figure 118: Wrap text formatting

Manual line breaks

To insert a manual line break while typing in a cell, press Ctrl+Enter. This method does not work
with the cursor in the input line. When editing text, double-click the cell, then reposition the cursor
to where you want the line break.

When a manual line break is entered, the cell width does not change and your text may still overlap
the end of the cell. You have to change the cell width manually or reposition your line break so that
your text does not overlap the end of the cell.

144 | Getting Started with LibreOffice 4.2



Shrinking text to fit the cell

The font size of the data in a cell can automatically adjust to fit inside cell borders. To do this,
select the Shrink to fit cell size option under Properties in the Format Cells dialog (Figure 117) on
the Alignment page. This dialog is also available by clicking the More Options button in the
Character title bar of the Properties deck on the opened Sidebar.

Formatting nhumbers

Several different number formats can be applied to cells by using icons on the Formatting toolbar
(highlighted in Figure 119). Select the cell, then click the relevant icon to change the number
format.

Formatting
@ |Liberationsans | =] 10 ~x B f U =

Figure 119: Number icons on Formatting toolbar

For more control or to select other number formats, use the Numbers page of the Format Cells
dialog (Figure 108 on page 135):

* Apply any of the data types in the Category list to the data.
* Control the number of decimal places and leading zeros in Options.
* Enter a custom format code.

* The Language setting controls the local settings for the different formats such as the date
format and currency symbol.

Some number formats are available from the Sidebar's Number Format panel in the Properties
deck. Click the More Options button to open the Format Cells dialog described above.

El Number Format =
Category:

|General i

23| % Jy [T |nec

Figure 120: Number format icons in the
Number Format panel on the Sidebar

Formatting a font
To quickly select a font and format it for use in a cell:

1) Select the cell.

2) Click the small triangle on the right of the Font Name box on the Formatting toolbar
(highlighted in Figure 121) and select a font from the drop-down list.

3) Click on the small triangle on the right of the Font Size on the Formatting toolbar and select
a font size from the drop down list.

Formattin s
S beratonsons |+ (10 |DB / U ExammM X%l €& 0 -2 A- [

Figure 121: Font Name and Size on Formatting toolbar

4) To change the character format, click on the Bold, /talic, or Underline icons.
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5) To change the paragraph allgnment of the font, click on one of the four alignment icons

(Left, Center, Right, Justified) = = =

6) To change the font color, click the arrow next to the Font Color icon & to display the color
palette, then select the desired color.

The Properties deck of the Sidebar has two panels, Character and Alignment, which between
them contain all the formatting controls from the Formatting toolbar.

To specify the language used in the cell, open the Font page on the Format Cells dialog. You can
also select the More Options button on either of the Sidebar panels to open the Format Cells
dialog. Changing language in a cell allows different languages to be used within the same
document.

Use the Font Effects tab on the Format Cells dialog to set other font characteristics. See the Calc
Guide Chapter 4 Using Styles and Templates in Calc for more information.

Formatting cell borders

To format the borders of a cell or a group of selected cells, click on the Borders icon [] on the
Formatting toolbar, and select one of the border options displayed in the palette.

To format the line style and line color for the borders of a cell, click the small arrows next to the

palette and a border color palette respectively are displayed.

The Cell Appearance panel of the Properties deck in the Sidebar contains Cell border, Line
style and Line color controls.

For more control, including the spacing between cell borders and any data in the cell, use the
Borders page of the Format Cells dialog (Figure 108 on page 135), where you can also define a
shadow style. Clicking the More Options button on the Cell Appearance title bar, or clicking More
in the panel’s line style drop-down list, opens the Format Cells dialog at the Borders page.

See the Calc Guide Chapter 4 Using Styles and Templates in Calc for more information.

Cell border properties apply only to the selected cells and can only be changed if
you are editing those cells. For example, if cell C3 has a top border, that border
can only be removed by selecting C3. It cannot be removed in C2 despite also
appearing to be the bottom border for cell C2.

Note

Formatting cell background
To format the background color for a cell or a group of cells, click the small arrow next to the

Background Color icon on the Formatting toolbar. A color palette, similar to the Font Color
palette, is displayed. You can also use the Background tab of the Format Cells dialog (Figure 108
on page 135). The Cell Appearance panel of the Properties deck in the Sidebar contains a Cell
background control with a color palette. See the Calc Guide Chapter 4 Using Styles and
Templates in Calc for more information.
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AutoFormat of cells

Using AutoFormat

You can use Calc’s AutoFormat feature to format a group of cells quickly and easily.
Select the cells in at least three columns and rows, including column and row headers, that

1)
2)

3)
4)
5)
6)

you want to format.

Go to Format > AutoFormat on the Menu bar to open the AutoFormat dialog (Figure

122).

Select the type of format and format color from the list.
If necessary, click More to open Formatting if Formatting is not visible.
Select the formatting properties to be included in the AutoFormat function.

Click OK.

& AutoFormat

Format
'

Black 1

Black 2

Blue

Brown

Currency

Currency 3-D

Currency Grey

Currency Lavender

Currency Turquoise

Default L
Green =
Formatting
& Number Format & Font
& Borders & Pattern

{

Delete

|

Rename

& Alignment
[ AutoFit width and heighl

Figure 122: AutoFormat dialog

Defining a new AutoFormat

You can define a new AutoFormat so that it becomes available for use in all spreadsheets.
Format the data type, font, font size, cell borders, cell background and so on for a group of

1

2)
3)

4)
5)

6)

cells.

Go to Edit > Select All on the Menu bar to select the whole spreadsheet.
Go to Format > AutoFormat to open the AutoFormat dialog and the Add button is now

active.
Click Add.

In the Name box of the Add AutoFormat dialog that opens, type a meaningful name for the

new format.

Click OK to save. The new AutoFormat is now available in the Format list in the AutoFormat

dialog.
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Using themes

Calc comes with a predefined set of formatting themes that you can apply to spreadsheets. It is not
possible to add themes to Calc and they cannot be modified. However, you can modify their styles
after you apply them to a spreadsheet and the modified styles are only available for use for that
spreadsheet when you save the spreadsheet.

To apply a theme to a spreadsheet:

1) Click the Choose Themes icon % in the Tools toolbar. If this toolbar is not visible, go to
View > Toolbars on the Menu bar and select Tools, and the Theme Selection dialog
(Figure 123) opens. This dialog lists the available themes for the whole spreadsheet.

2) Select the theme that you want to apply. As soon as you select a theme, the theme styles
are applied to the spreadsheet and are immediately visible.
3) Click OK.

4) If you wish, you can now open the Styles and Formatting window to modify specific styles.
These modifications do not modify the theme; they only change the appearance of the style
in the specific spreadsheet you are creating.

#® Theme Selection

(standard) -]
Autumn Leaves
Be

Black and White
Blackberry Bush
Blue Jeans
Fifties Diner
Glacier

Green Grapes
Marine
Millennium
Nature

MNeon 1
Night
PC Nostalgia
Pactal

Figure 123: Theme Selection dialog

Using conditional formatting

You can set up cell formats to change depending on conditions that you specify. For example, in a
table of numbers, you can show all the values above the average in green and all those below the
average in red.

Conditional formatting depends upon the use of styles and the AutoCalculate feature must be
enabled. Go to Tools > Cell Contents > AutoCalculate on the Menu bar to enable this feature.
See the Calc Guide Chapter 2 Entering, Editing, and Formatting Data for more information.
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Hiding and showing data

In Calc you can hide elements so that they are neither visible on a computer display nor printed
when a spreadsheet is printed. However, hidden elements can still be selected for copying if you
select the elements around them. For example, if column B is hidden, it is copied when you select
columns A and C.

For more information on how to hide and show data, including how to use outline groups and
filtering, see the Calc Guide Chapter 2 Entering, Editing, and Formatting Data.

Hiding data

To hide sheets, rows, and columns:

1)
2)
3)
4)

Select the sheet, row or column you want to hide.

Go to Format on the Menu bar and select Sheet, Row or Column.
Select Hide from the menu and the sheet, row or column can no longer viewed or printed.

Alternatively, right-click on the sheet tab, row header or column header and select Hide
from the context menu.

To hide and protect data in selected cells:

1) Go to Tools > Protect Document and select Sheet from the menu options. The Protect
Sheet dialog dialog will open (Figure 124).

2) Select Protect this sheet and the contents of protected cells.

3) Create a password and then confirm the password.

4) Select or deselect the user selection options for cells.

5) Click OK.

6) Select the cells you want to hide.

7) Go to Format > Cells on the Menu bar, or right-click and select Format Cells from the
context menu, or use the keyboard shortcut Ctr/+1 to open the Format Cells dialog.

8) Click the Cell Protection tab (Figure 125) and select an option to hide the cells.

9) Click OK.

When data in cells are hidden, it is only the data contained in the cells that are
Note hidden and the protected cells cannot be modified. The blank cells remain visible

in the spreadsheet.

@ Protect Sheet

[# Protect this sheet and the contents of protected cells

Password [ ]  cancel
Confirm [ ] -T-

Options

Allow all users of this sheet to:

" flselect protected cells|

B select unprotected cells
Figure 124: Protect Sheet dialog
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@ Format Cells

Numbers| Font|Font Effects| Alignment| Borders Backgruund|Cell Prntectiun|
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sheet has been protected.

& Protected

. Select 'Protect Document' from the 'Tools' menu
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Print
[ Hide when printing The cells selected will be omitted when printing.

Figure 125: Cell Protection page in Format Cells dialog

Showing data

To show hidden sheets, rows, and columns:
1) Select the sheets, rows or columns each side of the hidden sheet, row or column.

2) Go to Format on the Menu bar and select Sheet, Row or Column.

3) Select Show from the menu and the sheet, row or column will be displayed and can be
printed.

4) Alternatively, right-click on the sheet tabs, row headers or column headers and select
Show from the context menu.
To show hidden data in cells:
1) Go to Tools > Protect Document and select Sheet from the menu options.
2) Enter the password to unprotect the sheet and click OK.

3) Go to Format > Cells on the Menu bar, or right-click and select Format Cells from the
context menu, or use the keyboard shortcut Ctr/+1 to open the Format Cells dialog.

4) Click the Cell Protection tab (Figure 125) and deselect the hide options for the cells.
5) Click OK.

Sorting records

Sorting within Calc arranges the cells in a sheet using the sort criteria that you specify. Several
criteria can be used and a sort applies each criteria consecutively. Sorts are useful when you are
searching for a particular item and become even more useful after you have filtered data.

Also, sorting is useful when you add new information to your spreadsheet. When a spreadsheet is
long, it is usually easier to add new information at the bottom of the sheet, rather than adding rows
in their correct place. After you have added information, you then carry out a sort to update the
spreadsheet.

For more information on how to sort records and the sorting options available, see the Calc Guide
Chapter 2 Entering, Editing, and Formatting Data.
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Figure 126: Sort Criteria dialog

To sort cells in your spreadsheet:
1) Select the cells to be sorted.
2) Go to Data > Sort on the Menu bar to open the Sort dialog (Figure 126).

3) Select the sort criteria from the drop down lists. The selected lists are populated from the
selected cells.

4) Select either ascending order (A-Z, 1-9) or descending order (Z-A, 9-1).
5) Click OK and the sort is carried out on your spreadsheet.

Using formulas and functions

You may need more than numbers and text on your spreadsheet. Often the contents of one cell
depend on the contents of other cells. Formulas are equations that use numbers and variables to
produce a result. Variables are placed in cells to hold data required equations.

A function is a predefined calculation entered in a cell to help you analyze or manipulate data. All
you have to do is enter the arguments and the calculation is automatically made for you. Functions
help you create the formulas required to get the results that you are looking for.

See the Calc Guide, Chapter 7 Using Formulas and Functions for more information.

Analyzing data

Calc includes several tools to help you analyze the information in your spreadsheets, ranging from
features for copying and reusing data, to creating subtotals automatically, to varying information to
help you find the answers you need. These tools are divided between the Tools and Data menus.

One of the most useful of these tools is the PivotTable, which is used for combining, comparing,
and analyzing large amounts of data easily. Using the PivotTable, you can view different
summaries of the source data, display the details of areas of interest, and create reports, whether
you are a beginner, an intermediate or advanced user.

See the Calc Guide Chapter 8 Using Pivot Tables and Chapter 9 Data Analysis for more
information on pivot tables and other tools available in Calc to analyze your data.
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Printing

Printing from Calc is much the same as printing from other LibreOffice components (see Chapter
10 Printing, Exporting, and Emailing in this guide). However, some details for printing in Calc are
different, especially regarding preparation for printing.

Print ranges

Print ranges have several uses, including printing only a specific part of the data or printing
selected rows or columns on every page. For more information about using print ranges, see the
Calc Guide Chapter 6 Printing, Exporting, and E-mailing.

Defining a print range
To define a new print range or modify an existing print range:
1) Select the range of cells to be included in the print range.

2) Go to Format > Print Ranges > Define on the Menu bar. Page break lines are displayed
on screen.

3) To check the print range, go to File > Page Preview on the Menu bar or click on the Page

Preview icon ﬁ LibreOffice will display the cells in the print range.

Adding to a print range

After defining a print range, you can add more cells to it by creating another print range. This
allows multiple, separate areas of the same sheet to be printed while not printing the whole sheet.

1) After defining a print range, select an extra range of cells for adding to the print range.

2) Go to Format > Print Ranges > Add on the Menu bar to add the extra cells to the print
range. The page break lines are no longer displayed on the screen.

3) To check the print ranges, go to File > Page Preview on the Menu bar or click on the Page

Preview icon . LibreOffice will display the print ranges as separate pages.

The additional print range will print as a separate page, even if both ranges are on

Note the same sheet.

Removing a print range
It may become necessary to remove a defined print range, for example, if the whole sheet needs to
be printed later.

To remove all the defined print ranges, go to Format > Print Ranges > Remove on the Menu bar.
After the print ranges have been removed, the default page break lines will appear on the screen.

Editing a print range

At any time, you can directly edit the print range, for example to remove or resize part of the print
range. Go to Format > Print Ranges > Edit on the Menu bar to open the Edit Print Ranges
dialog where you can define the print range.
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Printing options

To select the printing options for page order, details, and scale to be used when printing a

spreadsheet:

1) Go to Format > Page on the Menu bar to open the Page Style dialog (Figure 127).
2) Select the Sheet tab and make your selections from the available options.

3) Click OK.

For more information on printing options, see the Calc Guide Chapter 6 Printing, Exporting, and

E-mailing.

% o Page Style: Default

Paper format

Format: A4
Width: 21.00cm | -
Height: 29.70cm | -

Orientation: @ Portrait

Landscape
Margins
Left: 2.00cm |3
Right: 2.00cm |3
Top: 2.00cm | =
Bottom: 2.00cm | -

Paper tray:

Layout settings
Page layout:

Format:

Table alignment:

_

[From printer settings] =

Right and left 2

. .

Horizontal

Vertical

Cancel || Help | | Reset

Figure 127: Page Style dialog

Repeat printing of rows or columns

If a sheet is printed on multiple pages, you can set up certain rows or columns to repeat on each
printed page. For example, if the top two rows of the sheet as well as column A need to be printed

on all pages, do the following:

1) Go to Format > Print Ranges > Edit on the Menu bar to open the Edit Print Ranges

dialog (Figure 128).

2) Type the row identifiers in the Rows to repeat box. For example, to repeat rows 1 and 2,
type $1:$2. This automatically changes Rows to repeat from, - none - to - user defined -.

3) Type the column identifiers in the Columns to repeat box. For example, to repeat column A,
type $A. In the Columns to repeat list, - none - changes to - user defined -.

4) Click OK.

For more information on editing print ranges, see the Calc Guide, Chapter 6 Printing, Exporting,

and E-mailing.
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% O Edit Print Ranges

Print range

-entiresheet- = | _ [

Rows to repeat
-userdefined- |= | |g1:52

Columns to repeat

-

|-none- =4 [ |

oK [ | Cancel [ | Help

Figure 128: Edit Print Ranges dialog

Page breaks

While defining a print range can be a powerful tool, it may sometimes be necessary to manually
adjust the Calc printout manually using a manual or page break. A page break helps to ensure that
your data prints properly according to your page size and page orientation. You can insert a
horizontal page break above or a vertical page break to the left of the active cell.

For more information on manual breaks, see the Calc Guide Chapter 6 Printing, Exporting, and
E-mailing.

Inserting a break
To insert a page break:
1) Navigate to the cell where the page break will begin.
2) GotoInsert > Page Break on the Menu bar.
3) Select Row Break to create a page break above the selected cell.
4) Select Column Break to create a page break to the left of the selected cell.

Deleting a page break
To remove a page break:
1) Navigate to a cell that is next to the break you want to remove.
2) Go to Edit > Delete Page Break on the Menu bar.
3) Select Row Break or Column Break depending on your need and break is removed.

Not Multiple manual row and column breaks can exist on the same page. When you
Ll want to remove them, you have to remove each break individually.

Headers and footers

Headers and footers are predefined pieces of text that are printed at the top or bottom of a printed
page when a spreadsheet is printed. Headers and footers are set and defined using the same
method. For more information on setting and defining headers and footers, see the Calc Guide
Chapter 6 Printing, Exporting, and E-mailing.

154 | Getting Started with LibreOffice 4.2



Headers and footers are also assigned to a page style. You can define more than one page style
for a spreadsheet and assign different page styles to different sheets within a spreadsheet. For
more information on page styles, see the Calc Guide Chapter 4 Using Styles and Templates.

Setting a header or footer
To set a header or footer:
Navigate to the sheet that you want to set the header or footer for.

Go to Format > Page on the Menu bar to open the Page Style dialog (Figure 129).
On the Page Style dialog, select Header or Footer tab.

1)
2)
3)
4)
5)

6)
7

8)

Select the Header on or Footer on option.

Select Same content left/right option if you want the same header or footer to appear on

all the printed pages.

Set the margins, spacing, and height for the header or footer. You can also select AutoFit
height box to automatically adjust the height of the header or footer.

To change the appearance of the header or footer, click on More to open the borders and

background dialog.

To set the contents, for example page number, date and so on, that appears in the header
or footer, click on Edit to open the style dialog.

% O Page Style: Default

Organizer Page Borders Background |Header Footer Sheet

Header

& it

[ same content left/right

Left margin:

Right margin:
Spacing:

Height:

[ AutoFit height

| More.. | | Edit..

Figure 129: Header page of Page Style dialog
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What is Impress?

Impress is the presentation (slide show) program included in LibreOffice. You can create slides that
contain many different elements, including text, bulleted and numbered lists, tables, charts, and a
wide range of graphic objects such as clipart, drawings and photographs. Impress also includes a
spelling checker, a thesaurus, text styles, and background styles.

This chapter includes instructions, screenshots, and hints to guide you through the Impress
environment while designing your presentations. Although more difficult designs are mentioned
throughout this chapter, explanations for creating them are in the Impress Guide. If you have a
working knowledge of how to create slide shows, we recommend you use the Impress Guide for
your source of information.

To use Impress for more than very simple slide shows requires some knowledge of the elements
which the slides contain. Slides containing text use styles to determine the appearance of that text.
Creating drawings in Impress is similar to the Draw program included in LibreOffice. For this
reason, we recommend that you also see Chapter 3 Using Styles and Templates, and Chapter 7
Getting Started with Draw in this guide. You may also wish to consult the Draw Guide for more
details on how to use the drawing tools.

Starting Impress

You can start Impress in several ways:

* From the LibreOffice Start Center, if no component is open, click on the Impress
Presentation icon.

* From the system menu, the standard menu from which most applications are started. On
Windows, it is called the Start menu. On Gnome, it is called the Applications menu. On
KDE it is identified by the KDE logo. On Mac OS X, it is the Applications menu. Details vary
with your operating system; see Chapter 1 Introducing LibreOffice.

* On Windows, use the Presentation selection in the LibreOffice Quickstarter. Similar
functions exist for Mac and Linux; see Chapter 1 Introducing LibreOffice.

* From any open component of LibreOffice. Click the triangle to the right of the New icon on
the Menu bar and select Presentation from the drop-down menu or go to File > New >
Presentation on the Menu bar.

When LibreOffice was installed on your computer, in most cases a menu entry for
Note each component was added to your system menu. The exact name and location of
these menu entries depend on the operating system and graphical user interface.

When you start Impress for the first time, the Presentation Wizard is shown. Here you can choose
from the following options:

* Empty presentation gives you a blank document

*  From template is a presentation designed with a template of your choice
* Open existing presentation

* Click Create to open the main Impress window.

For detailed instructions about how to use the Presentation Wizard, see “Creating a new
presentation” on page 166.

If you prefer not to use the Presentation Wizard in future, you can select Do not show this wizard
again. You can enable the wizard again later in Tools > Options > LibreOffice Impress >
General > New document and select the Start with wizard option.
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Main Impress window

The main Impress window (Figure 130) has three parts: the Slides pane, Workspace, and Sidebar.
Additionally, several toolbars can be displayed or hidden during the creation of a presentation.

File Edit wiew Insert Format Jools Slideshow window Help

BH-E-WHo BE 'y & - b= -® 5 @R - @ B-E-BE
B a=s- 2| poom |z (HEED 2| & (golor |2 || i W @k - T
Slides %X Mormal Outline Notes Handout Slide Sorter Properties LI
1 ° | BiLayouts P
(B E] =
Click to add Title L=
| | =
= = = ®
C) Click to add Text O
Slides pane Sidebar
Workspace

Bl / »wWeT 2-%-¢-8-%» @ -P % Z/man

£3 161 063 iH 000 x0.00 & Slide 1/1 DeFault - + GE%

Figure 130: Main window of Impress; ovals indicate the Hide/Show markers

You can close the Slides pane or the Sidebar by clicking the X in the upper right
corner of each pane or go to View > Slides Pane or View > Sidebar on the Menu
bar to deselect the pane. To reopen a pane, go to View on the Menu bar and select
Slide Pane or Sidebar again.

Tip You can also maximize the Workspace area by clicking on the Hide/Show marker in
the middle of the vertical separator line (highlighted in Figure 130). Using the
Hide/Show marker hides, but does not close, the Slide pane or Sidebar. To restore a
pane, click again on its Hide/Show marker.
Slides pane

The Slides pane contains thumbnail pictures of the slides in your presentation, in the order they will
be shown unless you change the slide show order. Clicking a slide in this pane selects it and
places it in the Workspace. When a slide is in the Workspace, you can make changes any way you
like.

Several additional operations can be performed on one or more slides simultaneously in the Slides
pane:

* Add new slides to the presentation.

* Mark a slide as hidden so that it will not be shown as part of the presentation.

* Delete a slide from the presentation if it is no longer needed.
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* Rename a slide.

* Duplicate a slide (copy and paste) or move it to a different position in the presentation (cut
and paste).

It is also possible to perform the following operations, although there are more efficient methods
than using the Slides pane:

* Change the slide transition following the selected slide or after each slide in a group of
slides.

* Change the sequence of slides in the presentation.
* Change the slide design.
* Change slide layout for a group of slides simultaneously.

Sidebar

The Sidebar has seven sections. To expand a section you want to use, click on its icon or click on
the small triangle at the top of the icons and select a section from the drop down list. Only one
section at a time can be open.
e
Properties -
Shows the layouts included within Impress. You can choose the one you want and use it as it
is, or modify it to meet your own requirements. However, it is not possible to save customized

layouts.

Master Pages a
Here you define the page (slide) style for your presentation. Impress includes several designs
of Master Pages (slide masters). One of them — Default — is blank, and the rest have

background and styled text.

Go to Format > Styles and Formatting on the Menu bar or press the F11 key to
Tip open the Styles and Formatting dialog, where you can modify the styles used in any
master page to suit your purpose. This can be done at any time.

Custom Animation if
A variety of animations can be used to emphasize or enhance different elements of each slide.
The Custom Animation section provides an easy way to add, change, or remove animations.
Slide Transition [{F
Provides a number of slide transition options. The default is set to No Transition, in which the
following slide simply replaces the existing one. However, many additional transitions are
available. You can also specify the transition speed (slow, medium, fast), choose between an

automatic or manual transition, and choose how long the selected slide should be shown
(automatic transition only).

L]
Styles and Formatting l'
Here you can edit and apply graphics styles, but you can only edit presentation styles. When
you edit a style, the changes are automatically applied to all of the elements formatted with this
style in your presentation. If you want to ensure that the styles on a specific slide are not
updated, create a new master page for the slide.
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Gallery “=
Opens the Impress gallery where you can insert an object into your presentation either as a
copy or as a link. A copy of an object is independent of the original object. Changes to the
original object have no effect on the copy. A link remains dependent on the original object.
Changes to the original object are also reflected in the link.

Navigator @

Opens the Impress navigator, in which you can quickly move to another slide or select an
object on a slide. It is recommended to give slides and objects in your presentation meaningful
names so that you can easily identify them when using the navigator.

Workspace

The Workspace (normally in the center of the main window) has five tabs: Normal, Outline, Notes,
Handout, and Slide Sorter (Figure 131). These five tabs are called View buttons. The Workspace
below the View buttons changes depending on the chosen view. The workspace views are
described in “Workspace views” on page 162.

‘Nurmal‘c&utline Motes Handout | Slide Sorter

Figure 131: Workspace tabs

Toolbars

Many toolbars can be used during slide creation; they can be displayed or hidden by going to View
> Toolbars on the Menu bar and selecting from the context menu.

You can also select the icons that you wish to appear on each toolbar. For more information, refer
to Chapter 1 Introducing LibreOffice.

Many of the toolbars in Impress are similar to the toolbars in Draw. Refer to the Draw Guide for
details on the functions available and how to use them.

Status bar

The Status bar (Figure 132), located at the bottom of the Impress window, contains information that
you may find useful when working on a presentation. For details on the contents and use of these
fields, see Chapter 1 Introducing LibreOffice in this guide and the Impress Guide Chapter 1
Introducing Impress.

Information area Unsaved changes Page (slide) style Zoom percentage
Textedit: Paragraph 1, Row 1, Column 1 43 0.55/1.93 i 992x4.79 e Slide 1/ 1 (Layout) Default - O + 22%
Cursor position Digital signature Slide number Zoom slider

Figure 132: Status bar

The sizes are given in the current measurement unit (not to be confused with the
Note ruler units). This measurement unit is defined in Tools > Options > LibreOffice
Impress > General.
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From left to right, you will find:
* Information area — changes depending on the selection. For example:

Example selection Examples of information shown
Text area Text Edit: Paragraph x, Row y, Column z
Charts, spreadsheets Embedded object (OLE) “ObjectName” selected
Graphics Bitmap with transparency selected

* Cursor position — the position of the cursor or of the top left corner of the selection
measured from the top left corner of the slide, followed by the width and height of the
selection or text box where the cursor is located.

* Unsaved changes — a flag indicating that the file needs saving. Double clicking on this flag
opens the file save dialog.

* Digital signature — a flag indicating whether the document is digitally signed. After the file
has been saved, double clicking on this flag opens the digital signatures dialog.

* Slide number — the slide number currently displayed in the Workspace and the total
number of slides in the presentation.

* Page (slide) style — the style associated with the slide, handout, or notes page currently in
the Workspace. Double clicking on the style name opens the slide design dialog.

* Zoom slider — adjusts the zoom percentage of the Workspace displayed.

e Zoom percentage — indicates the zoom percentage of the Workspace displayed. Double
clicking on zoom percentage opens the zoom and layout dialog.

* You can hide the Status Bar and its information by going to View on the Menu bar and
deselecting Status Bar.

Workspace views

Each of the workspace views is designed to ease the completion of certain tasks; it is therefore
useful to familiarize yourself with them in order to quickly accomplish those tasks.

Each Workspace view displays a different set of toolbars when selected. These
Note toolbar sets can be customized by going to View > Toolbars on the Menu bar,
then check or uncheck the toolbar you want to add or remove.

Normal view

Normal view is the main view for working with individual slides. Use this view to format and design
and to add text, graphics, and animation effects.

To place a slide in the slide design area (Normal view) (Figure 130 on page 159), click the slide
thumbnail in the Slides pane or double-click it in the Navigator (see Chapter 1 Introducing
LibreOffice and the Impress Guide for more information on the Navigator).

Outline view

Outline view (Figure 133) contains all the slides of the presentation in their numbered sequence. It
shows topic titles, bulleted lists, and numbered lists for each slide in outline format. Only the text
contained in the default text boxes in each slide is shown, so if your slide includes other text boxes
or drawing objects, the text in these objects is not displayed. Slide names are also not included.
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=iDefault Slide Example

~ Here is space for your content ...

Figure 133: Outline view

Text Formatting v X
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Figure 134: Outline level and movement arrows in Text Formatting toolbar

L
I»

Use Outline view for the following purposes.

1) Making changes in the text of a slide:
* Add and delete the text in a slide just as in the Normal view.

* Move the paragraphs of text in the selected slide up or down by using the up and down
arrow buttons (Move Up or Move Down) on the Text Formatting toolbar (highlighted in
Figure 134).

* Change the outline level for any of the paragraphs in a slide using the left and right
arrow buttons (Promote or Demote) on the Text Formatting toolbar.

* Both move a paragraph and change its outline level using a combination of these four
arrow buttons.

2) Compare slides with your outline (if you have prepared one in advance). If you notice from
your outline that another slide is needed, you can create it directly in the Outline view or
you can return to the Normal view to create it.

Notes view

Use the Notes view (Figure 135) to add notes to a slide. These notes are not seen when the
presentation is shown.

Normal | Outline | Notes | Handout | Slide Sorter

=4 1 2 3 14 5 6 7 g8

Default Slide Example

o 7 Here isspace for your content ...
7 Some hints:

Click to add Notes

o

Figure 135: Notes view
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1) Click the Notes tab in the Workspace.
2) Select the slide to which you want to add notes.
3) Click the slide in the Slides pane, or double-click the slide name in the Navigator.
4) In the text box below the slide, click on the words Click to add notes and begin typing.
You can resize the Notes text box using the colored resizing handles which appear when you click

on the edge of the box. You can also move the box by placing the pointer on the border, then
clicking and dragging. To make changes in the text style, press the F11 key to open the Styles and

-
Formatting dialog or click on the Styles and Formatting icon === on the Sidebar.

Handout view

Handout view is for setting up the layout of your slide for a printed handout. Click the Handout tab
in the workspace and the Layouts section opens on the Sidebar (Figure 136) where you can then
choose to print 1, 2, 3, 4, 6, or 9 slides per page. If the Layouts section does not open, then click

| L
on the Properties icon 1’?' at the side of the Sidebar.

Use this view also to customize the information printed on the handout. Refer to the Impress Guide

Chapter 10 Printing, E-mailing, Exporting, and Saving Slide Shows for instructions on printing
slides, handouts, and notes.

Properties X =
= uts =
Layo @
=
Figure 136: Handout layouts
& o LibreOffice 4.2
Slides | Notes and Handouts
T T
Header texkt: [
& Date and time
® Fixed
—1
(O Variable
Format 03/17/14
Language |English (USA)
& Footer
Footer text:
[] Page Number
[.Apply_tnnll ‘ | Cancel || Help

Figure 137: Header and Footer dialog — Notes and Handouts page

164 | Getting Started with LibreOffice 4.2



Go to Insert > Page Number or Insert > Date and Time on the Menu bar and the Header and
Footer dialog opens. Click on the Notes and Handouts tab (Figure 137) and use this page to select
the elements you want to appear on each handout page and their contents. More details on how to
use this dialog are provided in the Impress Guide.

Slide Sorter view

Slide Sorter view (Figure 138) contains all of the slide thumbnails. Use this view to work with a
group of slides or with only one slide.

« B laslides =
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=
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Figure 138: Slide Sorter view

Customizing Slide Sorter view
To change the number of slides per row:

1) Go to View > Toolbars and select Slide Sorter and Slide View to show or hide the Slide
Sorter and Slide View toolbars (Figure 139)

2) Adjust the number of slides (up to a maximum of 15).

.E- (] 4 B 4slides =

Figure 139: Slide Sorter and Slide View toolbars

Moving a slide using Slide Sorter

To move a slide in a presentation in the Slide Sorter:
1) Click the slide and the slide is highlighted (Figure 138).
2) Drag and drop the slide to the location you want.

Selecting and moving groups of slides
To select a group of slides, use one of these methods:

* Using the Citrl key — click on the first slide and, while pressing the Ctrl key, select the other
desired slides.

* Using the Shift key — click on the first slide, and while pressing the Shift key, select the final
slide in the group. This selects all of the other slides between the first and the last slide
selected.

* Using the mouse — click slightly to one side (left or right) of the first slide to be selected.
Hold down the left mouse button and drag the cursor until all of the slides you want
selected are highlighted.
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To move a group of slides:
1) Select a group of slides.
2) Drag and drop the group to their new location.

Working in Slide Sorter view

You can work with slides in the Slide Sorter view just as you can in the Slide pane. To make
changes, right-click a slide and choose any of the following from the context menu:

* New Slide — adds a new slide after the selected slide (see “New slide” on page 169).

* Duplicate Slide — creates a duplicate of the selected slide and places the new slide
immediately after the selected slide (see “Duplicate slide” on page 170).

* Delete Slide — deletes the selected slide.
* Rename Slide — allows you to rename the selected slide.
* Slide Layout — allows you to change the layout of the selected slide.
* Slide Transition — allows you to change the transition of the selected slide.
— For one slide, select a slide and add the desired transition.
- For more than one slide, select a group of slides and add the desired transition.
* Hide Slide — any slides that are hidden are not shown in the slide show.
* Cut - removes the selected slide and saves it to the clipboard.
* Copy — copies the selected slide to the clipboard without removing it.
* Paste —inserts a slide from the clipboard after the selected slide.

Creating a new presentation

This section describes how to start a new presentation using the Presentation Wizard.

The first thing to do is decide on the purpose of the presentation and plan the
presentation. Although you can make changes as you go, having an idea of who the
audience will be, the structure, the content, and how the presentation will be
delivered, will save you a lot of time from the start.

Tip

When you start Impress, the Presentation Wizard appears (Figure 140).
1) Under Type, choose one of the options. These options are covered in the Impress Guide.

- Empty presentation creates a blank presentation.

- From template uses a template design already created as the basis for a new
presentation. The wizard changes to show a list of available templates. Choose the
template you want.

- Open existing presentation continues work on a previously created presentation. The
wizard changes to show a list of existing presentations. Choose the presentation you
want.

2) Click Next. Figure 141 shows the Presentation Wizard step 2 as it appears if you selected
Empty Presentation at step 1. If you selected From template, an example slide is shown in
the Preview box.
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® Presentation Wizard

Type
@& Emptypresentation

() From template

() Open existing presentation

& Preview

[C] Do notshow this wizard again

l Help l l cancel l [ <<Back

Figure 140: Choosing the type of presentation
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lss)

|<Original>
!Abstract Green
|Abstract Red

|Abstract Yellow
IRrinht Rlua

Select an output medium

W il @x0

) Qriginal @ screen
() overhead sheet O slide & Preview
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Figure 141: Selecting a slide design

3) Choose a design under Select a slide design. The slide design section gives you two
main choices: Presentation Backgrounds and Presentations. Each one has a list of choices
for slide designs. If you want to use one of these other than <Original>, click it to select it.

- The types of Presentation Backgrounds are shown in Figure 141. When you select a
presentation background, you will see a preview of the slide design in the Preview

window.

- <Original> is for a blank presentation slide design.

4) Select how the presentation will be used under Select an output medium. Majority of
presentations are created for computer screen display. It is recommended to select Screen.

You can change the page format at any time.
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The Screen page is optimized for a 4:3 display (28cm x 21cm) so it is not suitable for
modern widescreen displays. You can change the slide size at any time switching to
Normal view and selecting Format > Page.

5) Click Next and step 3 of the Presentation Wizard appears (Figure 142).
- Choose the desired slide transition from the Effect drop-down menu.

- Select the desired speed for the transition between the different slides in the
presentation from the Speed drop-down menu. Medium is a good choice for now.

% Presentation Wizard

Select a slide transition

Effect |No Effect )

Speed \Medium 8
Select the presentation bype

@ Default

() Automatic

Duration of page 00:00:10

] )

Duration of pause  pp:00:10

W

& Preview

[+ show logo

| mHelp || cancel || <<Back || next>> [ iCreate

Figure 142: Selecting a slide transition effect
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Describe your basic ideas
What is your name or the name of your company?

lMy Very Own l

what is the subject of your presentation?

lCreal:ing Presentations l

Further ideas to be presented?

How to create a professional presentation

I Help ‘ I Cancel ‘ I << Back ‘ ﬁ Create .

Figure 143: Entering information about your presentation
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If you did not select a template in step 1 of the Presentation Wizard, then steps 4
and 5 in the Presentation Wizard will not appear after step 3. Click Create and your
new presentation is created.

6) Click Next and step 4 of the Presentation Wizard appears allowing you to enter information
about your company and the presentation you are creating.

7) Click Next and step 5 of the Presentation Wizard appears showing a preview of what your
presentation will look like (Figure 144). If the preview does not appear, select Preview.

8) If you want to create a summary of your presentation, select Create summary.
9) Click Create and your new presentation is created.

® Presentation Wizard (Abstract Green)

Choose your pages

[ @slide 1

B Preview

[[] Create summary

I Help ‘ I Cancel ‘ I <<Back ‘ i Next>>

Figure 144: Presentation preview

You can accept the default values for both Effect and Speed unless you are skilled
at creating presentations. Both of these values can be changed later while working
with slide transitions and animations. These two features are explained in more
detail in the Impress Guide Chapter 9 Slide Shows.

Tip

Formatting a presentation

A new presentation contains only one empty slide. In this section we will start adding new slides
and preparing them for the intended contents.

Inserting slides

New slide
A new slide can be inserted into a presentation as follows:.
1) Go to Insert on the Menu bar and select Slide.

2) Orright-click on a slide in the Slides Pane or Slide Sorter view and select New Slide from
the context menu.
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3) Or, right click in am empty space in the Workspace and select Slide > New Slide from the
context menu.

+
4) Or click the Slide icon in the Presentation toolbar. If the Presentation toolbar is not
visible, go to View > Toolbars on the Menu bar and select Presentation from the list.

5) Anew slide is inserted after the selected slide in the presentation.

Duplicate slide
Sometimes, rather than starting from a new slide you may want to duplicate a slide already
included in your presentation. To duplicate a slide:

1) Select the slide you want to duplicate from the Slides Pane.

2) Go to Insert on the Menu bar and select Duplicate Slide.

3) Or, right click on the slide in the Slides Pane or Slide Sorter view and select Duplicate
Slide from the context menu.

4) Or, right click on a slide in the Workspace and select Slide > Duplicate Slide from the
context menu.

+
5) Or click on the triangle to the right of the Slide icon in the Presentation toolbar and
select Duplicate Slide from the context menu. If the Presentation toolbar is not visible, go
to View > Toolbars on the Menu bar and select Presentation from the list.

6) Aduplicate slide is inserted after the selected slide in the presentation.

Selecting slide layout

When creating a presentation, the first slide is normally a title slide. You can use either a blank
layout or one of the title layouts as your title slide.

T

Click on the Properties icon T, at the side of the Sidebar to open Layouts section and display
the available layouts (Figure 145). The layouts included in LibreOffice range from a blank slide to a
slide with six contents boxes and a title.

Properties x =
E Layouts !'i‘-_.'j:
— [12d]

Figure 145: Available slide layouts

To create a title, if one of the title layouts has been selected, click on Click to add title and then type
the title text. To add text content, depending on the slide layout selected, click on Click to add text.
To adjust the formatting of the title, subtitle or content modify the presentation style; see the
Impress Guide Chapter 2 Using Slide Masters, Styles, and Templates for more information.
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Text and graphic elements can be readjusted at any time during the preparation of the
presentation, but changing the layout of a slide that already contains some contents
can have an effect on the content format . Therefore, it is recommended that you pay
particular attention to the layout you select to prevent any loss of content.

Note

To view the names for the included layouts, use the Tooltip feature: position the
cursor on an icon in the Layout section (or on any toolbar icon) and its name will be
displayed in a small rectangle.

Tip If tooltips are not enabled, choose Tools > Options > LibreOffice > General > Help
and select the Tips option. If the Extended tips option is also selected, you will get
more detailed tooltip information, but the tooltip names themselves will not be
provided.

To select or change the layout of a slide, select the slide in the Slides Pane so that it appears in the
Workspace and select the desired layout from the Layouts section in the Sidebar. Several layouts
contain one or more content boxes. Each of these content boxes can be configured to contain text,
movies, images, charts or tables.

You can choose the type of contents by clicking on the corresponding icon that is displayed in the
middle of the contents box as shown in Figure 146. If you intend to use the contents box for text,
click on Click to add text.

Click to add Title

* Click to add Text

Insert Table Insert Chart

Insert Image Insert Movie

Figure 146: Selecting contents type

Modifying slide elements

A slide contains elements that were included in the slide master, as well as those elements
included in the selected slide layout. However, it is unlikely that the predefined layouts will suit all
your needs for your presentation. You may want to remove elements that are not required or insert
objects such as text and graphics.
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Although Impress does not have the functionality to create new layouts, it allows you to resize and
move the layout elements. It is also possible to add elements without being limited to the size and
position of the layout boxes.

To resize a contents box, click on the outer frame so that the resizing handles are displayed. To
move it place the mouse cursor on the frame so that the cursor changes shape. You can now click
and drag the contents box to a new position on the slide.

To remove any unwanted elements:

1) Click the element to highlight it. The resizing handles show it is selected.
2) Press the Delete key to remove it.

Changes to any of the layouts included in Impress can only be made using View >
Normal, which is the default. Attempting any changes by modifying a slide master,
although possible, may result in unpredictable results and requires extra care as well
as a certain amount of trial and error.

Note

Adding text

To add text to a slide that contains a text frame, click on Click to add text in the text frame and then
type your text. The Outline styles are automatically applied to the text as you insert it. You can
change the outline level of each paragraph as well as its position within the text by using the arrow
buttons on the Text Formatting toolbar (see Figure 134 and “Outline view” on page 162). For more
information on text, see “Adding and formatting text” on page 173.

Adding objects

To add any objects to a slide, for example a picture, clipart, drawing, photograph, or spreadsheet,
click on Insert then select from the drop down menu what type of object you want to insert. For
more information, see “Adding pictures, tables, charts, and media” on page 178.

Modifying appearance of all slides

To change the background and other characteristics of all slides in the presentation, you need to
modify the master page or choose a different master page as explained in “Working with slide
masters and styles” on page 181.

A Slide Master is a slide with a specified set of characteristics that acts as a template and is used
as the starting point for creating other slides. These characteristics include slide background,
objects in the background, formatting of any text used, and any background graphics.

LibreOffice uses three interchangeable terms for this one concept. Master slide,
slide master, and master page. These terms all refer to a slide that is used to
create other slides. This guide, however, uses only the term slide master, except
when describing the user interface.

Note

Impress has a range of slide masters and these are found in the Master Pages section of the
Sidebar. You can also create and save additional slide masters or add more from other sources.
See the Impress Guide Chapter 2 Using Slide Masters, Styles, and Templates for more information
on creating and modifying slide masters.
If all you need to do is to change the background, you can use a shortcut:
1) Select Format > Page and go to the Background tab on the Page Setup dialog that opens.
2) Select the desired background between solid color, gradient, hatching and bitmap.
3) Click OK to apply it.
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4) Adialog opens asking if the background should be applied to all the slides. Click Yes if you
want all the slides modified and Impress will automatically modify the master page for you.

Inserting and correctly formatting a background is beyond the scope of this chapter,
Note but you can find all the information you need in the Draw Guide Chapter 4 Changing
Object Attributes or in the Impress Guide Chapter 6 Formatting Graphic Objects.

Modifying the slide show

By default the slide show will display all the slides in the same order as they appear in the slide
sorter, without any transition between slides. You need to use keyboard input or mouse interaction
to move from one slide to the next.

You can use Slide Show on the Menu bar to change the order of the slides, choose which ones
are shown, automate moving from one slide to the next, and other settings. To change the slide
transition, animate slides, add a soundtrack to the presentation, and make other enhancements,
you need to use functions in the Sidebar. See the Impress Guide for details on how to use all of
these features.

Adding and formatting text

Many of your slides are likely to contain some text. This section gives you some guidelines on how
to add text and how to change its appearance. Text used in slides is contained in text boxes. For
more information on adding and formatting text, see the Impress Guide Chapter 3 Adding and
Formatting Text.

There are two types of text boxes that you can add to a slide:

* Choose a predefined layout from the Layouts section of the Sidebar and do not select any
special contents type. These text boxes are called AutoLayout text boxes.

* Create a text box using the Text icon T on the Drawing toolbar (Figure 147) or the Text
toolbar (Figure 148), or use the keyboard shortcut F2.

Drawing v X

R/ »EHO@T € - "% - -© -« @ -P-%- K, al@
Figure 147: Drawing toolbar

Text -
TERQHB®

Figure 148: Text toolbar

Using AutoLayout text boxes

1) Make sure Normal view is selected.
2) Click in the text box that reads Click to add text.
3) Type or paste your text in the text box.

Using text boxes
1) Make sure Normal view is selected.
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2) Click on the Text icon T on the Drawing or Text toolbar or use the keyboard shortcut F2. If
the Drawing or Text toolbars are not visible, go to View > Toolbars on the Menu bar and
select Drawing or Text.

3) Click and drag to draw a box for the text on the slide. Do not worry about the vertical size
and position as the text box will expand if needed as you type.

4) Release the mouse button when finished. The cursor appears in the text box, which is now
in edit mode (a colored border shown in Figure 149).

5) Type or paste your text in the text box.
6) Click outside the text box to deselect it.

You can move, resize, and delete text boxes. For more information, see the Impress Guide
Chapter 3 Adding and Formatting Text.

Using text boxes

¥ Click on the Text icon on the Drawing or Text toolbar or use
the keyboard shortcut F2. If the Drawing or Text toolbars are
not visible, go to View > Toolbars on the main menu bar and
select Drawing or Text.

v Click and drag to draw a box for the text on the slide. Do not
worry about the vertical size and position as the text box will
expand if needed as you type.

v Release the mouse button when finished. The cursor appears
in the text box, which is now in edit mode (a colored border
shown in Figure 20).

- : 3
U Libreoffice LibreOffice Productivity Stite

Figure 149: Creating and editing text boxes

Vertical text

In addition to the normal text boxes where text is horizontally aligned, it is possible to insert text
boxes where the text is aligned vertically. Vertical text is available only when Asian languages are

enabled in Tools > Options > Language Settings > Languages. Click the Vertical Text icon |
in the Drawing toolbar or Text toolbar to create a vertical text box.

Quick font resizing

Impress has an Increase Font icon and a Decrease Font icon on the Text Formatting toolbar
(highlighted in Figure 150) to increase or decrease font size of selected text. The amount by which
the font size changes depends on the standard sizes available for the font in use.

Text Formatting ¥

Liberation Sans:Ni| + | | 26 « B 7T UM Hestl T ) l =R im A -

Figure 150: Quick font resizing on Text Formatting toolbar

Pasting text

Text may be inserted into the text box by copying it from another document and pasting it into
Impress. However, pasted text will probably not match the formatting of the surrounding text on the
slide or that of the other slides in the presentation. This may be what you want on some occasions;
however, in most cases you want to make sure that the presentation style is consistent and does
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not become a patchwork of different paragraph styles, font types, bullet points and so on. There
are several ways to ensure consistency in your presentation.

Pasting unformatted text
It is normally good practice to paste text without formatting and apply the formatting later. To paste
text without formatting:
1) Use the keyboard shortcut Ctrl+Shift+V and select Unformatted text from the Paste
Special dialog that opens.
2) Or click on the small triangle next to the Paste icon in the Standard toolbar and select
Unformatted text from the context menu.

3) The unformatted text will be formatted with the outline or paragraph style at the cursor
position in an AutoLayout text box or with the default graphic style in a normal text box.

Formatting pasted text

When formatting pasted text, you can use the tools available on the Text Formatting toolbar (Figure

151), or the tools available in the Character and Paragraph sections on the Sidebar (Figure 152). If

the Character and Paragraph sections do not automatically open after selecting some text, click on
1-.‘:3

the Properties icon A at the side of the Sidebar.

Text Formatting
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Figure 151: Text Formatting toolbar
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Figure 152: Sidebar Character section
If you are pasting the text into an AutoLayout text box, you need to apply the appropriate outline
style to the text to give it the same look and feel as the rest of the presentation.

1) Paste the text in the desired position.
2) Select the text you have just pasted.
3) Select Format > Default formatting on the Menu bar.
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4)

5)

Use the four arrow buttons on the Text Formatting toolbar (highlighted in Figure 134 on
page 163) to move the text to the appropriate position and give it the appropriate outline
level.

- Left arrow promotes a list entry by one level (for example from Outline 3 to Outline 2).
- Right arrow button demotes a list entry by one level.

- Up arrow moves a list entry up in the list order.

- Down arrow moves a list entry down in the list order.

Apply any necessary manual formatting to the text to change font attributes, tabs, and so
on.

If you are pasting text in a text box, you can still use styles to quickly format the text. Only one
graphic style can be applied to the pasted text as follows:

1)
2)
3)
4)

Paste the text in the desired position.
Select the text you have just pasted.
Select the desired graphic style to format the text.

Apply any necessary manual formatting to the text to change font attributes, tabs, and so
on.

Creating bulleted and numbered lists

The procedure to create a bulleted or numbered list is quite different depending on the type of text
box used, although the tools to manage the list and customize the appearance are the same. In
AutoLayout text boxes, the outline styles available are, by default, bulleted lists. For normal text
boxes an additional step is required to create a bulleted list.

AutolLayout text boxes

AutoLayout text boxes included in the available layouts are already formatted as a bulleted list.
Create a slide with a bulleted list as follows:

1)
2)
3)
4)

From the Layout pane, choose a slide design that contains a text box.
In the text box, click on Click to add text.
Type your text and press the Enter key to start a new bulleted point.

The default list type is a bulleted list. Methods for changing the appearance of a list are
explained in “Changing list appearance” on page 177.

Press Shift+Enter to start a new line without creating a new bullet point. The new
line will have the same indentation as the previous line. To switch off bullets

Tip altogether, click the Bullets On/Off icon 8= on the Text Formatting toolbar. If the

Text Formatting toolbar is not displayed, go to View > Toolbar > Text Formatting on
the Menu bar.

Text boxes
Create a bulleted list in a text box as follows:

1)
2)
3)
4)

Click the Text icon T on the Drawing toolbar and draw a text box on your slide.

Click the Bullets OnlOff icon s= on the Text Formatting toolbar.
Type the text and press Enter to start a new bulleted line.

The default list type is a bulleted list. Methods for changing the appearance of a list are
explained in “Changing list appearance” on page 177.
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Creating a new outline level
In AutoLayout text boxes a new outline level is created as follows:
1) If necessary, press Enter to begin a new list entry.

2) To demote a list entry (move it to the right), press the Tab key or click the Demote (right
arrow) icon on the Text Formatting toolbar or use the keyboard shortcut Alt+Shift+Right.
The list entry moves to the right and is indented to the next outline level.

3) Pressing Enter again creates a new list entry at the same level as the previous one.

4) To promote a list entry (move it to the left), press Shift+Tab or click the Promote (left arrow)
icon on the Text Formatting toolbar or use the keyboard shortcut Alt+Shift+Left. The list
entry moves to the left and is indented at the next higher level.

5) Pressing Enter again creates a new list entry at the same level as the previous one.

In the AutoLayout text boxes, promoting or demoting an item in the list corresponds to applying a
different outline style. The second outline level corresponds to Outline 2 style, the third outline level
to Outline 3 style, and so on. A change in level and style produces other changes, for example, to
font size, bullet type, and so on.

In text boxes, a hew outline level can only be created using the Tab key to demote the list entry
and the Shift+Tab key combination to promote the list entry.

Do not try to change the outline level by selecting the text and then clicking the
Note desired outline style as you would in Writer. Due to the way that presentation styles
work in Impress, it is not possible to change the level in this way.

Changing list appearance

You can fully customize list appearance by changing the bullet type or numbering for the entire list

or for only a single entry. All of the changes can be made using the Bullets and Numbering dialog

(Figure 153), which is accessed by going to Format > Bullets and Numbering on the Menu bar or
a—

by clicking on the Bullets and Numbering icon a1l on the Text Formatting toolbar.

& Bullets and Numbering

Bullets |Numbering type Graphics Position Customize
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Figure 153: Bullets and Numbering dialog
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For the entire list:

1) Select the entire list or click on the border of the text box so that the resizing handles are
displayed.
2) Select Format > Bullets and Numbering on the Menu bar or click on the Bullets and

—
Numbering icon 815 on the Text Formatting toolbar.

3) The Bullets and Numbering dialog (Figure 153) contains five pages: Bullets, Numbering
type, Graphics, Position, and Customize.

- If a bullet list is needed, select the desired bullet style from the default styles available
on the Bullets page.

- If a graphics style is needed, select one from those available on the Graphics page.

- If a numbered list is needed, select one of the default numbering styles on the
Numbering type page.

- The Position page allows you to set the indent and numbering spacing and alignment
of your list.

-  The Customize page allows you to customize the numbering, color, relative size and
character used for your list.
4) For a single list entry, click anywhere in the text and then follow steps 2 and 3 above.

If the list was created in an AutoLayout text box, then an alternative way to change the entire list is
to modify the Outline styles. Changes made to the outline style will apply to all the slides using
them.

Adding pictures, tables, charts, and media

A contents box can also contain pictures, tables, charts, or media as well as text. This section
provides a quick overview of how to work with these objects. For more information on adding
pictures, tables, charts, or media, please refer to the Impress Guide.

Adding pictures

To add a picture to a contents box:
1) Go to Insert > Picture on the Menu bar and then select either From file or Scan.

2) Alternatively, after inserting a new slide, click the Insert Picture icon (Figure 146 on page
171) on the new slide and select the file from the Insert Picture dialog that opens. To see a
preview of the picture, check Preview at the bottom of the Insert Picture dialog.

3) Move the picture to the desired location.

4) The picture will automatically resize to fill the area of the contents box. Follow the directions
in the note below when manually resizing a graphic.

When resizing a graphic, right-click the picture. Select Position and Size from the
context menu and make sure that Keep ratio is selected. Then adjust the height or
width to the size you need. As you adjust one dimension, both dimensions will change
to keep the width and height ratio the same. Failure to do so will cause the picture to
become distorted. Remember also that resizing a bitmap image will reduce its quality;
it is better to create an image of the desired size outside of Impress.

Note
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Adding tables

To add basic tables to a slide:

1) Go to Insert > Table on the Menu bar, or click the Table icon E&E on the Standard toolbar.

2) If there is a table already on the slide and it is selected, click the Table icon @ on the
Table toolbar. The Table toolbar is only visible after selecting View > Toolbars > Table on
the Menu bar and when a table is selected.

3) Alternatively and after inserting a new slide into your presentation, click the Insert Table
icon (Figure 146 on page 171).

4) Select the number of rows and columns required from the Insert Table dialog that opens.

5) Alternatively, click the small triangle to the right of the Table icon E and select the
number of rows and columns by dragging the cursor.

6) Select a design style from the available options for your table in the Table Design section in
the Sidebar (Figure 154). If the Table Design section does not automatically open after

inserting or selecting a table, click on the Properties icon

iﬁg

at the side of the Sidebar.
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Figure 154: Sidebar Table Design section

Selecting from any of the styles in the Table Design section in the Sidebar creates a

Note

a style of your choice later.

table based on that style. If you create a table by another method, you can still apply
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The Table toolbar in Impress offers the same functions as the Table toolbar in Writer, with the
exception of the calculation functions Sort and Sum. To use Sum and Sort in your presentation you
have to insert a Calc spreadsheet.

After the table is created, you can modify it by adding and deleting rows and columns, adjusting
width and spacing, adding borders, background colors and so on. For more information on working
with tables see the Impress Guide Chapter 3 Adding and Formatting Text and the Writer Guide
Chapter 9 Working with Tables.

Entering data into table cells is similar to working with text box objects. Click in the cell you wish to
add data to and begin typing. To move around cells quickly, use the following keyboard options:

* Press the arrow keys to move the cursor to another cell if the cell is empty, or to the next
character if the cell already contains text.

* Press the Tab key to move to the next cell on the right and press Shift+Tab to move to the
next cell on the left..

Adding charts

To insert a chart in a slide:

1) Goto Insert > Chart on the Menu bar or click on the Chart icon @ in the Standard
toolbar.

2) Alternatively and after inserting a new slide, click on the Insert Chart icon (Figure 146 on
page 171).

3) Impress will insert a default chart and open the Chart dialog. To modify the chart type,
insert your own data and change the formatting, refer to the Impress Guide.

Adding media files

To insert media files, such as music and movie clips, in a slide:
1) Go to Insert > Movie and Sound on the Menu bar.
2) Alternatively and after inserting a new slide, click on the Insert Movie icon (Figure 146 on
page 171).
3) A media player will open at the bottom of the screen and you can preview the media.
4) When an audio file is inserted, the contents box will show a loudspeaker image.

In Linux-based systems such as Ubuntu, media files do not immediately work. You
Note have to download the Java Media Framework APl (JMF) and add the path jmf. jar
to the Class Path in Tools > Options > LibreOffice > Java.

Adding graphics, spreadsheets, and other objects

Graphics, such as shapes, callouts, arrows, and so on, are often useful to complement the text on
a slide. These objects are handled much the same way as graphics in Draw. For more information,
see the Draw Guide Chapter 7 Getting Started with Draw, or the Impress Guide Chapters 4, 5,
and 6.

Spreadsheets embedded in Impress include most of the functionality of Calc spreadsheets and are
capable of performing extremely complex calculations and data analysis. If you need to analyze
your data or apply formulas, these operations are best performed in a Calc spreadsheet and the
results displayed in an embedded Calc spreadsheet or even better in an Impress table.
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Alternatively, go to Insert > Object > OLE Object on the Menu bar. This opens a spreadsheet in
the middle of the slide and the menus and toolbars change to those used in Calc. You can start
adding data, though you may have to resize the visible area on the slide. You can also insert an
existing spreadsheet and use the viewport to select the data that you want to display on your slide.

Impress offers the capability of inserting into a slide various other types of objects such Writer
documents, Math formulae, or another presentation. For details on using these objects, refer to the
Impress Guide Chapter 7 Including Spreadsheets, Charts, and Other Objects.

Working with slide masters and styles

A slide master is a slide that is used as the starting point for other slides. It is similar to a page style
in Writer and it controls the basic formatting of all slides based on it. A slide show can have more
than one slide master.

LibreOffice uses three terms for a slide that is used to create other slides: master
Note slide, slide master, and master page. This book uses the term slide master, except
when describing the user interface.

A slide master has a defined set of characteristics, including background colors, graphics,
gradients; and other objects (such as logos, decorative lines and so on), headers and footers,
placement and size of text frames, and text format.

Styles

All of the characteristics of slide masters are controlled by styles. New slides that you create using
a slide master have styles that are inherited from the slide master from which was used. Changing
a style in a slide master results in changes to all slides based on that slide master, but you can
modify individual slides without affecting the slide master.

Although it is highly recommended to use the slide masters whenever possible, there
Note are occasions where manual changes are needed for a particular slide, for example
to enlarge the chart area when the text and chart layout is used.

Slide masters have two types of styles associated with them: presentation styles and image styles.
The prepackaged presentation styles can be modified, but new presentation styles cannot be
created. For image styles, you can modify the prepackaged styles and also create new image
styles.

Presentation styles affect three elements of a slide master: background, background objects (such
as icons, decorative lines, and text frames), and text placed on the slide. Text styles are further
divided into Notes, Outline 1 through Outline 9, Subtitle, and Title. The outline styles are used for
the different levels of the outline to which they belong. For example, Outline 2 is used for the sub-
points of Outline 1, and Outline 3 is used for the sub-points of Outline 2, and so on.

Image styles are not restricted and can affect many of the elements of a slide. Note that text styles
exist in both the presentation and image style selections.
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Slide masters

Impress comes with a collection of slide masters. These slide masters are shown in the Master
Pages section of the Sidebar (Figure 155) and has three subsections: Used in This Presentation,
Recently Used, and Available for Use. Click the + sign next to the name of a subsection to expand

it to show thumbnails of the slides, or click the — sign to collapse the subsection to hide the
thumbnails.

Each of the slide masters shown in the Available for Use list is from a template of the same name.

If you have created your own templates, or added templates from other sources, slide masters
from those templates will also appear in this list.
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Figure 155: Sidebar Master Pages section
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Figure 156: Master View toolbar

Creating a slide master

Creating a new slide master is similar to modifying the default slide master.

1) Enable editing of slide masters by selecting View > Master > Slide Master on the Menu

bar and the Master View toolbar opens (Figure 156). If the Master View toolbar does not
appear, go to View > Toolbars and select Master View.

2) On the Master View toolbar, click the New Master icon B

3) Anew slide master appears in the Slides pane. Modify this slide master to suit your
requirements.
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4) ltis also recommended that you rename this new slide master. Right-click on the slide in
the Slides pane and select Rename master from the context menu.

5) When finished creating a slide master, click Close Master View on the Master View toolbar
and return to normal slide editing mode.

Applying a slide master
To apply a slide master to all the slides in your presentation:

1) Click on the Master Pages icon E‘ in the Sidebar to open the Master Pages section
(Figure 155).

2) To apply one of the slide masters to all slides in your presentation, right-click on it from the
available selection and select Apply to All Slides on the context menu.

To apply a different slide master to one or more selected slides:
1) Inthe Slide Pane, select the slide or slides where you want to use a new slide master.

2) In the Master Pages section on the Sidebar, right-click on the slide master you want to
apply to the selected slides, and select Apply to Selected Slides on the context menu.

Loading additional slide masters

Sometimes, in the same set of slides, you may need to mix multiple slide masters that may belong
to different templates. For example, you may need a completely different layout for the first slide of
the presentation, or you may want to add to your presentation a slide from a different presentation
(based on a template available on the hard disk).

& o slide Design

Select a slide design

Default
Exchange background page

[] Delete unused backgrounds

ok | cancel Help Load...

Figure 157: Slide Design dialog

1) Go to Format > Slide Design on the Menu bar or right-click on a slide in the Slides Pane
and select Slide Design from the context menu to open the Slide Design dialog (Figure
157). This dialog shows the slide masters already available for use.

2) To add more slide masters, click the Load button to open the Load Slide Design dialog
(Figure 158).
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Figure 158: Load Slide Design dialog
3) Selectin the Load Slide Design dialog the template from which to load the slide master and
click OK.
4) Click OK again to close the Slide Design dialog.

5) The slide masters in the template you selected to use are now shown in the Available for
use subsection of Master Pages.

The slide masters you have loaded will also be available the next time you load the
presentation. If you want to delete the unused slide masters, click the corresponding

Note checkbox in the Slide Design dialog. If the slide master was not used in the
presentation, it is removed from the list of available slide masters.

To limit the size of the presentation file, you may want to minimize the number of

Tip slide masters used.

Modifying a slide master

The following items can be changed on a slide master:
e Background (color, gradient, hatching, or bitmap)
e Background objects (for example, a logo or decorative graphics)
* Size, placement, and contents of header and footer elements to appear on every slide
* Size and placement of default frames for slide titles and content

For more information on modifying slide masters, see the Impress Guide Chapter 2 Using Slide
Masters, Styles, and Templates.

1) Select View > Master > Slide Master from the menu bar. This unlocks the properties of a
slide master so you can edit it.

2) Select a slide master in Master Pages in the Slides pane.

3) Select an object on the slide master in the Workspace and the Sidebar will display the
property options that can be changed for the selected object. Figure 159 Shows a graphic
object selected with the Graphic properties section open on the Sidebar.

4) Make all necessary changes to the slide master, then click the Close Master View icon on

the Master View toolbar or go to View > Normal on the Menu bar to exit from editing slide
masters.

5) Save your presentation file before continuing.

Any changes made to one slide when in Master View mode will appear on all slides
Note using this slide master. Always make sure you Close Master View and return to
Normal view before working on any of the presentation slides.
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Figure 159: Editing a slide master

The changes made to one of the slides in Normal view (for example, changes to the
bullet point style, the color of the title area, and so on) will not be overridden by
subsequent changes to the slide master. There are cases, however, where it is
desirable to revert a manually modified element of the slide to the style defined in
the slide master. To revert back to default formatting, select the element and select
Format > Default Formatting from the Menu bar.

Adding text, footers, and fields to all slides

A slide master can have text, footers, or fields added so that they appear on every slide in your
presentation. Due to the layout of slides in Impress, headers are not normally added to slides.

Text
1)
2)
3)

4)

Go to View > Master > Slide Master on the Menu bar to open Master View (Figure 160).
On the Drawing toolbar, select the Text icon or press the F2 key.

Click and drag in the master page to draw a text object and then type or paste your text into
the text object.

Go to View > Normal on the Menu bar or click on Close Master View on the Master View
toolbar when you have finished entering text objects that you want to appear on every slide
in your presentation.

Footers
To add a footer to your slides:

1)
2)

3)

Go to View > Master > Slide Master on the Menu bar to open Master View (Figure 160).

Go to Insert > Date or Insert > Page Number on the Menu bar and time to open the
Header and Footer dialog (Figure 161).

Select the type of date and time and type in the footer text and slide number from the
available options in the dialog.
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Figure 161: Footer dialog in Impress
4) Click Apply to All to apply your changes to all the slide masters in your presentation, or
click Apply to apply your changes to the selected slide master in your presentation.

5) Alternatively, you can add the date/time, footer text and slide number directly into their
respective areas as shown in Figure 160.

Normally only footers are used on a slide. To create a header, you can use a text
Note H H 15 $1
box as explained in “Text” on page 185.
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Fields

To add a field into an object or as a separate object on a slide, select Insert > Fields on the Menu
bar and select the required field from the submenu. If you want to edit this field in your slide, see
the Impress Guide Chapter 3 Adding and Formatting Text for more information.

The fields you can use in Impress are as follows:
* Date (fixed)
¢ Date (variable): updates automatically when you reload a file
* Time (fixed)
* Time (variable): updates automatically when you reload a file
* Author: first and last names listed in the LibreOffice user data
* Page Number: this is the slide number in Impress.
* Page Count: this is the number of slides in your presentation.
* File Name

To change the author information, go to Tools > Options > LibreOffice > User Data
on the Menu bar.

To change the number format (1,2,3 or a,b,c or i,ii,iii, and so on) for the number field,
Tip go to Format > Page on the Menu bar and then select a format from the Format list
in the Layout Settings area.

To change a paragraph style throughout your presentation, open the Styles and
Formatting dialog and modify the appropriate presentation style.

Adding comments to a presentation

Impress supports comments similar to those in Writer and Calc.

In Normal View, go to Insert > Comment on the Menu bar to open a blank comment (Figure 162).
A small box containing your initials appears in the upper left-hand corner of the slide, with a larger
text box beside it. Impress automatically adds your name and the current date at the bottom of the
text box.

This is a sample of a comment that you can
add into your presentation |

B Bold

u gnderlins

asc  Strikethrough

| ®] Delete Comment
Peter Schofie
Today, 11:56 Delete All Comments by Peter 5

Figure 162: Inserting comments

Type or paste your comment into the text box. You can optionally apply some basic formatting to
the comment by selecting it, right-clicking, and choosing from the context menu that opens. This
menu allows you to apply formatting to selected text, delete the current comment, delete all
comments from the same author, or delete all comments in the presentation.
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You can move the small comment markers to anywhere you wish on the slide. Typically you might
place it on or near an object you refer to in the comment.

To show or hide the comment markers, choose View > Comments.
Select Tools > Options > User Data to configure the name you want to appear in the comment.

If more than one person edits the document, each author is automatically allocated a different
background color for their comments.

Setting up a slide show

As mentioned in “Modifying the slide show” on page 173, Impress allocates reasonable default
settings for slide shows, while at the same time allowing for customizing many aspects of the slide
show experience. This section covers only some aspects and more advanced techniques are
explained in the Impress Guide Chapter 9 Slide Shows.

Most of the tasks are best done in Slide Sorter view where you can see most of the slides
simultaneously. Go to View > Slide Sorter on the Menu bar or click the Slide Sorter tab at the top
of the Workspace.

One slide set — multiple presentations

In many situations, you may find that you have more slides than the time available to present them
or you may want to provide a rapid overview without dwelling on the details. Rather than having to
create a new presentation, you can use two tools that Impress offers: hiding slides and custom
slide shows.

Hiding slides
1) Select the slide you want to hide in the Slide Pane or Slide Sorter view on the Workspace
area.

2) Go to Slide Show > Hide Slide on the Menu bar or right-click on the slide thumbnail and
select Hide Slide from the context menu. Hidden slides are marked by a diagonal bars
across the slide.

Custom slide shows

If you want to create a custom slide show from the same presentation:
1) Select the slides you want to use in your custom slide show.
2) Go to Slide Show > Custom Slide Show on the Menu bar.

3) Click on the New button to create a new sequence of slides and save it with a different
name. You can have as many slide shows as you want from a single presentation.

Slide transitions

Slide transition is the animation that is played when a slide is changed for the next slide in your
presentation. You can configure the slide transition from the Slide Transition section in the Tasks
Pane.

1) Go to Slide Show > Slide Transition on the Menu bar or click on the Slide Transition icon
E on the Sidebar to open the options available for slide transitions.

2) Select the desired transition, the speed of the animation, and whether the transition should
happen when you click the mouse (preferred) or automatically after a certain number of
seconds.
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3) Click Apply to All Slides to apply the transition for all of your presentation or continue
selecting transitions to place between each slide in your presentation.

The Slide Transition section has a very useful choice: Automatic preview. Select its
Tip checkbox and when you make any changes in a slide transition, the new slide is
previewed in the Slide Design area, including its transition effect.

Slide advance
You can set the presentation to automatically advance to the next slide after a set amount of time
from the Slide Transition section in the Sidebar.
1) Go to Advance slide and select the Automatically after option.
2) Enter the required amount of time in seconds that each slide will be displayed.
3) Click on the Apply to All Slides button to apply the same display time to all slides.
To apply a different display time to each slide in your presentation:
1) Go to Slide Show > Rehearse Timings on the Menu bar and the slide show starts.

2) When you are ready to advance to the next slide, mouse click on the display background or
press the right arrow or spacebar on your keyboard.

3) Impress will memorize the timings for each slide and advance to next the slide
automatically using the timings when you run the slide show.

To automatically restart a slide show after the last slide has been displayed:
1) Go to Slide Show > Slide Show Settings on the Menu bar.
2) Select Auto and the timing of the pause between slide shows.
3) Click OK when you have finished.

Running a slide show

To run a slide show, do one of the following:
* Click Slide Show > Start from first Slide on the Menu bar.

* Click the Start from first Slide icon IgQ_I on the Presentation toolbar.
* Press F5 on the keyboard.

If the slide advance is set to Automatically after X sec, let the slide show run by itself.

If the slide advance is set to On mouse click, do one of the following to move from one slide to the
next:

* Use the arrow keys on the keyboard to go to the next slide or to go back to the previous
one.

¢ Click the mouse to move to the next slide.

* Press the spacebar on the keyboard to advance to the next slide.

Right-click anywhere on the screen to open a context menu where you can navigate through the
slides and set other options.

To exit the slide show at any time including when the slide show has ended, press the Esc key.
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Figure 163: Impress Presenter Console

Presenter Console

LibreOffice Impress has a Presenter Console function that can be used when an extra display for
presentation has been connected to your computer. The Presenter Console (Figure 163) provides
extra control over slide shows by using different views on your computer display and on the display
that the audience sees. The view you see on your computer display includes the current slide, the

upcoming slide, any slide notes, and a presentation timer.

For more information and details about using the Presenter Console, see the Impress Guide

Chapter 9 Slide Shows.

Next Slide

The Documentation Team

~ Small group of active contributors.
= Jean Hollis Weber (team leader)
~ Peter Schofield (Draw & Impress Guides)
+ Hazel Russman (copy editor)
~ Dan Lewis (Base Guide)
~ Larger group of occasional contributors & advisors, including
Martin Fox (Calc) and Andrew Pitonyak (macros)
~ Input from translators and others
= Initial group (early 2011) mostly gone or inactive
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What is Draw?

LibreOffice Draw is a vector graphics drawing program, although it can also perform some
operations on raster graphics (pixels). Using Draw, you can quickly create a wide variety of
graphical images.

Vector graphics store and display an image as simple geometric elements such as lines, circles,
and polygons rather than a collections of pixels (points on the screen). Vector graphics allow for
easier storage and scaling of the image.

Draw is fully integrated into the LibreOffice suite, and this simplifies exchanging graphics with all
components of the suite. For example, if you create an image in Draw, reusing it in a Writer
document is as simple as copying and pasting the image. You can also work with drawings directly
from within Writer or Impress, using a subset of the functions and tools from Draw.

The functionality of LibreOffice Draw is extensive and, even though it was not designed to rival
high-end graphics applications, it possesses more functionality than the drawing tools that are
generally integrated with most office productivity suites.

A few examples of the drawing functions are: layer management, magnetic grid-point system,
dimensions and measurement display, connectors for making organization charts, 3D functions
that enable small three-dimensional drawings to be created (with texture and lighting effects),
drawing and page-style integration, and Bézier curves.

This chapter introduces some features of Draw and does not attempt to cover all of the Draw
features. See the Draw Guide and the application help for more information.

Draw main window

The main components of the Draw main window are shown in Figure 164 and are as follows:
* Main menu bar
* Standard toolbar
* Line and Filling toolbar
* Page pane
* Workspace
* Status bar
* Drawing toolbar
* Sidebar

Workspace

The large area in the center of the window (Workspace) is where you create your drawings and
this drawing area can be surrounded with toolbars and information areas. The number and position
of the visible tools vary with the task in hand and user preferences, therefore your setup may look
different from Figure 164.

In LibreOffice Draw, the maximum size of a drawing is 300 cm by 300 cm.
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Figure 164: LibreOffice Draw workspace

Page pane

Sidebar

You can split drawings in Draw over several pages. Multi-page drawings are used mainly for
presentations. The Pages pane gives an overview of the pages that you create in your drawing. If
the Pages pane is not visible, go to View on the main menu bar and select Page Pane from the
context menu. To make changes to the page order, just drag and drop one or more pages.

Sidebar

The Sidebar has four main sections. To expand a section you want to use, click on its icon or click
on the small triangle at the top of the icons and select a section from the drop down list. Only one
section at a time can be open. If the Sidebar is not visible, go to View on the main menu bar and

select Sidebar from the context menu.

L]
Properties 15}

Opens sub-sections for object properties that you can change to suit your requirements. The
sub-sections are Insert Shapes, Character, Paragraph, Area, Line and Position and Size.
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Styles and Formatting i
Here you can edit and apply image styles to objects within your drawing. When you edit a style,
the changes are automatically applied to all of the elements formatted with this image style in
your drawing.

Gallery '@

Opens the Drawing gallery where you can insert an object into your drawing either as a copy or
as a link. A copy of an object is independent of the original object. Changes to the original
object have no effect on the copy. A link remains dependent on the original object. Changes to
the original object are also reflected in the link.

Navigator @

Opens the Drawing navigator, in which you can quickly move between pages in your drawing
or select an object on the drawing. It is recommended to give pages and objects in your
drawing meaningful names so that you can easily identify them when using the Navigator.

Rulers

You should see rulers (bars with numbers) on the upper and left-hand sides of the workspace. If
they are not visible, you can enable them by selecting View > Ruler in the main menu bar. The
rulers show the size of a selected object on the page using double lines (highlighted in Figure 165).
When no object is selected, they show the location of the mouse pointer, which helps to position
drawing objects more accurately.

You can also use the rulers to manage object handles and guide lines, making it easier to position
objects.

The page margins in the drawing area are also represented on the rulers. You can change the
margins directly on the rulers by dragging them with the mouse. The margin area is indicated by
the grayed out area on the rulers as shown in Figure 165.

To change the measurement units of the rulers, which can be defined independently, right-click on
a ruler and select the measurement units from the drop down list, as illustrated for the horizontal

ruler in Figure 166.
‘rmlaliwnﬂw@

| oy |

Figure 165: Rulers showing size of a selected object
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Status bar

The Status bar is located at the bottom of the screen in all LibreOffice components; it includes
several Draw-specific fields. For details on the contents and use of these fields, see Chapter 1
Introducing LibreOffice in this guide and in the Draw Guide Chapter 1 Introducing Draw.

Information area Object size  Digital signature Zoom slider
| Shape selected T3 076/064  :EIs572x4.19 * Slide 1/1 (Lavout) Default - ——0— + 100%
Position Unsaved changes Slide number Zoom percentage

Figure 167: Draw status bar

The sizes are given in the current measurement unit and are not to be confused with
the ruler units. The measurement unit on the Status bar is defined in Tools >
Options > LibreOffice Draw > General, where you can also change the scale of
the page.

Note

Toolbars

To display or hide the various Draw toolbars, go to View > Toolbars on the main menu bar. On the
menu that appears, select which toolbars you want to display. For more about working with
toolbars, see Chapter 1 Introducing LibreOffice in this guide.

The tools available in the Draw toolbars are explained in the following sections. The appearance of
the toolbar icons may vary depending on your operating system and the selection of icon size and
style in Tools > Options > LibreOffice > View.

Standard toolbar

The Standard toolbar is the same for all LibreOffice components and is not described in detail in
this chapter.

Standard >
& - 2 7 B & Y 2@ @ % - @

Figure 168: Standard toolbar

Chapter 7 Getting Started with Draw | 195



Drawing toolbar

The Drawing toolbar is the most important toolbar in Draw. It contains all the necessary functions
for drawing various geometric and freehand shapes and for organizing them on the page.

Drawing T
G /- E@T 2 -% -2 -®-@ -« " F P - k- Xs,@aRE W

Figure 169: Drawing toolbar

Line and Filling toolbar

The Line and Filling toolbar lets you modify the main properties of a drawing object. The icons
and pull-down lists vary, according to the type of object selected. For example, to change the style
of a line, click on the up and down arrows for Line Style and select the required style.

A < - || €2 fo.oocm |3 2] & (colour |2 [HEQ i = & -fd - T -
Figure 170: Line and Filling toolbar

Text Formatting toolbar

If the selected object is text, the Line and Filling toolbar changes to the Text Formatting toolbar,
which is similar to the Formatting toolbar in Writer. For more information, see Chapter 4 Getting
Started with Writer in this guide.

Text Formatting . TX
|LiberationSsans |~/ (18 |+| B / U M E == o= - E = K08 A A -

Figure 171: Text Formatting toolbar

Options toolbar

Use the Options toolbar to activate or deactivate various drawing aids. The Options toolbar is not
one of the toolbars displayed by default. To display the Options toolbar, select View > Toolbars >
Options.

options v X
® 8 @e@er DEE L

Figure 172: Options toolbar
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Figure 173: Colors dialog
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Choosing and defining colors

To display the Colors dialog (Figure 173), select View > Toolbars > Color Bar to display the
current color palette. This dialog lets you rapidly choose the color of the various objects (lines,
areas, and 3D effects). The first box in the panel corresponds to none (no color).

You can access several specialized color palettes in Draw, as well as change individual colors to
your own taste. This is done using the Area dialog by selecting Format > Area on the main menu

bar or clicking the Area icon & on the Line and Filling toolbar, then selecting the Colors tab
(Figure 174).
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Figure 174: Area dialog — Colors page

To load another palette, click on the Load Color List icon [E The file selector dialog asks you to
choose one of the standard LibreOffice palettes (files with the file extension *.soc). For example,
web . soc is a color palette that is adapted to creating drawings for placing in web pages. These
colors will display correctly on workstations with screens capable of at least 256 colors.

The color selection box also lets you individually change any color by modifying the numerical
values in the fields provided to the right of the color palette. You can use the color schemes known
as CMYK (Cyan, Magenta, Yellow, Black) or RGB (Red, Green, Blue).

Click on the Edit button to open the Color dialog, where you can set individual colors. See “Color
options” in Chapter 2 Setting Up LibreOffice in this guide.

For a more detailed description of color palettes and their options, see the Draw Guide Chapter 10
Advanced Draw Techniques.
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Drawing basic shapes

Draw provides a wide range of shapes, located in palettes accessed from the Drawing toolbar
(Figure 169) and a full list of these various tools is shown in Figure 175. The icons or buttons that
are already installed on the Drawing toolbar are highlighted in Figure 175.

Block Arrows

! i
B Bg Extrusion On/OFf

@ Select B callouts

B Line G| stars

@ Line Ends with Arrow £< Points

& Rectangle @] Glue Points
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(T) Text &7 To Polygon

=] Vertical Text & To3D

B curve ) To 3-D Rotation Object
i connector @ Fontwork Gallery
[ Linesand Arrows & FromFile

@ 3-DObjects B callery

@ Basic Shapes & Insert

@ symbolshapes 28 Controls

[¢o)

Figure 175: Tools available for Drawing toolbar

This section describes only a few of the basic shapes, including text, which are treated as objects
in Draw. See the Draw Guide for a complete description of the shapes available.

Please note that some of the icons on the Drawing toolbar will change according to the shape that
has been selected from the choice available. Icons with tool palettes available are indicated by a
small triangle to the right of the icon.

When you draw a basic shape or select one for editing, the Info field at the left side
Note in the status bar changes to reflect the present action: for example Line created,
Text frame xxyy selected, and so on.

Drawing a straight line

Click on the Line icon _,/ and place the cursor at the point where you want to start the line (Figure
176). Drag the mouse while keeping the mouse button pressed. Release the mouse button at the
point where you want to end the line. A selection handle appears at each end of the line, showing
that this object is the currently selected object. The selection handle at the starting point of the line
is slightly larger than the other selection handle.

Keep the Shift key pressed while you draw a line to restrict the drawing angle of the line to a
multiple of 45 degrees (0, 45, 90, 135, and so on).

This is the default behavior of the Shift key. However, if the option When creating or
moving objects in the Snap position section of Tools > Options > LibreOffice Draw
> Grid has been selected, the action of the Shift key is the opposite. Lines will
automatically be drawn at a multiple of 45 degrees unless the Shift key is pressed.

Note
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Keep the Ctrl key pressed while drawing a line to enable the end of the line to snap to the nearest
grid point.

Starting point

g

Figure 176: Drawing a straight line

This is the default behavior of the Ctrl key. However, if the Snap to Grid option on
Note the View > Grid menu has been selected, the Ctrl key deactivates the snap to grid
activity.

Hold down the Alt key while drawing a line to cause the line to extend outwards symmetrically in
both directions from the start point. This lets you draw lines by starting from the middle of the line.

When a line is drawn, it uses default attributes. To change any of these attributes, select a line by
clicking on it, then right-click and select Line from the context menu or got to Format > Line on the

L)
main menu bar to open the Line dialog (Figure 177). Alternatively, click on the Properties icon 75}
on the Sidebar and open the Line sub-section. Line style, line width, and line color can also be
changed using the controls in the Line and Filling toolbar at the top of the workspace.
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Llne Shadow|Line Styles| Arrow Styles
Line properties Arrow styles
Style Style
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Width Centre Centre
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[{)%7 = Corner style Cap style
[Rnunded = ] [Flat B ]

VAN

L OK | cancel || Help || Reset

Figure 177: Line dialog
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Drawing an arrow

Arrows are drawn like lines. In fact Draw classifies arrows as a subgroup of lines: lines with
arrowheads. The information field on the status bar shows them only as lines. Click on the Line

Ends with Arrow icon =+ on the Drawing toolbar or the Insert Shapes sub-section in Sidebar
Properties to draw an arrow. The arrow head is drawn at the end point of the arrow when you
release the mouse button.

Choosing line endings

Several types of line endings (arrows, circles, squares, and others) are available in Draw. Click on

the small triangle to the right of the Lines and Arrows =¥ icon on the Drawing toolbar or the
Insert Shapes sub-section in Sidebar Properties to open a tool palette containing tools for drawing
lines and arrows. Alternatively, go to View > Toolbars > Arrows to open the Arrows toolbar as a
floating toolbar (Figure 178). The icon for the tool used most recently will be shown on the Drawing
toolbar or the Insert Shapes sub-section in Sidebar Properties to make it easier to use the same
tool again.

1—
After drawing the line, you can change the arrow style by clicking on the Arrowheads icon —# in
the Line and Filling toolbar and select the arrow start and end options.
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|#= Line with Arrow/Square
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| Linewith Arrows

Figure 178: Arrows toolbar and available tools

Drawing rectangles or squares

Drawing a rectangle is similar to drawing a straight line. Click on the Rectangle icon & in the
Drawing toolbar or the Insert Shapes sub-section in Sidebar Properties. As you draw the rectangle
with the mouse cursor, the rectangle appears with the bottom right corner of the rectangle attached
to the cursor.

Squares are rectangles with all sides of equal length. To draw a square, click on the Rectangle
icon [l and hold down the Shift key whilst you draw a square.

If the option When creating or moving objects has been selected in Tools >
Options > LibreOffice Draw > General, the action of the Shift key is reversed.

Note When the Rectangle tool is selected, a square is drawn. To draw a rectangle, you
have to press the Shift key when drawing. This Shift key reversal also applies when
drawing ellipses and circles.
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To draw a rectangle or square from its center rather than the bottom right corner, position your
cursor on the drawing, press the mouse button and then hold down the Alt key while dragging with
the cursor. The rectangle or square uses the start point (where you first clicked the mouse button)
as the center.

Drawing circles or ellipses

To draw an ellipse (also called an oval), click on the Ellipse icon @ on the Drawing toolbar or the
Insert Shapes sub-section in Sidebar Properties. A circle is an ellipse with both axes the same
length. To draw a circle, click on the Ellipse icon and hold down the Shift key whilst you draw a
circle.

To draw an ellipse or circle from its center, position your cursor on the drawing, press the mouse
button and then hold down the Alt key while dragging with the cursor. The ellipse or circle uses the
start point (where you first clicked the mouse button) as the center.

If you first press and hold down the Ctrl key and then click on one of the icons for
Line, Rectangle, Ellipse, or Text, a standard sized object is drawn automatically in
the work area; the size, shape, and color are all standard values. These attributes
can be changed later, if desired. See the Draw Guide for more information.

Note

Drawing curves or polygons

To draw a curve or polygon click the Curve icon "g on the Drawing toolbar or the Insert Shapes
sub-section in Sidebar Properties. Click on the triangle to the right of the icon to open the tool
palette containing tools that are available for drawing curves and polygons (Figure 179). The icon
for the tool used most recently will be shown on the Drawing toolbar to make it easier to use the
same tool again.

If you move the mouse cursor over one of the icons, a tooltip pops up with a description of the
function.

YTy

Curve, Filled
Polygon, Filled
Polygon (45°), Filled
Free-form Line, Filled

Curve
Polygon

Polygon (45°)
Free-form Line

PR RPKS

Figure 179: Curves (Lines) toolbar and available tools

Hovering the mouse pointer over this icon gives a tooltip of Curve. If you open the
floating toolbar, the title is Lines, as shown in Figure 179.

Holding down the Shift key when drawing lines with the Curve or Polygon tools will
restrict the angles between the lines to 45 or 90 degrees.

Note
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Curves

Click and hold the left mouse button to create the starting point of your curve, then, while holding
down the left mouse button, drag from the starting point to draw a line. Release the left mouse
button and continue to drag the cursor to bend the line into a curve. Click to set the end point of the
curve and fix the line on the page. To continue with your line, drag the mouse cursor to draw a
straight line. Each mouse click sets a corner point and allows you to continue drawing another
straight line from the corner point. A double click ends the drawing of your line.

Afilled curve automatically joins the last point to the first point to close off the figure and fills it with
the current standard fill color. A curve without filling will not be closed at the end of the drawing.

Polygons

Click and draw the first line from the start point with the left mouse button held down. As soon as
you release the mouse button, a line between the first and second points is drawn. Move the
cursor to draw the next line. Each mouse click sets a corner point and allows you to draw another
line. A double-click ends the drawing.

Afilled polygon automatically joins the last point to the first point to close off the figure and fills it
with the current standard fill color. A polygon without filling will not be closed at the end of the
drawing.

Polygons 45°

Like ordinary polygons, these are formed from lines, but the angles between lines are restricted to
45 or 90 degrees.

Freeform lines

Using the freeform line tools is similar to drawing with a pencil on paper. Press and hold the left
mouse button and drag the cursor to the line shape you require. It is not necessary to end the
drawing with a double-click, just release the mouse button and the drawing is completed.

If Freeform Line Filled is selected, the end point is joined automatically to the start point and the
object is filled with the appropriate color.

Adding text

To activate the text tool, click on the Text icon T for horizontal text or the Vertical Text icon - for
vertical script. If the Vertical Text icon is not visible, check that the option Enabled for Asian
languages has been selected in Tools > Options > Language Settings > Languages. The Text
Formatting toolbar appears (Figure 171 on page 196) when the Text icon is selected; from this
toolbar you can select font type, font size, and other text properties before you start typing your
text.

Note The Vertical Text icon ™ is only available on the Drawing toolbar.

After activating the Text command, click at the location where you want to position the text. A small
text frame appears, containing only the cursor. This frame can be moved like any other object. A
text frame is also dynamic and grows as you enter text.

Observe the information field in the status bar: it shows that you are editing text and also provides
details about the current cursor location using paragraph, row, and column numbers (Figure 180).
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Figure 180: Text information on the Status Bar

You can insert a line break with the Shift+Enter key combination or start a new paragraph with the
Enter key. The insertion of line breaks or new paragraphs does not terminate text editing or
deselect the text frame. When you have finished typing text, click outside the text frame to cancel
adding or editing text.

If you want to edit text, double-click on the text to open the Text Formatting toolbar and highlight
the text to start editing.

Text properties can also be changed during text input, with any changes taking effect from the
cursor position onwards. To change the properties for all of the text in the text frame, you have to
highlight all text in the text frame.

You can create Image styles that you can reuse for other text frames. Select Format > Styles and
Formatting or press F11 to open the Styles and Formatting dialog, or click on the Styles and

L
Formatting icon === on the Sidebar. Image styles affect all of the text within a text frame. To only
format parts of the text, use direct formatting with the Text Formatting toolbar or the Character and
Paragraph sub-sections in Sidebar Properties.

Text frames can also have fill colors, shadows, and other attributes, just like any other Draw object.
You can rotate the frame and write the text at any angle. These options are available by right-
clicking on the text frame itself.

If you double-click on a graphic object, or press F2 or click on the Text icon when an object is
selected, you can add text to the graphic object. This text then becomes part of the graphic object.

A graphic object is not dynamic and does not behave like a text frame. To keep text within the
borders of the object, you have to use paragraphs, line breaks, or smaller text size, increase the
object size, or combine all four methods.

For more information about text, see the Draw Guide Chapter 2 Drawing Basic Shapes and
Chapter 9 Adding and Formatting Text.

Glue points and connectors

Glue points

All Draw objects have glue points, which are not normally displayed. Glue points become visible

when the Connectors icon “ls is selected on the Drawing toolbar or the Insert Shapes
sub-section in Sidebar Properties. Most objects have four glue points (Figure 181). You can add
more glue points and customize glue points, using the Glue Points toolbar (Figure 182). Go to
View > Toolbars > Glue Points on to open the toolbar.
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Glue points are not the same as the selection handles of an object. The handles are for moving or
changing the shape of an object. Glue points are used to fix or glue a connector to an object so
that when the object moves, the connector stays fixed to the object. For a more detailed
description on the use of glue points, see the Draw Guide Chapter 3 Working with Objects and
Object Points and Chapter 8 Connections, Flowcharts and Organization Charts.

Figure 181: Glue points
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Figure 182: Glue Points toolbar and available tools

Connectors

Connectors are lines or arrows whose ends automatically snap to a glue point of an object.
Connectors are especially useful in drawing organization charts, flow diagrams, and mind-maps.
When objects are moved or reordered, the connectors remain attached to a glue point. Figure 183
shows an example of two objects and a connector.

Draw offers a range of different connectors and connector functions. On the Drawing toolbar or the
Insert Shapes sub-section in Sidebar Properties, click on the triangle next to the Connector icon

™ to open the Connectors toolbar (Figure 184). For a more detailed description of the use of
connectors, see the Draw Guide Chapter 8 Connections, Flowcharts and Organization Charts.
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Figure 184: Connectors toolbar and available tools

Drawing geometric shapes

The icons for drawing geometric shapes are located on the Drawing toolbar and each geometric
shape is explained in the following sections. Clicking on the triangle to the right of the icon on the
Drawing toolbar or the Insert Shapes sub-section in Sidebar Properties opens a floating toolbar

giving access to the tools for that geometric shape.

Tip

The use of these tools for geometric shapes is similar to the tool used for drawing
rectangles and squares. For more information, see “Drawing basic shapes” on page
198 and the Draw Guide Chapter 2 Drawing Basic Shapes.

The icons for geometric shapes displayed on the Drawing toolbar will change shape
according to the last tool selected and used to draw an object.
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Basic shapes

Click on the triangle to the right of the Basic Shapes icon @ to open the Basic Shapes toolbar
for drawing basic shapes. This toolbar also includes a rectangle tool identical to the one already
displayed on the Drawing toolbar, or the Insert Shapes sub-section in Sidebar Properties.

BasicShapes 000 ¥
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Figure 185: Basic Shapes toolbar

Symbol shapes

Click on the triangle to the right of the Symbol Shapes icon @ to open the Symbol Shapes
toolbar for drawing symbols.

Symbol shapes v X
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Figure 186: Symbol Shapes toolbar

Block arrows

Click on the triangle to the right of the Block Arrows icon %+ to open the Block Arrows toolbar
for drawing block arrows.

Block Arrows ¥ X
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> DB RPAEIDRSEBOANTS

Figure 187: Block Arrows toolbar

Flowcharts

Click on the triangle to the right of the Flowcharts icon ﬁ to open the Flowchart toolbar for
symbols used in drawing flowcharts. The creation of flowcharts, organization charts, and similar
planning tools are further described in the Draw Guide Chapter 8 Connections, Flowcharts and
Organization Charts.

Flowchart ~ ¥Xx
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Figure 188: Flowcharts toolbar
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Callouts

Click on the triangle to the right of the Callouts icon Q to open the Callouts toolbar for drawing
callouts.

Callouts v X
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Figure 189: Callouts toolbar

Stars and banners

Click on the triangle to the right of the Stars icon 'ﬁ' to open the Stars and Banners toolbar for
drawing stars and banners.

Stars and Banners -

wy R ERFREEQG@

Figure 190: Stars and Banners toolbar

You can add text to all these geometric shapes. For more information, see the Draw
Note Guide Chapter 2 Drawing Basic Shapes and Chapter 10 Advanced Draw
Techniques.

Selecting objects

Direct selection

The easiest way to select an object is to click directly on it. For objects that are not filled, click on
the object outline to select it. One click selects; a second click deselects. To select or deselect
more than one object, hold the shift button down while clicking.

Selection by framing

You can also select several objects at once by dragging the mouse cursor around the objects. This
cursor dragging draws a rectangle around the objects and only objects that lie entirely within the
rectangle will be selected.

To select multiple objects by framing, the Select icon on the Drawing toolbar must be active.

When dragging the mouse cursor to select multiple objects, the selection rectangle

Note being drawn is also known as a marquee.

Selecting hidden objects

Even if objects are located behind others and not visible, they can still be selected. Hold down the
Alt key and click on the object at the front of where the hidden object is located, then click again to
select the hidden object. If there are several hidden objects, keep holding down the Alt key and
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clicking until you reach the object you want. To cycle through the objects in reverse order, hold
down the Alt+Shift keys and click.

When you click on the selected object, its outline will appear briefly through the objects covering it.

Using the Alt key method works on computers using a Windows or Mac operating
Note systems. On a computer using a Linux operating system the Tab key method,
described below, has to be used.

To select an object that is covered by another object using the keyboard, use the Tab key to cycle
through the objects, stopping at the object you want to select. To cycle through the objects in
reverse order, press Shift+Tab. This is a very quick way to reach an object, but it may not be
practical if there a large number of objects in a drawing.

Arranging objects

In a complex drawing, several objects may be stacked on top of one another. To rearrange the
stacking order by moving an object forward or backward, select an object, click Modify > Arrange
on the main menu bar and select Bring Forward or Send Backward. Alternatively, right-click the
object, select Arrange from the context menu, then Bring Forward or Send Backward.

The arrange options are also available by clicking on the small triangle to the right of the Arrange

icon on the Line and Filling toolbar. This opens the Position toolbar giving access to the
various arrangement options (Figure 191).

Position v X
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Bring to Front
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Figure 191: Position toolbar and available tools

Moving and adjusting object size

When moving an object or changing its size, check the left-hand area of the status bar at the
bottom of the Draw window (Figure 192). The area on the left of the Status bar, from left to right,
shows what object is selected, its position on the drawing in X/Y coordinates and dimensions of the
object. The units of measurement are those selected in Tools > Options > LibreOffice Draw >
General.

For more information on moving and adjusting object size, see the Draw Guide Chapter 3 Working
with Objects and Object Points.
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Figure 192: Left end of status bar when moving or adjusting an object

Moving objects

To move an object (or a group of objects), select it and then click within the object borders and hold
down the left mouse button while dragging the mouse. During movement, the ghost image of the
object appears to help with repositioning (Figure 193). To locate the object at its new location,
release the mouse button.

Figure 193: Moving an object

Adjusting object size

To change the size of a selected object (or a group of selected objects), move the mouse cursor to
one of the selection handles. The mouse cursor will change shape to indicate the direction of
movement for that selection handle. As you change the size of the object, a ghosted outline of the
object appears (Figure 194). When you have reached the desired size of the object, release the
mouse button.

The results depend on which selection handle you use. To resize an object along one axis, use a
side handle. To resize along both axes, use a corner handle.

Figure 194: Adjusting object size

If you press the Shift key while resizing an object, the change in size will be carried
out symmetrically with respect to the two axes so that the aspect ratio of the object
remains the same. This Shift key behavior works on all selection handles.

This is the default behavior of the Shift key. However, if When creating or moving
objects has been selected in Tools > Options > LibreOffice Draw > Grid, the
action of the Shift key is reversed: that is the aspect ratio will be preserved unless
the Shift key is pressed.
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Rotating and slanting an object

For more information on rotating and slanting an object, see the Draw Guide Chapter 3 Working
with Objects and Object Points.

Rotating an object

To rotate an object (or a group of objects), select the object, then go to rotation mode using one of
the following methods:

* Click on the Rotate icon @' on the Line and Filling toolbar.

* Go to View > Toolbars > Mode and select the Rotate icon @a

The selection handles will change shape and color (Figure 195). Also a center of rotation point will
appear in the center of the object. As you move the mouse cursor over the handles the cursor
changes shape. The corner handles are for rotating an object and the top, bottom and side handles
are to slant an object.
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Figure 195: Rotating an object

Move the mouse cursor to one of the corner handles and it normally changes to an arc with an
arrow at each end. Click and hold the mouse button, then start to move the cursor to rotate the
object. A ghost image of the object being rotated appears and the current angle of rotation is
shown in the status bar.

Rotation works differently for 3D objects because rotation occurs in global axes and
Note not in a single axis. See the Draw Guide Chapter 7 Working with 3D Objects for more
information.

The rotation point is normally located at the center of an object. To change the position of the
rotation point, click on the object with the mouse cursor and drag the object until the rotation point
is at the desired position. This rotation point can even be outside of the object.

If you press the Shift key while rotating an object, rotation will be restricted to 15° of
movement.

This is the default behavior of the Shift key. However, if When creating or moving
objects has been selected in Tools > Options > LibreOffice Draw > Grid, the
action of the Shift key is reversed: that is rotation will be restricted to 15° of
movement unless the Shift key is pressed.

Note
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Slanting an object

To slant an object, use the handles located at the midpoints on the top, bottom and sides of a
selected object. The mouse cursor changes when it hovers over one of these midpoint handles.
The axis used for slanting an object is the object edge directly opposite the midpoint handle being
used to slant the object. This axis stays fixed in location while the other sides of the object move in
relation to it as you drag the mouse cursor.

Click and hold the mouse button, then start to move the cursor to shear the object. A ghost image
of the object being slanted appears (Figure 196) and the current angle of slanting is shown in the
status bar.

If you press the Shift key while slanting an object, slanting will be restricted to 15° of
movement. This is the default behavior of the Shift key. However, if When creating

Note or moving objects has been selected in Tools > Options > LibreOffice Draw >
Grid, the action of the Shift key is reversed: that is slanting will be restricted to 15°
of movement unless the Shift key is pressed.

Figure 196: Slanting an object

Editing objects

To edit an object or change its attributes, such as color or border width, and so on, the Line and
Filling toolbar, the Text Formatting toolbar, the Sidebar Properties section, or a context menu can
be used. More information on editing objects and changing attributes can be found in the Draw
Guide Chapter 4 Changing Object Attributes.
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Figure 197: Line and Filling toolbar and its available tools
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Line and Filling toolbar

By default, the Line and Filling toolbar in Draw is placed at the top of the workspace. However, if
the Line and Filling toolbar is not displayed, go to View > Toolbars > Line and Filling on the main
menu bar to open the toolbar (Figure 197). The most common object attributes can be edited using

this toolbar. You can also open the Line dialog by clicking on the Line icon ﬂ and the Area dialog

by clicking on the Area icon & for access to more formatting options.

Text Formatting toolbar

When you select text, the Line and Filling toolbar automatically changes to show the Text
Formatting toolbar (Figure 198). You can also open the Text Formatting toolbar by selecting View
> Toolbars > Text Formatting on the main menu bar. The tools on this toolbar will not become
active until text has been selected.
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Figure 198: Text Formatting toolbar and its available tools

Properties x =
El Insert Shapes
/S 2 E@TE - %"/~
Q- -®-F P&
o

H Character | U
® Paragraph =
H Area =
H Line =

|

Position and Size

Figure 199: Sub-sections in Sidebar Properties
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Sidebar Properties

When you select an object in your drawing, the sub-sections in Sidebar Properties become active
(Figure 199). This allows you to change the properties or options of an object without having to
open a dialog or use any of the available tools on the various toolbars provided by Draw. To
expand a sub-section, click on the plus (+) sign next to the sub-section title.

Context menu

When an object is selected and you right-click on the object, a context menu (Figure 200) opens
that applies to the selected object. This context menu provides access to the options available and
allows you to change object attributes without having to open a dialog. Menu entries with a small
arrow on the right-hand side contain a submenu.
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Figure 200: Example of a context menu

Formatting lines and borders

In LibreOffice the term line indicates both a freestanding segment (line), outer edge of a shape
(border), or an arrow. In most cases the properties of the line you can modify are its style (solid,
dashed, invisible, and so on), its width and its color.

Select the line you need to format and then use the controls on the Line and Filling toolbar to
change the most common options (highlighted in Figure 201).

Line and Fillin —
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Figure 201: Common line properties (style, color, width)
If you need to fine tune the appearance of a line, choose Format > Line from the main menu bar,

or right-click on the line and select Line from the context menu, or select the Line icon Eﬁ from the
Line and Filling toolbar. All of these methods open the Line dialog (Figure 178 on page 200),
where you can set line properties. This dialog consists of three pages: Line, Line Styles, and Arrow
Styles. Alternatively, use the Line sub-section in Sidebar Properties to change the appearance of a
line.
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Arrows, arrowheads and line endings

Arrows, arrowheads and other line endings are usually referred to as arrows and can be treated
the same as lines when editing and changing attributes. Select a line and click on the Arrow Style

1__
icon —# from the Line and Filling toolbar to open the Arrowheads menu (Figure 202).
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Figure 202: Arrowheads menu

Several types of arrowheads are available. Each end of a line can have a different arrowhead or no
arrowhead). Arrowheads are only applicable to lines and they have no effect on the border of an
object.

Formatting area fill

The term area fill refers to the inside of an object, which can be a uniform color, gradient, hatching
pattern, or bitmap (Figure 203). An area fill can be made partly or wholly transparent. In most
cases, you will choose one of the standard fill options, which are all available from the Line and
Filling toolbar, or the Area sub-section in Sidebar Properties.. You can also define your own area
fills. For more information on formatting area fill, see the Draw Guide Chapter 4 Changing Object
Attributes.
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Figure 203: Different types of area fill
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Using styles

Suppose that you want to apply the same area fill, line thickness, and border to a set of objects.
This repetitive process can be greatly simplified by the use of styles. Styles allow you to define a
formatting template (a style) and then to apply that style to multiple objects. For more information
on styles, see Chapter 3 Using Styles and Templates in this guide, the Writer Guide Chapter 6
Introduction to Styles and the Draw Guide Chapter 4 Changing Object Attributes.

Positioning objects

Snap function

In Draw, objects can be accurately and consistently positioned using the snap function. Grid points,
shap points and lines, object frames, individual points on objects, or page edges can all be used
with the snap function.

Snap function is easier to work with at the high zoom values that are practical for your display. Two
different snap functions can be used at the same time; for example snapping to a guide line and to
the page edge. It is recommended, however, to activate only the functions that you really need.

For more detailed information about the snap function, see the Draw Guide Chapter 3 Working
with Objects and Object Points and Chapter 10 Advanced Draw Techniques.

Snap to grid
Snap to grid allows you to position an object to a grid point (Figure 204). Go to View > Grid >

Snap to Grid on the main menu bar or click on the Snap to Grid icon on the Options toolbar
to turn on or off the snap to grid function. If the Options toolbar is not displayed, go to View >
Toolbars > Options on the main menu bar.

Figure 204: Positioning with snap to grid

Displaying the grid
To display the grid in Draw or to switch off the grid, go to View > Grid > Display Grid on the main

menu bar or click on the Display Grid “= jcon on the Options toolbar.
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Configuring the grid

The resolution, snap and snap position of the grid points can be configured. Go to Tools >
Options > LibreOffice Draw > Grid on the main menu bar to open the options dialog for the grid
(Figure 205).

& oOptions - LibreOFffice Draw - Grid

» LibreOfFfice Grid
» Load/Save )
» Language Settings [ snap to grid
¥ LibreOFffice Draw . .
General [ visible grid
View
Grid Resolution Subdivision
Print : L — : e
» LibreOFffice Base Haorizontal: |D.50 - Horizontal: |10 - | space(s)
> chaibs Vertical: o.50" |: Vertical: [10 > | space(s)

* Internet

[C] synchronize axes

Snap Snap position
[ Tosnap lines ["] When creating or moving objects
[ To the page margins & Extend edges

L] To object frame [] when rotating 15.00° | -

["] To object points

) Point reduction |.15.00° =
Snap range |5pixels =

NS | oncel || melp [ gewen

Figure 205: Configuring the grid

Vertical and horizontal spacing of the dots in the grid. You can also change the unit of
measurement used in the general Draw options by going to Tools > Options > LibreOffice
Draw > General.

The resolution is the size of the squares or rectangles in the grid. If the resolution is 1 cm
horizontal and 2 cm vertical, the grid consists of rectangles 2 cm high and 1 cm wide.

Subdivisions are additional points that appear along the sides of each rectangle or square
in the grid. Objects snap to subdivisions as well as to the corners of the grid.

The pixel size of the snap area defines how close you need to bring an object to a snap
point or line before it will snap to it.

The default color of the grid is light gray. To change the color of the grid points, go to Tools
> Options > LibreOffice > Appearance on the main menu bar.

Help lines

Draw has help lines to easily allow you to position an object using the rulers at the top and left side
of the workspace. To turn on or off the help lines, go to Tools > Options > LibreOffice Draw >
View on the main menu bar and select Snap Lines when moving option or go to the Options

toolbar and click on the Helplines While Moving icon .

Applying special effects

With Draw, you can apply many special effects to objects and groups of objects. This section is an
introduction to some of these effects. For more information on special effects, see the Draw Guide
Chapter 4 Changing Object Attributes.
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To access the tools used for special effects, go to View > Toolbars > Mode (Figure 206). Rotate
and Flip can also be accessed by going to Modify on the main menu bar or by right-clicking on the
object and using the context menu.

Mode v x
R oYY
Rotate

Elip

In 3D Rotation Object
Setin Circle (perspective)

Set ko circle (slank)
Distort

Transparency

ErPOLE €CERE

Gradient

Figure 206: Mode toolbar and its available tools

Flipping objects
The quickest and easiest method to flip an object horizontally or vertically is as follows:

1) Click on a graphic object and the selection handles will show.

2) Right-click and select Flip > Vertically or Horizontally, or got to Modify > Flip > Vertically
or Horizontally on the main menu bar and the selected object will be flipped to face the
other direction.

However, the Flip tool on the Mode or Drawing toolbar can be used to give you greater control
over the flipping process. Using the Flip tool allows you to change the position and angle that the
object flips over and this is described in the Draw Guide Chapter 4 Changing Object Attributes.

Mirror copies

At the moment no mirror command exists in Draw. However, mirroring an object can be emulated
by using the Flip tool, as described in the Draw Guide Chapter 4 Changing Object Attributes.

Distorting an object
Three tools on the Mode toolbar let you drag the corners and edges of an object to distort the

image.
o

¢ Distort tool distorts an object in perspective.

m]
* Set to Circle (slant) "”ﬂ] creates a pseudo three-dimensional effect.

m]
* Setin Circle (perspective) “F creates a pseudo three-dimensional effect.

In all three cases you are initially asked if you want to transform the object to a curve. This is a
necessary first step, so click Yes. Then you can move the object handles to produce the desired
effect. See the Draw Guide Chapter 4 Changing Object Attributes for more information on how to
distort an object.
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Dynamic transparency gradients

You can control transparency gradients in the same manner as color gradients. Both types of
gradient can be used together. With a transparency gradient, the direction and degree of object fill
color changes from opaque to transparent. In a regular gradient, the fill changes from one color to
another, but the degree of transparency remains the same.

The Transparency and Gradient tools on the Mode toolbar dynamically control transparency and
color gradients. See the Draw Guide Chapter 4 Changing Object Attributes for more information on
how to create transparencies and gradients in an object.

Duplication

Duplication makes copies of an object while applying a set of changes such as color or rotation to
the duplicates that are created.

& Duplicate
Number of copies i10 = &£ Pra—n C—
Placement Cancel
x-Axis 0.50cm = = |
e Help
y-Axis |0.50cm = )
T Default |
Angle |5 degrees = |
Enlargement
width {0.00cm =
Height [0.00cm =
Colours
Start [ | Light red -
End (I Light blue 8

Figure 207: Duplicate dialog

1) Click on an object or group of objects and go to Edit > Duplicate on the main menu bar or
use the keyboard shortcut Shift+F3 to open the Duplicate dialog (Figure 207).

2) Select the required options chosen from the options available. For example, when the
options in the dialog are applied to a rectangle, they produce the result shown in Figure
208.

Figure 208: Duplication result
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Cross-fading
Cross-fading transforms one object shape to another object shape and only works when two
objects are selected.
1) Select two differently shaped objects.
2) Go to Edit > Cross-fading on the main menu bar to open the Cross-fading dialog (Figure
209).
3) Select Increments to determine the number of shapes between the two objects.
4) Select Cross-fading attributes to apply a gradual change of line and fill properties
between the two objects.
5) Select Same orientation to apply a smooth transition between the two objects.
6) Click on OK and the result is a new group of objects with the first object selected as the
start object and the second object selected as the end object. For example, when the

options in the dialog are applied to a rectangle and a triangle, the cross fade produces the
result shown in Figure 210.

# o Cross-fading

Settings

Increments 16 =

[ Cross-fade attributes

& same orientation

RS | concel || e |

Figure 209: Cross-fading dialog

Figure 210: Cross-fading result

Combining multiple objects

Using Draw, you can group or combine objects together allowing you to treat multiple objects as
one unit, or to merge objects to form a new shape. For more information, see the Draw Guide
Chapter 5 Combining Multiple Objects.

Grouping of objects is similar to putting objects into a container. You can move the objects as a
group and apply global changes to the objects within the group. A group can always be undone
and the objects that make up the group can always be manipulated separately. The objects within
a group also retain their own individual properties.

Combining objects is a permanent merging of objects that creates a new object. The original
objects are no longer available as individual entities and cannot be edited as individual objects.
Any editing of a combined object affects all the objects that were used when combination was
carried out.
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Grouping
Temporary grouping

A temporary grouping is when several objects are selected using the Select icon on the
Drawing toolbar or using the mouse to drag a rectangle around the objects (also known as a
marquee). Any changes to object parameters you carry out are applied to all of the objects within
the temporary group. For example, you can rotate a temporary group of objects in its entirety.

To cancel a temporary grouping of objects simply click outside of the selection handles displayed
around the objects.

Permanent grouping

A permanent grouping of objects is created after you have selected your objects and then going to
Modify > Group on the main menu bar, or right clicking on the selection and select Group from
the context menu, or using the keyboard shortcut Ctr/+Shift+G. When you deselect your selection
the objects remain grouped together.

When objects are permanently grouped, any editing operations carried out on that group are
applied to all members of the group. If you click on one member of the group, the whole group is
selected.

You can edit an individual member of a group without ungrouping or breaking the group. Select the
group and go to Modify > Enter Group, or right click and select Enter Group from the context
menu, or use the keyboard shortcut F3, or double click on the group.

When you have finished editing an individual member of a group, go to Modify > Exit Group, or
right click and select Exit Group from the context menu, or use the keyboard shortcut Shift+F3.

Ungrouping
To ungroup or break apart a group of objects, select the group then go to Modify > Ungroup on

the main menu bar, or right click and select Ungroup from the context menu or use the keyboard
shortcut Ctrl+Alt+Shift+G.

Combining objects

Combining objects is a permanent merging of objects that creates a new object. The original
objects are no longer available as individual entities and cannot be edited as individual objects.
Any editing of a combined object affects all the objects that were used when combination was
carried out.

Select several objects, then go to Modify > Combine on the main menu bar, or right click on the
objects and select Combine from the context menu, or use the keyboard shortcut Ctr/+Shift+K.

After you have selected your objects, the Merge, Subtract, and Intersect functions also become
available so that you can create a hew object from your selected objects. See the Draw Guide
Chapter 5 Combining Multiple Objects for more information on these functions.
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Arranging, aligning and distributing objects

In Draw you can arrange, align and distribute selected objects in relation to each other:

* Arrange the position of an object by moving it either forward or backward in relation to the
order of objects.

¢ Align objects with respect to each other using Left, Centered, or Right for horizontal
alignment and Top, Center or Bottom for vertical alignment.

e Distribute objects so that the space between each of the objects is the same.

See the Draw Guide Chapter 5 Combining Multiple Objects for more information on arranging and
aligning objects in relation to each other.

Inserting and editing pictures

Draw contains a number of functions for editing pictures or raster graphics (bitmaps); for example,
photos and scanned images. This includes the import and export of graphics, and the conversion
of one graphic format to another graphic format.

Draw includes a large range of graphic filters so that it can read and display several graphic file
formats. It also includes several tools for working with raster graphics, but does not have the same
functionality as specialized graphic programs like Gimp or Adobe Photoshop. See the Draw Guide
Chapter 6 Editing Pictures for more information.

You can add pictures from several sources:
¢ Directly from a scanner (Insert > Picture > Scan)

* Images created by another program, including photographs from a digital camera (Insert >
Picture > From File)

* The Draw Gallery; see Chapter 11 Graphics, the Gallery, and Fontwork in this guide for
more information.

Working with 3D objects

Although Draw does not match the functionality of the leading drawing or picture editing programs,
it is capable of producing and editing very good 3D drawings.

Draw offers two types of 3D objects: 3D bodies and 3D shapes. Depending on which type you
choose, there are different methods of editing of a 3D object (rotation, illumination, perspective,
and so on) with 3D shapes being simpler to set up and edit than 3D bodies. However, 3D bodies
currently allow for more customization.

See the Draw Guide Chapter 7 Working with 3D Objects for more information.

Exporting graphics

Draw saves graphics and images in the open source format *.odg. To save a graphic or the entire
file in another format, use File > Export and select a format from the list displayed. The graphic
formats that Draw can export and save to are listed in Appendix B Open Source, Open Standards,
OpenDocument in this guide.

You can also export Draw files to HTML, XHTML, PDF, or Flash. PDF export for modules of
LibreOffice is described in Chapter 10 Printing, Exporting, and E-mailing of this guide.
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HTML export uses a conversion wizard that creates as many web pages as there are pages in
your Draw document. You can optionally choose to display pages in frames with a navigator and
set an index page. For more information, see Chapter 12 Creating Web Pages in this guide.

Inserting comments in a drawing

You can insert comments into your drawing and this a similar process used in Writer and Calc.

1) Go to Insert > Comment on the menu bar. A small box containing your initials appears in
the upper left-hand corner of your drawing with a larger text box beside it (Figure 211).
Draw automatically adds your name and the date at the bottom of this text box.

2) Type or paste your comment into the text box. You can apply basic formatting to parts of
the text by selecting it, right-clicking, and choosing from the context menu. From this menu,
you can also delete the current comment, all the comments from the same author, or all the
comments in the document.

3) You can move the small comment markers to anywhere you wish on the drawing. Typically
you might place it on or near an object you refer to in the comment.

4) To show or hide the comment markers, go to View > Comments on the main menu bar.

Hz 1 1 2 3 4 5 6 7 8 § 10 11
ﬂ w1 This is a comment.

—

o™

w0

M

Figure 211: Inserting comments

5) Go to Tools > Options > User Data to enter the name you want to appear in the Author
field of the comment.

6) If more than one person edits the document, each author is automatically allocated a
different background color.
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Introduction

Base is the database component of LibreOffice. A data source, or database, is a collection of
information organized so that it can easily be accessed, managed, and updated. For example, a
list of names and addresses is a data source that could be used for producing a mail merge letter.
A shop stock list could be a data source managed through LibreOffice.

If you have information that you would like to organize, Base will help you do this. You could use a
spreadsheet to organize information, but maintaining a spreadsheet with Calc can often be more
complex and time consuming than using a database with Base.

This chapter is for the person who has not used Base before or who wants to review the basics of
creating and using a database. Terminology is kept to a minimum. This chapter covers the wizards
needed to create the database parts and the principles that the wizards use. It also provides
references to more information in the Base Handbook or the Base Guide (being written).

The Base Handbook and the Base Guide are for people who understand some of the basics of
how Base works and want a more in-depth discussion.

To use Base, you need to use a Java Runtime Environment (JRE). Please go to
Tools > Options > LibreOffice > Advanced to choose a JRE from those installed
on your computer.

Note If no JRE is already installed, you will need to download and install one. For
Windows, you need to get Java from www.java.com. For Linux, you can download
it from the same website or you can use openjdk-7-jre, available from the
repository of your Linux version. Mac OS X users can install a JRE from Apple Inc.

One of the things that sometimes confuses people is terminology. Specifically, what is the
difference between a database and a data source? Base uses the terms interchangeably, as
synonyms. This is because a database is a collection of data that can come in different forms.
These include text files, spreadsheets, or a file created by a database program.

A collection of data does not serve a good purpose unless we can use the information it contains.
Therefore, a structure has to be built using data. In a spreadsheet, formulas and cell links are used
to obtain information from the data contained in it. Database programs can do the same thing.

With Base, you create a Database document file. This file contains the data and all of the
structures you create to obtain information from the data. Because everything is included in one
file, it is known as an embedded database.

Base can also be used to connect to other databases. In this case, Base creates a file to make the
connection. These are not embedded databases since they exist outside the Base file. They are
front end database documents. See the Base Handbook and Base Guide for more information.

Types of database

The two types of database are known as flat and relational. Base can create and work with both
types. This chapter discusses flat databases. Relational databases are covered in detail in the
Base Handbook and the Base Guide.

A flat database contains one or more tables, each containing one or more fields. Each table is
completely independent of all the other tables in the database. For example, you might have an
address database with several tables in it. One might contain your family’s contacts, another your
business contacts, and another your spouse’s family contacts. While some contacts are contained
in more than one table, different tables may not have the same information about the same person.
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A relational database contains one or more tables with one or more relationships defined between
those tables; each relationship is defined by a pair of fields. One field of each pair belongs to one
table and the second field belongs to the same or a different table. Where relationships exist
between fields in the same or different tables, a flat database could still be used, but it provides no
mechanism for defining the relationship. Instead the same data must be entered in both fields,
making data entry errors more likely. A well designed relational database requires the data to be
entered only once, reducing possible errors.

Flat database

Consider an address book. Usually, the data in an address book can be divided into groups based
upon the relationships between the data. For example, all the first names are put into one group.
Other groups can include last names, spouse names, addresses, phone numbers, birthdays, and
S0 on. You probably need to identify phone numbers based on their use (home, work, mobile). If
you were keeping this information in a spreadsheet, you would use one column for each one of
these groups. In a database, this column is called a field.

Other relationships that exist between data can be used to further define the structure of that data.
In an address book, one value in each of these groups describes a specific individual. In a
spreadsheet, the columns would be as above. We would rearrange the rows so that each contains
information about an individual.

This divides the data into a table. Each column contains data with the same properties. Each row
contains data that describes a specific entity or individual. Each row is called a record. The
structure of rows and columns is called a table.

The collection of data we mentioned was a flat database without any structure. Now with the table,
we have a flat database we can use to obtain information from the data.

We use queries to obtain the information. You can think of queries as way to ask questions in Base
and receive the answers. If we want to give the information to someone else, we will give them a
report that is based upon a query we created. (A report can be created from a table as well.)

So, a flat database consists of a table whose columns are called fields and whose rows are called
records. We use the table structure to ask questions and to receive answers using queries. When
providing others with information obtained from a query, we create a report. These, then, are the
things we use in a database: table with its fields and records, queries, and reports.

Planning your database

Caution Before creating a database, you should take some time planning what you want it to
do and why. The better your plan, the better the results you will get from using the
database.

You need to have an idea of what you want to do with the data that you have. This includes how
you will divide the data into columns, the fields, and into rows, the records. This determines what
the table will be. What information do you want to get from the data? This determines what the
gueries will be. What information do you want to have in a report? So, take some time to think
through what you want first before ever creating a database.

The Base Guide has an extensive discussion on this topic in Chapter 2, Planning and Designing
your Database.

The Table Wizard (see discussion beginning on page 230) contains a list of suggested tables:
some for business purposes, and some for personal purposes. The wizard also contains a list of
fields for each of the suggested tables. Each of the fields also has been given the properties it
needs.
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As a result, the wizard does most of your planning for you. However, you do need to make some
decisions, for example whether to use all of the suggested fields. Will you want to use additional
fields that the wizard did not include? What properties should these fields have?

Therefore, you need to understand what you are doing as you do it. You need to practice creating
the objects of a database before creating them in your database. Learn how to apply the principles
first on an example. If necessary, take notes on the principles taught and how they are used.

Creating a new Base file

After you have planned your database, create a new Base file. To do this, open the Database
Wizard using one of the following methods:

* Choose File > New > Database from the main menu bar.

* Click the arrow by the New icon on the Standard toolbar and select Database from the
drop-down menu.

* Click the New Database icon on the splash screen if it appears when LibreOffice opens.

Step 1 of the Database Wizard (Figure 212) has three parts. Use the top part to create a new
database. The middle and bottom parts are used to open an existing database. (These two parts
are briefly discussed in “Using Base with other data sources” on page 264.)

Creating a database using the wizard requires two steps.
1) On the Select database page (Figure 212):

a) Under the question What do you want to do?, choose Create a new database (it is
selected by default).

b) Click the Next >> button at the bottom of the wizard.

800 Database Wizard

Welcome to the LibreOffice Database Wizard

S Use the Database Wizard to create a new database, open an existing database
............................ file, or connect to a database stored on a server.
2.5ave and proceed

What do you want to do?

(=) Create a new database
Embedded Database: |HSQLDB Embedded ¢ |
() Open an existing database file

Recently used
Open

() Connect to an existing database

JDBC

Help | <<Back | [EiNexta> ] Finish | Cancel

Figure 212: Creating a new database using the Database Wizard
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Note

Note

Beginning with version 4.2.0, the first page of the Database Wizard has a new drop-
down list for selecting the type of embedded database. At the time of writing, this
feature has not yet been activated; it will not be discussed here.

When you create a new database, you should register it. Registration lists the
location of the database location in one of the configuration files of LibreOffice. You
can then access the database from Writer or Calc.

2) On the Save and proceed page (Figure 213):

a)
b)

Choose Register the database for me (the default setting).

Choose what you want to do after the database file is saved. In this example, we
choose Open the database for editing.

800 Database Wizard
Steps Decide how to proceed after saving the database

L.Sakct datat“‘is_'s___ Do you want the wizard to register the database in LibreOffice?

(=) Yes, register the database for me
() No, do not register the database
After the database file has been saved, what do you want to do?
(¥ Open the database for editing
[ Create tables using the table wizard

Click 'Finish' to save the database.

Figure 213: Registering and opening the database file

Note

If you want to create a table with the wizard immediately after creating a new
database, select Create tables using the table wizard in addition to Open the

database for editing. If you do this, the main database window opens with the
Table Wizard opening in front of it.

We will discuss the main database window before the Table Wizard, so in our
example the second choice is not checked.

3) Click the Finish button at the bottom of the wizard. A standard Save as window opens.
Name and save the database.

You have created and saved a new database file that has opened the main database window. If
you wish, you can close it now and reopen it later.

Opening an existing database

You can reopen your new database in several ways. In any file browser, you can browse to where
you saved the database and double-click it. or you can right-click it and select LibreOffice to open
it. You can also use the database wizard to open it, as described below.
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Using the database wizard to open an existing database

Below the Open an existing database option on the first page of the Database Wizard is a drop-
down list of the databases you have recently used. After creating your first database, its name will
appear as the default value for this list. Once you create or open another database, other names
will appear in this list. You can use this list to select the database that you want to open.
1) Open the database wizard like you did when you created your database.
2) Click the Open an existing database option button.
. From the Recently used drop-down list, select the name of the database.
. Or, Click the Open button, browse to the location of the database, and select it.
3) Click the Finish button.
The third section of page 1 of the database wizard is used to connect to databases that have been

created by other than Base. This includes text databases, spreadsheets, MySQL, PostgreSQL,
Oracle, and Access among the more well known ones.

Ti These databases and how to connect to them using Base are discussed in Chapters
Ip 2 and 8 of the Base Guide.

Main database window and its parts

Everything you do with a database begins with the main database window (Figure 214). When
performing some tasks, you will have to come back to this window to complete the task. So,
become well acquainted with it.

Once you have created a new database and saved it, this window opens. Opening a database file
will also open it.

The main database window contains three sections: Database, Tasks, and List. However, you will
not see List as the heading of a section as you do for Database and Tasks. Instead, its heading
depends upon which icon is selected in the Database section.

800 SampleDatabase.odb - LibreOffice Base

B-&8- 6 E- @

= i Create Table in Design View... Description
e [#l Use Wizard to Create Table...
Tables Create View...

L=t

Queries

\NF= None ~
Forms

Al |

Reports

| Embedded database HSQL database engine

Figure 214: Main Database window
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Database section

This section is the column of icons on the left side of the window. There is an icon for each part of
the database. Your first step after opening a database is to select what part of the database you
will work in. The selection you make here changes what appears in the other sections, as
explained below.

Tasks section

This section contains a list of tasks that can be done related to the icon selected in the Database
section. When the Tables icon is selected in the Database section, three tasks appear in this
section. Two of them help you create a table, and one helps you create a view. When the Queries
icon is selected, three tasks appear to help you create a query. When the Forms icon is selected,
two tasks appear to help you create a form. When the Reports icon is selected, two tasks appear
to help you create a report.

The right side of the Tasks section has the heading Description. This area gives you information
about each of the tasks. Click any one of the tasks to see its description.

In this chapter, we are using only the wizards to create the tables, queries, forms,
Note and reports. The Base Guide discusses the rest of the tasks, their principles, and an
example of their uses.

List section

This section contains a list of the objects whose icon is selected in the Database section. Click the
Tables, Queries, Forms, or Report icon, and this section contains a list of the tables, queries,
forms, or reports respectively. The title for this section is the name of the icon selected.

A variety of things can be done with any member of the visible list by right-clicking the item and
selecting an action that appears in the context menu. The standard actions are Copy, Delete,
Rename, Edit, and Open. The context menu includes additional choices that depend upon the type
of list.

To the right of the list is a small window labeled Document view, giving you more information about
the specific document (table, query, form, or report) you have selected. The view is controlled by a
drop-down list containing three options: None, Document Information, and Document.

When Tables or Queries is selected in the Database section, only two choices are available: None
or Document. When Forms or Reports are selected, all three choices are available. Selecting
None leaves the Document view window blank.

Select Document information for a form to see who last modified the form and when it was
modified. If it has not been modified, there is no information.

Select Document and a member of the list, and you will see a snapshot of what you selected. In
most cases, you see only the top left portion because of size limitations. For a table or query, you
will see only the first few columns and rows along with any data. For a form, you will see the top
left portion of it. (If the form is small, you will see all of it.)

Document view does not work for reports. You will see all three choices in the drop-

Tip down list, but you will not see anything when you make a selection.
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Views

A View is a virtual table or stored query you create using the fields from one or more tables that
you have already created. A View allows you to set relationships between tables using selected
fields and view the results. View structures are written in the script file in the database folder of the
database document file. (Queries are written in a different file in another location of the database
document file.)

When we click Create View in the Tasks section, the View Design dialog opens. This dialog is
similar to the Query Design dialog. Discussing these dialogs is beyond the scope of this chapter.
Both are discussed in detail in Chapter 5, Queries, in the Base Guide.

Database objects

Database objects are the tables, queries, forms, and reports of the database. When a new
database is created, they have to also be created to make the database's data useful.

This chapter discusses the use of wizards for creating these objects. The principles used by the
wizards are included. The example database will be a household inventory.

Tables: use wizard to create tables

To open the table wizard, begin in the Database file window. Click the Tables icon in the Database
section on the left. This places three tasks in the Tasks section. Click this task: Use Wizard to
Create Table. The wizard opens to its first page.

The table wizard uses several steps to create a table. Each step is located on a separate page.
Within each step are smaller steps to do. The major steps are:

1) Select fields.

2) Settypes and formats.
3) Set primary key.

4) Create table.

Page 2, Set types and formats, refers to setting the types and formats for the fields.
Note On this page, you can choose among the supplied fields, create new fields and set
their type and format, and rename fields.

Table
A table consists of one or more vertical columns and one or more horizontal rows containing
the data of the database. The data of a given table of a database share one or more common
characteristic.

Field
A field is an attribute or characteristic that divides the data of a table into columns, one column
for each attribute.

Record
A record is a row of a table. The word Tuple is sometimes used in place of record in database
literature, but record is used more often. The contents of each row share a common
characteristic.
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Step 1: Select fields for your table

Category has two choices that determines the type of tables that you can use: Business, and
Personal. Select Business for business purposes and Personal for personal purposes.

Sample tables is a drop-down list of tables based upon the table's purpose. Select a table from this
list, and its fields appear in the Available fields list.

Use the arrows in the middle to move fields in the Available fields list to or from the Selected fields.
A single arrow moves a single field; a double arrow moves all of the fields at one time. If you want
to move more than one field at at time, highlight the fields first and then click the proper single
arrow.

The arrows on the right are for changing the order of the fields in the Selected fields list. Click a
field to highlight it. Click the up arrow to move it toward the top, or click the down arrow to move it
toward the bottom.

Select fields for your table

This wizard helps you to create a table for your database. After selecting a table
category and a sample table, choose the fields you want to include in your table. You
can include fields from more than one sample table.

Category
) Business ¢ (% Personal
Sample tables

HouseholdIinventory -

Available fields Selected fields

AppraisedValue #

CategoryID 47

DatePurchased

Description 47 ’ G

Insured )
InventorylD

>
ltemType »

v
E

1 2 3 4
1 Category labeled option buttons 3 Move selected fields from left to right
2 Move selected fields from right to left 4 Change the order of the listed fields

Figure 215: Step 1 of Table Wizard: Select fields

Here are the smaller steps required on this page. These will be applied to selecting
HouseholdInventory as the table and the fields in it in the example following these steps.

1) Select the category: Business or Personal. This determines what is listed in the Sample
tables drop-down list. (Select Personal for the example.)

2) Open the Sample tables drop-down list by clicking the down arrow.

3) Select the table you want to use.

(Select HouseholdInventory for the example. Available fields contains a list of this table's
fields.)

4) Move the fields you want to use in your database to the Selected fields list.
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5) To move all the fields at one time, click the double right arrow.
6) To move one or more fields, highlight the fields and then click the single right arrow.

7) To remove one or more fields from the Selected fields list, highlight the fields and click the
left single arrow. (To remove them all, click the left double arrow.)

8) Change the order of the fields.

a) Click the field which you want to move up or down in the list of fields.

b) Click the up arrow to move the field higher, or click the down arrow to move it lower.
9) Click Next to go to Page 2.

Practice exercise: Create the Householdinventory table

Begin in the Database file window by clicking the Table icon. From the Task section, click Use
Wizard to Create Table to open the Table Wizard.

The wizard contains many suggested tables that you can use. Some of them are for business
purposes and some are for personal purposes. The first thing to do is some research for the
names of the sample tables. This requires you to click either the Business option button and
search through the sample table names or click the Personal option button and search through its
Sample table names. Make a note of any tables that you may find useful. Also note the category of
the table (Business or Personal). When you want to use a sample table in a database, you will
know where to look for it.

If you looked through the sample table names, you discovered that its category is Personal. The
available fields list appears when you select Personal as the category and Householdinventory
from the Sample table drop-down list. So, make these selections now.

Sixteen fields are available for this table. You can select all or only a few of them, depending upon
the information needed for your database.

Choosing what fields to use is part of the planning of the database. It pays to look through the
available fields to see if specific fields should be part of the table. If you think that any of the fields
should not be apart of the database, do not select them for your table.

What if there is a field that you want to be part of the table, but it does not exist? You can create
one in step 2 of the wizard. You can also select a similar field in step 1 and change its type and
format in step 2.

For example: you want to include the names of the rooms that contain furniture. One of the 16
fields is RoomID. You can select this field in this step. Then in page 2, change the name of the field
from RoomID to Room. Also change the field type and format.

For this exercise, use these fields: AppraisedValue, DatePurchased, Description, Insured, Item,
Manufacturer, ModelNumber, Notes, PlacePurchased, PurchasePrice, RoomID, SerialNumber, and
InventorylD.

Move these fields from the Available fields to the Selected fields. You can click a single field or
Control+click multiple fields to highlight them. Then click the single right arrow. If you accidentally
move a field that should not be moved, click the field and then click the single left arrow.

Now comes another part of the planning. Think about the order that you want to use when entering
the data into your table. The fields are listed now in alphabetical order. Is that what you want?
Chances are that the answer is no. Then what order do you want? One possible order is shown in
Figure 216. This order will be used in the exercises for the rest of the steps of this wizard.

To complete this part of the practice exercise, click the Next > button. The exercise continues on
page 235.
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Step 2: Set types and formats

This page has two parts: the list of selected fields, and field information. The first part contains the
same list as you created in page 1 including the order you gave them. When you select one of the
fields in this list, the field's information appears in the second part (Figure 216).

Selected fields list

There are a couple of things that you can do with the Selected fields list (Figure 216). It has a pair
of arrows at the bottom right. You can reorder the fields in this list just as you did on page 1.

It also has a plus (+) button and minus (-) button. Use these to create a new field or delete an
existing field. Use the plus to add a field or the minus to remove one.

Be careful when removing a field. If you delete a field that should not be deleted, you will have to
use the plus to add the field to the list. Then you will have to give this field its field information. So,
before deleting any field, click it in the selected field list. Copy the field information that appears.
Then if you accidentally delete a field, you can recreate it with all of its field information.

L8 00 Table Wizard

Steps Set field types and formats

1.5elect fields Selected fields Field information

2.5et types and formats Item Field name Item

5 RoomiID

3.5k primary key Description Field type (Text [ VARCH *

4_Create table SerialNumber —
Manufacturer Entry required No .

ModelNumber

PlacePurchased Length
DatePurchased

PurchasePrice

AppraisedValue

Insured
Notes
InventorylD
W
= +
Help < Back [ Next > | Finish Cancel

Figure 216: Ordered selected fields list with field information items

Field information

All the fields have at least four items as field information. The actual number of items depends
upon the field type. When the field type is Integer, there are five items.

Most of the field types used in Base are similar to those used in database programs. However,
different programs are likely to have some field types that are not available in Base. For example,
MEDIUMINT, is used in MySQL. Its Length is less than INTEGER and larger than SMALLINT
which Base uses.

Whether you are new to creating databases or new to using Base to create them,
you will be selecting the field information for all of your fields. For this reason, those

used in Base are discussed in Appendix | of the Base Guide, Field Information for
Base.

Tip
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The Field name permits you to change the spelling of the field's name. The Field type determines
the main characteristic of the field such as text, numbers, dates, times, timestamps, Boolean (for
example, yes/no, true/false, or male/female), and very large fields including images.

Use Entry required for any field that must always have a value by selecting Yes. Always be sure
that an entry will always be required before selecting Yes.

Caution If you have a field that requires an entry, you will get an error message if you do not

enter a value. You will be able add values to all the other fields once only before the

A error message, But you can not add any more values until you enter one in the field
that requires one.

The Length property determines the size of the entry that can be used for a field. Each of the field
types have specific maximum lengths. So, check what these are when entering a length, and enter
what you need. You might need to change the field type if you need a larger length than your
chosen field type will permit. Then again, a field type that has a smaller length might be more
appropriate.

Text field types include CHAR, VARCHAR, VARCHAR_IGNORECASE, and MEMO. CHAR stores
entries in a fixed length. For example, the selected length is 10 and the values entered were cat,
mouse, leather, and something. These would be stored as cat0000000, mouse00000, leather000,
and something0. The zeros are added to make the length of each one 10. When this field is later
read, the zeros are ignored.

VARCHAR is variable character. Only the actual characters entered are stored up to the length
selected. If it also has a selected length of 10, the above examples are stored as cat, mouse,
leather, and something. So less storage is needed when using VARCHAR instead of CHAR. This is
especially useful when a field's values vary considerable in length. So the suggested length of 50
can be used for VARCHAR as long as the longest entry is less than or equal to 50. With 50 as the
selected length for VARCHAR with the examples above, the stored values are still cat, mouse,
leather, and something.
Use these steps to set the fields and their properties for your table:
1) To verify or modify the Field information for the selected fields,
a) Click the field name in the Selected field list.
b) Compare the field information to what you want the field to have.
¢) Change any of it if necessary.
d) Repeat steps la-c for the rest of the fields.
2) To create a new field:
a) Click the plus (+) button. (See Figure 216.)
b) Change Field name to the field name you want.
¢c) Modify any of the other Field information to what you need.
d) Repeat steps 2a-c for additional fields to be created.
3) To delete an unneeded field:
a) Click the field you want to delete.
b)  Click the minus (-) button.
c) Repeat steps 3a-b to delete any additional fields.
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Practice exercise

The field, RoomID, needs to change its name, field type, and length. Two of the fields,
AppraisedValue and PurchasePrice, require a change in the number of decimal places. Both are
accomplished in the same manner: click the field in the Selected Fields list, and then change the
part of the field information that needs it. Finally, for field, InventorylD, Change Auto value from No
to Yes. After making the changes a particular field needs, use the Tab key or click one of the other
fields. This saves the values to memory.

First click the field, RoomID. Change the Field name to Room. Now use the Tab key to move to
Field type. Click its drop-down list to open it. Now select Text[VARCHAR)]. To finish the changes,
change the Length to 50 unless you have a room with a name longer than 50 characters. Use the
Tab key or click one of the other fields.

Click the field, AppraisedValue. Change Decimal places from 0 to 2. Now we can store values in
dollars and cents. Change Decimal places for PurchasePrice the same way.

Click the field, InventorylD. Change the Auto value from No to Yes. This is because this field will be
used as the table's primary key. (See Step 3 below for more information about primary keys.)

Use the Tab key or click one of the other fields. This saves the values you entered for the last field
you changed.

* Click Next > to go to Step 3.

When using the table wizard to create a table, very seldom will you need to make
any changes in the field information since the suggested values are usually the ones
you need. However, check the Decimal places value for currency fields as the wizard
suggests using O.

Note

Step 3: Set primary key

First of all, what is a primary key, and what is its purpose? It consists of one or more fields that
have a special characteristic: no two values of the primary key are the same. Its purpose is to
identify the rows of a table.

For beginners, any primary key used should be a single field. It is even better if this field has the
field type, Integer, and has Auto value set to Yes. When you create your primary key this way, Base
will assign values to the field beginning at 0. Each new value for this field will be an Integer that is
one greater than the previous one. This guarantees this field will contain distinct values.

Atable consists of rows and columns of data. When the table contains a primary key, we can
select a given row by selecting the primary key value for that row. Each column of the table
contains the values of a specific field. So when we specify both a single value of the primary key
and the name of a field, we can select a specific cell of the table. This is what we need when we
want to search for specific information that the table contains: a way to determine what row and
column we want to use in our search.

Primary keys containing more than one field require more vigilance to make sure no two rows have
the same values for these fields. Consider the table below. No two rows are identical even though
Field1 has duplicate values as does Field2. However, together there are no duplications of the
combination.

Some types of tables do not require a primary key, but remembering which type of table does and
which does not can lead to potential problems. So, it is best to have a primary key for every field
unless you can always remember whether a table type requires one or not.
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Table 5: Example of values for a two-field primary key

Field1 Field2
1 0
0 1
0 0
1 1

When a table is created without a primary key and should have one, you will not be
Caution able to enter any data into the table. This can be frustrating. You will first have to
learn how to use the Table Design dialog before you can correct this error. (See
A Chapter 3 of the Base Guide.) So when using the table wizard always have this
checked on Page 3: Create a primary key.

There are three choices on this page of the table wizard once you have made sure that Create
primary key has been selected. This should be the default setting, but make sure anyway. The

choices are Automatically add a primary key, Use an existing field as a primary key, and Define
primary key as a combination of several fields.

The first option adds an additional field, /D as the table's primary key. Its field type is Integer.
However, Auto value is set to No. This means you would have to manually enter each value for the

field, ID. Using the second option instead of this one will permit you to have Base create the values
for the primary key for you.

The second option selection has been selected in the figure below. The field name has been
selected from the drop-down list of field names. Check the Auto value checkbox to have Base
select the values for this field automatically.

| &0 0 hl'l'ab]e Wizarld: .
Steps Set primary key
1.5elect fields A primary key uniquely identifies each record in a database table. Primary keys ease

the linking of information in separate tables, and it is recommended that you have a

primary key in every table. Without a primary key, it will not be possible to enter data
3.Set primary key into this table.

4_Create table

2.5et types and formats

™ Create a primary key

() Automatically add a primary key
Auto value
(=) Use an existing field as a primary key

Fieldname InventorylD i 3| M Auto value

() Define primary key as a combination of several fields
Available fields Primary key fields
tem
Room
Description
SerialNumber

Help < Back [ Next > . Finish Cancel

Figure 217: Table Wizard Step 3
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The third option allows you to select two or more fields to use for the primary key. If you select this,
you can select the fields from the Available fields list and move them to the Primary key field list
using the right arrow in the middle. You can even change the order in the Primary key field list
using the up or down arrow.

If you want to experiment with a multiple field primary key, select the Personal Category and the
Addresses sample table. Select FirstName, LastName, and any other fields you want. Then in this
page, select the third option. Move FirstName and LastName from Available fields to Primary key
fields. When you added data to this table make sure that you do not use the same first name last
name combination more than once.

Practice exercise
Select InventorylD to be the primary key for the table and give it the Auto value property.

* Click Next to go to page 4.

Step 4: Create table

800 T
Steps Create table
1.Select fields What do you want to name your table?
2.Set types and formats Household Inventory

3.5et primary key
4.Create table Congratulations. You have entered all the information needed to create your table.
What do you want to do next?

(s) Insert data immediately
() Modify the table design

() Create a form based on this table

Help < Back Next > [ Finish | Cancel

Figure 218: Table Wizard Step 4

A common nhaming practice has been to make two or more words into one word for
the name of a field or database. (Each word is capitalized when joining them.)
HouseholdIinventory and InventorylD are two examples. You may use spaces in
names used in a database if you want. Such names may require double quotes
when using SQL to create, delete, or modify a table or field. (See Chapter 3 of the
Base Guide for detailed information.)

Tip

Use this page to name the table you are creating. You can use the name suggested, modify it, or
give it a name of your choice. Then you have three options regarding what to do next: Insert data
immediately, Modify the table design, or Create a form based on this table. After making any
modification in the table name and selecting your option, close the table wizard.
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When the first option is selected and the table wizard is closed, the Table Data View dialog opens.
At this point you can add information in this table. (See Figure 219.)

When the second option is selected and the table wizard is closed, the Table Design dialog opens.
With this you can modify the fields of the table. (See Chapter 3, “Tables” in the Base Guide.)

With the third option and the Table Wizard closed, the Form Wizard opens. With this you can
create a form for the Household Inventory table. (See Forms.)

Practice exercise

Modify the name of the table to Household Inventory. Then select the first option, Insert data
immediately. Click Finish to close the Table Wizard. The Table Data View dialog (Figure 219)
opens.

Enter or remove data using the Table Data View dialog

Data can be entered into a table using this dialog or the form based upon this table. Instructions
are give here about how to enter data using this dialog; later instructions will be given for how to
insert, modify, or remove data in a form at the end of the Forms section.

This section contains basic instructions for adding and removing data in a table.

Note Chapters 3 and 4 of the Base Guide discuss this in more detalil.

To insert or remove data using this dialog, it has to be opened. This can be done while creating the
table by selecting Insert data immediately in the last step of creation. Also, you can always open
any table at any time from the Main Database window to edit its data.

1) Click the Tables icon in the Database section.
2) Right-click the name of the table in the list of tables.
3) Select Open from the context menu. The table data view dialog opens.

File Edit View Insert Tools Window Help

[tem Room Description SerialNumber
o
Manufacturer ModelNumber PlacePurchased DatePurchased
DatePurchased PurchasePrice AppraisedValue Insured MNotes InventorylD

Figure 219: Table Data View dialog

Enter data into a table

When the table is first created, it contains no data as shown in the above figure. It consists of a row
and a column for each field contained in the table. (The table is divided into three snapshots
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because of the width of the table.) The heading for each column is the name of field whose data is
contained in it.

Before entering data into the cells, you may need some reminders about the rows and columns of
a table. All the data contained in a given row apply to a given item. All the data contained in a given
column belong to the field whose name appears as the heading of that column.

For example, each row in the figure above contains data about a distinct item, say a sofa which is
in the living room. The data entered in this row are its name, Item; its location, Room; information
about it, Description; identification number, SerialNumber; who built it, Manufacturer; its model,
ModelNumber; where bought, PlacePurchased; bought when, DatePurchased; cost,
PurchasePrice; its worth, AppaisedValue; insurance, Insured; other information, Notes; and primary
key value, InventoryID.

For a second example, a second sofa is also in the inventory. It is an older sofa that is in the family
den. The row of data that applies to this sofa has some differences from the row that applies to the
first sofa. (DatePurchased is one such difference.)

Because of these differences, care must be taken when entering data to make sure that all of the
data entered into a given row applies to only one item. Otherwise, the data you obtain from the
table contains errors.

Now consider the columns of our two examples about the sofas. The Iltem column contains the
name of the items. The Room column contains their locations. The Description column contains
information about them ... The InventoryID column contains their unique identification numbers.

So, this is another are in which care must be taken. The data entered into a table must be placed
into the correct column. Otherwise, this too will produce errors in the data.

An item's serial number should be unique for a given manufacturer, we have no
Note guarantee that different manufacturers may use the same serial number. That is why
we need to use a unique identification number for the items of our inventory.

When the dialog is opened, a cursor appears in the first cell of the row. It is ready for you to enter
data into that cell. Once you have entered data into a cell, you can move the cursor into the other
cells so that data can be entered there as well.

Entering data into the dialog is similar to entering data into the cells of a spreadsheet. The cursor
can be moved from one cell to another using the arrow keys. (In a spreadsheet, sometimes the
Enter key must be used.) Typing data only places it into the cell where the cursor is located.

There are important differences as well. Typing data into a cell of a table does not enter the data
into the table as it does in a spreadsheet. The data only appears in the cell. To enter it into the cell,
the cursor must be moved by either the Enter or by an arrow key. Finally, using the Enter key when
the cursor is in the last column of a row moves the cursor to the first column of the next row.
Entering data into an empty table: (The cursor is located in the first column of the first row.)
1) The first row:
a) Type the data into the first cell.
b)  Move the cursor to the next cell. (Use the Enter or right arrow key.)
c) Repeat steps a) and b) until the cursor is in the last cell of the row.
d) Type the data into the last cell.
e) Move the cursor to the first cell of the second row. (Use the Enter key.)
2) Additional rows:
Repeat steps a) —e) in 1).
3) Close the table data view dialog, saving it if necessary.
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Entering data into any empty cell of a table is very similar to the above steps.
1) Use the mouse to move the cursor to the empty cell.
2) Type the data into it.
3) Move the cursor to another cell. (Use the Enter or right arrow key.)
4) Close the table data view dialog, saving it if necessary.
When creating lists of the data that you want to enter into a table, you should consider the format
of the list. Consider which of the following two lists is easier to use.
This is a list of data separated by commas and semicolons:

Row 1: Item, Keyboard; Room, Den; Description, “ “; Serial Number, 1426894123;
Manufacturer, Casio; Model Number, CTK-720; Place Purchased, Target; Date Purchased,
05/16/2008; Purchase Price, 90.00; Appraised Value, 75.00 ...

The table below shows the same data in table format.

Item Room Description Serial Number | Manufacturer Model

Number
Keyboard Den 1426894123 Casio CTK-720
HP Computer Computer KQ946AA#AB Hewlett Packard ab503f
Pavillion wi/printer

Practical exercise

Enter this data into the Household Inventory table:

Table 6: Sample data (first 6 fields)

Item Room Description SerialNumber Manufacturer ModelNumber
Keyboard | Den 14268941235 Casio CTK-720

HP Computer | computer KQ946AA#ABA Hewlett Packard | A6503f

Pavillion wi/printer

Piano Living Upright STE112211 Steinway 2002STE4556
Table Dining round Ww2113 Woodworks, Inc. | WW126
Microwave | Kitchen 900W SHR4568de222 Sharp SHR54678KL

Table 7: Sample data (last 7 fields)

Place Date Purchase | Appraised | Insured Notes InventoryID
Purchased Purchased | Price Value

Target 05/16/08 90 75 TRUE 1

Best Buy 09/04/11 1097 1097 TRUE 2

Classical 08/12/02 5895 6000 TRUE 3
Instruments

Sonny's 10/19/67 825 125 TRUE 6 chairs | 4

Furniture

Service 08/30/11 145.99 145.99 TRUE 5

Deluxe
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Modify data in a cell of a table
Modifying data requires only five steps:
1) Open the table.
2) Click the cell containing the data.
3) Change the data as you would data in any text box.
4) Save the table.
5) Close the table.

Delete data from a table
Deleting data involves one of two things: either deleting the data from a single cell or deleting the
data from all the cells of a row. Deleting data from a single cell is done the same way as modifying
the data of a single cell. In step 3, you delete the data that you no longer want.
Deleting all the data in a table's row requires only a few steps:

1) Open the table.

2) Click the gray box to the left of the row whose data you want to delete to highlight it.

3) Right the gray box and select Delete Row from the context menu. A dialog appears labeled
Do you want to delete the selected data?

4) Click OK if that is the row of data you want to delete. Click NO if it is not.
5) Save the table.
6) Close it.

Be very careful when deleting a row of data.

Caution If you delete the wrong row, you will have to reenter the data. This will take an
unnecessary use of time but it may not be too much of a problem if you have a

A copy of the data somewhere.

If you do not have a copy and can not obtain the data somewhere else, you have
permanently deleted data that you need.

Forms: using the Forms Wizard

If we had to enter all of our data directly into our table, it would be more time consuming than it
needs to be. Creating a form based upon the table we created will allow us to enter our data in a
more meaningful way. When we look at a table, we see many rows of data simultaneously. The
form allows us to see only one row (one record) at a time.

Create a simple form using the Form Wizard

The wizard guides us through some fairly easy steps for creating a form based on the table we
have already created. The wizard creates a layout of controls (the table's fields and their labels)
based upon the choices we make while using it.

Once the form is created, it can be edited. Because of the additional complexity that editing
involves, editing of forms is discussed in Chapter 3 of the Base Guide.
Here are two ways to open the wizard for create a form. Use 1) OR 2). Do not use both.
1) Click the Table icon in the Database section of the main database window.
a) Right-click the table you want to use. (Right click the Inventory table.)
b) Select Form Wizard from the context menu.
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2) OR, click the Forms icon in the Database section of the main window, then in the Task
section, click Use Wizard to create form.

Step 1: Field selection (Figure 220)
1) Select the table, Inventory, in the Tables and queries drop-down list.

2) If you right-clicked the Inventory table and selected Form Wizard from the context menu,
Table: Inventory will already be selected. OR

3) If you had earlier clicked Use Wizard to create form, select Table: Household Inventory.
4) Choose fields from the Household Inventory table to be used in the form.

* Since we want to use all of the fields, click the right double arrow to move all the
fields listed under Available fields to the Fields in the form list.

* OR, if you only want to move part of the fields, click the field you want to move and
click the right arrow to move this field.

* Repeat for the rest of the fields to be moved.

5) Click Next.
Steps Select the fields of your form
1.Field selection Tables or queries
2 Ip a su T Table: Household Inventory |v |
i ’_f':""' ' o Available fields Fields in the form
e 5= CategoryID »|
5. Arrang Appraisedvalue »-
set dat DatePurchased -
Description e 45
7.A styles Insured -
Manufacturer
ModelNumber 4_
Notes
ey TR e BTN b
Binary fields are alwalys ligted and selectable from|the left list.
If possible, they are irfterpfeted as images.
Help Ba l |[ Next = " [ Hinish l [ Cancel
1 2 3 4 5 6
Move selected field to the right 4 | Move selected field to the left
2 |Move all fields to the right 5 | Move selected field higher in list
Move all fields to the left Move selected field lower in list

Figure 220: Page 1 of the Form Wizard

Notice that the drop-down list we used to select the Household Inventory table is
Tip labeled, Tables or queries. This is because a form can be created from a query just as
it can be from a table.
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Step 2: Set up a subform.

1) We will not use another table along with the Household Inventory table. So, we will not be
using a subform.

2) Click Next.

Step 3, Add Subform fields, and 4, Get joined fields.

Both of these pages only apply when you are using a second table to create a subform. Since we
did not select the second table in page 2, pages 3 and 4 are grayed out.

Step 5: Arrange the controls on your form.

Arrange the controls on your form

Label placement
(%) align left
() align right

Arrangement of the main form

-o-o || EoEs EEH BEE
-] =] — — - — —

-oO-c (| &2 = e
=] =[] —irc— = —ir—

Columnar - Labels Left

Figure 221: Arranging the controls of the form

Control
A Control consists of a label and field. The label contains the name of the control, and the Field
contains the data entered into the form.

You have four choices in arranging your controls as shown in the figure from left to right: Columnar
— Label left, Columnar — Label on top, As Data Sheet, and In Blocks — Labels Above. Each choice
gives a slightly different layout.

Both of the columnar layouts create the controls in columns beginning with the first control at the
upper left and continuing down the left side. If additional columns are needed, they are filled in
from top to bottom and then columns from left to right. The first control is the top control in the left
column. The last control is the bottom control in the column on the right.

The Data Sheet arrangement looks like a spreadsheet with the labels across the top. This is
probably best used for a subform rather than for the main form. It is your choice.

The In Blocks — Labels Above arrangement places the controls in rows from left to right. When one
row is filled, the next control is placed at the left end of the row below. So, the first control is at the
left end of the top row, and the last control is at the right end of the bottom row.

We will use Columnar — Labels Left for the Household Inventory form.

The In Blocks — Labels Above arrangement places the controls in rows from left to right. When one
row if filled, the next control is placed at the left end of the next row below the row that is filled. So,
the first control is at the left end of the top row, and the last control is at the right end of the bottom
row.
We will use Columnar — Labels Left for the Household Inventory form.

1) Label placement: Select how you want the labels to be aligned: left or right.

Accept the Default value of Align left, or click the bottom option button to select Align right.
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2) Arrangement of the main form: click the graphic on the left. (See Figure 221 for the correct
appearance of the window.

3) Arrangement of the subform: we are using only one table in this form, so this is grayed out.
. Click Next.

Step 6: Select the data entry mode.

* The default choice match our needs. Click Next.

| strongly advise that you look at the data entry choices available, thinking about how
Tip each of these choices might meet your future needs. For instructions on the purpose
of each of these choices, see Chapter 3 of the Base Guide.

Step 7: Apply the style of your form.
1) Apply styles: page color:
a) Chose one of the listed colors. The default color is as good as any. (This color can be
changed when we modify the form.)
b)  You can create your own color to use using Tools > Options > LibreOffice > Colors.
You can use RGB or CMYK values in this dialog. After creating the color you want,
you can select your color while modifying the form.
2) Field border:
a) Experiment with the three choices.

b) Use the mouse to move the Form window around so that you can see each of the
three choices in the form.

c) Use the default value. (This choice can be changed if the form is edited. The border of
the control labels could be changed then as well if you so desire.)

3) Click Next.

Step 8: Set the name of the form.

1) The suggested name for the form is the same as the table that was used to create the
form: Household Inventory. Use the suggested name this time, but remember that you can
choose the name you want to use. You can rename the form if you like.

2) How do you want to precede after creating the form?
. If you want to add data immediately after creating the form, use Work with the form.
Select this choice for this example.
3) Click Finish.
a) Since we chose Work with the form above, the Household Inventory form opens in the
“read only” mode, as in Figure 222. You can start inserting data into your table.

b) If you had chosen Modify the form, the Household Inventory form would have opened
in edit mode. (Modifying a form is discussed in Chapter 4 of the Base Guide.)

“Read only” is confusing to many people. In Edit mode, you can modify anything that
you earlier created: controls, background, and text you may have added to the page.

) In this mode, you can not add nor remove any data previously entered into any of
Tip the fields unless you click the Design Mode On/Off icon to turn the design mode off.

In Read Only mode, none of the controls nor styles of the form can be changed.
However, you can add, delete, or modify data in any of the fields.

This form, which is actually created by Writer, can be modified in many different ways that are
described in Chapter 4 of the Base Guide.
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Enter or remove data from forms

The data for any of the fields in a given record can be entered, removed, or changed at the same
time. There are some similarities and differences between adding data to a table and a form. This
discussion involves two parts: working with individual controls, and removing an entire record from
the database. The latter is similar to deleting an entire row from a table with the same possible
consequences.

Item AppraisedValue
Room Insured

]
Description Notes
SerialNumber
Manufacturer

InventorylD
ModelNumber

PlacePurchased

DatePurchased

PurchasePrice

Figure 222: Newly created Household Inventory form

Enter or remove data from individual controls

The form contains a control for each of the fields in the table. Each control contains a label which
identifies the field from the table and a box which contains data from the field. When the cursor is
in a box, data can be typed into it.

Before entering or removing data from individual controls, you need to acquaint yourself with both
the newly created form and the left side of the Form Navigation toolbar, shown in Figure 223. (The
rest of the tools on it are discussed in Chapter 4, Forms, in the Base Guide.)
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# Record ET cf% g 4 b Bl P ?

1 2 34 5 6 7 8 9 10
1| Record number 6| Last record
2| Total records 7| New record
3| First record 8| Save record
4| Previous record 9| Undo: data entry
5| Next record 10 Delete record

Figure 223: Form Navigation toolbar

* Record number: The form numbers the rows of the underlying table from the top row to the
bottom row. The record number shown is the number of the row that appears on the form.

* Total records: This shows the total number of records of the underlying table when the
number of rows is small. With larger tables, this shows only part of the total number.

* First record: Click this arrow to go to the first record. (The record number becomes 1 or
whatever is the smallest number. If the present record is the first record, this arrow is
grayed out and not useable.)

* Previous record: Click this arrow to go to the previous record. (The record number
becomes one less than what it had been. If the present record is the first record, this arrow
is grayed out and can not be used.)

* Next record: Click this arrow to go to the next record. (The record number will be one larger
than what it has been. If the present record is the last one, no data will appear in this record
with one exception: the form contains the table's primary key, and its field property,
AutoValue, is set to Yes. Only then will the primary key show AutoValue.)

e Last record: Click this arrow to go to the last record. (The record number becomes the
largest one. If the present record is the last record, this arrow is grayed out and can not be
used.)

* New record: Click this icon if you want to create a new record becoming the last record.
(The record number becomes one larger than the previous largest one. No data appears in
the controls of this record except for a primary key control whose field property for
AutoValue is Yes.)

* Save record: Click this icon to save data that has been typed into one or more controls. The
data entered is saved to the table.

* Undo data entry: If you have made some entries but have not saved them, you can click
this icon to remove all the entries you have made in the present record since the last time
the record was saved.

* Delete record: Click this icon if you want to delete the data from all of the controls in the
present record. This will remove data that you just entered as well as the data that had
been saved earlier. (A window appears requiring you to verify that you want to delete the
data from all the controls of the present record.)

Caution Be very careful when clicking t_he Delete record icon. This is equival_ent to deleting a
row from a table. Only do this if you are absolutely sure that you will no longer need
A the data that you are deleting. The present record no longer exist in the form, and
the corresponding row of the underlying table also ceases to exist.
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Some of these tools in the Form Navigation toolbar serve other purposes. When
active, these tools can be used to save data typed into a record:

* First record
* Previous record

Tip * Next record
* Lastrecord
* New record
* Save record
Caution When records are saved, they are written to the underlying table. However, this is

done in the computer's memory (RAM). Only when the database is closed is the
A data written to the Base file (.odb). As long as you are not entering a large quantity
of data to your database between closing it, you should not have a problem.

Entering data in a new record requires only a few individual steps.
1) Click the New record icon to create a new record. (The cursor appears in the first control.)
2) Type the data into the first control.
3) To move to another control:
. Use the Tab or Enter key to move to the next control.
. Use the Shift+Tab key to move to the previous control.
4) Type the data into the control to where you have moved.
5) Repeat steps 1-4 to enter the data into the record.
6) After typing data into the last control, use the Tab or Enter key to save the data and create
another new record.
Removing or modifying data from an individual control:

1) Go to the record that contains the data to be deleted or modified using the first, previous,
next, or last record arrow.

2) Click the field (box) that contains the data you want to change.
3) Delete or modify the data.
4) Save the record.

Practice exercise
1) Create five more records in the form using the data in Tables 8 and 9 below.

2) Modify the following records with the data given:
a) Change the appraised value for the piano from 6000 to 5700.
b) Delete the Description for the WiFi. (802.11g is not needed.)
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Table 8: Data for first six controls

Item Room Description SerialNumber Manufacturer | Model
Number
Dishwasher Kitchen built-in GE4581839315 General Electric | GE456ee781
Refrigerator Kitchen side by side HP4865818634 Hot Point SBS44588F19
90
Stove Kitchen counter top 456789123258 Whirlpool WP5748we84
w/built-in oven
TV Den 19" Digital MOT123456789 | Motorola MOT57dde85
ready 815
WiFi modem | Computer | 802.11g CGNC1H111980 | Linksys WRT54GS V7
compatible

Table 9: Data for last seven controls

Place Date Purchase | Appraised | Insured Notes Inventory

Purchased Purchased | Price Value ID

Lowes 04/20/99 450.95 250 TRUE 5 cycles 6

Brothers 12/16/90 1599.99 528 TRUE 7

Appliances

Sears 12/30/99 899 452 TRUE oven built- | 8
in

Sanders TV & | 03/31/09 249.99 143 TRUE 9

Repair

Webster's 04/22/04 35.99 20 TRUE 4-RJ45 10

Computers

Deleting records in a form

This can be done fairly quickly once the specific record to be deleted is located. You click the
Delete record icon in the Form Navigation toolbar and then click the Yes button in the message:
You intend to delete 1 record. If you click Yes, you won't be able to undo this operation. Do
you want to continue anyway.

Practice exercise:

Delete the record for the WiFi modem. While you are at it, add a new record for the WiFi modem.

Queries: using the Query Wizard

The query is used to obtain information from the database and present it in a useful way. Search
conditions are applied to the database data to limit it to the specific data we are wanting. We can
do this using the Query Wizard for simple queries using a single table. The Query Design dialog is
designed for the more complex queries using multiple tables. It is discussed in Chapter 5, Queries,
of the Base Guide.
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Query example
When we are sick, we go to a doctor who gathers data about our condition.

The medical tests your doctor has ordered is a database (data source). The
knowledge the doctor has from training and education is another database. A
diagnosis is a query of his training and education databases for what matches the
symptoms you have: the doctor seeks this information. This query will also suggest
that some other symptoms may be present. The doctor searches your medical tests
for them: another query.

Query
A query is a search of the database to locate specific types of information.

Some of this information may be what has been entered. We may want to know the appraised
value of the items in the Living Room. This produces a query whose output is a detailed list. A
guery can also manipulate the data to obtain desirable information. For example: Based upon
the appraised values of the individual items, what is the total appraised value of the entire
inventory? This produces a single cell containing the total appraised value of the inventory.

Detailed query
A query that produces a detailed list as its output. The data in this list are part of the data
contained in the database. The list consists of one or more rows.

Summary query
A query that manipulates database data to produce its output. Unless the summary query is
group, its output will contain only one row and each column will contain manipulated data.

Three tools are available to help you to work with your data to get the information
you need. One is the View located in the Table section of the database. This tool
Tip allows you to view selected data. Another is the Query, which allows you to both
view and manipulate selected data. Finally, you can use the Report to create a text
document that uses a table, view, or query from the database for its information.

Plan the query

Creating a query is similar to solving a word problem in basic algebra. Doing either one of these
requires asking questions, finding the answers, and then using the answers to solve the problem.

As when creating a table, some thinking needs to be done about the purposes of the query before
creating it. Questions based on them should be asked, questions based upon the eight steps that
the wizard uses. It is best to ask the questions before using the wizard. Then you have the
answers you need to make your selections in each of the steps.

Steps 5 and 6 are for summary queries that groups the information you seek. While
Note an example of one of these is given, the detailed discussion of them is in Chapter 5
of the Base Guide.
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Query Wizard

Steps Select the fields (columns) for your query
1. Field selection Tables
2. Sorting order able: Household Inventory 3
3. Search conditions ) ) ; -
: y Available fields Fields in the Query:
4. Detail or summary ; — T
: i (ltem c
5. Grouping Room
6. Grouping conditions Description
— SerialNumber >
s |Manufacturer
8. Overview ModelNumber >>
PlacePurchased
DatePurchased
PurchasePrice
|AppraisedValue g
[Insured
Motes
InventorylD hd |
Help < Back Next > FEinish Cancel

Figure 224: Query wizard Step 1

Step 1. Field Selection:

* What table or query contains the fields the query needs?

* What fields are needed?
Step 2. Sorting order:

* What fields will you use to sort the query output?

* Will the sorting for a give field be ascending or descending?
Step 3. Search conditions:

* What fields need to have conditions added to them?

* What are the specific conditions?
Step 4. Detailed or Summary:

¢ Do you want the output to be a detailed list or a summary of selected database data?
Step 5. Grouped by:

* (No selections are available for this step. Instead the selection in Step 2 is used.)
Step 6. Grouping conditions:

* (No selections available for this step. Instead the selection in Step 3 is used.)
Step 7. Aliases:

* What fields should have their names modified?

* What should the modifications be?
Step 8. Overview:

* In the Overview window, what does not match what you wanted?

* What should the name of the query be? (Base suggests a name.)

* Do you want to display or modify the query? (The latter is discussed in Chapter 5, Queries,
in the Base Guide.)
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The importance of these questions should become clearer when you create two sample queries
using the Household Inventory database (detailed and summary). First we will explain what needs
to be done for each of these eight steps.

Create the query

To do this, we begin with the main database window open.
1) Click the Queries icon in the Database section.
2) In the Task section, click Use Wizard to Create Query. The wizard opens.

Select the fields (columns) for your query

Tables
Table: Household Inventory

Available fields Fields in the Query:
CategorylD 8

AppraisedValue
DatePurchased
Description
Insured

Item
Manufacturer
ModelNumber
Notes
PlacePurchased
PurchasePrice

Room
SerialNimhar »

Ilﬂg
:

1 2 3 4 56

1| Move selected field to the right | 4| Move all fields to the left

2| Move all fields to the right 5| Move selected field up

3| Move selected field to the left 6| Move selected field down

Figure 225: Selection of fields in a query

Step 1: Field selection
1) Click Tables: Select the table or query to be used from the Table list.
2) Select the fields to be used from the Inventory table.
3) Click one that is in the Available fields list.
Click the right arrow to move it to the Fields in the Query list.
4) Change the order of the fields in the Fields in the Query.
Click the name of the field you want to move.
Use the up arrow to move it higher in the list, or the down arrow to move it lower.

5) Rearrange the order of fields if necessary (AppraisedValue, then Purchase Price, then
Room).
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Step 2: Sorting order

Select the sorting order
Sort by
- @ Ascending
HouseholdIinventory.AppraisedValue v
3 Descending
Then by
@ Ascendin
- undefined - e - -
> Descending

Figure 226: Sorting order selection

Select the field to be used for sorting the information you want.
1) Open the Sort by drop-down menu by clicking the box labeled Undefined.
2) Click the field's name in this drop-down list to select it.
3) Select Ascending or Descending as the order of the sorting.
4) Click Next.

Step 3: Search conditions

Select the search conditions

& Match all of the following
O Match any of the following

Fields Condition Value

HouseholdInventory. Ap|~ | |is greater than v 50

Figure 227: Selecting the search conditions

Define the search conditions that will be applied to the query data.
1) Select the field in the Fields drop-down list in the top row.
2) Select the first condition from the Condition drop-down list.
3) Enter the value in Value.

4) If additional conditions should be defined, follow steps 1-3 in the succeeding rows of
Fields, Condition, and Value.

5) If you have selected multiple conditions,

. If you want all of the data to match all conditions in your query output, select the
Match all of the following option button.

. If you want any individual datum (singular of data) to match any of the selected search
conditions, select Match any of the following option button.

6) Click Next.

Two examples of a query with multiple search conditions: the last name must be Smith and the city
must be Selma; and the last name can be Smith or Jones.

For the first example, you need two rows. Select Last Name in Fields; for Condition, select is equal
to; and enter Smith in Value. For the second row, enter City in Fields; for Condition, select is equal
to; and enter Selma in Value. When this query is run, the only rows in the output will be those
containing Smith in the Last Name field and Selma in the City field.

For the second example, you also need two rows. Select Last Name in Fields; for Condition, select
is equal to; and enter Smith in Value. For the second row, select Last Name in Fields; for
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Condition, select is equal to; and enter Jones in Value. With this query, the only rows in the output
will be those containing either Smith or Jones in the Last Name field.

Step 4: Detailed or Summary
This is where you define whether the query is detailed or summary.

¢ Click Next.

Select the type of query

& Detailed query (Shows all records of the query.)
> Summary query (Shows only results of aggregate functions.)

Aggregate functions Fields

| JN J

Steps 5 and 6: Group by and Grouping conditions

Grouping is only used with summary queries. Because of the very limited applications of these two
steps, only an example will be given of a summary query with grouping. Chapter 5, Queries, in the
Base Guide includes examples and detailed instructions about summary queries with grouping.

¢ Click Next.

Step 7: Aliases

Alias
A name given to a field, table, or expression that can be used instead of a name it already has.

In everyday life, people are given nicknames. Sometimes they are a shorter version of the given
name, and sometimes they are quite different.

An alias is similar to a nickname. For example, the name of suggested fields in the table wizard are
often two or more words that have been combined into one word. At this point you may wish to
create aliases that have these names divided into their original words or changed to something
more meaningful.

Summary gueries are a good place to use aliases. For example, we want the total appraised value
of our furnishings. The name for this, without any changes, is SUM(“AppraisedValue”). We could
use the alias: Total Appraised Value. More complex summary queries can have names that are
rather involved, and an alias is recommended.

¢ Click Next.

Step 8: Overview

Figure 228 shows the overview of a query. It contains three parts: naming the query, what will be
done next after the query is created, and an overview of the selections made using the wizard.

You should enter what you want to call the query in the Name of the query text box. The
suggested name combines Query with the name of the table used in the query using an underline.

Do not use the name of the table as the name of the query as well; doing so will cause an error
message. Because tables and queries can be used when creating queries, forms, and reports, a
name for a table or query can be used only one time to prevent selecting the wrong one if duplicate
names are allowed.
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Query Wizard

Check the overview and decide how to proceed

Name of the query How do you want to proceed after creating
|Query_HDusehDId Inventory] | LECLER
+= Display Query
Modify Query
Overview
Fields in the Query: Item (Household Inventory.ltem), Appraised Value [~

(Household Inventory Appraisedvalue), Place Purchased (Household
Inventory.PlacePurchased), Purchase Price (Household
Inventory.PurchasePrice)

Sorting order: Appraised Value (ASC)
Search conditions: Appraised Value is greater than 50
MNo Groups were assigned.

Mo grouping conditions were assigned.

Figure 228: Overview of a query

You have two choices after closing the query wizard: display the query results, or modify the query.
The first choice runs the query to give you an output. The second choice opens the Query Design
dialog. Because the second choice leads to something that is beyond the discussion of this
chapter, do not change the default setting (Display Query).

Like the naming of the query, the overview list is rather important. It contains three pieces of
information that we need to verify matches what we originally wanted in the query.

There are four fields in the query, all from the Household Inventory table: Item, AppraisedValue,
PlacePurchased, and PurchasePrice. These have been given the aliases Item, Appraised Value,
Place Purchased, and Purchase Price respectively.

Verification: Household Inventory is the correct table, the listed fields are the correct fields, and
the alias are also correct.

The field, Appraised Value, is the field that will be used for sorting, and the direction of the sort is
ascending (from the least value to the greatest). (The alias, Appraised Value, is used in place of
the field name, AppraisedValue.)

Verification: This is the correct field, and the sorting is in the correct direction.

The search condition applies only to Appraised Value and it restricts its values to $50 or more. Any
items worth less than or equal to $50 will not be shown when the query is run.

Verification: This is the correct field, and the search condition is also correct.
Verification: Since none of the fields are manipulated, we have a detailed query. This is correct.

If this were a query that we wanted to use, we would click the Finish button. The query wizard
would close, and a Table Data View dialog would open with the query output.
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Detailed query example

We want a listing of our inventory containing the following information about each item: the name
of each item, its appraised value, the date purchased, and the place purchased. Furthermore, we
want the list to contain only those items whose appraised value is greater than $50. We also want
the information to be sorted using the appraised values of the items.

Create a query using the wizard by following the instructions in the eight steps above. Name the
query: Query_Household Inventory. When you get to step 8 of the wizard, it should look like the
figure below. Try to do all of the eight steps before referring to this figure to compare your work with
it.

When you click the Finish button, the query wizard closes and the Query_Household Inventory-
Inventory-LibreOffice Base: Table Data View dialog opens with the output for the query. (See
Figure 229.) All of the items have an appraised value greater than $50. The WiFi modem is not part
of the output because its appraised value is less than $50. If an item in the inventory had an
appraised value of $50, it would not be in the output either.

Check the overview and decide how to proceed

Name of the query How do you want to proceed after creating
|Query_HDusehDIdlnvemDry I
= Display Query
Modify Query

Overview

Fields in the Query: ltem (Householdinventory.ltem), Appraised Value
(Householdinventory . AppraisedValue), Date Purchased
(Householdinventory.DatePurchased), Purchase Price
(Householdinventory.PurchasePrice)

Sorting order: Appraised Value (ASC)

Search conditions: Appraised Value is greater than 50

Mo Groups were assigned.

Mo grouping conditions were assigned. |

x | _lao] Query_Householdinventory - Inventory - LibreOffice Base: Table Data View

File Edit WView Insert Tools Window Help

S wF- R R v
Item Appraised Value Date Purchased Purchase Price

B [painting :75.00 os/ovo7 100.00
] Keyboard 75.00 05/16/08 90.00
] table 125.00 10/19/67 825.00
LTV 143.00 03/31/09 249.99
M icrowave 145.99 08/30/11 145.99
] chair 146.00 11/15/00 299.99
] couch 200.00 02/28/00 399.99
] bed 230.00 09/10/77 1199.99
____ |Dishwasher 250.00 04/20/99 450.95

Figure 229: The Table Data View for this query
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Summary query example

For this example query, what you want to know is this: What is the total purchase price and
appraised price for the contents of each room in our inventory? The output should be in
alphabetical order by Room. Finally, only the totals that exceed $500 in a given room should be
shown.

This requires grouping the values for these two fields by room. Then the SUM function is applied to
the values of these two fields for each group.
Step 1: Field Selection.

1) The table will be Household Inventory.
2) Select these fields from it: PurchasePrice and AppraisedValue.
3) Click Next.

Select the sorting order

Sort by

Household Inventory.Room * Ascending

L]

Descending
Then by

- undefined - * Ascending

L]

Descending

Step 2: Sort Order.

1) Select the field, Room, as the one to sort by.
2) Select Ascending as the direction of the sort.
3) Click Next.

When you create a summary query with grouping of the results, enter the field by
which the grouping is done in Step 2 instead of Step 5.

When the summary query also contains a restriction on the values for each group,
use Step 3 to do this instead of Step 6.

Tip

Select the search conditions

+ Match all of the following
Match any of the following

Fields Condition Value

<
)]
=]

=3

Householdinventory.Rot 2 is greater than

Fields Condition Value

~

o is eqgual to

<>
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Step 3: Search Condition.

1) Select Room as the Fields.

2) Select is greater than as the Condition.

3) Enter 500 as the Value.

4) Since there is only one condition, Match all of the following (Default) is appropriate.
5) Click Next.

Step 4: Detailed or Summary.

Select the type of query

Detailed query (Shows all records of the query.)
+ Summary query (Shows only results of aggregate functions.)

Aggregate functions Fields

Household Inventory.Purchas: 2

<>

get the sum of

L]

get the sum of Household Inventory.Appraise

1) Selectthe Summary query (Shows only results of aggregate functions.)
2) Aggregate functions
a) Click the arrows at the right end of its drop-down list.
b) From this list, select get the sum of.
Cc) From the Fields dropdown list, select Household Inventory.PurchasePrice
d) Click the plus (+) button to reveal a second row of drop-down lists.
e) From the Aggregate functions drop-down list, select get the sum of.
f) From the Fields dropdown list, select Household Inventory.AppraisedValue.
3) Click Next.

Steps 5 and 6. (These are not used by the wizard, which uses Steps 2 and 3 instead.)

* Click Next in Step 5 and then in Step 6.

Step 7: Aliases.
1) Change PurchasePrice to Purchase Price.
2) Change AppraisedValue to Appraised Value.
3) Click Next.
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Assign aliases if desired

Field Alias
Household Inventory.Room ‘Room |
Household Inventory.PurchasePrice ‘Purchase Price |

Household Inventory Appraisedvalue ‘Appraised Value |

Step 8: Overview.

1) Name the query Household Inventory Summary.
2) Display the query after closing the query (Default selection).
3) Check the Overview:
a) The table used is Household Inventory. (Correct)
b) The fields used are Room, PurchasePrice, and AppraisedValue. (Correct)

c) The Sorting order is Room. (This is really the field by which the data will be grouped
because we are creating a summary query.)

d) The Searching conditions is Room is greater than 500. (Correct) (This is really the
grouping condition because of the limitations of the wizard.)

To close the wizard and display the query in a Table Data View dialog, click Finish.
Check the overview and decide how to proceed

Name of the query How do you want to proceed after creating
the query?

Household Inventory Summary

* Display Query
Modify Query
Overview

Fields in the Query: Room (Household Inventory.Room), Purchase Price
(Household Inventory.PurchasePrice), Appraised Value (Household
Inventory. Appraisedvalue)

Sorting order: Room (ASC)

Search conditions: Room is greater than 'S00°

Grouped by: Room

Mo grouping conditions were assigned.

Reports: use wizard to create reports

Reports present information found in the database in a useful way. In this respect they are similar
to queries. Reports are generated from the database’s tables or queries. They can contain all of
the fields of the table or query or just a selected group of fields. Since the data that concerns us is
contained in a query, we will use that.

Reports can be static or dynamic. Static reports contain the data from the selected fields at the
time the report was created. Dynamic reports can be updated to show the latest data. If you are
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sure that data for your report does not change with time, creating a static report is a good choice. A
report of your inventory’s total appraised value for the year 2008 is an example of a static report. (It
is very unlikely that the data for 2008 will change.) But a similar report for your insurance agent for
updating your policy needs to be a dynamic report. This report needs to contain any purchases
made since the last report was made. When you purchase or replace an item, this report can tell
you whether you even need to contact your agent or not.

The report that we will create, is based upon Query_Household Inventory. We will look for all items
listed in this query.

Follow these steps to create a report.
Step 1: Open the Report Wizard. (See Figure 230.)

1) Inthe main database window, click the Report icon in the Database section.

2) In the Task section, click Use Wizard to Create Report. (The Report Wizard opens with
the Report Builder opening in the background.)

As you go through the steps of the Report Wizard, use the mouse to move it so that

Tip you can see what effects your selections in the wizard have on the Report Builder.

Under Tables or queries, a drop-down list contains the tables and queries you have created.

Report Wizard
Which fields do you want to have in your report?

Tables or queries
Query: Query Household Inge

Available fields Fields in report
Appraised Value

Item

Date Purchased —

Purchase Price

1 2 3

1 | Move available fields to the right 3 | Change order of report fields
2 |Move report fields to the left

Figure 230: Report Wizard field selection

Step 2: Select the table and its field for the report.

1) Select Query_Household Inventory from the Tables or queries drop-down list.

2) Move the list of Available fields to the list of Fields in report using the double right arrow
button.
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3) If you want to change the order of the fields in the Fields in report list, click the field you

want to move up or down in this list. Click one of the arrows (#3 above) to move the field up
or down to where you want it.

The fields in your report should match the ones in the figure below.

Tables or queries

Query: Query_Household Im

Available fields Fields in report

Appraised Value
Item

Date Purchased
Purchase Price

<<

Step 3: Labeling fields.

Here you can give aliases to one or more fields. The report suggests using the name of the fields
of the query. If you have added the aliases you wanted when creating the query, you will not have

to make any changes in this step. If, however, you want to make some changes, now is the time to
make them.

1) Review the suggested labels for the fields. Change them if you think your name is better.

2) Remember to use the vertical scrollbar if all of the fields are not visible, and then review the
rest of the suggested labels.

We added aliases for these fields in the query earlier: AppraisedValue, DatePurchased, and
PurchasePrice. So, the report will use the aliases of the query instead: Appraised Value,
Date Purchased, and Purchase Price respectively.

3) Click Next.
Step 4: Grouping.
Report Wizard

Do you want to add grouping levels?

Fields Groupings
Appraised value Date Purchased
ltem

1) Click Date Purchased in the Fields list.
2) Click the right arrow button to move it to the Groupings list.
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3) Make sure your lists match those in the figure above. If a field is in the wrong list, select it
and use the right or left arrow button to move it the correct list.

Step 5: Sort options.

According to which fields do you want to sort the data?
Sort by
(# Ascending
Date Purchased ot
(" Descending
Then by
— Ascendin
- undefined - i ® - g
] (" Descending

By selecting how the report should group the data, we have already selected the field, Date

Purchased, as the first sort option. We want the field’s sorting order to be ascending. No more
fields will be used in the sorting.

1) If you want to sort by more fields of the report, do so now.
a) Click the drop-down list below Then by to open the list.
b) Select the field you want to use to sort the report by. This sorting will be in addition to

the sorting by the Date Purchased field.
2) Click Next.
Step 5: Choose layout.

Report Wizard

How do you want your report to look?

Layout of data Layout of headers and footers

Columnar, single-column
Columnar, two columns
Columnar, three columns
In blocks, labels above
In blocks, labels left

Orientation
+ lLandscape

L]

Portrait

Page orientation can be either Landscape or Portrait. Which one you use depends upon the
number of fields contained in the report. For a large number of fields in the report, use the
Landscape orientation. For a smaller number of fields, Portrait will probably be the best selection.
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To see each of the data layout choices, move the Report Wizard so you can see the layout in the
Report Builder. Then select the layouts one at a time while observing what happens in the Report
Builder.

1) Select the Layout of data that meets your needs. For this example, select Columnatr, three
columns.

2) Select the Orientation for your report. For this example, select Portrait.

3) Click Next.

= Date Pu...

& Detail
Figure 231: Report Builder layout for the selections above
Step 6: Create report.
Report Wizard
Decide how you want to proceed

Title of report

|Rep0ri|_Househ0ld Inventory

What kind of report do you want to create?

Static report
= Dynamic report
How do you want to proceed after creating the report?

Modify report layout
¢+ Create report now

Name the report. The suggestion given is Query Household Inventory. This is the same name as
the query we used to create this report. Change Query_Household Inventory to Report_Household
Inventory.

You can create two types of report: static or dynamic. A static report is a Writer document which
can be modified like any text document, but any changes in the data in the underlying query will
not change the report. A dynamic report is much more flexible. Changes in the data of the
database will change the report the next time the report is run.

The Report Builder can also be used to modify the fields of the report. For example, the date
format for the Date Purchased can be changed and the Report saved. The next time the Report is
run, the data in this field will have the changed format. In a static report, you would have to change
the date format for each place this field appears in the report.

The final selection involves what should happen next. Selecting Modify report layout will open the
Report Builder so that the report can be edited. This is beyond the scope of this chapter. (See
Chapter 6 for how to use the Report Builder.) So, use the Default choice, Create report now.

Click Finish.
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Date Purchased 10/19/67
Appraised Value 125.00 [Item table Purchase Price 825.00

Date Purchased 09/10/77
Appraised Value 230.00 liem bed Purchase Price 1199.99

Date Purchased 12/16/90
Appraised Value 528.00 liem Refrigerak Purchase Price 1599.99

Date Purchased 01/02/96
Appraised Value 789.00 Item cauch Purchase Price  1499.99

Figure 232: Top portion of the report

Figure 232 shows that sometimes the report needs to be edited once created. The layout did not
allow enough room for the word Refrigerator, and the space allowed for the field label Item is wider
than it needs to be. The data format might be changed as well, and this might require a change in
the length of this field. The fields containing currency amounts should be modified to the currency
being used in the Inventory database.

Mixing Base with the rest of LibreOffice

Base can be used alone or be used with other components of LibreOffice. Your choice depends on
what you want to do with the information in the database.

This section mentions a few ways in which Base can be used with the other components of
LibreOffice. Chapter 7, Exchanging Data, in the Base Guide, as well as the individual guides for
the other components of LibreOffice, contain instructions how to do this.

Writer

One very common database is the address book. Base will connect to several of them. Using
Writer with Base, you can print envelopes using the postal addresses in the address book and you
can send an email to several people in the address book at one time. This process is called mail
merge. It is explained in Chapter 11, Mail Merge, of the Writer Guide.

To include in a Writer document data that exists in one of our databases. we could look up the data
and type it into the document, but we might make a mistake in typing. By using Base with Writer,
we can place a field linked to the desired data in the document. Doing it this way guarantees the
data shown in the document will be as accurate as the data in the corresponding database. This is
explained in Chapter 14, Working with Fields, of the Writer Guide.

Using Writer, tables in text documents can be copied into a table in a database. A new table can be
created in the database including the data in the text document table. Or, a new table can be
created in the database without any data. Or, if the data in the table is arranged properly, this data
can be added to an existing table of a database. This is discussed in Chapter 7 of the Base Guide.

Calc

Base and Calc work together well. Using F4 or View Data Sources in Calc opens the Data
window. Data and column names can be copied from the data source to the spreadsheet that is
open in Calc. Data can also be copied from the spreadsheet to the data source. These methods
are discussed in the Calc Guide and in Chapter 7 of the Base Guide.
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Once the data has been copied from the data source to the spreadsheet, you can apply all of the
available Calc functions to the data, including creating charts from the data. This is also discussed
in the Calc Guide and in Chapter 7 of the Base Guide.

There are different ways to use the data in a spreadsheet as a data source. One way is to create a
Base file to connect to the spreadsheet. A second way is to save the spreadsheet using the .dbf file
format. This is the file format used by dBase. Base will open this file format. This is discussed in
Chapter 7 of the Base Guide.

Impress

Base and Impress are not directly used together, but they can be used together in an indirect way.
Calc spreadsheets can be inserted into slides. So when you want to use data from a database in a
slide, you first copy the data into a spreadsheet and then insert this spreadsheet into the slide. This
is discussed in Chapter 7, Inserting Spreadsheets, Charts, and Other Objects, in the Impress
Guide.

Using Base with other data sources

Base can be used with a variety of data sources, including Oracle, Groupwise, Evolution (LDAP

and Local), KDE Address Book, Thunderbird/Icedove Address Book, Spreadsheet, dBASE, Text,
MySQL, and Postgresgl. Also included are the data sources which Base can access using JDBC
(java database connectivity or ODBC (open database connectivity).

You can connect Base directly to some of these data sources (text files and spreadsheets) by
making only a few selections in the Base Wizard. Chapter 7 of the Base Guide contains
instructions for how to work with these data sources.

Base requires a special driver to connect to some data sources. PostgreSQL, MySQL, JDBC, and
Oracle JDBC are examples of these data sources. Chapter 7 of the Base Guide discusses how to
connect to these database sources as well as how to work with them.
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What is Math?

Math is LibreOffice’s component for writing mathematical and chemical equations. It is most
commonly used as an equation editor for text documents, but it can also be used with other types
of documents or stand-alone. When used inside Writer, the equation is treated as an object inside
the text document.

The equation editor is for writing equations in symbolic form, as in equation 1, below.

Note If you want to evaluate a numeric value, see the Calc Guide.

=In(x)+tan*(x?) (1)

or
o
NH,+H, O =NH}+OH

Getting started

You can create an equation (formula) as a separate document or insert it into a document in Writer
or another component of LibreOffice.

Creating an equation as a separate document

To create an equation as a separate document, open the Math component of LibreOffice using one
of these methods:

* On the Menu bar, choose File > New > Formula.

* On the Standard Toolbar, click the triangle to the right of the New icon and choose
Formula.

* From the Start Center, click Math Formula.
An empty Math document opens (see Figure 233).

@ - 0 Untitled 1- LibreOFffice Math
File Edit View Format Tools Window Help

B-B-0= @& @ aags [i=

|Unary/Binary Operators

+J - =

Fd

0+0 0-0 00
OxO OO f
O-0 O/a Q.0
0 O

Y ob

-d daQ QvQa

[ - s + | 100%

Figure 233: An empty Math document
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The upper area on the right is the preview window, where the equation will appear during and
after input. The lower area on the right is the equation editor, where the markup code for the
equation is entered. On the left is the Elements Dock.

Inserting a formula into a Writer document

To insert a formula into a Writer document, open the document and then choose Insert > Object >
Formula from the Menu bar.

The formula editor opens at the bottom of the Writer window. You will also see a small box with a
gray border in your document, where the formula will be displayed. Depending on your setup, the
Elements Dock or the Elements window may also appear.

When you are done entering the formula, you can close the editor by pressing the Esc key or by
clicking an area outside the formula in the main document. A double-click on the box will open the
editor again, so you can edit the formula.

Formulas are inserted as OLE objects. In a Writer document, the formula is anchored as a
character, so it is embedded in the continuous text. You can, as with any other OLE object, change
the anchor and make the formula floating. In Calc, Impress and Draw documents, formulas are
embedded as floating OLE objects.

If you frequently need to insert formulas, you may wish to add the Formula button to the Standard
toolbar or create a keyboard shortcut. See Chapter 14, Customizing LibreOffice, for more
information.

Entering a formula

The equation editor uses a markup language to represent formulas. For example, %beta creates
the Greek character beta ( ). This markup is designed to read similar to English whenever

. . a
possible. For example, a over b produces a fraction: b

You can enter a formula in three ways:
* Select a symbol from the Elements Dock or Elements window.
* Right-click on the equation editor and select the symbol from the context menu.
* Type markup in the equation editor.

The context menu, the Elements Dock, and the Elements window all insert the markup
corresponding to a symbol. This provides a convenient way to learn the LibreOffice Math markup.

Click on the document body to exit the formula editor.

el Double-click on a formula to enter the formula editor again.

Elements Dock

The simplest method for entering a formula is by using Elements. By default, an Elements Dock is
visible at the left of the equation editor when first opening Math. If a greater area is needed to
display the preview window or equation editor, the Elements Dock can be hidden with View >
Elements Dock.

The Elements Dock is divided into two main parts.
* The drop-down list at the top of the Dock shows symbol categories.

* The symbols are displayed beneath the drop-down list. These symbols change according
to the category selected.
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B-EB-0o @&
\Unary/Binary Operators |

Unary/Binary Operators
Relations A
Set Operations

Functions

Operators

Attributes

Brackets

Formats

Others

Examples
Tl

-0 /a 04d-Q

Ja oY

-0 Qa0 Qw0

Figure 234:Selecting a category in the Elements Dock

Example 1: 5x4
For this example we will enter a simple formula: 5x4 . On the Elements Dock:

1) Ensure the Unary/Binary Operators category is selected in the drop-down list (see Figure
234).

2) Click the multiplication symbol (see Figure 235).

|Unary/Binary Operators

+ - +[]

- |

FO

0+0 0-0 Q0
Ox0 0«0
N

)

D -

g Multiplication (x

7o oY

-0 OaAQ0 OvA

o0

Figure 235: Selecting the multiplication symbol

When you select the multiplication symbol, two things happen:
* The equation editor shows the markup: <?> times <?>
* The body of the document shows a gray box like this: [L1Xx ]
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bl times <7>

£ i 100%

Figure 236: Result of selecting the multiplication symbol

The <?> symbols shown in Figure 236 are placeholders that you can replace by other text, for
example 5 and 4. The equation will update automatically, as shown in Figure 237.

When you add a formula, reserved placeholders are indicated by squares in the
Tip formula and <?> in the command window. You can navigate through these
placeholders using F4 and Shift+F4.

Ti To keep the equation from updating automatically, select View > AutoUpdate display
P to deselect it. To update a formula manually, press F9 or select View > Update.

ox 4

5 times 4

£ . 100%

Figure 237: Result of entering 5 and 4 next to the times operator

Elements window

Elements can also be accessed in a separate floating window. To display the Elements window, go
to View > Elements.

The Elements window operates in a similar manner to the Elements Dock and is also divided into
two main parts (see Figure 238).

* The upper area shows the symbol categories. Click on these to change the list of symbols.
* The lower area shows the symbols available in the current category.
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& Elements

%usb asd i 2a

N a —— Categories
N Ol J

+d -4 4 Fa4a -d

a+b a-b axb axb asb

—— Symbols
a-b % azb a/b avb Y

aab

Figure 238: The Elements window

Right-click (context) menu

Another way to access mathematical symbols is to right-click on the equation editor. This pops up
the menu shown in Figure 239. The items in this menu correspond to those in the Elements
window, with some extra commands.

|
5 times 4 Al
' Unary/Binary Operators +a U
Relations . -a ‘
[ —— Set Operations ' +a - - |
Functions v -+3 3 ;
g +  100% |
———— Dge.ral:ors v 2ib e ]
Attributes v i
Brackets v S 6iokD
Others v 2l
aover b
adivb
a/b
acircb

awideslash b
a widebslash b

nega
aandb
aorb

Figure 239: Right-click (context) menu

Neither the window elements, nor the context menu contain a complete list of
commands. For some seldom-used commands, you must always enter the markup.
A complete list of commands can be found in the appendix of the Math Guide.
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Markup

You can type the markup directly in the equation editor. For example, you can type 5 times 4to
obtain 5x4 . If you know the markup, this can be the fastest way to enter a formula.

Tip The formula markup resembles the way the formula reads in English.

Below is a short list of common equations and their corresponding markup.

Display Command Display Command
a=b a=b Ja sqrt {a}
a’ an2 a, an
f f(x)dx int f(x) dx D a, suma_n
a<b a<=b 0 infinity
axb atimesb Xy x cdot y

Greek characters

Greek characters (a, ,y,0 , etc) are common in mathematical formulas. These characters are
not available in the Elements window or the right-click menu. Fortunately, the markup for Greek
characters is simple: Type a % sign followed by the name of the character, in English.

* To write a lowercase character, type the name of the character in lowercase.
* To write an uppercase character, type the name of the character in uppercase.
* To write in italic, just add an i between the % sign and the name of the character.

A complete table of Greek characters is provided in the appendix of the Math Guide. See the table
below for some examples.

Lowercase Uppercase Italic lowercase Italic uppercase
%alpha > « %ALPHA > A %ialpha > « %iALPHA > A
%beta > P %BETA > B %ibeta -» B %1BETA > B
%gamma - y %GAMMA > T %igamma - y %iGAMMA -» I
%psi > g %PSI > W %ipsi > wy %iPSI > W
%phi 2> @ %PHI > O %iphi 2> @ %iPHI > @
%theta - 0 %THETA > © %itheta » 0 %1iTHETA > @

Another way to enter Greek characters is by using the Symbols catalog window. Choose Tools >
Catalog. This window is shown in Figure 240. Under Symbol set, select Greek and double-click on
a Greek letter from the list. The markup name of the character is shown below the list window.
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® 0 Symbols

Symbol set —
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| Close
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alpha

Figure 240: Symbols catalog, used for entering Greek characters and special symbols

Example 2: © ~ 3.14159

For this example we will suppose that:
* We want to enter the above formula (the value of pi rounded to 5 decimal places).
* We know the name of the Greek character (pi).
¢ But we do not know the markup associated with the =~ symbol.

Step 1: Type % followed by the text pi. This displays the Greek character 7T .
Step 2: Open the Elements window (View > Elements).

Step 3: The = symbol is a relation, so we click on the Relations button. If you hover the mouse
over this button you see the tooltip Relations (Figure 241).

Figure 242 shows the Elements window after clicking the Relations button. The symbol we want is
circled.

2 Elements ® Elements
74 as& ash i) 2a T4, asb ash fry o

g elations g% i & (0 &

+04 -0 fa Fa -a a=b a=b axb alb alb
a+b a-b axb axb asb a<b a>ba||b alb
a-b % azb a/b avb asb azb a~b a=b
asb azb a=b aeb asb
Figure 241: Tooltip indicates the aeb as=b a=b

Relations button Figure 242: After selecting Relations

Step 4: Click on the a =~ b symbol. The equation editor now shows the markup
%pi<?> simeq <?>.
Step 5: Delete the first <?> text, then press the F4 key to move to the next <?> entry. Type

3.14159 to replace the <?> at the end of the equation. We end up with the markup %pi simeq
3.14159. The result is shown in Figure 243.
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m=3.14159

%pi simeq 3.14159|

Figure 243: Final result

Changing a formula
You can change a formula at any time. To switch into edit mode, double-click on the formula.

To get to the appropriate section in the markup code, do any one of the following:
* In the equation editor, click on the location.
* Select an area of the markup code that you wish to change.

* Click on an element in the preview area; the cursor will automatically move to the
corresponding point in the equation editor.

* Double-click on an element in the preview area; the corresponding section in the equation
editor will be selected.

To be able to work in the upper (preview) area in the stand-alone Math window (Figure 233), the
formula cursor must be activated. Use the Formula Cursor button on the Tools toolbar.

You can change an equation by overwriting selected text or by inserting new markup code at the
cursor position.

Formula layout

The most difficult part of using LibreOffice Math comes when writing complicated formulas. This
section provides some advice.

Brackets

Math knows nothing about order of operation. You must use brackets to state the order of
operations explicitly. Consider the following examples.

Markup Result Markup Result

2 over x + 1 g+1 2 over {x + 1} 2
X Xx+1

- 1 over 2 _—21 - {1 over 2} —%
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In the first example, Math has recognized that the 2 before and the x after the over belong to the
fraction, and has represented them accordingly. If you want x+1 rather than x to be the
denominator, you must bracket them together so that both will be placed there.

In the second example, Math has recognized the minus sign as a prefix for the 1 and has therefore
placed it in the numerator of the fraction. If you wish to show that the whole thing is negative, with
the minus sign in front of the fraction, you must put the fraction in brackets in order to signify to
Math that the characters belong together.

The braces belong solely to the layout of the markup code and are not printed. If you wish to use
braces in the formula, use the commands Ibrace and rbrace.

Compare the following examples:

Markup Result Markup Result
X X
x over {-x + 1 X over lbrace -x + 1 rbrace
{ } —x+1 [=x+1]}

Scalable brackets

For background, we start with an overview of the matrix command.

Markup Result

a b

matrix { a # b ## c # d } . d

Rows are separated by two # symbols and entries within each row are separated by

Note one #.

The first problem people have with matrices is that brackets do not scale with the matrix:

Markup Result
( matrix { a# b ## c #d 1} ) (gg)

Math provides scalable brackets. That is, the brackets grow in size to match the size of their
contents. Use the commands left( and right) to make scalable brackets.

Markup Result
left( matrix { a # b ## c # d } right) 2 3

Use left] and right] to obtain square brackets. The list of all available brackets is

Tip available in the appendix of the Math Guide.

These scalable brackets may also be used with any element, such as a fraction, square root, etc.
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Isolated and unpaired brackets

Math expects that for every opening bracket there will be a closing one. If you forget a bracket,
Math places an inverted question mark by the corresponding bracket. This disappears when all
brackets are matched. Sometimes forgetting a bracket causes the whole structure of the formula to
fall apart.

However, an unpaired bracket is sometimes necessary. In such cases, you have two options:

* With non-scalable brackets, use a preceding backslash \ to indicate that the following
character should not be regarded as a bracket but as a literal character. So the half-open
interval [a;b[ is represented by \[a;b\[ — try comparing this with [a;b[

* Scalable brackets can also be unpaired. The same half-open interval is represented by
left [ a; b right [

For scalable brackets, you can also use the command none to replace a non-existent paired
bracket.

Ix|= xforx=0
—x forx<0
can be represented by
abs x = left lbrace stack {x "for" x >= 0 # -x "for" x < 0} right none

Recognizing functions in Math

In the basic installation, Math outputs variables in italics. If you enter a function, Math usually
recognizes it and outputs it normally (a list of recognized functions is available in the Math Guide).
If Math fails to recognize a function, you can inform Math about it. Enter the markup code func
before the function, and the text that follows will be recognized as a function.

Some functions recognized by Math need to be followed by numbers or variables. If these are
missing, Math puts an inverted red question mark ¢ in their place, which you can only remove by
correcting the formula: enter a variable or a number, or a pair of empty braces { } as a placeholder.

Tip You can navigate through errors using F3 and Shift+F3.

Equations over more than one line

x=3
y=1

Your first reaction would be to simply press the Enter key. However, if you press the Enter key,

although the markup goes to a new line, the resulting equation does not. You must type the
newline command explicitly. This is illustrated in the table below.

Suppose you want to make an equation covering more than one line, for example:

Markup Result
X = 3 _3y=1
y =1 xRy
X = 3 newline X=3
y =1 y=1
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Continuing the calculation on a new line without writing a complete new equation is not directly
possible, because Math expects a term on the left hand side of an equals sign. You can substitute:

* Empty quotes "". This will automatically cause the line to be left-justified.
* Empty braces { }. The following line will then be centered.
* Spaces characters " or ~. The line will be centered with the spaces.

The alignment of equals signs under each other is described on page 278.

Additionally, spacing between elements in formulas are not set by space characters in the code.
You need to use special markup to add spaces: ~ (grave) for a small space, ~ (tilde) for a large
space. Another solution would be to add space characters between quotes, to be considered as
text. Space markup at the end of a formula are ignored by default.

How do | add limits to my suml/integral?

The sum and int commands (see complete list in the appendix of the Math Guide) can (optionally)
take the parameters from and to. These are used for lower and upper limits respectively. These
parameters can be used individually or can be combined.

Markup Result
sum from k = 1 to n a_k > a,
k=1

int from @ to x f(t) dt
or
int_0Ax f(t) dt

o’—,x

f(t)dt or f:f(t)dt

int from Re f ff
R

sum to infinity 2A{-n} 3o

How do | write a derivative?
Writing derivatives essentially comes down to one trick: Tell LibreOffice it’s a fraction.

In other words, you have to use the over command. Combine this with either the letter d (for a total
derivative) or the partial command (for a partial derivative) to achieve the effect of a derivative.

Markup Result
df
df} over {d oar
{df} over {dx} i
. : of
{partial f} over {partial y} E
. : oO°f
{partialnr2 f} over {partial tA2} pye
Note Notice that we have to use braces (squiggly brackets) to make the derivative.
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To write function names with primes, as is usual in school notation, you must first add the signs to
the catalog. Using single and double quotes is typographically ugly. See “Customizing the catalog”
on page 284.

Markup characters as regular characters

Characters that are used for controlling markup cannot be entered directly as normal characters.
The characters concerned are: %, {, }, &, |, _, A and ". So, for example, you cannot write 2% =
0.02 or 1" = 2.56cm. Two methods are available to overcome this limitation:

* Use double quotes to mark the character as text, for example 2"%"= 0.02. This is not
possible for the double-quote character itself.

* Add the character to the catalog. See the section “Customizing the catalog” on page 284.

In some cases you can use commands. For example:
* lbrace and rbrace give you literal braces {].

Conversion into a character entity as in HTML or the use of an escape character is not possible in
Math.

Text in a formula
To include text in a formula, enclose it in straight double-quotes:

abs x = left lbrace matrix {x # "for " x >= 0 ## -x # "for " x < 0} right none

x for x=0

X|=
X —x for x<0

All characters except double quotes are permissible in text. Unfortunately the Special characters
dialog is not available. If necessary, you can write the text in a text document and copy it into the
equation editor via the clipboard. In this way smart quotes can be inserted, as shown below.

'@ - o Untitled 1 - LibreOFfice Math
File Edit View Format Tools Window Help
H-2-H= @& B - @ 48 g& F »

The example shows so-called “curve sketching”.

"The example shows so-called “curve sketching”."|

b . 100%
Figure 244: Smart quotes included by copy and paste from Writer
Text is shown in the font that is selected from the Text list in the Fonts dialog (see “Changing the

font” on page 279). To select a font for the lower window of the equation editor, set the attribute
Serif, Sans or Fixed before typing the text.

By default, text is left-justified. You can change the justification with alignc or alignr.

Commands are not interpreted within text. Use quotes to break up the text if you wish to use
special formatting commands.
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"In " color blue bold "isosceles" " triangles, the base angles are equal"

In isosceles triangles, the base angles are equal

How do | align my equations at the equals sign?

Math does not have a command for aligning equations on a particular character, but you can use a
matrix to do this, as shown below.

Markup Result
matrix{
alignr x+y # {}={} # alignl 2 ## X+y = 2
alignr x # {}={} # alignl 2-y X = 2-y
}

The empty braces around = are necessary because = is a binary operator and thus needs an

expression on each side.

You can reduce the spacing around = if you change the inter-column spacing of the matrix:
1) With the equation editor open, choose Format > Spacing from the Menu bar.

2) In the Spacing dialog (Figure 245), click the Category button and select Matrices in the
drop-down menu.

3) Enter 0% for Column spacing and click OK.

g O Spacing

Spacing — |

Spacing how = —
Cancel

Line spacing 5% |- ¢l + b —

. - ks | Category ~ |

Root spacing 0% = e —
Default
Help

Figure 245: Changing spacing in a formula

Changing the appearance of formulas

Changing the font size

This is one of the most common questions people ask about LibreOffice Math. The answer is
simple, but not intuitive:

1) Start the formula editor and choose Format > Font size.
2) Select a larger font size under Base size (upper-most entry).
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% O Font Sizes

Basesize hz2pt > oK |

Relative sizes

Cancel
Texkt 100% -

Help
Indexes 60% | -

Default
Functions [100% | - b

Operators [100% |-
Limits 60% | -
Figure 246: Edit Base size (top) to make a formula bigger

The result of this change is illustrated in Figure 247.

Before: m=3 141359

After: m=3.14159

Figure 247. Result of changing the base font size

The change in font size applies only to the current formula. To change the default

font size, click on the Default button and then OK. A change in the default font size

might, for example, make your work easier when you are preparing a big

presentation and want all the formulas in it to have a base size of 28pt—but do not
Note forget to set the font size back to its original value when the work is finished.

Warning: this will modify only the current formula and future formulas you write. To

modify existing formulas in the document, you need to use a macro (see section
about macros in the Math Guide).

The size of a subset of characters in a formula may be modified using the size command. For
example: b size 5{a} givestheresult b..Inthe context menu (see Figure 239, above), the
Attributes listing gives the size command. The value just after size may be absolute (numeric
value) or relative to the context (base size by default): for example, +6, -3, /2, or *2.

Changing the font
The fonts used in formulas can be changed using Format > Fonts.

The Formula fonts section of the Fonts dialog (Figure 248) refers to the four specified formula
elements. The font for operators, relationships and brackets is not affected, as these elements
normally come from the OpenSymbol font. Similarly elements from the catalog (see “Customizing
the catalog” on page 284) continue to be displayed in the font specified there.
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& 0O Fonts

Formula Fonts ? |
. ok |

Variables

Functions |Liberation Serif = Cancel
Numbers |Liberation Serif B | Modify ~ |
Text |Liberation Serif =| | Help
Custom fonts L Default J
Serif |Liberation Serif i

sans |Liberation Sans S |

Fixed |Liberation Mono e |

Figure 248: Fonts dialog

The Custom fonts section determines which font will be used when the attribute font serif, font
sans or font fixed is specified.

To change a font, first click on Modify and choose the type of entry you wish to modify. The Fonts
dialog opens, showing all the fonts available on your system.

& O Fonts

Fonkt ' oK |

Liberation Serif

Liberation Sans - | Cancel |
Liberation Sans Narrow
= a— 1 | Help |

Lohit Beng_gill
Lohit Gujarati
Lohit Hindi =

Liberation Serif

Figure 249: Font modification dialog

The Font text input box uses predictive text as you type to assist locating the wanted font. If you do
not know its hame, use the scrollbar to scroll through them. Click on any name and the preview
box will show a sample.

Variables should be written in italics, so make sure that the Italic box is checked. For all other
elements, use the basic (Roman) form. The style can be easily altered in the formula itself by using
the commands italic or bold to set these characteristics and nitalic or nbold to unset
them.

When you have chosen a new font for a formula, the old font remains in the list alongside the new
one and can be selected again. This applies only to the current session; the old font is not stored
permanently.

You can choose any fonts from the list, but if you are exchanging documents with someone else,
you should choose fonts that are present on your colleague’s computer.
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Changing the color

Use the command color to change the color of a subset of a formula: color red ABC gives
ABC . Choose from 8 colors: white, black, cyan, magenta, red, blue, green, yellow.

You may set a color for a subset of a formula if it is enclosed between { } or other parentheses.
For instance: A B color green {C D} Egives ABCDE.

Color commands can be nested in subsets of formulas as shown in this example : color blue
{A B color yellow C D} gives AB D . The space between C and D limits the color to the
variable following the command.

It is not possible to select a background color: it is always transparent in Math. The background
color of the whole formula is then the same as the background of the document or frame (in a text
document for instance). In Writer, you can use object properties (right-click the formula Object) to
choose a background color for the whole formula (see “Background, borders, and size” on page
283).

Formulas in Writer documents

Numbering equations

Equation numbering is one of Writer's best hidden features. The steps are simple, but obscure:
1) Start a new line.
2) Type fn and then press F3. Note this is NOT the keyboard Fn key.

The fn is replaced by a numbered formula:
E=mc? (2

Now you can double-click on the formula to edit it. Click in any blank space within the document to
revert to standard Writer menu. Click again to deselect the formula.

You can insert a cross-reference to an equation (for example “as shown in Equation (2)") as
follows:

1) Choose Insert > Cross-reference from the Menu bar.

2) On the Cross-references tab (Figure 250), under Type, select Text.

3) Under Selection, select the equation number.

4) Under Insert reference to, select Reference.

5) Click Insert.

If you later add more equations in a position above the referenced equation, all the equations will
automatically renumber and the cross-references will update.

. To insert the equation number in the cross-reference without parentheses around it,
Tip choose Numbering instead of Reference under Insert reference to.

The AutoText inserted as a result of the above procedure consists of a 1x2 table. The left cell
contains the formula and the right one the number. The number is an automatic counter named
Text. You can edit the AutoText if, for example, you prefer square rather than round brackets, or if
you want formula and number to be separated by tabs rather than formatted as a table. For more
information, read the section on “Using AutoText” in Chapter 3 (Working with Text) in the Writer
Guide.
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% O Fields

Document | Cross-references | Functions | Docinformation | Variables | Database

Type Selection
Set Reference 1

Insert Reference (2)
Headings

Numbered Paragraphs

Fi'g'ure
Bookmarks
Fooktnotes

Insert reference to

Page
_Cha_lpter

Above/Below

As Page Skyle

Category and Number

Caption Text

Numbering Name

Insert _ Close _ Help

Figure 250: Inserting a cross-reference to an equation number

Position

Normally a formula is anchored As character in a Writer document. But as with any other OLE
object, you can change the anchoring mode to position the formula where you want it. For more
information, see Chapter 11 (Graphics, the Gallery, and Fontwork) of this guide.

By default, formula objects anchored As character are automatically aligned vertically to the
baseline of the surrounding text. To align the formula manually, go to Tools > Options >
LibreOffice Writer > Formatting Aids and uncheck the option Math baseline alignment. This
setting is stored with the document and applies to all formulas within it. New documents use the
current setting from this dialog.

Margins

An inserted Math object has margins to left and right of it, separating it from surrounding text. If you
do not want this, it is best to alter the frame style for formulas, as this will apply simultaneously to
all existing formulas and those still to be inserted in the document. Proceed as follows:

1) Press F11. The Styles and Formatting dialog opens.

2) Click on the Frame Styles icon.

3) Find the Formula frame style and right-click on it.

4) Choose Modify from the context menu. The Frame Style dialog opens.

5) Switch to the Wrap tab of the dialog. Change the values for Left and Right in the Spacing
section to 0.00.

6) Click OK to close the dialog.
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This changes the spacing for all formulas that have not had their spacing adjusted manually. You
can find more information on using styles in “Default layout with style” on page 286 and in Chapter
3 (Using Styles and Templates) of this guide.

Text mode

Larger formulas should always be in a paragraph of their own, separated from the text. When you
use formula elements in running text, they can often be higher than the letter height.

However, if it is necessary to place a formula within running text, switch into the equation editor
and go to Format > Text mode. Math will try to shrink the formula to fit the letter height. The
numerators and denominators of fractions are shrunk, and the limits of integrals and sums are
placed beside the integral/sum sign.

Example:
A formula in a separate paragraph:

5
20
i=2
and the same formula embedded in text mode: X, i°

Background, borders, and size

With regard to formatting, formulas are treated as objects of the Frame Style type with the Formula
frame style. Background color and borders can be set using this style or directly with Format >
Framel/Object, or by right-clicking the formula and choosing Object from the context menu. In the
default installation, formulas have a transparent background and no borders. The size of a formula
cannot be adjusted; in a Writer document it depends directly on the way the formula is constructed
(see “Changing the font size” on page 278).

Creating a formula library

When you use the Math component of LibreOffice directly from the Start Center or with File > New
> Formula, you create documents with the file suffix ODF, each containing a single formula. You
can use these to build up a library of frequently-used formulas. Embedded formulas can also be
stored as separate Math documents by right-clicking on the formula and choosing Save copy as
from the context menu. To insert such a Math document into a Writer document, use Insert >
Object > OLE Object. Select the option Create from file and enter the path name of the file or
browse for it using your system’s file manager by pressing the Search button.

You cannot insert the document by dragging and dropping with the mouse, nor by

Note using Insert > File.

Formulas cannot be stored in the gallery because they are not in graphical format. You can
however store a formula as AutoText. Write the formula in a separate paragraph, select it and go to
Edit > AutoText. For further information see “Using AutoText” in Chapter 3 (Working with Text) in
the Writer Guide.

Fast insertion of formulas

If you already know the markup of your formula, here is a faster method to build your formula:
* Write the formula markup in Writer.
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* Select the markup.
* Insert the formula using a toolbar button, a menu item, or a keyboard shortcut.

This method avoids the need to open and close the Math window and thus saves time.

Customizations

Customizing the catalog

If you need to use a symbol that is not available in Math, you can add it to the catalog yourself. The
following example shows the procedure for symbols that are used in marking school work.

1) Go to Tools > Catalog or click on the catalog button Z to open the Symbols catalog
(Figure 240).
2) Click the Edit button. The Edit symbols dialog (Figure 251) opens.

3) The symbols are arranged in symbol sets. In the lower part of the window, choose an
available set for your new symbol from the Symbol set list, for example the Special set. Or
you can type the name of a new symbol set directly into the box.

4) From the Font list, choose a font that contains the desired symbol.

When you have selected a font, its characters appear in the font summary window. You can
scroll through it using the scrollbar at the side, or use the Subset list to go straight to the
place you need.

To follow this example, choose the font DejaVu Sans and the subset General punctuation.

5) Click on the desired symbol (here Ux2032). It appears enlarged in the right-hand preview
box (see Figure 252). Make sure that the symbol set is set to Special.

6) In the Symbol field, enter a name for the symbol, for example prime.
7) If the name is not already in use, the Add button becomes active. Click on it.

8) You can immediately add more symbols. In the example, the “U+2033" symbol, named
dblprime, and the “U+2034” symbol, named triprime, are added (see Figure 253).

9) Click OK to close the dialog.

[ @ Edit Symbols

old symbol bLPHA v | ©ld symbol set Greek v | oK |
= A B I A E Z H - Cancel
(5] K A M N = 0O I p b3} T Y il X W :
Q ¥ [ y 0 £ i il b L K A u v E ( Help
n p - ¥ T v ) % 1 0] 9 i q w o €
- — II ] t t .
i [ F £ Rs | W d € - C £ g
h 3 { IN e [n] R R ™ z L] & N =
1 5 é — y Ly I = = = I+~ -+ Q £
Symbol ALPHA v
Symbol set Greek v ALPHA ALPHA
OpenSymbol &
Font Opensy - g
Subset Basic Greek = ¥i i E> A
Standard
Typstace sttt = Greek Greek

Delete Modify Add

Figure 251: Edit Symbols dialog
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Symbol prime] v
Symbol set Special - ALPHA prime
DejaVu Sans z
Font Dej r s
Subset General punctuation 2 I k Z>
Typeface Standard v P i
Delete Modify Add

Figure 252: Edit Symbols dialog: characters selected

Now the Symbol set view area shows the new symbol. It can be selected just like the other
symbols, either from here, or by writing them directly into the equation editor in the form %prime.

Caution o -
Symbols (Greek or Special), in contrast to commands, are case sensitive

A (lowercase/uppercase).

Numerous free fonts contain a great number of mathematical symbols. The “STIX1” font is worthy
of special mention here. It was developed specially for writing mathematical/technical texts. The
DejaVu?2 and Lucida3 fonts also have a wide range of symbols.

# 0 Symbols
Symbol set — |
Special s ;_
Close
A X E =om & £ V ﬁm-
o S , _ EdiL...
Help

prime

Figure 253: Catalog with new symbol

Not Many symbols occur in more than one font. If you want to exchange documents with
oie others, take care to use a font that is installed on their machine.

In the default LibreOffice installation, only those user-defined symbols that actually occur in the
document are stored with it. Sometimes it is useful to embed all the user-defined symbols, for
example when the document is going to be further edited by another person. Go to Tools >
Options > LibreOffice Math and on the Settings page, uncheck the option Embed only used
symbols (smaller file size).This setting is only available when you are working on a Math

document.

1 Font files for STIX are available from http://www.stixfonts.org
2 Font files for DejaVu Sans are available from http://www.dejavu-fonts.org
3 Lucida Sans belongs to the JRE package, which is probably already on your computer.
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Default layout with style

In Writer, formulas are formatted according to the Formula EEEEBE &
frame style. In the Style and Formatting window (displayed
with F11), click on the third icon at the top: Frame Styles. Graphics
Right-click on Formula and select Modify. By this means, * OOoframe
you can directly modify all formulas in your document, with ganggraphics
regard to spacing (page 282) or background (page 283), p o A
unless you manually modify formula formatting. OLE  New...
To apply this style in all your new Writer documents, you e Modify... |
. . Marginaua
must include the Formula style in your default template. To S il
do so, create a new Writer document and modify the . .
Formula frame style as you wish. Save the document using 53%31254 : Modify Frame Style

File > Save as Template and save it into My Templates
with a name of your choice. To define this template as your default template, select the template
you just created and choose Set as default. If you wish to return to the default template given at
installation, open the Template Manager (File > Templates > Manage), click on the Action Menu
and point to Reset Default Template, on the drop-down menu, and click Text Document. This
menu choice does not appear unless a custom template has been set as the default.

The next time that you create a document by choosing File > New, the document will be created
from the new default template.

For more information on the Template Manager, see Chapter 9, Styles and Templates.

Application to chemical formulas

Math was designed to build mathematical formulas, but it can also be used to write chemical
formulas. In chemistry, formulas look like H20: names are usually non-italic uppercase. To write
chemical formulas with Math, deselect the Italic attribute in the Fonts dialog (see “Changing the
font” on page 279).

Here some examples of chemical formulas:

Construction Example Entry

Molecules H,SO, H_2 SO_4 (please note the space!)
Isotopes 22U U 1sub 92 lsup 238

lons S0% S0_4n{2-{}} or SO_4n{2"-"}

Notes: 1sub or 1sup are abbreviations for left subscript and left superscript. Empty braces after
2- are necessary to avoid errors as there is no right member after the minus sign.

For reversible reactions, there is no satisfactory double arrow in Math. If you have a font with a
suitable symbol, you may use the method described in “Customizing the catalog” on page 284. For

N

instance, DejaVu fonts have these double arrows 2 = = =,

Alternatively, if you find a special character in a document you can copy it, for example here in this
formula: C+0O<=CO "=". Other double arrows can be found here:
http://dev.w3.org/html5/html-author/charref from character x021C4, or here:
http://www.unicode.org/charts/PDF/U2190.pdf, which is a subset of this location:
http://www.unicode.org/charts/#symbols

286 | Getting Started with LibreOffice 4.2


http://www.unicode.org/charts/PDF/U2190.pdf
http://dev.w3.org/html5/html-author/charref

Math commands - Reference

The complete list of commands and reserved words used by Math is available in the Math Guide:

Unary / binary operators
Relations

Set operations
Functions

Operators

Attributes

Brackets

Formats

Others

Characters — Greek
Characters — Special

Reserved words in alphabetic order
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Quick printing

Click the Print File Directly icon ( i ) to send the entire document to the default printer defined
for your computer.

You can change the action of the Print File Directly icon to send the document to
the printer defined for the document instead of the default printer for the computer.
Go to Tools > Options > Load/Save > General and select the Load printer
settings with the document option.

Controlling printing

For more control over printing, use the Print dialog (File > Print or Ctr/+P).

@ o Print

General | LibreOffice Writer  Page Layout  Options

210mm (A4) Printer

MG3200-series

[ LibreOffice

The Document Foundation

Geiting Stared Guide

= » Details Properties...
2 E{ﬁﬂ?ﬁ&:’wmﬂg' &N Range and copies _
@ Allpages Number of copies [l =
) Pages |1 Collate @ @
Selection
[ Printin reverse page order
Print
— — Comments |None (document onl
(/2 [ 4@ - { -

(o) el | e

Figure 255: The Print dialog

The options selected on the Print dialog apply to this printing of this document only.

To specify default printing settings for LibreOffice, go to Tools > Options >
LibreOffice — Print and Tools > Options > LibreOffice Writer — Print. See
Chapter 2, Setting Up LibreOffice, for more details.

The Print dialog has four pages, from which you can choose a range of options, as described in the
following sections.
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The different components of LibreOffice have different available print settings, as summarized in
Table 10.

Table 10: Print options in LibreOffice components

Feature Writer Calc Impress Draw
Select pages/sheets/slides to print Yes Yes Yes Yes
Print multiple pages/sheets/slides on one page Yes Yes Yes Yes
Print a brochure Yes No Yes Yes
Print envelopes Yes No No No
Print labels or business cards Yes No No No
Preview pages/sheets before printing Yes Yes No No

Selecting general printing options

On the General tab of the Print dialog, you can choose:
* The printer (from the printers available)

* Which pages to print, the number of copies to print, and whether to collate multiple copies
(Range and copies section)

* Whether to print any comments that are in the document, and where to print the
comments.

Some selections may not be available all the time. For example, if the document contains no
comments, the Print — Comments drop-down list does not work.

Print

Ay e B T E .
Comments TN TN R - |

"Eél'"nments only " 1 .
Place at end of document l || Cancel | Help
Place at end of page

Figure 256: Choosing whether and where to print comments

Select the Properties button to display the selected printer's properties dialog where you can
choose portrait or landscape orientation, which paper tray to use, and the paper size to print on.

On the Options tab of the Print dialog (Figure 257), the last item, Use only paper tray from printer
preference, is not available in Calc.

General LibreOffice Writer | Page Layout | Options

Options

Create single print jobs For collated output
Use only paper tray from printer preferences

Use anly paper size from printer preferences

Figure 257: General print options
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Printing multiple pages on a single sheet of paper

You can print multiple pages of a document on one sheet of paper. To do this:
1) Inthe Print dialog, select the Page Layout tab (Figure 258).

& o Print
General | LibreOFffice Writer | Page Layout | Options

Layout
® Pages persheet [2

4

1i2

ik

Order [leﬂ: to right, then down

297mm (A4)
- | Draw a border around each page

") Brochure

Page sides

Include ' All pages |
All pages

Back sides / left pages
Front sides [ right pages

210mm
{
&

1 /11 |
[&H Cancel H Help

Figure 258: Printing multiple page per sheet of paper
2) Inthe Layout section, select from the drop-down list the number of pages to print per sheet.
The preview panel on the left of the Print dialog shows how the printed document will look.
When printing more than 2 pages per sheet, you can choose the order in which they are
printing across and down the paper.

General LibreOffice Writer | Page Layout | Options

Layout
@ Pages persheet |4 -

Order left to right, then down =
() Draw aborderal left to right, then down

top to bottom, then right
7} Brochure top to bottom, then left
right to left, then down

1 2
3 4

3) In the Page sides section, select whether to print all pages or only some pages. Click the
OK button.

Ti In Writer, to print two pages per sheet in “facing pages” (book layout) style, print from
Ip Print Preview instead. See page 298.
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Selecting pages/sheets/slides to print

In addition to printing a full document, you can choose to print individual pages/sheets/slides,
ranges of pages/sheets/slides, or a selection of a document. The details vary slightly in Writer,
Calc, Draw and Impress, as described in this section.

Writer

Printing an individual page:

1)
2)

3)

Choose File > Print from the Menu bar, or press Ctrl+P.
On the Print dialog, select the page to print.

a) Inthe Ranges and copies section of the General page, select the Pages option. The
text input box displays the current page number.

b) Enter the page number of the page you want to print. The preview box changes to show
the selected page.

Click the OK button.

Printing a range of pages:

1)
2)

3)

Choose File > Print from the Menu bar, or press Ctrl+P.

On the Print dialog, select the range of pages to print.

a) In the Ranges and copies section of the General page, select the Pages option.
b) Enter the sequence numbers of the pages to print (for example, 1-4 or 1,3,7,11).
Click the OK button.

Printing a selection of text:

1)
2)
3)

4)

In the document, select the material (text and graphics) to print.
Choose File > Print from the Menu bar, or press Ctrl+P.

The Ranges and copies section of the Print dialog now includes a Selection option and the
preview box shows the selected material. See Figure 259.

Click the OK button.

|Selecting pagesisheetsislides to print

In addition to printing a full document, you can choose to print individual pages/sheets/slides,
ranges of pagesSheeisklides, am o - . L
|Calc, Draw and Impress, as desct &

\Writer

PR SRS S N VO —

% 0 Print

General | LibreOffice Writer | Page Layout Options

|Printing an individual page:
1) Choose File > Print from t
2) On the Print dialog, select

a) In the Ranges and cap
text input box displays

b) Enter the page numbel
the selected page.

3) Click the OK button.
Printing a range of pages:
1) Choose File > Print from t
2) On the Print dialog, select
a) In the Ranges and cap
b) Enter the sequence nu
3) Click the OK button.
Printing a selection of text:
1) Inthe document, select the
2) Choose File > Print from 1

3) The Ranges and copies s¢
preview box shows the sel

4) Click the OK button.

297mm

210mm (A4)

1| /1

Printer
MG3200-series

» Details

Range and copies

All pages

Pages |7

®

| Print in reverse page order
Print

Comments None (document only)

| Properties...

Number of copies |1

Collake BE 2

OK Cancel | Help

Figure 259: Printing a selection of text
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Calc
You can choose single sheets, multiple sheets, and selections of cells for printing.

Range and copies
All sheets Number of copies =

® selected sheets ) = =
Collate 1 2 3 : 2 3

Selected cells
From which print
® Allpages
Pages

Print in reverse page order

Figure 260: Choosing what to print in Calc

Printing an individual sheet:
1) Inthe spreadsheet, click on the sheet tab to select the sheet you want to print.
2) Choose File > Print from the Menu bar, or press Ctrl+P.
3) Inthe Ranges and copies section of the Print dialog, choose the Selected sheets option.
4) Click the OK button.

Printing a range of sheets:
1) Inthe spreadsheet, select the sheets to print.
a) Select the first sheet.
b) Hold down the Control key.
c) Click on the additional sheet tabs.
d) Release the Control key when all required sheets are selected.
2) Choose File > Print from the Menu bar, or press Ctrl+P.
3) Inthe Ranges and copies section of the Print dialog, choose the Selected sheets option.
4) Click the OK button.

Printing a selection of cells:
1) Inthe document, select the section of cells to print.
2) Choose File > Print from the Menu bar, or press Ctrl+P.
3) Inthe Ranges and copies section of the Print dialog, select the Selected cells option.
4) Click the OK button.

Caution After printing, be sure to deselect the extra sheets. If you keep them selected, the
next time you enter data on one sheet, you enter data on all the selected sheets.
This might not be what you want.
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Impress and Draw
You can choose individual slides, ranges of slides, or selections of slides for printing.

Range and copies

@® Allslides Number of copies [l =
2] 1
Slides Colate \jﬂi mﬂi
Selection

Print in reverse page order

Print

Document |Slides i

Slides per page |Default Order |Leftto right, then down

Figure 261: Choosing what to print in Impress and Draw

Printing an individual slide:

1)
2)

3)

Choose File > Print from the Menu bar, or press Ctrl+P.

Select the slide to print.

a) Inthe Ranges and copies section of the Print dialog, select the Slides option.
b) Enter the number of the slide to print.

Click the OK button.

Printing a range of slides:

1)
2)

Choose File > Print from the Menu bar, or press Ctrl+P.
Select the slides to print.

a) Inthe Ranges and copies section of the Print dialog, select the Slides option.
b) Enter the number of the slides to print (for example 1-4 or 1,3,7,11).
3) Click the OK button.

Printing a selection from a slide, or a selection from multiple slides:
1) In the document, select the section of the slide to print.
2) Choose File > Print from the Menu bar, or press Ctrl+P.
3) Select the Selection option in the Ranges and copies section of the Print dialog.
4) Click the OK button.

Printing handouts, notes, or outlines in Impress

Handouts prints the slides in reduced size on the page, from one to nine slides per page. The
slides can be printed horizontally (landscape orientation) or vertically (portrait orientation) on the

page.
Notes prints a single slide per page with any notes entered for that slide in Notes View.
Outline prints the title and headings of each slide in outline format.

To print handouts, notes, or outlines:

1)
2)
3)

4)

Choose File > Print from the Menu bar, or press Ctrl+P.
In the Print section of the Print dialog, select the required option.

For Handouts, you can then choose how many slides to print per page, and the order in
which they are printed.

Click the OK button.
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Range and copies

i® allslides Number of copies |1 m
) slides |1 Collate @3 ﬁg
) Selection

[ Printin reverse page order

Prink

slides per page |Default | | Order |Lefttoright, then down

Printing a brochure

In Writer, Impress, and Draw, you can print a document with two pages on each side of a sheet of
paper, arranged so that when the printed pages are folded in half, the pages are in the correct
order to form a booklet or brochure.

Plan your document so it will look good when printed half size; choose appropriate

Tip margins, font sizes, and so on. You may need to experiment.

To print a brochure on a single-sided printer:
1) Choose File > Print, or press Ctrl+P.
2) In the Print dialog, click Properties.

3) Check the printer is set to the same orientation (portrait or landscape) as specified in the
page setup for your document. Usually the orientation does not matter, but it does for
brochures. Click OK to return to the Print dialog.

4) Select the Page layout tab in the Print dialog.
5) Select the Brochure option.

6) In the Page sides section, select Back sides / left pages option from the Include drop-down
list.

General | LibreOffice Writer | Page Layout | Options

Layout
® Pages persheet 11

k

e,

Order [leﬂ:tu right, thendown % |

[1 Draw a border around each page

) Brochure
Page sides
Include .Ilpages &y |

All pages

Back sides / left pages
Frontsides / right pages

Figure 262: Selecting which pages to print
7) Click the OK button.
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8) Take the printed pages out of the printer, turn the pages over, and put them back into the
printer in the correct orientation to print on the blank side. You may need to experiment a bit
to find out what the correct arrangement is for your printer.

9) On the Print dialog, in the Page sides section, select Front sides / right pages option from
the Include drop down box.

10) Click the OK button.

Tip If your printer can print double-sided automatically, choose All pages.

Printing envelopes, labels, business cards
Printing envelopes, labels, or business cards using Writer involves two steps: setup and printing.

For details of how to set these up, see Chapter 11, Using Mail Merge, in the Writer Guide. To print:
1) Choose File > Print from the Menu bar, or press Ctrl+P.

2) On the Print dialog, under Range and copies, choose Pages and type 1 in the box. Click
the OK button.

Printing in black and white (on a color printer)

You may wish to print documents in black and white on a color printer. Several choices are
available. Please note that some color printers may print in color regardless of the settings you
choose.
Change the printer settings to print in black and white or grayscale:

1) Choose File > Print, or press Ctrl+P, to open the Print dialog.

2) Click Properties to open the Properties dialog for the printer. The available choices vary
from one printer to another, but you should find options for the Color settings. See your
printer’s help or user manual for more information.

3) The choices for color might include black and white or grayscale. Choose the required
setting.
4) Click OK to confirm your choice and return to the Print dialog,

5) Click the OK button to print the document.

Tip Grayscale is best if you have any graphics in the document.

Change the LibreOffice settings to print all color text and graphics as grayscale:
1) Choose Tools > Options > LibreOffice > Print.
2) Select the Convert colors to grayscale option. Click OK to save the change.
3) Open the Print dialog (File > Print), or press Ctrl+P.
4) Click the OK button to print the document.
Change the LibreOffice Writer (or Calc, Impress, Draw) settings to print all color text as black, and
all graphics as grayscale:
1) Choose Tools > Options > LibreOffice Writer > Print.
2) Under Contents, select the Print text in black option. Click OK to save the change.
3) Open the Print dialog (File > Print), or press Ctrl+P.
4) Click the OK button to print the document.
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Previewing pages/sheets before printing

You can use the previewing options in Writer and Calc to view the document as it will be printed.
Different viewing options are available.

Writer

The normal page view in Writer shows you what each page will look like when printed and you can
edit the pages in that view. If you are designing a document to be printed double-sided, you may
want to see what facing pages look like. Writer provides two ways to do this:

* View Layout (editable view): use the Facing Pages (Book Preview) button on the status bar.

! C 90%

* Page Preview (read-only view).
To use Page Preview:

1) Choose File > Page Preview, click the Page Preview button ( &5 ) on the Standard toolbar
or press Ctrl+Shift+O.
Writer now displays the Page Preview toolbar instead of the Formatting toolbar.

E & & = BE -y @& |52% |+ € [ & Close Preview
Figure 263: Page Preview toolbar (Writer)
2) Select the required preview icon: Two Pages ( @& ), Multiple Pages (E5 - ) or Book

Preview ( 8 ).

3) To print the document from this view, click the Print document icon ( &) to open the Print
dialog. Choose the print options and click the OK button.

Calc
To preview the sheets in Calc before printing:
1) Choose File > Page Preview.
The Calc window now displays the Page Preview toolbar instead of the Formatting toolbar.

& Lj & € [ FormatPage Margins ¢ Close Preview
Figure 264: Page Preview toolbar (Calc)

2) To print the document from this view, click the Print document icon ( {Z) to open the Print
dialog.
3) Choose the print options and click the Print button.

Exporting to PDF

LibreOffice can export documents to PDF (Portable Document Format). This industry-standard file
format is ideal for sending the file to someone else to view using Adobe Reader or other PDF
viewers.

The process and dialogs are the same for Writer, Calc, Impress, and Draw, with a few minor
differences mentioned in this section.
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Quick export to PDF

—
Click the Export Directly as PDF icon ( ™ ) to export the entire document using the PDF settings
you most recently selected on the PDF Options dialog (see below). You are asked to enter the file
name and location for the PDF file, but you do not get a chance to choose a page range, the image
compression, or other options.

Controlling PDF content and quality

For more control over the content and quality of the resulting PDF, use File > Export as PDF. The
PDF Options dialog opens. This dialog has five pages (General, Initial View, User Interface, Links,
and Security). Select the appropriate settings, and then click Export. Then you are asked to enter
the location and file name of the PDF to be created, and click Save to export the file.

Another choice is to use File > Export. This opens the Export dialog. Select the
PDF file format, file name and location and click Export. This then opens the PDF
Options dialog, as described above. Click Export when all the selections have been
made.

Note

General page of PDF Options dialog

On the General page, you can choose which pages to include in the PDF, the type of compression
to use for images (which affects the quality of images in the PDF), and other options.

& 0 PDF Options
General | Initial View | User Interface | Links | Security

Range General

All & Embed OpenDocument file;

Pages | PDF/A-1a
selection | Tagged PDF
Images & Create PDF form
Lossless compression Submit format FDF =
@® JPEG compression Allow duplicate field names
Qualiky 90% = B Exportbookmarks
[ Reduce image resolution |75DPI v | Export comments

| Exportautomatically inserted blank pages

Watermark View PDF after Export

Sign with Watermark

watermark Text

Figure 265: General page of PDF Options dialog

Range section
* All: Exports the entire document to PDF.

* Pages: To export a range of pages, use the format 3-6 (pages 3 to 6). To export single
pages, use the format 7;9;11 (pages 7, 9 and 11). You can also export a combination of
page ranges and single pages, by using a format like 3-6;8;10;12.

* Selection: Exports all the selected material.
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Images section

Lossless compression: Images are stored without any loss of quality. Tends to make
large files when used with photographs. Recommended for other kinds of images or
graphics.

JPEG compression: Allows for varying degrees of quality. A setting of 90% works well with
photographs (small file size, little perceptible loss of quality).

Reduce image resolution: Lower DPI (dots per inch) images have lower quality. For
viewing on a computer screen, generally a resolution of 72dpi (for Windows) or 96dpi
(GNU/Linux) is sufficient, while for printing it is generally preferable to use at least 300 or
600dpi, depending on the capability of the printer. Higher DPI settings greatly increase the
size of the exported file.

EPS (Encapsulated PostScript) images with embedded previews are exported only

Note as previews. EPS images without embedded previews are exported as empty

placeholders.

Watermark section

Sign with Watermark: When this option is selected, a transparent overlay of the text you
enter into the Watermark Text box will appear on each page of the PDF.

General section

Embed OpenDocument file: Use this setting to export the document as a PDF file
containing two file formats: PDF and ODF. In PDF viewers it behaves like a normal PDF
file, and it remains fully editable in LibreOffice.

PDF/A-1a: PDF/Ais an ISO standard for long-term preservation of documents, by
embedding all the information necessary for faithful reproduction (such as fonts) while
forbidding other elements (including forms, security, and encryption). PDF tags are written.
If you select PDF/A-1a, the forbidden elements are grayed-out (not available).

Tagged PDF: Tagged PDF contains information about the structure of the document’s

contents. This can help to display the document on devices with different screens, and
when using screen reader software. Some tags that are exported are table of contents,
hyperlinks, and controls. This option can increase file sizes significantly.

Create PDF form - Submit format: Choose the format of submitting forms from within the
PDF file. This setting overrides the control’'s URL property that you set in the document.
There is only one common setting valid for the whole PDF document: PDF (sends the
whole document), FDF (sends the control contents), HTML, and XML. Most often you will
choose the PDF format.

Export bookmarks: Exports headings in Writer documents, and page or slide names in
Impress and Draw documents, as “bookmarks” (a table of contents list displayed by most
PDF viewers, including Adobe Reader).

Export comments: Exports comments as PDF notes. You may not want this!

Export automatically inserted blank pages: If selected, automatically inserted blank
pages are exported to the PDF. This is best if you are printing the PDF double-sided. For
example, books usually have chapters set to always start on an odd-numbered (right-hand)
page. When the previous chapter ends on an odd page, LibreOffice inserts a blank page
between the two odd pages. This option controls whether to export that blank page.

Earlier versions of LibreOffice had the option:

Embed standard fonts: Normally the 14 standard PostScript fonts were not embedded in
a PDF file, because PDF readers already contained these fonts. However, you could
choose to embed these fonts in all PDF documents created by LibreOffice to enhance
display accuracy in PDF viewers. The PostScript fonts are now embedded by default.
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Initial View page of PDF Options dialog

On the Initial View page (Figure 266), you can choose how the PDF opens by default in a PDF
viewer. The selections should be self-explanatory.

If you have Complex Text Layout enabled (in Tools > Options > Language settings >
Languages), an additional selection is available under Continuous facing: First page is left
(normally, the first page is on the right when using the Continuous facing option).

@ O PDF Options

General | Initial View | User Interface | Links | Security

Panes Page layout
@ Default
) Bookmarks and page ) single page
) Thumbnails and page ") Continuous
Open on page |1 & ) Continuous Facing

Magnification
@® Default

1 Fitin window
Fit width
) Fitvisible

) Zoom factor 100

Figure 266: Initial View page of PDF Options dialog

User Interface page of PDF Options dialog

On the User Interface page, you can choose more settings to control how a PDF viewer displays
the file. Some of these choices are particularly useful when you are creating a PDF to be used as a
presentation or a kiosk-type display.

@ 0 PDF Options

General | Initial View |User Interface | Links | Security

Window options User interface options
| Resize window to initial page: | Hide menubar
—| Center window on screen — | Hide toolbar
Openin full screen mode — | Hide window controls

& Display document title

Transitions Bookmarks

Use transition effects ® Allbookmark levels

1 Visible bookmark levels

Figure 267: User Interface page of the PDF Options dialog

Window options section
* Resize window to initial page. Causes the PDF viewer window to resize to fit the first
page of the PDF.

¢ Center window on screen. Causes the PDF viewer window to be centered on the
computer screen.
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* Open in full screen mode. Causes the PDF viewer to open full-screen instead of in a
smaller window.

* Display document title. Causes the PDF viewer to display the document’s title in the title
bar.

User interface options section
* Hide menubar. Causes the PDF viewer to hide the menu bar.

* Hide toolbar. Causes the PDF viewer to hide the toolbar.
¢ Hide window controls. Causes the PDF viewer to hide other window controls.

Transitions
In Impress, displays slide transition effects as their respective PDF effects.

Bookmarks
Select how many heading levels are displayed as bookmarks, if Export bookmarks is selected
on the General page.

Links page of PDF Options dialog
On the Links page, you can choose how links are exported to PDF.

# 0 PDF Options

General | Initial View  User Interface | Links | Security

General

Export bookmarks as named destinations;

Convert document references to PDF targets
Export URLs relative to file system
Cross-document links
@® Default mode
Open with PDF reader application

Open with Internet browser

Figure 268: Links page of PDF Options dialog

Export bookmarks as nhamed destinations
If you have defined Writer bookmarks, Impress or Draw slide names, or Calc sheet names, this
option exports them as “named destinations” to which Web pages and PDF documents can
link.

Convert document references to PDF targets
If you have defined links to other documents with OpenDocument extensions (such as .odt,
.0ds, and .odp), this option converts the files' extensions to .pdf in the exported PDF document.

Export URLSs relative to file system
If you have defined relative links in a document, this option exports those links to the PDF.

Cross-document links
Defines the behavior of links clicked in PDF files. Select one among the following alternatives:

* Default mode: The PDF links will be handled as specified in your operating system.
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* Open with PDF reader application: Use the same application used to display the PDF
document to open linked PDF documents.

* Open with Internet browser: Use the default Internet browser to display linked PDF
documents.

Security page of PDF Options dialog

PDF export includes options to encrypt the PDF (so it cannot be opened without a password) and
apply some digital rights management (DRM) features.

* With an open password set, the PDF can only be opened with the password. Once opened,
there are no restrictions on what the user can do with the document (for example, print,
copy, or change it).

* With a permissions password set, the PDF can be opened by anyone, but its permissions
can be restricted. See Figure 269. After you set a password for permissions, the other
choices on the Security page become available.

* With both the open password and permission password set, the PDF can only be opened
with the correct password, and its permissions can be restricted.

Note Permissions settings are effective only if the user’'s PDF viewer respects the settings.

% 0 PDF Options

General | Initial View  User Interface | Links | Security

File encryption and permission Printing
Mot permitted
Low resolution (150 dpi)
No open password set
PDF document will not be encrypted High resolution
No permission password set Changes
PDF document will be unrestricted Bl
Mot permitted
e g, deleting, and re g page
E g in Form Field
Commenting, g orm field

Figure 269: Security page of PDF Options dialog
Figure 270 shows the pop-up dialog displayed when you click the Set open password button on
the Security page of the PDF Options dialog.

Once you have set all the options you require, click on Export to open the Export dialog, where
you can set the file name and the save location.
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% O Set passwords

Set open password

Fassword: |###sseses

Confirm: |*xsweees

Set permission password

Password:

Confirm:

Help [ OK | . Cancel

Figure 270: Setting a password to encrypt a PDF

Exporting to other formats

LibreOffice uses the term “export” for some file operations involving a change of file type. If you
cannot find what you want under File > Save As, look under File > Export as well.

LibreOffice can export files to XHTML. In addition, Draw and Impress can export to Adobe Flash
(SWF) and a range of image formats.

To export to one of these formats, choose File > Export. On the Export dialog, specify a file name
for the exported document, then select the required format in the File format list and click the
Export button.

E-mailing documents

LibreOffice provides several ways to send documents quickly and easily as e-mail attachments in
one of three formats: OpenDocument (LibreOffice’s default format), Microsoft Office formats, or
PDF.

Documents can only be sent from the LibreOffice menu if a mail profile has been set

Note up in Tools > Options > LibreOffice Writer > Mail Merge E-mail.

To send the current document in OpenDocument format:
1) Choose File > Send > Document as E-mail. LibreOffice opens your default e-mail
program. The document is attached.

2) In your e-mail program, enter the recipient, subject, and any text you want to add, then
send the e-mail.

File > Send > E-mail as OpenDocument (Text, Spreadsheet, or Presentation) has the same
effect.

If you choose E-mail as Microsoft [Word, Excel, or PowerPoint], LibreOffice first creates a file in
one of those formats and then opens your e-mail program with the file attached.

Similarly, if you choose E-mail as PDF, LibreOffice first creates a PDF using your default PDF
settings (as when using the Export Directly as PDF toolbar button) and then opens your email
program with the PDF file attached.
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E-mailing a document to several recipients

To e-mail a document to several recipients, you can use the features in your e-mail program or you
can use LibreOffice’s mail merge facilities to extract email addresses from an address book.

You can use LibreOffice’s mail merge to send e-mail in two ways:

* Use the Mail Merge Wizard to create the document and send it. See Chapter 11, Using Malil
Merge, in the Writer Guide for details.

* Create the document in Writer without using the Wizard, then use the Wizard to send it.

This method is described here.

To use the Mail Merge Wizard to send a previously-created Writer document:
1) Click Tools > Mail Merge Wizard. On the first page of the wizard, select Use the current

document and click Next.

#@ Mail Merge Wizard

Steps

Select starting document for the mail merge

{® Usethecurrent document

2.Select document type

3.Insert address block ) Start from existing document

4. Create salutation

5. Adjust layout

) Start from a template | Browse... |

) Create a new document

Browse...

6. Edit document start from a recently saved starting document

7.Personalize document

8. Save, print or send

Figure 271: Select starting document

2) On the second page, select E-mail message and click Next.

Steps

1. Select starting document

3.5Select address list

4. Create salukation

5. Adjust layout

What type of document do you want to create?

1 Lektker

Send e-mailmessages to a group of recipients. Thg
The e-mail messages can be personalized for each

Figure 272: Select document type

3) On the third page, click the Select Address List button. Select the required address list
(even if only one is shown) and then click OK. (If the address list you need is not shown
here, you can click Add to find it and add it to the list.)
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% Mail Merge Wizard

Steps Insert address block
1.Select starting document 1. Select th;:etgddres?hl!stdmtnt.ainin%tt:jet:ddrezz |iihata I Select Address List...
2. select document type you want to use. This data is needed to crea =
address block.
3. Select address list
4. Create salutation
5. Adjust layout | @ o Select Address List
6. Edit document
7.Personalize document Select an address list. Click ‘Add..." to select recipients from a different list. If you do not
i have an address list you can create one by clicking 'Create...".
8. Save, print or send
Your recipients are currently selected from:
Name Table Add...
Addresse
| Create..
Addresses1 "
Addresses?2 Filter |
Edit...
changeTable... |
oK Cancel Hel,
—— ok || gancel || melp |

Figure 273: Selecting an address list

4) Back on the Select address list page, click Next. On the Create salutation page, deselect
This document should contain a salutation.

& Mail Merge Wizard

Steps Create a salutation
1.Select starting docuTeme miiiseteenmeT T should contain a salutation!

2.Select document type
3.Select address list

Insert personalized salutation

. Female Dear Mrs. <Last Name>,
4. Create salutation
5. Adjust layout Male Dear Mr. <Last Name>,

6. Edit document

Address list field indicating a Female recipient
7.Personalize document

. Field name Gender
8. Save, print or send

Field value

Figure 274: Deselecting a salutation

5) In the left-hand list, click 8. Save, print or send. LibreOffice displays a “Creating
documents” message and then displays the Save, print or send page of the Wizard.

6) Select Send merged document as E-Mail. The lower part of the page changes to show e-
mail settings choices. See Figure 275.

7) Type a subject for your email and click Send documents. LibreOffice sends the e-mails.

306 | Getting Started with LibreOffice 4.2



' % Mail Merge Wizard

Steps Save, print or send the document
1.Select starting document Select one of the options below:

2.Select document type
3. Select address list

Save starting documenkt

Save merged document

4. Create salutation :
Print merged document

5. Adjust layoutk

6. Edit document

@ Send merged document as E-Mail:

7.Personalize document E-Mail settings

To |E-mail Address g | Copy to... ;
Subject
Send as |HTML Message = Properties...

Name of the attachment

a]
= |

GS4210-PrintingExportingEmailing_JHW_JAS_22Mar

7]

@® send all documents
From 1 To |1

Send documents

Cancel

I
= |
1Y)
=

Help <<Back Next >>

Figure 275: Sending a document as an email message

Digital sighing of documents

To sign a document digitally, you need a personal key, also known as a certificate. A personal key
is stored on your computer as a combination of a private key, which must be kept secret, and a
public key, which you add to your documents when you sign them. You can get a certificate from a
certification authority, which may be a private company or a governmental institution.

When you apply a digital signature to a document, a kind of checksum is computed from the
document’s content plus your personal key. The checksum and your public key are stored together
with the document.

When someone later opens the document on any computer with a recent version of LibreOffice,
the program will compute the checksum again and compare it with the stored checksum. If both
are the same, the program will signal that you see the original, unchanged document. In addition,
the program can show you the public key information from the certificate. You can compare the
public key with the public key that is published on the web site of the certificate authority.
Whenever someone changes something in the document, this change breaks the digital signature.

On Windows operating systems, the Windows features of validating a signature are used. On
Solaris and Linux systems, files that are supplied by Thunderbird, Mozilla or Firefox are used. For
a more detailed description of how to get and manage a certificate, and signature validation, see
“About Digital Signatures” in the LibreOffice Help.

To sign a document:

1) Choose File > Digital Signatures.

2) If you have not saved the document since the last change, a message box appears. Click
Yes to save the file.
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3) The Digital Signatures dialog opens. Click Sigh Document to add a public key to the
document.

4) In the Select Certificate dialog, select your certificate and click OK to return to the Digital
Signatures dialog.

5) The certificate used is displayed in the dialog with an icon next to its name.
This icon indicates the status of the digital signature.

* Anicon with a red seal (3) indicates that the document was signed and the certificate
was validated.

* Anicon with a yellow caution triangle overlaying the red seal (i@ ) indicates that the
document is signed but that the certificate could not be validated.

* Anicon of a yellow caution triangle (‘!") indicates an invalid digital signature.
6) Click Close to apply the digital signature.

A signed document shows an icon in the status bar. You can double-click the icon to view the
certificate. More than one signature can be added to a document.

Removing personal data

You may wish to ensure that personal data, versions, notes, hidden information, or recorded
changes are removed from files before you send them to other people or create PDFs from them.

In Tools > Options > LibreOffice > Security > Options, you can set LibreOffice to remind (warn)
you when files contain certain information and remove personal information automatically on
saving.

To remove personal and some other data from a file, go to File > Properties. On the General tab,
uncheck Apply user data and then click the Reset button. This removes any names in the created
and modified fields, deletes the modification and printing dates, and resets the editing time to zero,
the creation date to the current date and time, and the version number to 1.

To remove version information, either (a) go to File > Versions, select the versions from the list
and click Delete; or (b) use File > Save As and save the file with a different name.
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Introduction

You can add graphic and image files, including photos, drawings, scanned images, and others, to
LibreOffice documents. LibreOffice can import various vector (line drawing) and raster (bitmap) file
formats. The most commonly used graphic formats are GIF, JPG, PNG, and BMP. See Appendix B
for a full list of the graphic formats LibreOffice can import.

Graphics in LibreOffice are of three basic types:
* Image files, such as photos, drawings, and scanned images
* Diagrams created using LibreOffice’s drawing tools
* Charts created using LibreOffice’s Chart component

This chapter covers images and diagrams.

More detailed descriptions on working with drawing tools can be found in the Draw Guide and
Impress Guide. Instructions on how to create charts are given in the Calc Guide.

Adding images to a document

Images can be added to a document in several ways: by inserting an image file, directly from a
graphics program or a scanner, from a file stored on your computer, or by copying and pasting from
a source being viewed on your computer.

Inserting an image file

When the image is in a file stored on the computer, you can insert it into an LibreOffice document
using either of the following methods.

Drag and drop
1) Open a file browser window and locate the image you want to insert.

2) Drag the image into the LibreOffice document and drop it where you want it to appear. A
faint vertical line marks where the image will be dropped.

This method embeds (saves a copy of) the image file in the document. To link the file instead of
embedding it, hold down the Ctrl+Shift keys while dragging the image.

Insert Image dialog
1) Click in the LibreOffice document where you want the image to appear.
2) Choose Insert > Image > From File from the menu bar.
3) On the Insert Image dialog, navigate to the file to be inserted, and select it.

At the bottom of the dialog (Figure 276) are two options, Preview and Link. Select
Preview to view a thumbnail of the selected image in the preview pane on the right, so that
you can verify that you have the correct file. See page 311 for the use of Link.

4) Click Open.

If you choose the Link option, a message box appears when you click Open. The
message states that the picture will not be stored with the document, but only
referenced as a link, and asks if you want to embed the graphic instead. Choose

Note Keep Link if you want the link, or Embed Graphic if you do not. To prevent this
message from appearing again, deselect the box by Ask when linking a graphic at
the bottom of the message.
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\# | |4 |[Eradiance | Pictures|
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Figure 276: Insert Image dialog

Linking an image file

If the Link option in the Insert picture dialog is selected, LibreOffice creates a link to the file
containing the image instead of saving a copy of the image in the document. The result is that the
image is displayed in the document, but when the document is saved, it contains only a reference
to the image file—not the image itself. The document and the image remain as two separate files,
and they are merged together only when you open the document again.

Linking an image has two advantages and one disadvantage:

Advantage — Linking can reduce the size of the document when it is saved, because the
image file itself is not included. File size is usually not a problem on a modern computer
with a reasonable amount of memory, unless the document includes many large graphics
files; LibreOffice can handle quite large files.

Advantage — You can modify the image file separately without changing the document
because the link to the file remains valid, and the modified image will appear when you
next open the document. This can be a big advantage if you (or someone else, perhaps a
graphic artist) is updating images.

Disadvantage — If you send the document to someone else, or move it to a different
computer, you must also send the image files, or the receiver will not be able to see the
linked images. You need to keep track of the location of the images and make sure the
recipient knows where to put them on another machine, so that the document can find
them. For example, you might keep images in a subfolder named Images (under the folder
containing the document); the recipient of the file needs to put the images in a subfolder
with the same name and in the same place relative to the document.
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When inserting the same image several times in the document, it would appear
Note beneficial to link rather than embed; however, this is not necessary as LibreOffice
embeds only one copy of the image file in the document.

Embedding linked images

If you originally linked the images, you can easily embed one or more of them later if you wish. To
do so:

1) Open the document in LibreOffice and choose Edit > Links.

2) The Edit Links dialog (Figure 277) shows all the linked files. In the Source file list, select the
files you want to change from linked to embedded.

3) Click the Break Link button.
4) Save the document.

Going the other way, from embedded to linked, is not so easy—you must delete and

Note reinsert the images, one at a time, selecting the Link option when you do so.

@ Edit Links

source File Element: Type Status close

./IMG_20130716_170904.jp( <All Formats> " Image “Manual , Help

.../IMG_20130603_082125.jpt <AllFormats= Image Manual

..f/IMG_20130603_082125.jpt <All Formats> Image Manual _ Update
Medify...
Break Link

Source file file:///home/radiance/Pictures/IMG_20130417_162911.jpg

Element: <All formats>

Type: Image

Update: Automatic Manual

Figure 277: The Edit Links dialog

Inserting an image from the clipboard
Using the clipboard, you can copy images into a LibreOffice document from another LibreOffice
document and from other programs. To do this:
1) Open both the source document and the target document.
2) In the source document, select the image to be copied.
3) Click once on the selected image and press Ctr/+C to copy the image to the clipboard.
4) Switch to the target document.
5) Click to place the cursor where the graphic is to be inserted.
6) Press Ctrl+V to insert the image.

Caujtlon If the application from which the graphic was copied is closed before the graphic is

pasted into the target, the image stored on the clipboard could be lost.
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Inserting an image using a scanner

If a scanner is connected to your computer, LibreOffice can call the scanning application and
inserted the scanned item into the LibreOffice document as an image. To start this procedure,
place the cursor where you want the graphic to be inserted and choose Insert > Image > Scan >
Select Source.

Although this practice is quick and easy, it is unlikely to result in a high-quality image of the correct
size. You may get better results by scanned material into a graphics program and cleaning it up
there before inserting the resulting image into LibreOffice.

Inserting an image from the Gallery

The Gallery provides a convenient way to group reusable objects such as graphics and sounds
that you can insert into your documents. The Gallery is available in all components of LibreOffice.
See “Managing the LibreOffice Gallery* on page 314. You can copy or link an object from the
Gallery into a document.

To insert an object:

1) Choose Tools > Gallery or click the Gallery icon |@| on the Standard toolbar (in Writer
and Calc) or the Drawing toolbar (in Impress, Writer, and Draw). The Gallery is also
accessible in the Sidebar (View > Sidebar and click the Gallery tab).

2) Select a theme.

3) Select an object with a single click.

4) Drag and drop the image into the document. (See Figure 278.)

You can also right-click on the object and choose Insert > Copy.

This then causes the Frame toolbar to replace the Formatting toolbar and opens the Picture
toolbar, docked to the Status bar.
To insert an object as a link:

1) Choose Tools > Gallery and select a theme.

2) Select an object with a single click, then while pressing the Shift and Ctrl keys, drag and
drop the object into the document.

Inserting an image as a background

To insert an image as the background to a page or paragraph:
1) Choose Tools > Gallery and select a theme.

2) Select an object with a single click, right-click on the object, and choose Insert >
Background > Page or > Paragraph.

Modifying and positioning graphics

LibreOffice provides many tools for resizing, modifying, filtering, and positioning graphics; wrapping
text around graphics; and using graphics as backgrounds and watermarks. These tools are
described in relevant chapters of the other guides. Some sophisticated adjustments of the graphics
are best done in an image manipulation program and the results brought into LibreOffice, rather
than using LibreOffice’s built-in tools.
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Figure 278: Copying a graphic object from the Gallery into a document (the Hide/Show button for
the Gallery is indicated by the ellipse)

Managing the LibreOffice Gallery

Graphics in the Gallery are grouped by themes, such as Bullets, Rulers, and Backgrounds. You
can create other groups or themes and add your own pictures or find extensions containing more
graphics.

The Gallery list box lists the available themes. Click on a theme to see its contents displayed in the
Gallery window.

You can display the Gallery in Icon View (Figure 279) or Detailed View, and you can hide or show
the Gallery by clicking on the Hide button (similar to the Hide button for the Navigator and the
Styles and Formatting windows when they are docked).

By default, the Gallery is docked above the workspace unless opened in the Sidebar when it is
opened in a vertical orientation to the right of the work space. To expand the Gallery, position the
pointer over the line that divides it from the top (or the left if the Sidebar Gallery) of the workspace.
When the pointer changes to parallel lines with arrows, click and drag downward. The workspace
resizes in response.

As with other docked windows, you can “float” the Gallery by moving the mouse pointer over an
edge of the Gallery window, holding down the Ctrl key, and double-clicking. Drag the floating
window to any of the edges of the LibreOffice window to dock the Gallery again.

In a default installation, only the My themes theme is customizable, although new
themes can be added as explained in “Adding a new theme to the Gallery” on page

Note 316. The locked themes are easily recognizable by right-clicking on them; the only
available option in the context menu is Properties. In some installations, or when
you are running LibreOffice as an Administrator, all themes are customizable.
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Figure 279: Icon view of one theme in the Gallery accessed from a toolbar

Adding objects to the Gallery

You may wish to add to the Gallery any images that you use frequently, for example, a company
logo. You can then very easily insert these graphics into a document later.

Method 1 (selecting a file)

1) Right-click on the desired theme and select Properties from the context menu.
2) In the theme’s Properties dialog, click the Files tab.

On the Files tab, you can either:
a) Click the Find Files button.

b) The Select path dialog (not shown) opens. You can enter the path for the file’s directory in
the Path text box, or you can navigate to locate the file’s directory.

c) Click the Select button to start the search. A list of graphic files is then displayed in the
Properties dialog. You can use the File type drop-down list to limit the files displayed.

d) To add all of the files shown in the list, click Add All. Otherwise, select the files to add and
then click Add (hold down either the Shift key or the Cirl key while clicking on the files).
Or, to add a single file:
a) Click the Add button to open the Gallery dialog.

b) Use the navigation controls to locate the image to add to the theme. Select it and then click
Open to add it to the theme.

c) Click the OK button of the Properties dialog to close it.

| New Theme... | || E @ Properties of My Theme

B Compukers = General | Files

B Diagramwm  Delete

B Environi  Rename ) . : Y

M Finance File type }:All Files> (*.bmp;*.dxf;*.emf;*.eps;*.gif;* | = . Find Files... [

E _ <No Files> | Add
B People

B School & University Add All
B Sounds -

Figure 280: Gallery Properties dialog
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Method 2 (drag and drop)
You can drag and drop an image into the Gallery from a document.

1) Open the document containing an image you want to add to the Gallery, and display the
Gallery theme to which you want to add it.

2) Position the mouse pointer above the image, without clicking.

3) If the mouse pointer changes to a hand symbol, the image refers to a hyperlink. In this
case, press the Alt key while you click the image, to select it without activating the link. If
the mouse pointer does not change to a hand symbol, you can simply click the image to
select it.

4) Once the image is selected, evident from the colored selection handles around it, release
the mouse button. Click again on the image, keeping the mouse button pressed for more
than two seconds. Without releasing the mouse button, drag the image into the Gallery.

5) Release the mouse button.

Deleting images from the Gallery

To delete an image from a theme:
1) Right-click on the name of the image file or its thumbnail in the Gallery.

2) Click Delete in the context menu. A message appears, asking if you want to delete this
object. Click Yes.

N Deleting the name of a file from the list in the Gallery does not delete the file from
ote the hard disk or other location. This includes the drag-drop folder in the Gallery.

Adding a new theme to the Gallery

To add a new theme to the Gallery:
1) Click the New Theme button above the list of themes (Figure 279).

2) In the Properties of New Theme dialog, click the General tab and type a name for the new
theme.

3) Click the Files tab and add images to the theme, as described earlier.

Deleting a theme from the Gallery

To delete a theme from the Gallery:
1) Go to Tools > Gallery.
2) Select from the list of themes the theme you wish to delete.
3) Right-click on the theme, then click Delete on the context menu.

Location of the Gallery and the objects in it

Graphics and other objects shown in the Gallery can be located anywhere on your computer’s hard
disk, on a network drive, or other removable media. Listings in the Gallery show the location of
each object. When you add graphics to the Gallery using method 1, the files are not moved or
copied; only the location of each new object is added as a reference. When files are added using
drag and drop, they are copied into a folder (dragdrop) in the Gallery, and allocated a file name.

Figure 281 shows in Detailed View, two files in the My Theme in the Gallery, one is contained in
the dragdrop folder, and the other is a reference path to its actual location.
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Figure 281: Theme showing files inserted with drag-and-drop and by reference

In a workgroup, you may have access to a shared Gallery (where you cannot change the contents
unless authorized to do so) and a user Gallery, where you can add, change, or delete objects.

The location of the user Gallery is specified in Tools > Options > LibreOffice > Paths. You can
change this location, and you can copy your gallery files (SDV) to other computers.

Gallery contents provided with LibreOffice are stored in a different location. You cannot change this
location.

Creating an image map

An image map defines areas of an image (called hotspots) with hyperlinks to web addresses, other
files on the computer, or parts of the same document. Hotspots are the graphic equivalent of text
hyperlinks (described in Chapter 12). Clicking on a hotspot causes LibreOffice to open the linked
page in the appropriate program (for example, the default browser for an HTML page; LibreOffice
Calc for an ODS file; a PDF viewer for a PDF file). You can create hotspots of various shapes and
include several hotspots in the same image.
To use the image map editor:
1) Inyour LibreOffice document, click on the picture in which you want to create the hotspots.
2) Choose Edit > ImageMap from the menu bar. The ImageMap Editor (Figure 282) opens.

3) Use the tools and fields in the dialog (described below) to define the hotspots and links
necessary.

4) Click the Apply icon “ to apply the settings.

5) When done, click the Save icon to save the image map to a file, then click the X in the
upper right corner to close the dialog.

The main part of the dialog shows the image on which the hotspots are defined. A hotspot is
identified by a line indicating its shape.
The toolbar at the top of the dialog contains the following tools:

* Apply button: click this button to apply the changes.

* Load, Save, and Select icons.

* Tools for drawing a hotspot shape: these tools work in exactly the same way as the
corresponding tools in the Drawing toolbar.

¢ Edit, Move, Insert, Delete Points: advanced editing tools to manipulate the shape of a
polygon hotspot. Choose the Edit Points tool to activate the other tools.

* Active icon: toggles the status of a selected hotspot between active and inactive.
* Macro: associates a macro with the hotspot instead of just associating a hyperlink.
* Properties: sets the hyperlink properties and adds the Name attribute to the hyperlink.
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Figure 282: The dialog to create or edit an image map

Below the toolbar, specify for the selected hotspot:

* Address: the address pointed to by the hyperlink. You can also point to an anchor in a
document; to do this, write the address in this format:
file:///<path>/document_name#anchor_name

* Text: type the text that you want to be displayed when the mouse pointer is moved over the
hotspot.

* Frame: where the target of the hyperlink will open: pick among _blank (opens in a new
browser window), _self (opens in the active browser window), _top or _parent.

The value _self for the target frame will usually work just fine. It is therefore not

Tip recommended to use the other choices unless absolutely necessary.

Using LibreOffice’s drawing tools

You can use LibreOffice’s drawing tools to create graphics such as simple diagrams using
rectangles, circles, lines, text, and other predefined shapes. You can also group several drawing
objects to make sure they maintain their relative position and proportion.

You can place the drawing objects directly on a page in your document, or you can insert them into
a frame.

You can also use the drawing tools to annotate photographs, screen captures, or other illustrations
produced by other programs, but this is hot recommended because:

* You cannot include images in a group with drawing objects, so they may not remain aligned
in your document.
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¢ If you convert a document to another format, such as HTML, the drawing objects and the
graphics will not remain associated; they are saved separately.

In general, if you need to create complex drawings, it is recommended to use LibreOffice Draw,
which includes many more features such as layers, styles, and so on.

Creating drawing objects

To begin using the drawing tools, display the Drawing toolbar (Figure 283) by clicking View >
Toolbars > Drawing.

If you are planning to use the drawing tools repeatedly, you can tear off this toolbar and move it to
a convenient place on the window.

G|/  m@®wTE|$-O-&-0-D-%- = =
1 2 3 4 5 6 7 8 9 10 1M1 12 13 4 15 16 17
1 Select 5 Freeform Line 9 Symbol Shapes 13 Stars
2 Line 6 Text 10 Block arrows 14 Points
3 Rectangle 7 Callouts 11 Flowcharts 15 Fontwork Gallery
4 Ellipse 8 Basic Shapes 12 Callouts 16 From File

17 Extrusion On/Off
Figure 283: The Drawing toolbar

To use a drawing tool:

1) Click in the document where you want the drawing to be anchored. You can change the
anchor later, if necessary.

2) Choose the tool from the Drawing toolbar (Figure 283). The mouse pointer changes to a
|

drawing-functions pointer similar to this one for a rectangle shape 'o,

3) Move the cross-hair pointer to the place in the document where you want the graphic to
appear and then click and drag to create the drawing object. Release the mouse button.
The selected drawing function remains active, so that you can draw another object of the
same type.

4) To cancel the selected drawing function, press the Esc key or click on the Select icon (the
arrow) on the Drawing toolbar.

5) You can now change the properties (fill color, line type and weight, anchoring, and others)
of the drawing object using either the Drawing Object Properties toolbar (Figure 284) or the
choices and dialogs reached by right-clicking on the drawing object.

Set or change properties for drawing objects

To set the properties for a drawing object before you draw it:
1) On the Drawing toolbar (Figure 283), click the Select tool.

2) On the Drawing Object Properties toolbar (Figure 284), click on the icon for each property
and select the value you want for that property.

3) For more control, or to define new attributes, you can click on the Area or Line icons on the
toolbar to display detailed dialogs.
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Figure 284: Drawing Object Properties toolbar

The default you set applies to the current document and session. It is not retained when you close
the document or close Writer, and it does not apply to any other document you open. The defaults
apply to all the drawing objects except text objects.
To change the properties for an existing drawing object:

1) Select the object.

2) Continue as described above.

You can also specify the position and size, rotation, and slant and corner radius properties of the
drawing object:
1) Right-click on the drawing object and then choose Position and Size from the context
menu. The Position and Size dialog is displayed.

2) Choose any properties, as required.

Resizing a drawing object
An object is resized in a similar way to an image. Select the object, click on one of the eight

handles around it and drag it to its new position. For a scaled resizing, select one of the corner
handles and keep the Shift key pressed while dragging the handle to its new position.

For more sophisticated control of the size of the object, choose Format > Object > Position and
Size from the Menu bar. Use the Position and Size dialog to set the width and height
independently. If the Keep ratio option is selected, then the two dimensions change so that the
proportion is maintained, allowing for a scaled resizing.

Grouping drawing objects

To group drawing objects:
1) Select one object, then hold down the Shift key and select the others you want to include in
the group. The bounding box expands to include all the selected objects.

2) With the objects selected, hover the mouse pointer over one of the objects and choose
Format > Group > Group from the Menu bar or right-click and choose Group > Group
from the pop-up menu.

Note You cannot include an embedded or linked graphic in a group with drawing objects.

Using Fontwork

With Fontwork you can create graphical text art objects to make your work more attractive. There
are many different settings for text art objects (line, area, position, size, and more), so you have a
large choice.

Fontwork is available with each component of LibreOffice, but you will notice small differences in
the way that each component displays it.
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The Fontwork toolbars
You can use two different toolbars for creating and editing a Fontwork object.
Choose either View > Toolbars > Fontwork or View > Toolbars > Drawing.

Fontwork v x
voRm o= -
Figure 285: The floating Fontwork toolbar

If you click on an existing Fontwork object, the Formatting toolbar changes to display the Fontwork
options as shown in Figure 290. The contents of this toolbar vary depending on the LibreOffice
component with which it is being used.

Creating a Fontwork object

-~

1) On the chosen toolbar, click the Fontwork Gallery icon E

2) Inthe Fontwork Gallery (Figure 286), select a Fontwork style then click OK. The Fontwork
object will appear in your document. Notice the colored squares around the edge
(indicating that the object is selected) and the yellow dot; these are discussed in “Moving
and resizing Fontwork objects” on page 325.

' & Fontwork Gallery

Select a Fontwork style:

FONtwek Fonfyork it

LN il

J
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Figure 286: The Fontwork Gallery

3) Double-click the object to edit the Fontwork text (see Figure 287). Select the text and type
your own text in place of the black Fontwork text that appears over the object.

4) Click anywhere in a free space or press Esc to apply your changes.
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Figure 287: Editing Fontwork text

Editing a Fontwork object

Now that the Fontwork object is created, you can edit some of its attributes. To do this, you can use
the Fontwork toolbar, the Formatting toolbar, or menu options as described in this section. If the
selected Fontwork object is a 3-D object, you can also use the 3D-Settings toolbar.

Using the Fontwork toolbar

Make sure that the Fontwork toolbar, shown in Figure 285, is visible. If you do not see it, go to
View > Toolbars > Fontwork. Click on the different icons to edit Fontwork objects.

-;E?_ . Fontwork Shape: Edits the shape of the selected object. i Fontwork v X
You can choose from a palette of shapes.
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Figure 288: Fontwork toolbar
showing palette of shapes

Fontwork Same Letter Heights: Changes the height of characters in the object. Toggles

Ad between normal height (some characters taller than others, for example capital letters, d,
h, | and others) and all letters the same height.

orwork FODEOM:

Figure 289: Left: normal letters; right: same letter heights
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Fontwork Alignment: Changes the alignment of characters.
Choices are left align, center, right align, word justify, and
stretch justify. The effects of the text alignment can only be
seen if the text spans over two or more lines. In the stretch
justify mode, all the lines are filled completely.

1l
4

’&9 . Fontwork Character Spacing: Changes the character spacing
and kerning in the object. Select from the choices in the drop-

down list.

Using the Formatting toolbar
Now let us go further and customize the Fontwork object with several

I
1
5
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1

Center
Right Align
Word Justify
Stretch Justify

Very Loose
Custom...

v Kern Characker Pairs

more attributes.

Click on the Fontwork object. The Formatting toolbar changes to show the options for editing the
object. (The toolbar shown in Figure 290 appears when you use Fontwork in Writer.)
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Figure 290: Formatting toolbar for a Fontwork object in Writer

This figure shows the toolbar floating. In its default, docked position it is one of the toolbars located
below the menu bar. The example toolbar has also been customized to show all of the available

options; by default only a subset of these options is shown.

The Formatting toolbar provides a large choice of options for customizing your object. These

choices are the same as the ones for other drawing objects. For more
Guide.

information, see the Draw
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Line options

Line icon: Opens a dialog with three tabs: Line, Line Styles, Arrow Styles. Use the Line tab to
edit the most common properties of the line around the selected Fontwork object, by choosing from
previously-defined attributes including line style, line color, and arrow styles. Use the Lines Styles
and Arrow Styles tabs to edit the properties of line and arrow styles, and define new styles.

Arrow Style icon: Choose from the different arrow styles.
Line Style box: Choose from the available line styles.
Line Width box: Set the width of the line.

Line Color box: Select the color of the line.

Area options

Area icon: Opens a dialog with seven tabs: Area, Shadow, Transparency, Colors, Gradients,
Hatching, Bitmaps.

* Areatab: Choose from the predefined list a color, bitmap, gradient or hatching pattern to fill
the selected object.

* Shadow tab: Set the shadow properties of the selected object.

* Transparency tab: Set the transparency properties of the selected object.

* Colors tab: Modify the available colors or add new ones to appear on the Area tab.

* Gradients tab: Modify the available gradients or add new ones to appear on the Area tab.

* Hatching tab: Modify the available hatching patterns or add new ones to appear on the
Area tab.

* Bitmaps tab: Create simple bitmap patterns and import bitmaps, to make them available
on the Area tab.

Area Style | Filling boxes: Select the type of the fill of the selected object. For more detailed
settings, use the Area icon.

Positioning options

Rotate icon: Rotate the selected object manually using the mouse to drag the object.
To Foreground icon: Move the selected object in front of the text.

To Background icon: Move the selected object behind the text.

Alignment icon: Modify the alignment of the selected objects.

Bring to front icon: Move the selected object in front of the others.

Send to back icon: Move the selected object behind the others.

Change Anchor icon: Choose between anchoring options:

* To Page—The object keeps the same position in relation to the page margins. It does not
move as you add or delete text.

* To Paragraph—The object is associated with a paragraph and moves with the paragraph. It
may be placed in the margin or another location.

* To Character—The object is associated with a character but is not in the text sequence. It
moves with the paragraph but may be placed in the margin or another location. This
method resembles anchoring to a paragraph.

* As Character—The object is placed in the document like any character and moves with the
paragraph as you add or delete text before the object.

Ungroup icon: Ungroup a selection of grouped objects, so that they can be managed individually.
Group icon: Group the selected objects, so you can manage them as a single object.
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Using menu options

You can use some the choices on the Format menu to anchor, align, arrange and group selected
Fontwork objects, wrap text around them, and flip them horizontally and vertically.

You can also right-click on a Fontwork object and choose many of the same options from the pop-
up menu. The pop-up menu also provides quick access to the Line, Area, Text, and Position and
Size dialogs. The Text dialog offers only a few options for Fontwork objects and is not discussed
here. On the Position and Size dialog, you can enter precise values concerning size and position.
For more information on all of these menu options, see the Draw Guide.

Using the 3D-Settings toolbar

If the selected Fontwork object is a 3-D object, you can also use the options on the 3D-Settings
toolbar. You can also change a 2-D Fontwork object into a 3-D object (or change a 3-D object into
a 2-D object) by clicking the Extrusion On/Off icon on the 3D-Settings toolbar. For more
information, see the Draw Guide.

3D-Settings 7
B L@ -9 -w-8 -
I | |

Egr?gfofn Depth ‘ Surface

n Direction 3D Color
Tilt Down, Up, oo
Left, Right Lighting

Figure 291: 3D-Settings toolbars

Moving and resizing Fontwork objects

When you select a Fontwork object, eight colored squares (known as handles) appear around the
edge of the object, as shown below. You can drag these handles to resize the object.

A yellow dot also appears on the object. This dot may be o o o
along an edge of the object, or it may be somewhere else;
in the example on the right. If you hover the pointer over
this yellow dot, the pointer turns into a hand symbol. You
can drag the dot in different directions to distort the object.

Hovering the pointer over other parts of the object turns the
pointer into the usual symbol for dragging the object to
another part of the page.

[m}

For precise control of the location and size of the object, use the Position and Size dialog.
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Introduction

This chapter describes how to do the following in Writer, Calc, Impress and Draw:

* Create hyperlinks within a document and to other documents such as web pages, PDFs,
and other files.

¢ Save documents as web pages (HTML documents).

When creating a document that you plan to deliver as a web page, you need to consider the
following:

* Inan HTML document, hyperlinks are active (clickable), but other cross-references inserted
by LibreOffice are not active links.

* An object such as a image is saved as a separate file. However, if that object has been
placed in a frame (for example, with an associated caption), it is not saved and does not
appear in the HTML document; instead, the name of the frame appears.

Relative and absolute hyperlinks

Hyperlinks stored within a file can be either relative or absolute.

Arelative hyperlink says, Here is how to get there starting from where you are now (meaning from
the folder in which your current document is saved) while an absolute hyperlink says, Here is how
to get there no matter where you start from.

An absolute link will stop working if the target is moved. A relative link will stop working if the start
and target locations change relative to each other. For instance, if you have two spreadsheets in
the same folder linked to each other and you move the entire folder to a new location, an absolute
hyperlink will break but a relative one will not.

To change the way that LibreOffice stores the hyperlinks in your file, select Tools > Options >
Load/Save > General and choose if you want URLs saved relatively when referencing the File
System, or the Internet, or both.

Calc will always display an absolute hyperlink. Do not be alarmed when it does this even when you
have saved a relative hyperlink. This ‘absolute’ target address will be updated if you move the file.

Make sure that the folder structure on your computer is the same as the file structure
Note on your web server if you save your links as relative to the file system and you are
going to upload pages to the Internet.

When you rest the mouse pointer on a hyperlink, a help tip displays the absolute
reference, because LibreOffice uses absolute path names internally. The complete

Tip path and address can only be seen when you view the result of the HTML export
(saving the spreadsheet as an HTML file), by loading the HTML file as text, or by
opening it with a text editor.

Creating hyperlinks

When you type text (such as a website addresses or URL) that can be used as a hyperlink, and
then press the spacebar or the Enter key, LibreOffice automatically creates the hyperlink and
applies formatting to the text (usually a color and underlining). If this does not happen, you can
enable this feature by going to Tools > AutoCorrect Options > Options on the main menu bar
and selecting the URL Recognition option.
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If you do not want LibreOffice to convert a specific URL to a hyperlink, go to Edit > Undo Insert on
the main menu bar, or press Ctrl+Z immediately after the formatting has been applied, or place the
cursor in the hyperlink, right-click, and select Remove Hyperlink from the context menu.

To change the color of hyperlinks, go to Tools > Options > LibreOffice >
Appearance, scroll to Unvisited links and/or Visited links, pick the new colors and
click OK. Caution: this will change the color for all hyperlinks in all components of

Tip LibreOffice; this may not be what you want.

In Writer and Calc (but not Draw or Impress), you can also change the Internet link
character style or define and apply new styles to selected links.

Using the Navigator

You can insert hyperlinks using the Navigator and this is an easy way to insert a hyperlink to
another part of the same document.

1)
2)

3)

4)

5)
6)

Open the documents containing the items you want to cross-reference.

-
Click on the Navigator icon @ or go to View > Navigator on the main menu bar, or press
the F5 key to open the Navigator dialog.

Click the triangle to right of the Drag Mode icon and select Insert as Hyperlink (Figure
292). Note that the Drag Mode icon changes shape depending on the type of insert that
was previously selected. The default icon for Drag Mode is to show the Hyperlink icon &=,

Select the document from the drop down list at the bottom of the Navigator that contains
the item that you want to cross-reference.

In the Navigator list, select the item that you want to insert as a hyperlink.

Drag the item to where you want to insert the hyperlink in the document. The name of the
item is inserted in the document as an active hyperlink.

@& MNavigator

0o-BE [ ==

i ] & E 3« Insertas Hyperlink

= Headings Insert as Link
% Tables Insert as Copy

[EText frames|
E& Graphics

|l OLE objects
& Bookmarks
= Sections

& Hyperlinks
E% References
*= Indexes

[Z] Comments
B Draw objects

|Untitled1 (active) =)

Figure 292: Inserting hyperlink using the Navigator

When using the Navigator to insert a hyperlink to an object such as a graphic, it is recommended
to have the hyperlink show a useful name, for example 2009 Sales Graph. You need to give such
objects useful names instead of leaving them as the default names, for example Graphics6, or you
will have to edit the name of the resulting link using the Hyperlink dialog, as described below.
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You can also use the Navigator to insert a hyperlink from one document (the source) to a specific
place in another document (the target). Open the Navigator in the target document and drag the
item to the position in the source document where you want the hyperlink to appear.

Using the Hyperlink dialog
You can the Hyperlink dialog to insert a hyperlink and modify all hyperlinks.

1)
2)

3)

4)
5)

6)

Highlight the existing text you want to use as a link.

Click the Hyperlink icon @ on the Standard toolbar or go to Insert > Hyperlink on the

main menu bar to open the Hyperlink dialog (Figure 293).

On the left side, select one of the four categories of hyperlink:
* Internet: the hyperlink points to a web address, normally starting with http://.
* Mail & News: the hyperlink opens an email message that is pre-addressed to a

particular recipient.

* Document: the hyperlink points to another document or to another place in the current

document

* New document: the hyperlink creates a new document.

The Hyperlink dialog changes depending on the type of hyperlink selected. Enter all

necessary details to create the hyperlink.

Click Apply to create the hyperlink and the Hyperlink dialog remains open allowing you to

create another hyperlink.
Click Close to close the Hyperlink dialog.

& Hyperlink

% Hyperlink type
Internet ® web O EP

Target [

0

Mail & News

Document
Further settings

= Frame v| Form |Text

g

S | e

Help ‘ l Back ‘

Figure 293. Hyperlink dialog showing details for Internet links

The dialog changes according to the choice made for the hyperlink category in the left panel. A full
description of all the choices and their interactions is beyond the scope of this chapter. Here is a
summary of the most common choices.

For an Internet hyperlink, choose the type of hyperlink (Web, FTP, or Telnet), and enter the

required web address (URL).

For a Mail and News hyperlink, specify whether it is a mail or news link, the address of the

receiver and, for email, the subject.

For a Document hyperlink, specify the document path (clicking Open File opens a file
browser) or leave this blank if you want to link to a target in the same document. Optionally
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specify the target in the document (for example a specific slide). Click the Target in

Document icon to open the Target in Document dialog where you can select the type
of target; or, if you know the name of the target, you can type it into the box.

For a New Document hyperlink, specify whether to edit the newly created document
immediately (Edit now) or just create it (Edit later). Enter the file name and select the type

of document to create (text, spreadsheet, and so on). Click the Select Path icon tl to
open a file browser and choose where to store the file.

The Further settings section in the bottom right part of the dialog is common to all the hyperlink
categories, although some choices are more relevant to some types of links.

Frame value determines how the hyperlink will open. This applies to documents that open
in a Web browser.

Form specifies if the link is to be presented as text or as a button. See the Writer Guide
Chapter 15 Using Forms in Writer for more information.

Text specifies the text that will be visible to the user. If you do not enter anything here,
LibreOffice uses the full URL or path as the link text. Note that if the link is relative and you
move the file, this text will not change, though the target will.

Name is applicable to HTML documents. It specifies text that will be added as a NAME
attribute in the HTML code behind the hyperlink.

Events @: click this icon to open the Assign Macro dialog and select a macro to run
when the link is clicked. See Chapter 13 Getting Started with Macros for more information.

Editing hyperlinks

To edit an existing link:

1)
2)

3)

4)

Click anywhere in the hyperlink text.

Click the Hyperlink icon @ on the Standard toolbar or go to Edit > Hyperlink on the
main menu bar or right-click and select Edit Hyperlink from the context menu. The
Hyperlink dialog opens.

Make your changes and click Apply to save your changes. The Hyperlink dialog remains
open allowing you to continue editing hyperlinks. Click Apply after editing each hyperlink.

When you are finished editing hyperlinks, click Close.

The standard (default) behavior for activating hyperlinks within LibreOffice is to use Ctrl+click. This
behavior can be changed in Tools > Options > LibreOffice > Security > Options and deselecting
the option Ctrl-click required to follow hyperlinks. If clicking in your links activates them, check
that page to see if the option has been deselected.

Removing hyperlinks

You can remove the link from hyperlink text and leave just the text by right-clicking on the link and
selecting Remove Hyperlink from the context menu. You may then need to re-apply some
formatting to match the text with the rest of your document.

To erase the link text or button from the document completely, select it and press the Backspace or
Delete key.
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Creating web pages using the Web Wizard

The Web Wizard in LibreOffice allows you to create several types of standard web pages and is
available all LibreOffice modules. However, each time you open the Web Wizard in a LibreOffice
module, Writer will automatically start before the Web Wizard dialog opens. The Web Wizard is
linked to Writer and is normally used in Writer for creating web pages.

1) Go to File > Wizards > Web Page on the menu bar to open the Web Wizard dialog (Figure
294).

@ web Wizard

Steps Introduction

1. Introduction

2.Documents

This Web Wizard is to aid you in publishing documents on the Internet.

It will convert the documents so that they can be viewed by a web browser. In addition,

3. Main layout
4. Layout details
5.Style

it will generate a Table of Contents page with links for easy access to the documents.
The Web Wizard will also allow you to customize the design and layout of your web site.

You will be able to keep the documents you have published on the web up-to-date and

6.Web site information add or remove documents at any time.

7.Preview

Choose settings for the Web Wizard
|<default> 2] | Delete

s O e (e

Figure 294: Introduction page of Web Wizard dialog

2) On the first page of the Wizard, choose settings and click Next >. If this is your first web
page, the only choice is <default>.

3) Select or browse to the document you would like to format. The information for Title,
Summary and Author is taken from the document properties. If necessary, edit this
information (Figure 295).

® web wizard

Steps Select the documents you want to publish

1.Introduction Web site content Export to File format:

G54000-Preface_PS_20130125.0dt HTML i
3. Main layout
4.Layout details Document information
5.Style Title:
6. Web site information 7 _Preface
7.Preview = :

= Summary:

Author:

’Jean Hollis Weber ]

Cancel

—

| sBack || Next= | | Finish

Figure 295: Documents page of Web Wizard dialog
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4) Click Next > and select a layout for the web site by clicking on the layout boxes (Figure
296).

& Wweb Wizard
Steps Choose a layout For the table of contents of your web site
1.Introduction Layouts:

2.Documents

4. Layout details
5.Style —
6.Web site information E?

7.Preview lix—

Table with 3 columns

Come SN o o

Figure 296: Main layout page of Web Wizard dialog

5) Click Next > to customize the layout and select the information to be listed and screen
resolution (Figure 297).

6) Click Next > and select a style for the page. Use the drop-down list to choose different
styles and color combinations. Browse to select a background image and icon set from the
Gallery (Figure 298).

#® web wizard

Steps Customize the selected layout

1.Introduction Include the following information for each document in the table of contents:

2.Documents

3. Main layout [ Filename [ File Format
.Layout details [ Description B File formaticon
5.Style [] Author [] Number of pages
6. Web site information [J Creation date ® sizein KB

[] Lastchange date

7.Preview
Optimize the layout fFor screen resolution:
) 640x480

@ 800x600
) 1024x768

Coms ) SN e (oo

Figure 297: Layout details page of Web Wizard dialog
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& Wweb wizard

Steps Select a style for the table of contents page

2.Documents

i . <no background image>
3. Main layout Background image: g g Choose
4, Layout details

Icon set: <no icon set> Choose...
5. Style

Theicon set is used for presentations in HTML Format.

1.Introduction Skyle: [Water = ]

6.Web site information
7.Preview

Site title

Document
Creation Date
Last Change Date
Filename

( )

' Help <Back m Finish | cancel

Figure 298: Style page of Web Wizard dialog

7) Click Next > and enter general information for the web site such as Title and HTML
Metadata information (Figure 299).

® Web wizard
Steps Enter general information for your web site
1.Introduction Title:

2.Documents
3. Main layout

. HTML Metadata
4. Layout details
5.Style Description: [ ]
:
E-mail: [ ]
7.Preview

Copyright notice: [ ]

Created: 02/09/13 |

Modified: 02/09/13 |

Cocms | S o e

Figure 299: Web site information page of Web Wizard dialog

8) Click Next > and select where to save the file and preview the page if you wish (Figure
300).

9) Enter the information of where to publish your new web site.
10) Click Finish to save the file and close the Web Wizard.
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@ Wweb wizard

Steps Where do you want to publish your web site?
1.Introduction click 'Preview’ to see a preview in your browser:
2.Documents = ]

Preview
3. Main layout

. Publish the new web site:
4. Layout details

5.Style & Toalocalfolder

6. Web site information [ ] D
[] ToazIParchive

[l To aweb server viaFTP

Configure...
[ save settings (recommended)
Save as: | web wizard Settings1 [+]
Help <Back Next > Finish Cancel

Figure 300: Preview page of Web Wizard dialog

Saving documents as web pages

HTML capabilities in LibreOffice include saving and exporting existing documents in HTML format.
You can also create several different types of web pages using the Web Wizard included with
LibreOffice, see “Creating web pages using the Web Wizard” on page 332 for more information.

The easiest way to create HTML documents is to start with an existing document. You can get a
good idea of how it will appear as a web page by using View > Web Layout. However, web layout
view does not show you which features will or will not be saved correctly in HTML format. Refer to
“Introduction” on page 328 on what to consider before creating a web page from a document.

Writer documents

Single web page

To save a document as a single web page (HTML format) by going to File > Save As on the menu
bar and specify HTML Document (Writer) as the file type or File > Export and specifying XHTML
format as the file type.

Writer does not replace multiple spaces in the original document with the HTML code
for non-breaking spaces. If you want to have extra spaces in your HTML file or web
page, you need to insert non-breaking spaces in LibreOffice. To do this, press
Ctrl+Spacebar instead of just Spacebar.

Note

Series of web pages
Writer can save a large document as a series of web pages (HTML files) with a table of contents
page.

1) Decide which headings in the document should start on a new page and make sure all
those headings have the same paragraph style (for example, Heading 1).

2) Go to File > Send > Create HTML Document on the menu bar to open the Name and
Path of the HTML Document dialog (Figure 301).
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@& Name and Path of the HTML Document

Name: [ ]
Save in folder: ul [ peter “ Dropbox “ LO40 Getting Started “ G500 Preface Create Folder
Places Name v Size Modified |-
Q, search | test web doc.html 6.1KB 10:19
& Recently Used |+| test web doc1.html 7.1KB | 10:19
|+ test web doc2.html 1.9KB 10:19
[ peter
& Desktop |+ test web doc3.html 2.8KB 10:19
A Fi || test web doc4.html 12.2KB 10:19
X File System
[ Documents l+ test web doc5.html 7.6KB |10:19
il Music || test web doc6.html 12.4KB 10:19
Il Pictures |+ test web doc7.html |44KB |10:19
@ Videos || test web doc8.html 1.7KB 10:19
& Downloads |+ test web doc9.html |2.6KB |10:19
[ home |+ test web doc10.html 7.8KB 10:19
) HTML Document =
> File type
Styles:| Outline: Level1 2

Figure 301. Creating a series of web pages from one document
3) Type the file name to save the pages under.

4) Specify which style indicates a new page using the Styles drop list at the bottom of the
dialog (for example Heading 1).

5) Click Save to create the multi-page HTML document. The resulting HTML files conforms to
the HTML 4 Transitional.

Calc spreadsheets

Calc can save files as HTML documents by going to File > Save As on the menu bar and select
HTML Document (Calc) format as the file type. This is similar to “Single web page” on page 335.

If the file contains more than one sheet and the web pages are created using the Web Wizard (see
“Creating web pages using the Web Wizard” on page 332), the additional sheets will follow one
another in the HTML file. Links to each sheet will be placed at the top of the document.

Calc also allows the insertion of links directly into the spreadsheet using the Hyperlink dialog. See
“Creating hyperlinks” on page 328 for more information on hyperlinks.

Impress presentations

Note Saving as web pages in HTML format does not retain animation and slide transitions.

Impress presentations cannot be saved in HTML format, but have to be exported as HTML
documents. Note that you can click Create at any step in the following procedure. The web pages
created will then use the default settings that you have not changed in any way.
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1)
2)

3)

Go to File > Export on the menu bar and specify the file name and location of where to
save the web page version of your presentation.

Select HTML document (Impress) as the file type and click Save to open the HTML
Export dialog (Figure 302).

On the Assign design page you can choose to create a new design and select or delete an
existing design. Specify a New design or an Existing design and click Next>>. If you have
not previously saved a web page design, the Existing Design choice is not available.

* New design — creates a new design in the next pages of the Wizard.

* Existing design — loads an existing design from the design list to use as a starting point
for the steps that follow. The list box displays all existing designs.

Delete Selected Design deletes the selected design from the design list. If you delete a
design, you will only delete the design information. An export file will not be deleted by this
action.

# HTML Export

Assign design
) New design

| Delete Selected Design

Select an existing design or create a new one

Lo ] oo NS G

Figure 302: HTML Export dialog - Assign design page

& HTML Export

Publication type Options
@ standard HIML Format B Createtitle page

() standard HTML with frames & Show notes

) Automatic

) WebCast

e

UUTEY!
i

[ Help ] I Cancel I I << Back ‘

Create

Figure 303: HTML Export dialog — Publication type page

4) Specify the Publication type for the web pages (Figure 303), then click Next>>. The

publication type defines the basic settings for the intended export. The choices are:
e Standard HTML format — creates standard HTML pages from export pages.
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* Standard HTML with frames — creates standard HTML pages with frames. The exported
page will be placed in the main frame and the frame to the left will display a table of
contents in the form of hyperlinks.

* Automatic — creates a default HTML presentation as a kiosk export in which the slides
are automatically advanced after a specified amount of time.

* WebCast — in a WebCast export, automatic scripts will be generated with Perl or ASP
support. This enables the speaker (for example, a speaker in a telephone conference
using a slide show on the Internet) to change the slides in the web browsers used by
the audience.

For more information on the options available for this page of the HTML Export dialog, click
Help to open the help pages.

5) Specify the options for Save graphics as, Monitor resolution and Effects used for the web
pages (Figure 304), then click Next>>. The options for this page of the HTML Export dialog
are as follows:

* Save graphics as — determines the image format. You can also define the compression
value for the export.

* Monitor resolution — defines the resolution for the target screen. Depending on the
selected resolution, the image will be displayed in a reduced size. You can specify a
reduction of up to 80% from the original size. When selecting a resolution, consider
what the majority of your viewers might be using. If you specify a high resolution, then a
viewer with a medium-resolution monitor will have to scroll sideways to see the entire
slide, which is probably not desirable.

* Effects — specifies that sound files defined as an effect for slide transitions and whether
any hidden slides are exported.

For more information on the options available for this page of the HTML Export dialog, click
Help to open the help pages.

@ HTML Export

Save graphics as Monitor resolution
@ PNG @ Low resolution (640x480 pixels)
O GIF () Medium resolution (800x600 pixels)
) JPG () High resolution (1024x768 pixels)

75% |+ | Quality

Effects
& Exportsounds when slide advances

[] Exporthidden slides

[ Help ] l Cancel l [ << Back ‘ w ' Create

Figure 304: HTML Export dialog — graphics and monitor resolution

6) Specify the Information for the title page to be used with the web version of your
presentation (Figure 305). The title page normally contains the author's name, an e-mail
address and home page, along with any additional information you may want to include.
This page is not available if you have selected not to create a title page and either
Automatic or WebCast publication type.
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@ HTML Export

Information For the title page
Author [Peter Schofield ]

E-mail address [ ]

Your homepage [ ]

Additional infermation

[] Link to a copy of the original presentation

| Help |  cancel | <<Back || Mextzs || create

Figure 305: HTML Export dialog — title page information

7) Select Link to a copy of the original presentation if you want to create a hyperlink to
download a copy of the presentation file and then click Next>>,

8) Select button style to be used for the web pages from the designs available (Figure 306)
and then click Next>>,

If you do not select a button style, LibreOffice will create a text navigator.
This page is not available if you have selected either Automatic or WebCast publication
type.

9) Select color scheme to be used for the web pages (Figure 307) such as the color scheme
and colors for text and background. This page is not available if you have selected either
Automatic or WebCast publication type.

| @ HTML Export
Select button style
& Textonly

UL L L LT T J
FEEEEEEE
BOPNE@OO
€ >Nt — ,

| —— I L create

Figure 306: HTML Export dialog — button style page
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@ HTML Export

select color scheme
@® Apply color scheme from document
() Use browser colors

() Use custom color scheme

l Text ] Text Background
l Hyperlink ] Hyperlink
[ Active Link ] Active link
l Visited Link l Visited link

[ Help ] l Cancel l [ << Back ] Next >> ' ﬁ

Figure 307: HTML Export dialog — color scheme page

10) Click Create.
11) If you have created a new design for your web pages, type in a name for your design and
click Save.

Depending on the size of your presentation and the number of graphics it contains,
the HTML export function creates several HTML, JPG, and GIF files. For example, if

Note you simply save to your desktop and not in a specific folder, these separate HTML
and graphics files will be placed all over your desktop. It is recommended to create a
folder to hold all the files created for the web version of your presentation.

Draw documents

Draw documents cannot be saved in HTML format, but have to be exported as HTML documents.
Exporting drawings as web pages from Draw is similar to exporting a presentation from Impress.
Go to File > Export and select HTML Document (Draw) as the file type, then follow the procedure
above for exporting Impress presentations.
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Introduction

A macro is a saved sequence of commands or keystrokes that are stored for later use. An example
of a simple macro is one that “types” your address. The LibreOffice macro language is very
flexible, allowing automation of both simple and complex tasks. Macros are very useful when you
have to repeat the same task in the same way over and over again.

LibreOffice macros are usually written in a language called LibreOffice Basic, sometimes
abbreviated to Basic. Although you can learn Basic and write macros, there is a steep learning
curve to writing macros from scratch. The usual methods for a beginner are to use macros that
someone else has written or use the built-in macro recorder, which records keystrokes and saves
them for use.

Most tasks in LibreOffice are accomplished by “dispatching a command” (sending a command),
which is intercepted and used. The macro recorder works by recording the commands that are
dispatched (see “Dispatch framework” on page 351).

Your first macros

Adding a macro

The first step in learning macro programming is to find and use existing macros. This section
assumes that you have a macro that you want to use, which may be in an email, on a web page, or
even in a book. For this example, the macro in Listing 1 is used. You must create a library and
module to contain your macro; see “Macro organization” on page 352 for more information.

Listing 1: Simple macro that says hello

Sub HelloMacro
Print "Hello"
End Sub

i@ LibreOffice Basic Macros

Macro name

i

» (& Formwizard

» (& Gimmicks

» (& Importwizard

» (& scriptBindingLibrary

¥ (5 Template
g ﬁm

& correspondence
& ModuleAgenda

[Main ]
Macro from Existing macros in: Autotext

¥ = My Macros )

¥ (5 standard CreateUserDatafield

& Module1 CreateBullet

¥ = LibreOffice Macros CreatePlaceholder

* (& Depot

» (& Euro

Delete

Qrganizer...
» (5 Tools L :
» (& wikiEditor 3 Help
= 1InkiHled 1 = =

Figure 308: LibreOffice Basic Macros dialog
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@& Libreoffice Basic Macro Organizer

Location [_= - Edit _=]
O S P - S
Library ) :
| password.. |
| import. |
| Export... |
|. Delete |

Figure 309: LibreOffice Basic Macro Organizer dialog

@ - 0 My Macros & Dialogs.TestLibrary - LibreOFffice Basic
File Edit View Tools Window Help

BE-BWd & e @Y s e
|[My Macros & Dialogs].TestLibrai 2 ] g me TN ¢ ) % B
Object Catalog REM *®%%x BASIC **%*x

¥ &= My Macros & Dialog Sub Main
¥ (& standard
» & Module1 End Sub

v (& TestLibra
> & X
r = LibreOFfice Macros
» [ untitled 1

{ i b »
Watch:l Calls:
Variable Value Type
[[<)[)) Module1 7 N 5
My Macros & Dialogs.TestLibrary.Module1 Ln 6, Col 1

Figure 310: Integrated Debugging Environment dialog

Use the following steps to create a library to contain your macro:

1) Use Tools > Macros > Organize Macros > LibreOffice Basic to open the LibreOffice
Basic Macro dialog (Figure 308).

2) Click Organizer to open the Basic Macro Organizer dialog (Figure 309) and select the
Libraries tab.

3) Set the Location to My Macros & Dialogs, which is the default location.
4) Click New to open the New Library dialog.

5) Enter a library name, for example TestLibrary, and click OK.

6) Select the Modules tab.

7) In the Module list, expand My Macros and select, for example TestLibrary. A module named

Modulel already exists and can contain your macro. If you wish, you can click New to
create another module in the library.
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8)

9)

10)

11)
12)

13)
14)

15)

Select Modulel, or the new module that you created, and click Edit to open the Integrated
Debugging Environment (IDE) (Figure 310). The IDE is a text editor included with
LibreOffice that allows you to create and edit macros.

When a new module is created, it contains a comment and an empty macro named Main,
which does nothing.

Add the new macro either before Sub Main or after End Sub. Listing 2 shows the new
macro has been added before Sub Main.

Click the Compile icon @’ on the Macro toolbar to compile the macro.

Place the cursor in the HelloMacro subroutine and click the Run BASIC icon [I] on the
Macro toolbar, or press the F5 key, to run the HelloMacro in the module. A small dialog will
open with the word “Hello” displayed. If the cursor is not in a subroutine or function, a
dialog will open; select the macro to run.

Click OK to close this small dialog.

To select and run any macro in the module, click the Select Macro icon @ on the
Standard toolbar or go to Tools > Macros > Organize Macros > LibreOffice Basic.

Select a macro and then click Run.

Listing 2: Modulel after adding the new macro.

REM

* Kk k k% BASIC * Kk k k%

Sub HelloMacro

Print "Hello"

End Sub

Sub Main

End Sub

Recording a macro

If you have to repeatedly enter the same information, you can copy this information after it has
been entered into your document for the first time, then paste the information into your document
each time you want to use it. However, if something else is copied to the clipboard, the contents on
the clipboard are changed. This means that you have to re-copy your repeated information. To
overcome this problem, you can create a macro that enters your repeated information.

For some types of information that you want to repeatedly enter into a document, it

Note maybe more convenient to create an AutoText file. See the Writer Guide Chapter 3

1)

2)
3)
4)

5)

Working with Text for more information.

Make sure macro recording is enabled by going to Tools > Options > LibreOffice >
Advanced on the main menu bar and selecting the option Enable macro recording. By
default, this feature is turned off when LibreOffice was installed on your computer.

Go to Tools > Macros > Record Macro on the main menu bar to start recording a macro.
A small dialog is displayed indicating that LibreOffice is recording a macro.

Type the desired information or perform an appropriate series of operations. As an
example, type your name.

Click Stop Recording on the small Recording dialog to stop recording and the LibreOffice
Basic Macros dialog opens (Figure 308 on page 342).

Open the library container My Macros.
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6) Find the library named Standard in My Macros. Note that every library container has a
library named Standard.

7) Select the Standard library and click New Module to create a new module to contain the
macro. This opens the New Module dialog (Figure 311).

@ New Module

Hame: r,—mﬂ

e —

Figure 311: New Module dialog

8) Type a descriptive name for the new module, for example Recorded and click OK to create
the module. The LibreOffice Basic Macros dialog now displays the name of the new module
in the Standard library.

9) In the Macro name text box, type a name for the macro you have just recorded, for
example EnterMyName.
10) Click Save to save the macro and close the LibreOffice Basic Macros dialog.

11) If you followed all of the above steps, the Standard library now contains a module named
Recorded and this module contains the EnterMyName macro.

When LibreOffice creates a new module, it automatically adds the macro named

Note Main.

Running a macro

1) Go to Tools > Macros > Run Macro on the main menu bar to open the Macro Selector
dialog (Figure 312).
2) For example, select your newly created macro EnterMyName and click Run.

3) Alternatively, go to Tools > Macros > Organize Macros > LibreOffice Basic on the main
menu bar to open the LibreOffice Basic Macros dialog, select your macro and click Run.

@ Macro Selector

Select the library that contains the macro you want. Then select the macro under (r——
'Macro name’'.

Library Macro name Cancel
¥ & My Macros =
v (5 standard F Main [E]
» [F Module1
>
» (& TestLibrary
» & wikiEditor
» = LibreOffice Macros
*» [5] untitled 1

Figure 312: Macro Selector dialog
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Viewing and editing macros

To view and/or edit the macro that you created:

1) Go to Tools > Macros > Organize Macros > LibreOffice Basic to open the LibreOffice
Basic Macros dialog.

2) Select your new macro EnterMyName and click Edit to open the macro in the Basic IDE.
The macro EnterMyName is shown in Listing 3.

The EnterMyName macro is not as complicated as it first appears. Learning a few things helps
significantly in understanding macros. The discussion starts with features near the top of the macro
listing and describes them.

Listing 3: Generated “EnterMyname” macro

REM kkkk*k BASIC kkkk*k
Sub Main

End Sub

sub EnterMyName
= R L LR e
rem define variables

dim document as object

dim dispatcher as object

) e LR E R
rem get access to the document
document = ThisComponent.CurrentController.Frame

dispatcher = createUnoService("com.sun.star.frame.DispatchHelper")

=) L L E L LR R
dim args1(0) as new com.sun.star.beans.PropertyValue
argsi(0).Name = "Text"

args1i(0).value = "Your name"

dispatcher.executeDispatch(document, ".uno:InsertText", "", 0, argsi())
end sub

REM comments

All comments in macro coding begin with REM, which stands for remark. All text after REM and on
the same line is ignored. As a short cut, the single quote character (') can also be used to start a
comment.

LibreOffice Basic is not case-sensitive for keywords, so REM, Rem, and rem can all start a
comment. If you use symbolic constants defined by the Application Programming Interface (API), it
is safer to assume that the names are case-sensitive. Symbolic constants are an advanced topic
not covered by this user guide and are not required when using the macro recorder in LibreOffice.

Defining subroutines with SUB

Individual macros are stored in subroutines and these subroutines begin with the keyword SUB.
The end of a subroutine is indicated by the words END SUB. The code starts by defining the
subroutine named Main, which is empty and does nothing. The next subroutine, EnterMyName,
contains the generated code for your macro.

LibreOffice always creates an empty subroutine named Main when it creates a

Note module.
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There are advanced topics that are beyond the scope of this user guide, but knowing about them
might be of interest:

* You can write a macro so that values can be passed to the subroutine. The values are
called arguments. However, recorded macros in LibreOffice do not accept arguments.

¢ Another kind of subroutine is called a function, which is a subroutine that returns a value.
Functions are defined by the keyword FUNCTION at the beginning. However, recorded
macros in LibreOffice always create subroutines, not functions.

Defining variables using Dim

You can write information on a piece of paper so that you can look at it later. A variable, like a piece
of paper, contains information that can be changed and read. The Dim keyword originally stood for
Dimension and was used to define the dimensions of an array. The dim statement used in the
EnterMyName macro is similar to setting aside a piece of paper to be used to store a message or
note.

In the EnterMyName macro, the variables document and dispatcher are defined as the type
object. Other common variable types include string, integer, and date. A third variable, named
argsl, is an array of property values. A variable of type array allows a single variable to contain
multiple values, similar to storing multiple pages in a single book. Values in an array are usually
numbered starting from zero. The number in the parentheses indicates the highest usable number
to access a storage location. In this example, there is only one value, and it is numbered zero.

Explaining macro code

The following is an explanation of the code used in the EnterMyName macro. You may not
understand all the details, but the explanation of each line of code may give you some idea of how
a macro works.

sub EnterMyName
Defines the start of the macro

dim document as object
Defined as a variable

dim dispatcher as object

Defined as a variable

document = ThisComponent.CurrentController.Frame

ThisComponent refers to the current document.

CurrentController is a property referring to a service that controls the document. For example,

when you type, it is the current controller that takes note of what you type. CurrentController
then dispatches the changes to the document frame.

Frame is a controller property that returns the main frame for a document. Therefore, the
variable named document refers to a document’s frame, which receives dispatched commands.
dispatcher = createUnoService("com.sun.star.frame.DispatchHelper")

Most tasks in LibreOffice are accomplished by dispatching a command. LibreOffice includes a
dispatch helper service, which does most of the work when using dispatches in macros. The
method CreateUnoService accepts the name of a service and it tries to create an instance of
that service. On completion, the dispatcher variable contains a reference to a DispatchHelper.
dim args1(0) as new com.sun.star.beans.PropertyVvalue

Declares an array of properties. Each property has a name and a value. In other words, it is a
name/value pair. The created array has one property at index zero.

args1i(0).Name = "Text"

args1(0).value = "Your name"

Chapter 13 Getting Started with Macros | 347



Gives the property the name “Text” and the value “Your name”, which is the text that is inserted
when the macro is run.
dispatcher.executeDispatch(document, ".uno:InsertText", "", 0, argsi())

This is where the magic happens. The dispatch helper sends a dispatch to the document frame
(stored in the variable named document) with the command .uno:InsertText. The next two
arguments, frame name and search flags, are beyond the scope of this document. The last
argument is the array of property values to be used while executing the command InsertText.
end sub

The last line of the code ends the subroutine.

Creating a macro

When creating a macro, it is important to ask two questions before recording:

1) Can the task be written as a simple set of commands?

2) Can the steps be arranged so that the last command leaves the cursor ready for the next
command or entering text or data into the document?

A more complicated example of a macro
A common task is to copy rows and columns of data from a web site and format them as a table in
a text document as follows:

1) Copy the data from the web site to the clipboard.

2) To avoid strange formatting and fonts, paste the text into a Writer document as unformatted
text.

3) Reformat the text with tabs between columns so that it can be converted into a table using
Table > Convert > Text to Table on the main menu bar.

DONTKNOW The font weight is not specified/known.
THIN specifies a 50% font weight.
ULTRALIGHT specifies a 60% font weight.

LIGHT specifies a 75% font weight.
SEMILIGHT specifies a 90% font weight.

NORMAL specifies a normal font weight.
SEMIBOLD specifies a 110% font weight.

BOLD specifies a 150% font weight.
ULTRABOLD specifies a 175% font weight.

BLACK specifies a 200% font weight.

Figure 313: Example of copied data

With the two questions given above in mind, inspect the text to see if a macro can be recorded to
format the text. An example of copied data showing the FontWeight constants group from the API
web site (Figure 313). The first column in this example indicates a constant name and each name
is followed by a space and a tab, and each line has two trailing spaces.

The first column in the table should contain a numeric value, the second column the name, and the
third column the description. This conversion is easily accomplished for every row except for
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DONTKNOW and NORMAL, which do not contain a numeric value, but the values are between 0
and 100 and can be entered manually.

The data can be cleaned up in several ways, all of them easy to accomplish. The example given
below uses keystrokes that assume the cursor is at the start of the line with the text THIN.

1) Make sure macro recording is enabled by going to Tools > Options > LibreOffice >
Advanced on the main menu bar and selecting the option Enable macro recording. By
default, this feature is turned off when LibreOffice was installed on your computer.

2) Go to Tools > Macros > Record Macro on the main menu bar to start recording.
3) Press Ctrl+Right Arrow to move the cursor to the start of “specifies”.
4) Press Backspace twice to remove the tab and the space.
5) Press Tab to add the tab without the space after the constant name.
6) Press Delete to delete the lower case s and then press Shift+S to add an upper case S.
7) Press Ctrl+Right Arrow twice to move the cursor to the start of the number.
8) Press Ctrl+Shift+Right Arrow to select and move the cursor before the % sign.
9) Press Ctrl+C to copy the selected text to the clipboard.
10) Press End to move the cursor to the end of the line.
11) Press Backspace twice to remove the two trailing spaces.
12) Press Home to move the cursor to the start of the line.
13) Press Ctrl+V to paste the selected number to the start of the line.

14) Pasting the value also pasted an extra space, so press Backspace to remove the extra
space.

15) Press Tab to insert a tab between the number and the name.

16) Press Home to move to the start of the line.

17) Press down arrow to move to the next line.

18) Stop recording the macro and save the macro, see “Recording a macro” on page 344.

It takes much longer to read and write the steps than to record the macro. Work slowly and think
about the steps as you do them. With practice this becomes second nature.

The generated macro code in Listing 4 has been modified to contain the step number in the
comments to match the code to the step above.

Listing 4: Copying numeric value to start of the column

sub CopyNumToCol1l

g e R
rem define variables

dim document as object

dim dispatcher as object

= e T
rem get access to the document
document = ThisComponent.CurrentController.Frame

dispatcher = createUnoService("com.sun.star.frame.DispatchHelper")

rem (3) Press Ctrl+Right Arrow to move the cursor to the start of “specifies”.
dispatcher.executeDispatch(document, ".uno:GoToNextWord", "", 0, Array())

rem (4) Press Backspace twice to remove the tab and the space.
dispatcher.executeDispatch(document, ".uno:SwBackspace", "", 0, Array())

g b R L
dispatcher.executeDispatch(document, ".uno:SwBackspace", "", 0, Array())
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rem (5) Press Tab to add the tab without the space after the constant name.
dim args4(0) as new com.sun.star.beans.PropertyVvValue

args4(0).Name = "Text"

args4(0).value = CHR$(9)

dispatcher.executeDispatch(document, ".uno:InsertText", "", 0, args4())

rem (6) Press Delete to delete the lower case s .
dispatcher.executeDispatch(document, ".uno:Delete", "", 0, Array())

rem (6) ... and then press Shift+S to add an upper case S.
dim args6(0) as new com.sun.star.beans.PropertyValue
args6(0).Name = "Text"

args6(0).value = "S"

dispatcher.executeDispatch(document, ".uno:InsertText", "", 0, argsé6())

rem (7) Press Ctrl+Right Arrow twice to move the cursor to the number.
dispatcher.executeDispatch(document, ".uno:GoToNextWord", "", 0, Array())

g e LR R
dispatcher.executeDispatch(document, ".uno:GoToNextWord", "", 0, Array())

rem (8) Press Ctrl+Shift+Right Arrow to select the number.
dispatcher.executeDispatch(document, ".uno:WordRightSel", "", 0, Array())

rem (9) Press Ctrl+C to copy the selected text to the clipboard.
dispatcher.executeDispatch(document, ".uno:Copy", "", 0, Array())

rem (10) Press End to move the cursor to the end of the line.
dispatcher.executeDispatch(document, ".uno:GoToEndOfLine", "", 0, Array())

rem (11) Press Backspace twice to remove the two trailing spaces.
dispatcher.executeDispatch(document, ".uno:SwBackspace", "", 0, Array())

=) L R L LR
dispatcher.executeDispatch(document, ".uno:SwBackspace", "", 0, Array())

rem (12) Press Home to move the cursor to the start of the line.
dispatcher.executeDispatch(document, ".uno:GoToStartOfLine", "", 0, Array())

rem (13) Press Ctrl+V to paste the selected number to the start of the line.
dispatcher.executeDispatch(document, ".uno:Paste", "", 0, Array())

rem (14) Press Backspace to remove the extra space.
dispatcher.executeDispatch(document, ".uno:SwBackspace", "", 0, Array())

rem (15) Press Tab to insert a tab between the number and the name.
dim args17(0) as new com.sun.star.beans.PropertyValue
args17(0).Name = "Text"

args17(0).vValue = CHR$(9)

dispatcher.executeDispatch(document, ".uno:InsertText", "", 0, argsi7())
rem (16) Press Home to move to the start of the line.
dispatcher.executeDispatch(document, ".uno:GoToStartOfLine", "", 0, Array())

rem (17) Press Down Arrow to move to the next line.
dim args19(1) as new com.sun.star.beans.PropertyValue
args19(0).Name = "Count"

args19(0).value = 1
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args19(1).Name = "Select"
args19(1).value = false

dispatcher.executeDispatch(document, ".uno:GoDown", "", 0, argsi9())
end sub

Cursor movements are used for all operations (as opposed to searching). If run on the
DONTKNOW line, the word weight is moved to the front of the line, and the first “The” is changed
to “She”. This is not perfect, but you should not run the macro on the lines that did not have the
proper format. You need to do these manually.

Running a macro quickly
It is tedious to repeatedly run the macro using Tools > Macros > Run Macro on the main menu
bar when the macro can be run from the IDE (Figure 310 on page 343).

1) Go to Tools > Macros > Organize Macros > LibreOffice Basic on the main menu bar to
open the Basic Macro dialog (Figure 308 on page 342).

2) Select your macro and click Edit to open the macro in the IDE.

3) Click the Run BASIC icon [I] on the Macro toolbar, or press the F5 key, to run the macro.
4) Unless you change the first macro, it is the empty macro named Main. Modify Main so that
it reads as shown in Listing 5.

5) Now, you can run CopyNumToColl by repeatedly clicking the Run Basic icon in the toolbar
of the IDE. This is very fast and easy, especially for temporary macros that will be used a
few times and then discarded.

Listing 5: Modify Main to call CopyNumToColl.

Sub Main
CopyNumToCol1l
End Sub

Macro recorder failures

Sometimes the macro recorder has a failure and understanding LibreOffice internal workings helps
to understand how and why the macro recorder sometimes fails. The primary offender is related to
the dispatch framework and its relationship to the macro recorder.

Dispatch framework

The purpose of the dispatch framework is to provide uniform access to components (documents)
for commands that usually correspond to menu items. Using File > Save from the main menu bar,
the shortcut keys Ctr/+S, or clicking the Save icon are all of commands that are translated into the
same “dispatch command”.

The dispatch framework can also be used to send “commands” back to the User Interface (Ul). For
example, after saving the document, the File Save command is disabled. As soon as the document
has been changed, the File Save command is enabled.

A dispatch command is text, for example .uno:InsertObject or .uno:GoToStartOfLine. The
command is sent to the document frame and this passes on the command until an object is found
that can handle the command.

How the macro recorder uses the dispatch framework

The macro recorder records the generated dispatches. The recorder is relatively simple tool to use
and the same commands that are issued are recorded for later use. The problem is that not all
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dispatched commands are complete. For example, inserting an object generates the following
code:

dispatcher.executeDispatch(document, ".uno:InsertObject", "", 0, Array())

It is not possible to specify what kind of object to create or insert. If an object is inserted from a file,
you cannot specify which file to insert.

Recording a macro and using Tools > Options on the main menu bar to open and modify
configuration items, the generated macro does not record any configuration changes. In fact, the
generated code is commented so it will not even be run.

rem dispatcher.executeDispatch(document,
".uno:0OptionsTreeDialog", "", 0, Array())

If a dialog is opened, a command to open the dialog is likely to be generated. Any work done inside
the dialog is not usually recorded. Examples of this include macro organization dialogs, inserting
special characters, and similar types of dialogs. Other possible problems using the macro recorder
include things such as inserting a formula, setting user data, setting filters in Calc, actions in
database forms, and exporting a document to an encrypted PDF file. You never know for certain
what will work unless you try it. For example, the actions from the search dialog are properly
captured.

Other options

When the macro recorder is not able to solve a specific problem, the usual solution is to write code
using the LibreOffice objects. Unfortunately, there is a steep learning curve for these LibreOffice
objects. It is usually best to start with simple examples and then increase the scope of macros as
you learn more. Learning to read generated macros is a good place to start.

If you record Calc macros, and the recorder can correctly generate a macro, there is an add-in
available which converts Calc macros when they are recorded. The final code manipulates
LibreOffice objects rather than generating dispatches. This can be very useful for learning the
object model and can be downloaded directly from the web site:

http://www.paolo-mantovani.org/downloads/DispatchToApiRecorder/

Macro organization

In LibreOffice, macros are grouped in modules, modules are grouped in libraries, and libraries are
grouped in library containers. A library is usually used as a major grouping for either an entire
category of macros, or for an entire application. Modules usually split functionality, such as user
interaction and calculations. Individual macros are subroutines and functions. Figure 314 shows an
example of the hierarchical structure of macro libraries in LibreOffice.

Go to Tools > Macros > Organize Macros > LibreOffice Basic on the main menu bar to open the
LibreOffice Basic Macros dialog (Figure 308 on page 342). All available library containers are
shown in the Macro from list. Every document is a library container, capable of containing multiple
libraries. The application itself acts as two library containers, one container for macros distributed
with LibreOffice called LibreOffice Macros, and one container for personal macros called My
Macros.

The LibreOffice Macros are stored with the application runtime code, which may not be editable to
you unless you are an administrator. This helps protect these macros because they should not be
changed and you should not store your own macros in the LibreOffice container.

Unless your macros are applicable to a single document, and only to a single document, your
macros will probably be stored in the My Macros container. The My Macros container is stored in
your user area or home directory.
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Library Container

Module 1
Module 2

Macro 1

Macro 2

Figure 314: Macro Library hierarchy

If a macro is contained in a document, then a recorded macro will attempt to work on that
document; because it primarily uses “ThisComponent” for its actions.

Every library container contains a library named Standard. It is better to create your own libraries
with meaningful names than to use the Standard library. Not only are meaningful names easier to
manage, but they can also be imported into other library containers whereas the Standard library
cannot.

Caution LibreOffice allows you to import libraries into a library container, but it will not allow
you to overwrite the library named Standard. Therefore, if you store your macros in
the Standard library, you cannot import them into another library container.

Just as it makes good sense to give your libraries meaningful names, it is prudent to use
meaningful names for your modules. By default, LibreOffice uses names such as Modulel,
Module2 and so on.

As you create your macros, you must decide where to store them. Storing a macro in a document
is useful if the document will be shared and you want the macro to be included with the document.
Macros stored in the application library container named My Macros, however, are globally
available to all documents.

Macros are not available until the library that contains them is loaded. The Standard library and
Template library, however, are automatically loaded. A loaded library is displayed differently from a
library that is not loaded. To load the library and the modules it contains, double-click on the library.

Where are macros stored?

LibreOffice stores user-specific data in a directory in the home directory for each user. The location
is operating system specific. Go to Tools > Options > LibreOffice > Paths on the main menu bar
to view where other configuration data are stored. For example, on computer running Windows XP,
thisis C:\Documents and Settings\<user name>\Application Data. User macros are
stored in LibreOffice\4\user\basic. Each library is stored in its own directory off the basic
directory.

Chapter 13 Getting Started with Macros | 353



It is not important to understand where macros are stored for casual use. If you know where they
are stored, however, you can create a backup, share your macros, or inspect them if there is an
error.

Go to Tools > Macros > Organize Dialogs on the main menu bar to open the LibreOffice Macro
Organizer dialog (Figure 309 on page 343). Alternatively, go to Tools > Macros > Organize
Macros > LibreOffice Basic on the main menu bar to open the LibreOffice Macros dialog (Figure
308 on page 342) and then click the Organizer button.

Importing macros

The LibreOffice Macro Organizer dialog allows you to import macro libraries into your document as
well as creating, deleting, and renaming libraries, modules, and dialogs.

1) Select the library container to use and then click Import to import macro libraries (Figure
309 on page 343).

2) Navigate to the directory containing the library to import (Figure 315). There are usually two
files from which to choose, dialog.xlb and script.xlb. It does not matter which of these two
files you select; both will be imported. Macros can be stored in libraries inside LibreOffice
documents. Select a document rather than a directory on disk to import libraries contained
in a document.

Note You cannot import the library named Standard.

@ Import Libraries

@ B[ﬁ pekes " conkig " libceabfice IEH user “ ba.r.ic]

Places ~ | Name v Size Modified
Q search
@ Recently Used TestLibrary . Saturday '
@ peter [ dialog.xlc 545 bytes 09:27

Desktop [ script.xlc 545 bytes 09:27

E2 File system

[i© Documents

[l Music

im| Pictures
[ = RV PP \TA

5 BASIC *
P File type

Cancel w

Figure 315: Navigating to a macro library

On a computer operating Linux, the LibreOffice specific files are stored in the home
directory of a user in a directory whose name begins with a period. Directories and

Tip files with names beginning with a period may be hidden and not shown in a normal
selection dialog. If using LibreOffice dialogs, rather than the operating system
specific dialogs, type the name of the desired directory in the Name field.

3) Select a file and click Open to continue and open the Import Libraries dialog (Figure 316).
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& Import Libraries

File name:dialog.xlb

%% TestLibrary

Options

[ Insert as reference (read-only)

[] Replace existing libraries

Cancel

Figure 316: Choose library import options

4) Select the following options for importing libraries:

a) If no options are selected, the library is copied to your user macro directory. However, if
the library you are importing has the same name and you are importing into the same

location, it will not be copied.

b) Select Replace existing libraries if the library you want to import has the same name
and you want to replace the existing library.

c) Select Insert as reference if you want to use the library as reference, but not import the
library into your document. When a library is used as a reference, it remains in its
current location and is read only.

5) Click OK to import the macro library you selected.

Downloading macros to import

Macros are available for download. Some macros are contained in documents, some as regular
files that you must select and import, and some as macro text that should be copied and pasted
into the Basic IDE. See “Adding a macro” on page 342 on how to add macros to your macro library
and “Viewing and editing macros” on page 346 on how to edit macros using the Basic IDE.

Some macros are available as free downloads on the Internet (see Table 11).

Table 11. Macro examples

Location

Description

http://www.pitonyak.org/oo.php

Reference materials regarding macros.

http://www.pitonyak.org/database/

Reference materials regarding database macros.

http://development.openoffice.org/

Lots of links to everything.

http://www.oooforum.org/

A forum, with many examples and help.

http://forum.openoffice.org/

Another forum, with many examples and help.
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How to run a macro

Although you can use Tools > Macros > Run Macro to run all macros, this is not efficient for
frequently run macros. See “Running a macro” on page 345 for more information.

A more common technique for frequently used macros is to assign the macro a toolbar icon, menu
item, keyboard shortcut, or a button embedded in a document. While choosing a method, it is also
good to ask questions such as:

¢ Should the macro be available for only one document, or globally for all documents?
* |s the macro for a specific document type, such as a Calc document?
* How frequently will the macro be used?

The answers will determine where to store the macro and how to make it available. For example,
you will probably not add a rarely used macro to a toolbar. To help determine your choices, see
Table 12.

Table 12. Methods for starting a macro

Type LibreOffice Document Type Document
Toolbar No Yes Yes

Menu No Yes Yes
Shortcut Yes Yes No

Event Yes No Yes

Toolbars, menu items and keyboard shortcuts

To add a menu item, keyboard shortcut, or toolbar icon that calls a macro, use the Customize
dialog (Figure 317). The Customize dialog contains pages to configure menus, keyboard shortcuts,
toolbars, and events. To open this dialog, go to Tools > Customize on the main menu bar or right-
click in an empty space on a toolbar and select Customize Toolbar from the context menu.

Complete coverage of the Customize dialog is beyond the scope of this chapter. Click the Help
button to access the help pages included with LibreOffice or see Chapter 14 Customizing
LibreOffice.
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Figure 317: Menus page in Customize dialog

Events

In LibreOffice, when something happens it means that an event occurred. For example, opening a
document, pressing a key, or moving the mouse cursor. LibreOffice allows events to cause a
macro to be called; the macro is then called an event handler. Full coverage of event handlers is
well beyond the scope of this document, but a little knowledge can accomplish much.

Be careful when you configure an event handler. For example, assume that you
write an event handler that is called every time that a key is pressed, but you make a
mistake so the event is not properly handled. One possible result is that your event
handler will consume all key presses, forcing you to forcibly terminate LibreOffice.

Caution

1) Go to Tools > Customize on the main menu bar to open the Customize dialog and select
the Events tab (Figure 318). The events in the Customize dialog are related to the entire
application and specific documents.

2) In Save In, select LibreOffice, or a specific document from the drop down menu to save
your event.

3) Acommon use is to assign the Open Document event to call a specific macro. The macro
then performs certain setup tasks for the document. Select the desired event and click
Macro to open the Macro Selector dialog (Figure 312 on page 345).

4) Select the desired macro and click OK to assign the macro to the event. The Events page
shows that the event has been assigned to a macro.
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Figure 318: Events page in Customize dialog

Many objects in a document can be set to call macros when events occur. The most common use
is to add a control, such as a button, into a document. Even double-clicking on a graphic opens a
dialog with a Macros tab that allows you to assign a macro to an event.

Extensions

An extension is a package that can be installed into LibreOffice to add new functionality.
Extensions can be written in almost any programming language and may be simple or
sophisticated. Extensions can be grouped into types:

* Calc Add-Ins, which provide new functionality for Calc, including new functions that act like
normal built-in functions

* New components and functionality, which normally include some level of User Interface (Ul)
integration such as new menus or toolbars

* Pivot Tables that are used directly in Calc

* Chart Add-Ins with new chart types

¢ Linguistic components such as spell checkers
* Document templates and images

Although individual extensions can be found in several places, there is currently an extension
repository at: http://extensions.libreoffice.org/ and some documentation at
http://libreplanet.org/wiki/Group:OpenOfficeExtensions/List.

For more about obtaining and installing extensions, see Chapter 14 Customizing LibreOffice.
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Writing macros without the recorder

The examples covered in this chapter are created using the macro recorder and the dispatcher.
You can also write macros that directly access the objects that comprise LibreOffice if you are
confident in writing computer code. In other words, you can create a macro that directly
manipulates a document.

Directly manipulating LibreOffice internal objects is an advanced topic that is beyond the scope of
this chapter. A simple example, however, demonstrates how this works.

Listing 6: Append the text “Hello” to the current document.

Sub AppendHello
Dim oDoc
Dim sTextService$
Dim oCurs

REM ThisComponent refers to the currently active document.
oDoc = ThisComponent

REM Verify that this is a text document

sTextService = "com.sun.star.text.TextDocument"

If NOT oDoc.supportsService(sTextService) Then
MsgBox "This macro only works with a text document"
Exit Sub

End If

REM Get the view cursor from the current controller.
oCurs = oDoc.currentController.getViewCursor()

REM Move the cursor to the end of the document
oCurs.gotoEnd(False)

REM Insert text "Hello" at the end of the document

oCurs.Text.insertString(oCurs, "Hello", False)
End Sub

Finding more information

Numerous resources are available that provide help with writing macros. Use Help > LibreOffice
Help to open the LibreOffice help pages. The upper left corner of the LibreOffice help system
contains a drop-down list that determines which help set is displayed. To view the help for Basic,
choose LibreOffice Basic from this list.

Included material

Many excellent macros are included with LibreOffice. Use Tools > Macros > Organize Macros >
LibreOffice Basic to open the Macro dialog. Expand the Tools library in the LibreOffice library
container. Inspect the Debug module—some good examples include Writedbginfo(document) and
printdbginfo(sheet).

Online resources

The following links and references contain information regarding macro programming:
http://ask.libreoffice.org/ (a Q & A site where volunteers answer questions related to LibreOffice)
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http://forum.openoffice.org/en/forum/ (Apache OpenOffice community forum; volunteers answer
questions about LibreOffice as well)

http://api.openoffice.org/docs/common/ref/com/sun/star/module-ix.html (official IDL reference; here
you will find almost every command with a description)

https://wiki.documentfoundation.org/Documentation/Other_Documentation_and_Resources (look
in Programmers section for BASIC Programmers’ Guide and Developers’ Guide; the latter contains
a detailed explanation)

http://www.pitonyak.org/oo.php (macro page for Andrew Pitonyak)
http://www.pitonyak.org/AndrewMacro.odt (numerous examples of working macros)
http://www.pitonyak.org/OOME_3_0.odt (Andrew Pitonyak’s book on macros)

http://www.pitonyak.org/database/ (numerous macro examples using Base)

Printed and eBook materials

There are currently no books specific to LibreOffice macros that are available for download.
Information in the following books is mostly applicable to LibreOffice; the books are available for
purchase in both printed and eBook form from their publishers:

Dr. Mark Alexander Bain's Learn OpenOffice.org Spreadsheet Macro Programming.

See http://www.packtpub.com/openoffice-ooobasic-calc-automation/book.

Roberto Benitez's Database Programming with OpenOffice.org Base & Basic.
See http://www.lulu.com/product/paperback/database-programming-with-openofficeorg-base-
basic/3568728
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Introduction

This chapter describes some common customizations that you may wish to carry out.

You can customize menus, toolbars, and keyboard shortcuts in LibreOffice, add new menus and
toolbars, and assign macros to events. However, you cannot customize context (right-click) menus.

Other customizations are made easy by extensions that you can install from the LibreOffice
website or from other providers.

Customizations to menus and toolbars can be saved in a template. To do so, first
Note save them in a document and then save the document as a template as described in
Chapter 3, Using Styles and Templates.

Customizing menu content

In addition to changing the menu font (described in Chapter 2, Setting up LibreOffice), you can add
and rearrange categories on the menu bar, add commands to menus, and make other changes.

To customize menus:
1) Choose Tools > Customize.
2) On the Customize dialog (Figure 319), choose the Menus page.

Customise

Menus | Keyboard | Toolbars | Events

LibreCffice Writer Menus

Menu File M [ New... |

[ Menu = ]

Menu Content

Entries New . [ Add... |
Open...
Recent Documents [ Modify b ]

Wizards

(B Close

E Save
E Save As...
Save Al
% Reload il
Save In LibreOffice Writer v

Description

Creates a new LibreQffice document.

Figure 319: The Menus page of the Customize dialog

3) Inthe Save In drop-down list, choose whether to save this changed menu for the
application (for example, LibreOffice Writer) or for a selected document (for example,
SampleDocument.odt).

4) In the section LibreOffice [name of the program (example: Writer)] Menus, select from
the Menu drop-down list the menu that you want to customize. The list includes all the main
menus as well as submenus (menus that are contained under another menu). For
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example, in addition to File, Edit, View, and so on, there is File | Send and Edit | Changes.
The commands available for the selected menu are shown in the central part of the dialog.

5) To customize the selected menu, click on the Modify button. You can also add commands
to a menu by clicking on the Add button. These actions are described in the following
sections. Use the up and down arrows next to the Entries list to move the selected menu
item to a different position.

6) When you have finished making all your changes, click OK (not shown in illustration) to
save them.

Creating a new menu
In the Menus page of the Customize dialog, click New to display the New Menu dialog, shown in
Figure 320.

1) Type a name for your new menu in the Menu name box.

2) Use the up and down arrow buttons to move the new menu into the required position on
the menu bar.

3) Click OK to save.

The new menu now appears on the list of menus in the Customize dialog. (It will appear on the
menu bar itself after you save your customizations.)

After creating a new menu, you need to add some commands to it, as described in “Adding a
command to a menu” on page 364.

L 1

New Menu

Menu name

Mew M 1
s ey Cancel

Menu position

File

Edit

View

Insert

Faormat E
Table .
Tools .
Window
Help

Mew Menu 1

II]m

Help

Figure 320: Adding a new menu

Modifying existing menus

To modify an existing menu, either user-made or inbuilt, select it in the Menu list and click the
Menu button to drop down a list of modifications: Move, Rename, Delete. Not all of these
modifications can be applied to all the entries in the Menu list. For example, Rename and Delete
are not available for the supplied menus, and Move is not available for submenus.

To move a menu (such as File), choose Menu > Move. A dialog similar to the one shown in Figure
320 (but without the Menu name box) opens. Use the up and down arrow buttons to move the
menu into the required position.
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To move submenus (such as File | Send), select the main menu (File) in the Menu list and then, in
the Menu Content section of the dialog, select the submenu (Send) in the Entries list and use the
arrow keys to move it up or down in the sequence. Submenus are easily identified in the Entries list
by a small black triangle on the right hand side of the name.

In addition to renaming, you can allocate a letter in a custom menu’s hame, which will become
underlined, to be used as a keyboard shortcut, allowing you to select that menu by pressing Alt+
that letter. Existing submenus can be edited to change the letter which is used to select theirdefault
shortcut.

1) Select a custom menu or a submenu in the Menu drop-down list.
2) Click the Menu button and select Rename.

3) Add a tilde (~) in front of the letter that you want to use as an accelerator. For example, to
select the Send submenu command by pressing S (after opening the File menu using
Alt+F), enter ~Send. This changes it from the default d.

It is possible to use a letter already in use in the menu list (for example, in the Insert
menu, the letter v is used in Envelope and in Movie and sound as an accelerator).
However, you should use an unused letter if possible, to make it simpler for the user
to navigate.

Note

Adding a command to a menu

You can add commands to both the supplied menus and menus you have created. On the
Customize dialog, select the menu in the Menu list and click the Add button in the Menu Content
section of the dialog.

On the Add Commands dialog (Figure 321), select a category and then the command, and click
Add. The dialog remains open, so you can select several commands. When you have finished
adding commands, click Close. Back on the Customize dialog, you can use the up and down
arrow buttons to arrange the commands in your preferred sequence.

[ o

Add Commands

To add a command to a menu, select the category and then the command.
You can also drag the command to the Commands list of the Menus tab page
in the Customise dialogue box.

Category Commands
Application: A About LibreOffice ~ add
Templates AutoPilot: Address Data Sour,

EE: AutoPilot: Presentation
Options Bibliography Database
BASIC Create HTML Document

Insert Create Master Document

Documents Edit Macros

Format .

Mavigate #>H Bt

Controls Extended Tips

Table &4 Help a

Drawing = s - : 7

Graphic - < 4
Description

Displays general program information such as version number and copyrights.

Figure 321: Adding a command to a menu
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Modifying menu entries

In addition to changing the sequence of entries on a menu or submenu, you can add submenus,
rename or delete the entries, and add group separators.

To begin, select the menu or submenu to be modified, from the Menu list near the top of the
Customize page, then select the entry in the Entries list under Menu Content. Click the Modify
button and choose the required action from the drop-down list of actions.

Most of the actions should be self-explanatory. Begin a group adds a separator line after the
highlighted entry.

Customizing toolbars

You can customize toolbars in several ways, including choosing which icons are visible and locking
the position of a docked toolbar (as described in Chapter 1, Introducing LibreOffice), and adding or
deleting icons (commands) in the list of those available on a toolbar. You can also create new
toolbars. This section describes how to create new toolbars and add or delete icons on existing
ones.

To get to the toolbar customization dialog (Figure 322), do any of the following:
* On the toolbar, right-click in the toolbar and choose Customize Toolbar.
* Choose View > Toolbars > Customize from the menu bar.
* Choose Tools > Customize from the menu bar and go to the Toolbars page.

Menus | Keyboard |Toolbars Events

LibreOffice Writer Toolbars

Toolbar Standard V [ Mew... l

[ Toolbar - l

Toolbar Content
Commands

@ Load URL A [ Add... |
|_'| Mew [
|_'| Mew Document From Templat' '

Open... 4+
i save

E Save As...

[, Document as E-mail. ..

Madify - |

=% Fdit File jladl

“RIEEOEEOED

Save In LibreOffice Writer v

Description

Loads a document specified by an entered URL. You can type a new URL, edit an URL or select one
fram the list, Displays the full path of the current document.

Figure 322: The Toolbars page of the Customize dialog
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Modifying existing toolbars

To modify an existing toolbar:

1) Inthe Save In drop-down list, choose whether to save this changed toolbar for the
application (for example, Writer) or for a selected document.

2) In the section LibreOffice [name of the program (example: Writer)] > Toolbars, select
from the Toolbar drop-down list the toolbar that you want to customize.

3) Click on the Toolbar or Modify buttons, and add commands to a toolbar by clicking on the
Add button. You can also create a new toolbar by clicking on the New button. These
actions are described in the following sections.

4) When you have finished making all your changes, click OK to save them.

Creating a new toolbar
To create a new toolbar:

1) Choose Tools > Customize > Toolbars from the menu bar.

2) Click New. On the Name dialog, type the new toolbar's name and choose from the Save In
drop-down list where to save this changed menu: for the application (for example, Writer) or
for a selected document. Click OK.

[§ Name X1
Toolbar Name | oK ‘
|New Toolbar 1

| Cancel ‘
Save In
LibreOffice Writer v] | Help |

The new toolbar now appears on the list of toolbars in the Customize dialog. After creating a new
toolbar, you need to add some commands to it, as described below.

Adding a command to a toolbar

If the list of available buttons for a toolbar does not include all the commands you want on that
toolbar, you can add commands. When you create a new toolbar, you need to add commands to it.

1) On the Toolbars page of the Customize dialog, select the toolbar in the Toolbar list and click
the Add button in the Toolbar Content section of the dialog.

2) The Add Commands dialog is the same as for adding commands to menus (Figure 321).
Select a category and then the command, and click Add. The dialog remains open, so you
can select several commands. When you have finished adding commands, click Close. If
you insert an item which does not have an associated icon, the toolbar will display the full
name of the item: the next section describes how to choose an icon for a toolbar command.

3) Back on the Customize dialog, you can use the up and down arrow buttons to arrange the
commands in your preferred sequence.

4) When you have finished making changes, click OK to save.
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Choosing icons for toolbar commands

Toolbar buttons usually have icons, not words, on them, but not all of the commands have
associated icons.

To choose an icon for a command, select the command and click Modify > Change icon. On the
Change Icon dialog, you can scroll through the available icons, select one, and click OK to assign
it to the command (Figure 323).

F{Ihangelcon -\
Icons

12 N BB s = wa

— TV RPERLERDE

f @ BT O i\ @< ™ 7 bl

HEY G Plh=E QA |

Maote:
The size of an icon should be 16x16 pixel to achieve best guality. Different sized
icons will be scaled automatically.

[ QK ] [ Cancel ] [ Help ]

Figure 323: Change Icon dialog

To use a custom icon, create it in a graphics program and import it into LibreOffice by clicking the
Import button on the Change Icon dialog. Custom icons should be 16 x 16 pixels in size to achieve
the best quality and should not contain more than 256 colors.

Example: Adding a Fax icon to a toolbar

You can customize LibreOffice so that a single click on an icon automatically sends the current
document as a fax.

1) Be sure the fax driver is installed. Consult the documentation for your fax modem for more
information.

2) Choose Tools > Options > LibreOffice Writer > Print. The dialog shown in Figure 324
opens.

3) Select the fax driver from the Fax list and click OK.

4) Right-click in the Standard toolbar. In the drop-down menu, choose Customize Toolbar.
The Toolbars page of the Customize dialog appears (Figure 322). Click Add.

5) On the Add Commands dialog (Figure 325), select Documents in the Category list, then
select Send Default Fax in the Commands list. Click Add. Now you can see the new icon
in the Commands list.

6) Inthe Commands list, click the up or down arrow button to position the new icon where you
want it. Click OK and then click Close.
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Figure 324: Setting up LibreOffice for sending faxes
Your toolbar now has a new icon to send the current document as a fax.
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Figure 325: Adding a Send Fax command to a toolbar

Assigning shortcut keys

In addition to using the built-in keyboard shortcuts (listed in Appendix A), you can define your own.
You can assign shortcuts to standard LibreOffice functions or your own macros and save them for
use with the entire LibreOffice suite.

Be careful when reassigning your operating system’s or LibreOffice’s predefined

Caution

computer.

shortcut keys. Many key assignments are universally understood shortcuts, such as
F1 for Help, and are always expected to provide certain results. Although you can
easily reset the shortcut key assignments to the LibreOffice defaults, changing some
common shortcut keys can cause confusion, especially if other users share your
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To adapt shortcut keys to your needs, use the Customize dialog, as described below.

1) Select Tools > Customize > Keyboard. The Customize dialog opens.
2) To have the shortcut key assignment available in all components of LibreOffice select the
LibreOffice button.
3) Next select the required function from the Category and Function lists.
4) Now select the desired shortcut keys in the Shortcut keys list and click the Modify button at
the upper right.
5) Click OK to accept the change. Now the chosen shortcut keys will execute the function
chosen in step 3 above whenever they are pressed.
All existing shortcut keys for the currently selected Function are listed in the Keys
selection box. If the Keys list is empty, it indicates that the chosen key combination is
free for use. If it were not, and you wanted to reassign a shortcut key combination
Note that is already in use, you must first delete the existing key.

Shortcut keys that are grayed-out in the listing on the Customize dialog, such as F1
and F10, are not available for reassignment.

Example: Assigning styles to shortcut keys

You can configure shortcut keys to quickly assign styles in your document. Some shortcuts are
predefined, such as Ctrl+0 for the Text body paragraph style, Ctrl+1 for the Heading 1 style, and
Ctrl+2 for Heading 2. You can modify these shortcuts and create your own.

1)

2)

3)

4)

5)

6)

7

Click Tools > Customize > Keyboard. The Keyboard page of the Customize dialog
(Figure 326) opens.

To have the shortcut key assignment available only with one component (for example,
Writer), select that component’s name in the upper right corner of the page; otherwise
select LibreOffice to make it available to every component.

Choose the shortcut keys you want to assign a style to. In this example, we have chosen
Ctrl+9. This enables the Modify button.

In the Functions section at the bottom of the dialog, scroll down in the Category list to
Styles. Click the expansion symbol (usually a + sign or triangle) to expand the list of styles.

Choose the category of style. (This example uses a paragraph style, but you can also
choose character styles and others.) The Function list will display the names of the
available styles for the selected category. The example shows some of LibreOffice’s
predefined styles.

To assign Ctrl+9 to be the shortcut key combination for the List 1 style, select List 1 in the
Function list, and then click Modify. Ctrl+9 now appears in the Keys list on the right, and
List 1 appears next to Ctrl+9 in the Shortcut keys box at the top.

Make any other required changes, and then click OK to save these settings and close the
dialog.
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Figure 326: Defining keyboard shortcuts for applying styles

Saving changes to a file

Changes to the shortcut key assignments can be saved in a keyboard configuration file for use at a
later time, thus permitting you to create and apply different configurations as the need arises. To
save keyboard shortcuts to a file:

1) After making your keyboard shortcut assignments, click the Save button at the right of the
Customize dialog (Figure 326).

2) Inthe Save Keyboard Configuration dialog, select All files from the Save as Type list.

3) Next enter a name for the keyboard configuration file in the File name box, or select an
existing file from the list. If you need to, browse to find a file from another location.

4) Click Save. A confirmation dialog appears if you are about to overwrite an existing file,
otherwise there will be no feedback and the file will be saved.

Loading a saved keyboard configuration

To load a saved keyboard configuration file and replace your existing configuration, click the Load
button at the right of the Customize dialog, and then select the configuration file from the Load
Keyboard Configuration dialog.

Resetting the shortcut keys

To reset all of the keyboard shortcuts to their default values, click the Reset button near the bottom
right of the Customize dialog. Use this feature with care as no confirmation dialog will be displayed,;
the defaults will be set without any further notice or user input.
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Assignhing macros to events

In LibreOffice, when something happens, we say that an event occurred. For example, a document
was opened, a key was pressed, or the mouse moved. You can associate a macro with an event,
so the macro is run when the event occurs. A common use is to assign the “open document” event
to run a macro that performs certain setup tasks for the document.

To associate a macro with an event, use the Events page of the Customize dialog. For more
information, see Chapter 13, Getting Started with Macros.

Adding functionality with extensions

An extension is a package that can be installed into LibreOffice to add new functionality.

Several extensions are shipped bundled with LibreOffice and are installed with the program.
Others can be downloaded from various websites. The official extension repository is located at
http://extensions.libreoffice.org/. These extensions are free of charge.

Some extensions from other sources are free of charge; others are available for a fee. Check the
descriptions to see what licenses and fees apply to the ones that interest you.

Installing extensions

Extensions can be installed in any of three ways.
1) Directly from the *.oxt file in your system's file browser.

2) From your web browser, if it can be configured to open this file type from a web page
hyperlink.

3) Directly from Tools > Extension Manager by clicking Add (Figure 327).
To install directly from a saved *.oxt file on your system, double-click the file.

To install from a suitably enabled web browser, select the hyperlink, and then select to Open the
file.

In both cases, after the Extension Manager opens, a warning dialog opens for you to verify the
installation and then continue (Figure 328). The file is installed as a “user only” file in a multi-user
system.

L] Extension Manager E]@
LT LanguageTool. Open source language checker 1.9 LanguageTool Elb
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Remove

Template Changer 1.2.6 André Schnabel

| E-—“w This extension enables you to assign a new template to writer documents, Al styles and formatting w...
he—

Type of Extension
[ installation Shared {ser:

Get more extensions onling. ..

[ Add... ” Chedk for Updates... ] [ Close

Figure 327: Using the Extension Manager
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' ‘fou are about to install the extension ‘LanguageTool. Open source language chedker'.
S 1 Click 'OK to proceed with the installation.
— Click 'Cancel to stop the installation.

[ Ok l [ Cancel

Figure 328: Installation warning dialog

To install directly from Extension Manager:

1) In LibreOffice, select Tools > Extension Manager from the menu bar. The option to view
the extensions bundled with LibreOffice can be deselected to view more easily those
installations that have been added by a user.

2) In the Extension Manager dialog (Figure 327), click Add.
3) Afile browser window opens. Find and select the extension you want to install and click
Open.

4) Users with administrator or root privileges will see a dialog (Figure 329) where they can
choose to install extensions “for all users” (shared) or “only for me” (user). Normal users
without those privileges can install, remove, or modify extensions only for their own use
(user).

Make sure that no further users are working with the same LibreQffice, when installing an
extension for all users in @ multi user environment.

For whom do you want to install the extension?

Only for me Cancel

Figure 329: Dialog showing the installation choices

5) The extension begins installing.

6) In all three cases, during the process you may be asked to accept a license agreement.
When the installation is complete, the extension is listed in the Extension Manager dialog.

To get extensions that are listed in the repository, you can open the Extension
Tip Manager and click the Get more extensions online link. You do not need to
download them separately.
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Introduction

You can use LibreOffice without requiring a pointing device, such as a mouse or touchpad, by
using its built-in keyboard shortcuts.

This appendix lists some of the most common built-in keyboard shortcuts that apply to all
components of LibreOffice. For shortcuts specific to Writer, Calc, Impress, Draw, or Base, read the
relevant component guide or search the application Help.

Some of the shortcuts listed here may not work if your operating system uses the
same shortcuts for other tasks.

Note To resolve any conflicts, assign different keys to these shortcuts by reconfiguring
either LibreOffice (see Chapter 14) or your operating system (see system
documentation).

Tip for Macintosh users

Some keystrokes are different on a Mac from those used in Windows and Linux. The following
table gives some common substitutions for the instructions in this chapter. For a more detailed list,
see the application Help.

Windows or Linux  Mac equivalent Effect
Right-click Control+click and/or right-click Opens a context menu
depending on computer system
Ctrl (Control) 3 (Command) Used with other keys
F5 Shift+38+F5 Opens the Navigator
Fi11 F+T Opens the Styles and Formatting window

374 | Getting Started with LibreOffice 4.2



General keyboard shortcuts

Opening menus and menu items

Shortcut Keys Result

Opens a menu where <?> is the underlined character of the menu
you want to open. For example, Alt+F opens the menu File

With the menu open, you will again find underlined characters. You
can access these menu items directly by simply pressing the
underlined character key. Where two menu items have the same
underlined character, press the character key again to move to the

Alt+<?> next item.

Example: to access the Printer Settings item of the File menu
after opening it, press R twice to move from the initial Digital
Signatures selection to Printer Settings.

There may be instances where an item in a menu has no
underlined character. This will have to be clicked directly.

Esc Closes an open menu.

Repeatedly pressing F6 switches the focus and circles through the
following objects:

* Menu bar

* Every toolbar from top to bottom and from left to right

* Every free window from left to right

¢ Document

F6

Shift+F6 Switches through objects in the opposite direction.

Ctri+F6 Switches the focus to the document.

F10 or Alt Switches to the Menu bar and back.

Esc Closes an open menu.

Accessing a menu command

Press Alt or F6 or F10 to select the first item on the menu bar (the File menu). With the right-arrow,
the next menu to the right is selected; with the left-arrow, the previous menu. The Home and End
keys select the first and the last item on the Menu bar.

The down-arrow opens a selected menu. An additional down-arrow or up-arrow moves the
selection through the menu commands. The right-arrow opens any existing submenus.

Press Enter to execute the selected menu command.
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Executing a toolbar command

Press F6 repeatedly until the first icon on the toolbar is selected. Use the right and left arrows to
select an icon on a horizontal toolbar. Similarly, use the up and down arrows to select an icon on a
vertical toolbar. The Home key selects the first icon on a toolbar and the End key, the last.

Press Enter to execute the selected icon. If the selected icon normally demands a consecutive
mouse action, such as inserting a rectangle, then pressing the Enter key is not sufficient: in these
cases press Ctrl+Enter.

* Press Ctrl+Enter on an icon for creating a draw object. A draw object will be placed into the
middle of the view, with a predefined size.

* Press Ctrl+Enter on the Selection tool to select the first draw object in the document. If you
want to edit, size, or move the selected draw object, first use Ctrl+F6 to move the focus into
the document.

Navigating and selecting with the keyboard

You can navigate through a document and make selections with the keyboard.
* To move the cursor, press the key or key combination given in the following table.

* To select the characters under the moving cursor, additionally hold down the Shift key when
you move the cursor.

Key

Function

Plus Ctrl key

Right, left arrow
keys

Moves the cursor one character to
the left or to the right.

Moves the cursor one word to the left
or to the right.

Up, down arrow
keys

Moves the cursor up or down one
line.

(Ctrl+Alt) Moves the current
paragraph up or down.

Home Moves the cursor to the beginning of Moves the cursor to the beginning of
the current line. the document.

End Moves the cursor to the end of the Moves the cursor to the end of the
current line. document.

PgUp Scrolls up one page. Moves the cursor to the header.

PgDn Scroll down one page. Moves the cursor to the footer.
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Controlling dialogs

When you open any dialog, one element (such as a button, an option field, an entry in a list box, or
a checkbox) is highlighted or indicated by a dotted box around the field or button name. This
element is said to have the focus on it.

Shortcut Keys Result

Enter Activates selected button. In most cases where no button is
selected, Enter is equivalent to clicking OK.

Closes dialog without saving any changes made while it was open.
Esc In most cases, Esc is equivalent to clicking Cancel. When an open
drop-down list is selected, Esc closes the list.

Spacebar Checks an empty checkbox. Clears a checked checkbox.

Moves focus up and down a list. Increases or decreases value of a

Up, down arrow keys variable. Moves focus vertically within a section of dialog.

Left, right arrow keys Moves focus horizontally within a section of a dialog.
Tab Advances focus to the next section or element of a dialog.
Shift+Tab Returns focus to the previous section or element in a dialog.
Alt+Down Arrow Shows items in a drop-down list.

Macros
Shortcut Keys Result
Ctrl+* (multiplication sign: Runs a macro field.

on number pad only)

Shift+Ctrl+Q Stops a running macro.

Getting help

Shortcut Keys Result
Opens the LibreOffice Help dialog. In LibreOffice Help: jumps to the

Fl first help page of the selected tab.
. Turns the cursor into the What'’s This? question mark. Shows the tip
Shift+F1 .
for an item underneath the cursor.
Shift+F2 Shows tip for a selected item.
Esc In LibreOffice Help: goes up one level.
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Managing documents

Shortcut Keys

Result

CtrI+F4 or Alt+F4

Closes the current document. Closes LibreOffice when the last
open document is closed.

Ctrl+O Launches the Open dialog to open a document.

Clri+S Saves the_ current document. If you are working ona previously
unsaved file, the shortcut launches the Save As dialog.

Ctrl+N Creates a new document.

Shift+Ctrl+N Opens the Templates and Documents dialog.

Ctrl+P Opens the Print dialog to print the document.

Ctrl+Q Closes the application.

Del In the Save and Qpen dialogs, deletes the_selected files or folders.
Items can be retrieved from the Recycle Bin (Trash).
In the Save and Open dialogs, deletes the selected files or folders.

Shift+Del Items are permanently deleted: they can not be retrieved from the
Recycle Bin.

Backspace In the Sa've and Open dialogs, shows contents of the current
directory's parent folder.

Editing

Shortcut Keys Result

Ctrl+X Cuts selected items.

Ctrl+C Copies selected items to the clipboard.

Ctrl+v Pastes copied or cut items from the clipboard.

Ctrl+Shift+V Opens the Paste Special dialog.

Ctrl+A Selects all.

Ctrl+z Undoes last action.

Ctrl+Y Redoes last action.

CtrlI+Shift+Y Repeats last command.

Ctrl+F Opens the Find dialog

Ctrl+H Opens the Find & Replace dialog.

Ctrl+Shift+F Searches for the last entered search term.

Ctrl+Shift+R Refreshes (redraws) the document view.

Ctrl+Shift+l Shows or hides the cursor in read-only text.

378 | Getting Started with LibreOffice 4.2



Selecting rows and columns in a database table opened by F4

Shortcut keys Result

Spacebar Toggles row selection, except when the row is in edit mode.
Ctrl+Spacebar Toggles row selection.

Shift+Spacebar Selects the current column.

Ctrl+Page Up Moves pointer to the first row.

Ctrl+Page Down Moves pointer to the last row.

Shortcut keys for drawing objects

Shortcut keys Result

Select the toolbar with F6. Use the Inserts a Drawing Object.
Down Arrow and Right Arrow to select
the desired toolbar icon and press

Ctrl+Enter.

Select the document with Ctr/+F6 and Selects a Drawing Object.

press Tab.

Tab Selects the next Drawing Object.

Shift+Tab Selects the previous Drawing Obiject.

Ctrl+Home Selects the first Drawing Object.

Ctrl+End Selects the last Drawing Object.

Esc Ends Drawing Object selection.

Esc (in Handle Selection Mode) Exit Handle Selection Mode and return to Object
Selection Mode.

Up/Down/Left/Right Arrow Move the selected point (the snap-to-grid functions are
temporarily disabled, but end points still snap to each
other).

Alt+Up/Down/Left/Right Arrow Moves the selected Drawing Object one pixel (in

Selection Mode).

Re-sizes a Drawing Object (in Handle Selection Mode).
Rotates a Drawing Object (in Rotation Mode).

Opens the properties dialog for a Drawing Object.

Activates the Point Selection mode for the selected
drawing object.
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Shortcut keys Result

Spacebar Select a point of a drawing object (in Point Selection
mode) / Cancel selection.
The selected point blinks once per second.

Shift+Spacebar Select an additional point in Point Selection mode.

Ctrl+Tab Select the next point of the drawing object (Point
Selection mode).
In Rotation mode, the center of rotation can also be
selected.

CtrlI+Shift+Tab Select the previous point of the drawing object (Point
Selection mode).

Ctrl+Enter A new drawing object with default size is placed in the

center of the current view.

Ctrl+Enter at the Selection icon

Activates the first drawing object in the document.

Esc

Leave the Point Selection mode. The drawing object is
selected afterwards.

Edit a point of a drawing object (Point Edit mode).

Any text or numerical key

If a drawing object is selected, switches to edit mode and
places the cursor at the end of the text in the drawing
object. A printable character is inserted.

Alt key while creating or scaling a
graphic object

The position of the object’s center is fixed.

Shift key while creating or scaling a
graphic object

The ratio of the object’s width to height is fixed.

Defining keyboard shortcuts

In addition to using the built-in keyboard shortcuts listed in this Appendix, you can define your own.
See Chapter 14, Customizing LibreOffice, for instructions.

Further reading

For help with LibreOffice’s keyboard shortcuts, or using LibreOffice with a keyboard only, search
the application Help using the “shortcut keys” or “accessibility” keywords.
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Introduction

LibreOffice is a productivity suite that is compatible with other major office suites and available on a
variety of platforms. It is open source software and therefore free to download, use, and distribute.
If you are new to LibreOffice, this appendix will provide some information regarding its history, its
community and some of its technical specifications.

A short history of LibreOffice

The OpenOffice.org project began when Sun Microsystems released the source code (“blueprints”)
for its StarOffice® software to the open source community on October 13, 2000. OpenOffice.org
1.0, the product, was released on April 30, 2002. Major updates to OpenOffice.org included version
2.0 in October 2005 and version 3.0 in October 2008. On January 26, 2010, Oracle Corporation
acquired Sun Microsystems.

On September 28, 2010, the community of volunteers who develop and promote OpenOffice.org
announce a major change in project structure. After ten years’ successful growth with Sun
Microsystems as founding and principle sponsor, the project launched an independent foundation
called The Document Foundation, to fulfill the promise of independence written in the original
charter. This foundation is the cornerstone of a new ecosystem where individuals and
organizations can contribute to and benefit from the availability of a truly free office suite.

Unable to acquire the trademarked OpenOffice.org name from Oracle Corporation, The Document
Foundation named its product LibreOffice. Continuing the version numbers from OpenOffice.org,
LibreOffice 3.3 was released in January 2011.

In February 2012, The Document Foundation was incorporated in Berlin as a German Stiftung. You
can read more about The Document Foundation at: http://www.documentfoundation.org/

The LibreOffice community

The Document Foundation's mission is:

“...to facilitate the evolution of the OpenOffice.org Community into a new open, independent,
and meritocratic organizational structure within the next few months. An independent
Foundation is a better match to the values of our contributors, users, and supporters, and will
enable a more effective, efficient, transparent, and inclusive Community. We will protect past
investments by building on the solid achievements of our first decade, encourage wide
participation in the Community, and co-ordinate activity across the Community.”
Some of our corporate supporters include Canonical, The GNOME Foundation, Google, Novell and
Red Hat. Additionally, over 450,000 people from nearly every part of the globe have joined this
project with the idea of creating the best possible office suite that all can use. This is the essence
of an “open source” community!

With its open source software license, LibreOffice is key in the drive to provide an office suite that
is available to anyone, anywhere, for commercial or personal use. The software has been
translated into many languages and runs on all major operating systems. New functionality can be
added in the form of extensions.

The LibreOffice community invites contributors in all areas, including translators, software
developers, graphic artists, technical writers, editors, donors and end-user support. Whatever you
do best, you can make a difference in LibreOffice. The Community operates internationally in all
time zones and in many languages, linked through the internet at www.libreoffice.org and
www.documentfoundation.org.
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How is LibreOffice licensed?

LibreOffice is distributed under the Open Source Initiative (OSI) approved Lesser General Public
License (LGPL).

The LGPL license is available from the LibreOffice website:
http://www.libreoffice.org/download/license/

What is “open source”?

The four essential rights of open-source software are embodied within the Free Software
Foundation’s General Public License (GPL):

* The right to use the software for any purpose.

* Freedom to redistribute the software for free or for a fee.

* Access to the complete source code of the program (that is, the “blueprints”).

* The right to modify any part of the source, or use portions of it in other programs.

The basic idea behind open source is very simple: When programmers can read, redistribute, and
modify the source code for a piece of software, the software evolves. People improve it, people
adapt it, people fix bugs.

For more information on Free and Open Source software, visit these websites:
Open Source Initiative (OSI): http://www.opensource.org

Free Software Foundation (FSF): http://www.gnu.org

What are “open standards”?

An open standard provides a means of doing something that is independent of manufacturer or
vendor, thus enabling competing software programs to freely use the same file formats. HTML,
XML, and ODF are examples of open standards for documents.

An open standard meets the following requirements:

* |tis well documented with the complete specification publicly available, either free or at a
nominal charge.

* It can be freely copied, distributed and used. The intellectual property of the standard is
made irrevocably available on a royalty-free basis.

* |tis standardized and maintained in an independent, open forum (also called "standards
organization") using an open process.

What is OpenDocument?

OpenDocument (ODF) is an XML-based file format for office documents (text documents,
spreadsheets, drawings, presentations and more), developed at OASIS (http://www.oasis-
open.org/who/), an independent, international standards group.

Unlike other file formats, ODF is an open standard. It is publicly available, royalty-free, and without
legal or other restrictions; therefore ODF files are not tied to a specific office suite and anybody can
build a program that interprets these files. For this reason ODF is quickly becoming the preferred
file format for government agencies, schools and other companies who prefer not to be too
dependent on any one software supplier.
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LibreOffice saves documents in OpenDocument Format by default. LibreOffice 3 adopted version
1.2 of the OpenDocument standard and LibreOffice 4 continues to use this standard. LibreOffice
can also open and save many other file formats; see “File formats LibreOffice can open” on this
page, “File formats LibreOffice can save to” on page 386, and “Exporting to other formats” on page
388.

OpenDocument filename extensions

The most common filename extensions used for OpenDocument documents are:
*.odt for word processing (text) documents

*.0ds for spreadsheets

*.0dp for presentations

*.0db for databases

*.0dg for graphics (vector drawings)

*.odf for formulas (mathematical equations)

File formats LibreOffice can open

LibreOffice can open a wide variety of file formats in addition to the OpenDocument formats,
including Portable Document Format (PDF), if an ODF file is embedded in the PDF (see Chapter
10 Printing, Exporting, and Emailing for more information).

Opening text documents

In addition to OpenDocument formats (.odt, .ott, .oth, .odm, and .fodt), Writer can open the formats
used by OpenOffice.org 1.x (.sxw, .stw, and .sxg), the following text document formats, and a
variety of legacy formats not listed below:

Microsoft Word 6.0/95/97/2000/XP/Mac) (.doc and .dot)

Microsoft Word 2003 XML (.xml)
Microsoft Word 2007/2010 XML (.docx, .docm, .dotx, .dotm)

Microsoft WinWord 5 (.doc) WordPerfect Document (.wpd)

Microsoft Works (.wps) Lotus WordPro (.lwp)

Abiword Document (.abw, .zabw) ClarisWorks/Appleworks Document (.cwk)
MacWrite Document (.mw, .mcw) Rich Text Format (.rtf)

Text CSV (.csv and .txt) StarWriter formats (.sdw, .sgl, .vor)
DocBook (.xml) Unified Office Format text (.uot, .uof)
Ichitaro 8/9/10/11 (.jtd and .jtt) Hangul WP 97 (.hwp)

T602 Document (.602, .txt) AportisDoc (Palm) (.pdb)

Pocket Word (.psw) eBook (.pdb)

HTML Document (.htm, .html)
Most of these file types are automatically detected by LibreOffice, so they can be opened without
explicitly selecting the document type in the file picker.

When opening .htm or .html files (used for web pages), LibreOffice customizes Writer for working
with these files.

384 | Getting Started with LibreOffice 4.2



Opening spreadsheets

In addition to OpenDocument formats (.ods, .ots, and .fods), Calc can open the formats used by
OpenOffice.org 1.x (.sxc and .stc) and the following spreadsheet formats:

Microsoft Excel 97/2000/XP (.xlIs, .xlw, and .xIt)
Microsoft Excel 4.x-5.0/95 (.xls, .xlw, and .xlt)

Microsoft Excel 2003 XML (.xml)

Microsoft Excel 2007/2010 XML (.xIsx, .xIsm, .xlts, .xltm)
Microsoft Excel 2007/2010 binary (.xIsb)

Lotus 1-2-3 (.wk1, .wks, and .123)

Data Interchange Format (.dif)

Rich Text Format (.rtf)

Text CSV (.csv and .txt)

StarCalc formats (.sdc and .vor)

dBASE (.dbf)

SYLK (.slk)

Unified Office Format spreadsheet (.uos, .uof)

HTML Document (.htm and .html files, including Web page queries)
Pocket Excel (pxI)

Quattro Pro 6.0 (.wb2)

Opening presentations

In addition to OpenDocument formats (.odp, .odg, .otp, and .fopd), Impress can open the formats
used by OpenOffice.org 1.x (.sxi and .sti) and the following presentation formats:

Microsoft PowerPoint 97/2000/XP (.ppt and .pot)

Microsoft PowerPoint 2007/2010 (.pptx, .pptm, .potx, .potm)
StarDraw and Starlmpress (.sda, .sdd, .sdp, and .vor)
Unified Office Format presentation (.uop, .uof)

CGM — Computer Graphics Metafile (.cgm)

Portable Document Format (.pdf)

Apple Keynote 5 (.key)

Opening graphic files

In addition to OpenDocument formats (.odg and .otg), Draw can open the formats used by
OpenOffice.org 1.x (.sxd and .std) and the following graphic formats:

Adobe Photoshop (*.psd)

AutoCAD Interchange Format (*.dxf)

Corel Draw (*.cdr)

Corel Presentation Exchange (*.cmx)

Microsoft Publisher 98-2010 (*.pub)

Microsoft Visio 2000-2013 (*.vdx; *.vsd; *.vsdm; *.vsdx)
WordPerfect Graphics (*.wpg)

BMP JPEG, JPG PCX PSD SGV WMF
DXF MET PGM RAS SVM XBM
EMF PBM PLT SDA TGA XPM
EPS PCD PNG SDD TIF, TIFF

GIF PCT PPM SGF VOR
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Opening formula files

In addition to OpenDocument Formula (.odf) files, Math can open the format used by
OpenOffice.org 1.x (.sxm), StarMath, (.smf), and MathML (.mml) files.

When opening a Word document that contains an embedded equation editor object, if the option
for it (MathType to LibreOffice Math or reverse) is checked in Tools > Options > Load/Save >
Microsoft Office, the object will be automatically converted to an LibreOffice Math object.

File formats LibreOffice can save to

Saving in an OpenDocument format guarantees the correct rendering of the file when it is
transferred to another person or when the file is re-opened with a later version of LibreOffice or
with another program. It is strongly recommended that you use OpenDocument as the default file
formats. However, you can save files in other formats, if you wish.

When sharing a document that you do not expect or want the recipient to modify, the
safest option is to convert the document to PDF. LibreOffice provides a very
straightforward way to convert documents to PDF. See Chapter 10 Printing,
Exporting, and E-Mailing in this guide.

Tip

Saving text documents

In addition to OpenDocument formats (.odt, .ott, and .fodt), Writer can save in these formats:

OpenOffice.org 1.x Text Document (.Sxw)

OpenOffice.org 1.x Text Document Template (.stw)

Microsoft Word 6.0, 95, and 97/2000/XP (.doc)

Microsoft Word 2003 XML (.xml)

Microsoft Word 2007/2010 XML (.docx)

Office Open XML Text (.docx)

Rich Text Format (.rtf)

StarWriter 3.0, 4.0, and 5.0 (.sdw)

StarWriter 3.0, 4.0, and 5.0 Template (.vor)

Text (.txt)

Text Encoded (.txt)

Unified Office Format text (.uot, .uof)

HTML Document (OpenOffice.org Writer) (.html and .htm)

DocBook (.xml)

AportisDoc (Palm) (.pdb)

Pocket Word (.psw)
Encryption support within the Microsoft Word 97/2000/XP filter allows password protected
Microsoft Word documents to be saved.

The .rtf format is a common format for transferring text files between applications,
Note but you are likely to experience loss of formatting and images. For this reason, other
formats should be used.
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Saving spreadsheet files

In addition to OpenDocument formats (.ods and .ots), Calc can save in these formats:

OpenOffice.org 1.x Spreadsheet (.sxc)
OpenOffice.org 1.x Spreadsheet Template (.stc)
Microsoft Excel 97/2000/XP (.xIs and .xIw)
Microsoft Excel 97/2000/XP Template (.xIt)
Microsoft Excel 5.0 and 95 (.xIs and .xlw)
Microsoft Excel 2003 XML (.xml)

Microsoft Excel 2007/2010 XML (.xIsx)

Office Open XML Spreadsheet (.xIsx)

Data Interchange Format (.dif)

dBase (.dbf)

SYLK (.slk)

Text CSV (.csv and .txt)

StarCalc 3.0, 4.0, and 5.0 formats (.sdc and .vor)
Unified Office Format spreadsheet (.uos)

HTML Document (OpenOffice.org Calc) (.html and .htm)
Pocket Excel (.pxl)

The Java Runtime Environment is required to use the mobile device filters for

Note AportisDoc (Palm), Pocket Word, and Pocket Excel.

Saving presentations

In addition to OpenDocument formats (.odp, .otp, .fodp, and .odg), Impress can save in these
formats:

OpenOffice.org 1.x Presentation (.Sxi)

OpenOffice.org 1.x Presentation Template (.sti)

Microsoft PowerPoint 97/2000/XP (.ppt)

Microsoft PowerPoint 97/2000/XP Template (.pot)

Microsoft PowerPoint 2007/2010 XML (.pptx, .potm)

Office Open XML Presentation (.pptx, .potm, .ppsx)

StarDraw, Starlmpress (.sda, .sdd, and .vor)

Unified Office Format presentation (.uop)
Impress can also export to MacroMedia Flash (.swf) and any of the graphics formats listed for
Draw.

Saving drawings

Draw can only save in the OpenDocument Drawing formats (.odg, .otg, and .fodg), the
OpenOffice.org 1.x formats (.sxd and .std) and StarDraw format (.sda, .sdd, and .vor).

However, Draw can also export to BMP, EMF, EPS, GIF, JPEG, MET, PBM, PCT, PGM, PNG,
PPM, RAS, SVG, SVM, TIFF, WMF, and XPM.

Writer/Web can save in these formats

HTML document (.html and .htm), as HTML 4.0 Transitional
OpenOffice.org 1.0 HTML Template (.stw)

OpenOffice.org 2.x HTML Template (.oth)

StarWriter/Web 4.0 and 5.0 (.vor)

Text and Text Encoded (LibreOffice Writer/Web) (.txt)
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Exporting to other formats

LibreOffice uses the term “export” for some file operations involving a change of file type. If you
cannot find the file type you are looking for under Save As, look under Export for additional types.

LibreOffice can export files to HTML and XHTML. In addition, Draw and Impress can export to
Adobe Flash (.swf) and a range of image formats.

To export to one of these formats, choose File > Export. On the Export dialog, specify a file name
for the exported document, then select the desired format in the File format list and click the

Export button.
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Index

This index is incomplete. We apologize, but no one has volunteered to update it. Our choices were
to have no index, or an incomplete index, or to delay publication for so long that the book would be

very out of date.
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